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Chapter 1
The Basics

This chapter describes everything you need to get started working 
Mathcad. The following sections make up this chapter:

First principles
Mathcad's design and interface.

What you can do with Mathcad
Starting Mathcad.

Working with windows
How to scroll a window, how to move and resize windows, and how to op
several worksheets at once.

A simple calculation
Calculating with Mathcad.

Definitions and variables
Creating simple Mathcad equations.

Entering text
Adding notes and labels to a worksheet.

Regions and menus
How equations, text, and plots make up a worksheet; Mathcad's menu c
mands.

Iterative calculations
Using range variables to repeat an equation for several values.

Graphs
Building a simple two-dimensional plot.

Saving, printing, and quitting
The Save, Print, and Exit commands from the File menu.
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First principles

Mathcad looks simple, and it is. It was created according to basic design principle
make it powerful, flexible, and easy to use. In Mathcad:

■ Everything appears in familiar math notation. If there's a standard mathematica
way to show an equation, operation, or graph, Mathcad uses it.

■ What you see is what you get. There is no hidden information; everything appea
on the screen. When you print, the output looks just like the screen display.

■ To create simple expressions, just type them. Mathcad uses the standard keys fo
standard mathematical operations.

■ Typing aids make equations easier to enter. There are palettes for most mathe
matical operators and symbols. 

■ Fill in the blanks. Mathcad guides you through the creation of plots, integrals, a
other mathematical expressions by laying down the framework and letting you
in the blanks.

■ Calculation features are modular. If you don't want to use a feature—like 
complex numbers, units, or matrices—you can just pretend it isn't there. 

■ The numerical algorithms are robust, standard, and predictable. Mathcad's 
numerical algorithms for features like integrals, matrix inversion, and equatio
solving are reliable, standard methods.

■ OLE support . Mathcad is an OLE2 application, providing drag and drop supp
of Mathcad objects into applications like Microsoft Word, in-place activation o
Mathcad objects in client applications, and enhanced support for embedded 
objects in Mathcad worksheets.

■ Exchange data with other applications. Mathcad gives you easy-to-use tools to
exchange data with spreadsheets, graphing packages, and other calculation 
cations.

■ On-line help. Pressing [F1] brings up an extensive on-line help system. Click o
error messages, operators and functions and press [F1] to display the relevant help 
screen. There's no need to search for the topic you're interested in. The User's Guide 
includes more detail on all the features, with step-by-step instructions and illu
tive examples. At the back of the User's Guide is a complete cross-referenced index

■ Collaboration features. If you’re connected to an electronic mail system comp
ible with Microsoft Mail, mail worksheets to colleagues from right within Mathca
And you have access to MathSoft’s Collaboratory server, a unique Web-base
resource where you can exchange text messages, upload and download Mat
files, and connect to a community of Mathcad users.

■ Resource Center. A collection of Mathcad worksheets in an interactive, searcha
Electronic Book, with links to resources on the World Wide Web. The Resour
18  Chapter 1  The Basics
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Center includes an Overview, Tutorial, Reference Tables, QuickSheets—pre
working templates for completing common mathematical tasks, ready for cus
ization and dragging into your own worksheets—and Practical Statistics, an o
view of hypothesis testing and data analysis in Mathcad. Mathcad Profession
includes in-depth sections on Solving and Programming drawn from The Mathcad 
Treasury, our best-selling Electronic Book. Visit MathSoft’s home page 
(www.mathsoft.com ) directly from the Resource Center, or browse to any oth
resources on the World Wide Web.

This chapter provides a quick introduction to Mathcad and demonstrates a few m
advanced features like iterative calculation and plotting. After you read this chap
you'll have enough information to begin to solve your own problems in Mathcad. 
rest of this User's Guide describes all the features in detail, so you can learn more ab
any selected topic. For more information about on-line resources like the Collabora
Resource Center, and on-line Help system, see Chapter 2, “On-line Resources.”

What you can do with Mathcad

Mathcad combines the live document interface of a spreadsheet with the WYSIWYG 
interface of a word processor. With Mathcad, you can typeset equations on the s
exactly the way you see them in a book. But Mathcad equations do more than lo
good on the screen. You can use them to actually do math.

Like a spreadsheet, as soon as you make a change anywhere in your worksheet, M
goes straight to work, updating results and redrawing graphs. With Mathcad, you
easily read data from a file and do mathematical chores ranging from adding up 
column of numbers to evaluating integrals and derivatives, inverting matrices and m
In fact, just about anything you can think of doing with math, you can do with Math

Like a word processor, Mathcad comes with a WYSIWYG interface, multiple fonts, and 
the ability to print whatever you see on the screen. This, combined with Mathcad's
document interface, makes it easy to produce up-to-date, publication quality rep

Starting Mathcad

For information on system requirements and how to install Mathcad on your comp
see the instructions that accompanied your installation media.

When you start Mathcad, you'll see the window shown in Figure 1-1. You can vie
hide the Math Palette, the Toolbar, and the Format Bar by choosing correspondi
commands from the View menu.
What you can do with Mathcad 19
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Figure 1-1: Mathcad Professional window with some math palettes displayed.

You can place equations anywhere in the Mathcad worksheet. To get to places 
visible in the window, use the scroll bars as you would in any Windows applicatio

Each button in the Math Palette opens a palette of operators or symbols. You can
many operators, Greek letters, and plot regions by clicking on the buttons found
these palettes. From left to right, these palettes are: 

   Button Opens palette...

Common arithmetic operators.

Equal signs for evaluation and definition. Boolean expressions.

Various two and three dimensional plot types.

Matrix and vector operators.

Derivatives, integrals, limits and iterated sums and products.

Programming constructs (Mathcad Professional only).

Greek letters.

Symbolic keywords.
20  Chapter 1  The Basics
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The Toolbar is the strip of buttons shown just below the Math Palette in Figure 1
Many menu commands can be accessed more quickly by clicking a button on th
Toolbar. To learn what a button does, click on the button and read the message l
you don't want to activate the button, move the pointer away without releasing th
mouse button. If you just want to know what the button does, let the pointer rest o
button momentarily. You'll see some text beside the pointer telling you what that bu
does.

The Format Bar is shown immediately under the Toolbar in Figure 1-1. This cont
scrolling lists and buttons used to specify font characteristics in equations and te

To conserve screen space, you can show or hide each of these elements individ
by choosing the appropriate command from the View menu. Throughout the figures in
this User's Guide, the symbol palette, the toolbar, and the format bar have all bee
hidden to allow more space for examples.

You can also detach each of these window elements and drag them around you
window. To do so, place the mouse pointer anywhere other than on a button or a
box. Then press and hold down the mouse button and drag. You'll find that the to
and the symbol palette will rearrange themselves appropriately depending on wh
you drag them. The format bar, on the other hand, will retain its shape no matter w
you drag it. And Mathcad remembers where you left your palettes the next time 
open the application.

Working with windows 

When you start Mathcad you'll open up a window on a Mathcad worksheet. There are 
times when a Mathcad worksheet cannot be displayed in its entirety because the w
is too small. To bring unseen portions of a worksheet into view, you can:

■ Use the scroll bars and arrow keys to move around the worksheet.

■ Make the window larger.

■ Choose Zoom from the View menu and choose a number smaller than 100%.

Mathcad windows work very much like those of most Windows applications. If you
worked with Windows applications before, much of the material in this section w
already be familiar to you. 

There are several ways to move the window from one part of a worksheet to ano

■ Move the mouse pointer and click the mouse button. The cursor jumps from 
wherever it was to wherever you clicked.

■ Use the arrow keys [↑], [↓], [→], and [←] to move the crosshair up, down, right an
left respectively. Mathcad scrolls the window whenever necessary.

■ Click in the scroll bar to position the scroll box. 
Working with windows 21
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■ With the mouse pointer on the scroll box, press and hold down the mouse bu
and move the mouse to drag the scroll box to another part of the scroll bar. 

■ Click on the arrows at the ends of the scroll bars to nudge the scroll box in th
directions indicated by the arrows.

■ Press [PgUp] and [PgDn] to move the cursor up and down by about one fourth t
height of the window. You can also use [Ctrl ][PgUp] and [Ctrl ][PgDn] to move 
the cursor up and down by about 80% of the height of the window.

■ Press [Ctrl ][Home] to go to the first region of the worksheet, and [Ctrl ][End] 
to go to the last region of a worksheet.

■ Press [Shift ][PgUp] and [Shift ][PgDn] to position the preceding or following 
pagebreak at the top of the window.

■ Choose Go to Page from the Edit  menu and enter the page number you want to 
to in the dialog box below. When you click “OK,” Mathcad places the top of th
page you specify at the top edge of the window.

The position of the scroll box within the scroll bar serves as a rough guide to the pos
of the window relative to the rest of the worksheet. If the top of the window is a th
of the way down from the top of the worksheet, the scroll box will be about a third
the way down the vertical scroll bar. The page number for whatever page is visib
the window is shown on the message line at the bottom of the window.

Multiple windows 

You can have as many windows open as your available system resources will a
This allows you to work on several worksheets at once by simply clicking the mo
in whatever document window you want to work in. If the worksheet you want to w
in is buried behind many other windows, pull down the Window menu and choose its 
name.

To open a new document window, choose New from the File menu. To open a window 
into a previously saved worksheet, choose Open from the File menu. For more 
information about opening new worksheets and templates, see Chapter 4, “Work
Management.”
22  Chapter 1  The Basics
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A simple calculation 

Although Mathcad can perform sophisticated mathematics, you can just as easil
it as a simple calculator. To try your first calculation, follow these steps:

■ Click anywhere in the worksheet. You see 
a small crosshair. Anything you type ap-
pears at the crosshair.

■ Type 15-8/104.5=  . When you press 
the equals sign, Mathcad computes and 
shows the result.

This calculation demonstrates the way Mathcad works:

■ Mathcad shows equations as you might see them in a book or on a blackboa
expanded fully in two dimensions. Mathcad sizes fraction bars, brackets, and o
symbols to display equations the same way you would write them on paper.

■ Mathcad understands which operation to perform first. In this example, Mathc
knew to perform the division before the subtraction and displayed the equatio
accordingly.

■ As soon as you type the equal sign, Mathcad returns the result. Unless you sp
otherwise, Mathcad processes each equation as you enter it. See the section
“Controlling calculations” in Chapter 7 to learn how to change this.

■ As you type each operator (in this case, − and /  ), Mathcad shows a small rectangle
called a placeholder. Placeholders hold spaces open for numbers or expressions
yet typed. As soon as you type a number, it replaces the placeholder in the equ
The placeholder that appears at the end of the equation is used for unit conver
Its use is discussed in the section “Displaying units of results” in Chapter 9.

Once an equation is on the screen, you can edit it by clicking in the appropriate 
and typing new letters, digits, or operators. You can type many operators and G
letters by clicking in the symbol palette located just below the menu bar. Chapte
“Editing Equations,” explains in detail how to edit Mathcad equations.
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Definitions and variables 

Mathcad's power and versatility quickly become apparent once you begin to use
variables and functions. By defining variables and functions, you can link equation
together and use intermediate results in further calculations.

The following examples show how to define and use several variables.

Defining variables 

To clear the previous equation and define a variable t, follow these steps:

■ Click in the equation you just typed and 
press [Space ] until the entire expression 
is held between the two editing lines. Then 
choose Cut from the Edit  menu. 

■ Now begin defining t. Type t:  
(the letter t, followed by a colon). Mathcad 
shows the colon as the definition symbol 
:= . 

■ Type 10  in the empty placeholder to com-
plete the definition for t.

If you make a mistake, click on the equation and press [Space ] until the entire 
expression is between the two editing lines, just as you did earlier. Then delete i
choosing Cut from the Edit  menu.

These steps show the form for typing any definition: 

■ Type the variable name to be defined.

■ Type the colon key to insert the definition symbol.

■ Type the value to be assigned to the variable. The value can be a single numb
in the example shown here, or a more complicated combination of numbers a
previously defined variables.

Mathcad worksheets read from top to bottom and left to right. Once you have de
a variable like t, you can compute with it anywhere below and to the right of the equation 
that defines it. 

Now enter another definition.

■ Press [↵]. This moves the crosshair below the first equation.
24  Chapter 1  The Basics
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■ To define acc as –9.8, type: acc:–9.8 . Then press [↵] again.

Figure 1-2 shows the two definitions you just entered.

Figure 1-2: Equations to define acc and t.

Calculating results    

Now that the variables acc and t are defined, you can use them in other expression

■ Click the mouse a few lines below the two definitions (see Figure 1-2). 

■ Type acc/2 [Space ]*t^2 . The caret symbol (^ ) represents raising to a power,
the asterisk (* ) is multiplication, and the slash (/ ) represents division.

■ Press the equal sign (=).

This equation calculates the distance traveled by a falling body in time t with acceler-
ation acc. When you enter the equation, Mathcad returns the result as shown in F
1-3. The window now contains two definitions, which define variables, and one 
evaluation, which computes a result.
Definitions and variables 25
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Figure 1-3: Calculating with variables.

Mathcad updates results as soon as you make changes. For example, If you clic
the 10 on your screen and change it to some other number, Mathcad changes the
as soon as you press [↵] or click outside of the equation.

Entering text 

Mathcad handles text as easily as it does equations, so you can make notes abo
calculations you are doing. To begin typing text, click in an empty space and do 
one of the following: choose Text Region from the Insert menu, press the double-
quote key (" ), or click on the text region button on the toolbar.

Here's how to enter some text:

■ Click in the blank space to the right of the equations you entered. You'll see a s
crosshair.

■ Press "  to tell Mathcad that you're about to enter some text. Mathcad changes
crosshair into a vertical line called the insertion point. Characters you type ap
behind this line. A box surrounds the insertion point, indicating you are now in
text region. This box is called a text box. It will grow as you enter text.

■ Type Equations of motion

Mathcad shows the text in the worksheet, next to the equations (Figure 1-4).
26  Chapter 1  The Basics
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Figure 1-4: Entering text. Notice the text box surrounding it.

To enter a second line of text, just press [↵] and continue typing:

■ Press [↵].

■ Then type for falling body under gravity.

■ Click in a different spot in the worksheet or press [Shift ][↵] to move out of the 
text region. The text box will disappear once you have done this. Don't use the[↵] 
key. If you press [↵], Mathcad will insert a line break in the text instead of leavin
the text region.

Figure 1-5 shows the worksheet with two lines of text and the cursor outside the
region. Since you are outside the text region, the cursor appears as a small cros
the text box is no longer visible.
Entering text 27
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Figure 1-5: After clicking outside of a text region.

You can set the width of a text region and change the font, size, and style of the t
it. For more information on how to do these things, see Chapter 5, “Text.”

Regions and menus 

Mathcad lets you enter equations and text anywhere in the worksheet. Each equ
or piece of text is a region. Mathcad creates an invisible rectangle to hold each regi
A Mathcad worksheet is a collection of such regions. To see these regions, choo
Regions from the View menu. Mathcad will display blank space in gray and leave a
regions in the default color. To turn the blank space back into the default color, ch 
Regions from the View menu again.

To start a new region, you must first click in blank space. This leaves a small cros
wherever you clicked the mouse. To start an equation, just start typing anywhere
put the crosshair, or choose Math Region from the Insert menu. To create a text region
first choose Text Region from the Insert menu. Whichever you do, Mathcad will place
a box around the region you're working with.

In addition to equations and text, Mathcad supports a variety of plot regions. Plot
introduced in “Graphs” on page 32.
28  Chapter 1  The Basics
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Iterative calculations 

Mathcad can do repeated or iterative calculations as easily as individual calculat
Mathcad uses a special variable called a range variable to perform iteration.

Range variables take on a range of values, such as all the integers from 0 to 10.
Whenever a range variable appears in a Mathcad equation, Mathcad calculates 
equation not just once, but once for each value of the range variable. 

This section describes how to use range variables to do iterative calculations.

Creating a range variable

To compute equations for a range of values, first create a range variable. In the pro
shown in Figure 1-5, for example, you can compute results for a range of valuest 
from 10 to 20 in steps of 1. To do so, follow these steps:

■ First, change t into a range variable by 
editing its definition. Click on the 10  in 
the equation t := 10 . The insertion point 
should be next to the 10 as shown on the right.

■ Type ,11 . This tells Mathcad that the next 
number in the range will be 11.

■ Type ;20 . This tells Mathcad that the last 
number in the range will be 20. Mathcad 
shows the semicolon as a pair of dots.

■ Now click outside the equation for t. Mathcad begins to compute with t defined as 
a range variable. Since t now takes on eleven different values, there must also 
eleven different answers. These are displayed in the table shown in Figure 1-6
may have to resize your window or scroll down to see the whole table.
Iterative calculations 29
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Figure 1-6: Generating a table of answers with a range variable.

Defining a function

You can gain additional flexibility by defining functions. Here's how to add a funct
definition to your worksheet:

■ First delete the table. To do so, click any-
where in the table press [Space ] until 
you've enclosed everything between the 
two editing lines.

■ Now define the function d(t) by typing 
d(t):

■ Complete the definition by typing this ex-
pression: 1600+acc/
2[Space ]*t^2 [↵]

The definition you just typed defines a function. The function name is d, and the 
argument of the function is t. You can use this function to evaluate the above express
for different values of t. To do so, simply replace t with an appropriate number. For 
example:
30  Chapter 1  The Basics
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■ To evaluate the function at the value 3.5, 
type d(3.5)= . Mathcad returns the cor-
rect value as shown on the right.

■ To evaluate the function once for each value of t you defined earlier, click below 
the other equations and type d(t)= .

Mathcad shows a table of values (Figure 1-7). The first two values,  
, are in exponential (powers of 10) notation.

Figure 1-7: Using a function to return a table of answers.

Formatting a result 

You can set the display format for any number Mathcad calculates and displays.
means changing the number of decimal places shown, changing exponential no
to ordinary decimal notation, and so on.

For example, here's how to change the table in Figure 1-7 so that none of the nu
in it are displayed in exponential notation:

■ Click on the table with the mouse. 

1.11 103⋅
1.007 103⋅
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■ Choose Number from the Format menu. You see the Format Number dialog bo
This box contains settings that affect how results are displayed, including the
number of decimal places, the use of exponential notation, and whether the nu
is shown in decimal, octal, or hexadecimal. The option button beside “Set for cu
region only” should be filled in. This indicates that whatever you do in this dia
box affects only the result you've selected. 

■ The default setting for Exponential Threshold is 3. This means that only num
greater than or equal to  are displayed in exponential notation. Click to the 
of the 3, press [BkSp] and type 6.

■ Click the “OK” button. The equation 
changes to reflect the new result format—
1110 is no longer shown in exponential 
notation.

When you format a result, only the display of the result is affected. Mathcad main
full precision internally.

Graphs 

Mathcad can show both two-dimensional Cartesian and polar graphs, contour pl
surface plots, and a variety of other three-dimensional plots. These are all examp
plot regions.

This section describes how to create a simple two-dimensional graph showing the p
calculated in the previous section.

Creating a graph 

To create a graph in Mathcad, click in blank space where you want the graph to ap
and choose Graph⇒X-Y Plot  from the Insert menu. An empty graph appears with 
placeholders on the x-axis and y-axis for the expressions to be graphed. X-Y and po
plots are ordinarily driven by range variables you define: Mathcad graphs one poin
each value of the range variable used in the graph. In most cases you will enter 
range variable, or an expression depending on the range variable, on the x-axis of the 
plot. But the QuickPlot feature in Mathcad lets you plot expressions even when y
don’t specify the range variable directly in the plot.

For example, here's how to create a QuickPlot of the function d(t) defined in the 
previous section:

103
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■ Position the crosshair and type d(t) . 
Make sure the editing lines remain dis-
played on the expression.

■ Now choose Graph⇒X-Y Plot  from the 
Insert menu, or click the X-Y Plot button 
on the Graphing palette. Mathcad dis-
plays the frame of the graph.

■ Click anywhere outside the graph. Mathcad calculates and graphs the points
shown in Figure 1-8. A sample line appears under the “d(t).” This helps you identify 
the different curves when you plot more than one function. Unless you specif
otherwise, Mathcad draws straight lines between the points and fills in the mis
axis limits.

Figure 1-8: Graph of d(t) versus t.

For detailed information on creating and formatting graphs, see Chapter 20, “Gra

Resizing a graph 

The graph shown in Figure 1-8 is the default size. It's easy to make a graph in Ma
any size you want: just select the graph and stretch it to the desired size.
Graphs 33
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To resize a graph, follow these steps:

■ Click the mouse just outside the graphics region. This anchors one corner of 
selection rectangle.

■ Press and hold down the mouse button. With the button still held, drag the m
toward the plot region. A dashed selection rectangle emerges from the anchor 

■ When the selection rectangle just enclos-
es the graphics region, let go of the mouse 
button. The dashed rectangle will turn 
into a solid rectangle with handles. 

■ Move the mouse pointer to any of the 
handles. It will change to a double-headed 
arrow.

■ Press and hold down the mouse button. 
With the mouse button still pressed, move 
the mouse. The graphics region will be stretched in the direction of motion.

■ Once the graphics region is the right size, let go of the mouse button. 

■ Click outside the graph to deselect it.

Figure 1-9 shows the result: a larger graph.

Figure 1-9: New graph, after resizing.
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Formatting a graph 

The graph in Figure 1-9 still has the default characteristics: numbered linear axe
grid lines, and points connected with solid lines. You can change these character
by formatting the graph, just as you earlier formatted a number.

To format the graph, follow these steps:

■ Double-click on the graph to bring up the appropriate dialog box. This box cont
settings for all available plot format options. To learn more about these settings
Chapter 20, “Graphs.”

■ Click on the Traces tab in the dialog box to see the correct page. 

■ Click on “trace 1” in the scrolling list under “Legend Label.” Mathcad places th
current settings for trace 1 in the boxes under the corresponding columns of 
scrolling list.

■ Click on the arrow under the “Type” column to see a drop-down list of trace ty

■ Choose “bar” from this drop-down list by clicking on it.

■ Click on the “OK” button to show the result of changing the setting. Mathcad sh
the graph as a bar chart instead of connecting the points with lines (Figure 1-
Note that the sample line under the d(t) now has a bar on top of it.

■ Click outside the graph to deselect it.
Graphs 35
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Figure 1-10: Graph formatted as a bar chart.

Saving, printing, and quitting 

Once you've created a worksheet, you will probably want to save or print it. This se
explains how to save and print in Mathcad.

Saving a worksheet 

To save the file,

■ Choose Save from the File menu or click on the disk icon in the toolbar. If the file
has never been saved before, the Save As dialog box appears. Otherwise, Mathca
saves the file with no further prompting. 

■ Type the name of the file in the text box provided. By default, Mathcad saves
file either in the folder in which Mathcad is installed or in the folder from whic
you most recently opened a worksheet during the current session. To save to a
folder, locate the folder using the Save As dialog box.

By default Mathcad saves the file in Mathcad (MCD) format, but you have the option
of saving in RTF format to be able to open the file in a word processor. You may a
save the file as a template for future Mathcad worksheets, or in a format compat
with earlier Mathcad versions. For more information on saving and opening files,
Chapter 4, “Worksheet Management.”
36  Chapter 1  The Basics



 

s in 
 want 
h 
ation.
Printing

To print, choose Print from the File menu or click on the printer icon in the toolbar.
You may preview the printed page by choosing Print Preview from the File menu

For more information on printing, see Chapter 4, “Worksheet Management.”

Quitting Mathcad 

When you're done using Mathcad, choose Exit  from the File menu. Mathcad closes 
down all its windows and returns you to the Desktop. If you've made any change
your worksheets since the last time you saved, a dialog box appears asking if you
to discard or save your changes. If you have moved the toolbar, font bar, or mat
palettes, Mathcad remembers their locations for the next time you open the applic
Saving, printing, and quitting 37
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