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Chapter 28
Importing and Exporting Graphics

Mathcad can read in graphic image files as data for you to manipul
mathematically and to view as pictures. You can process images as a
in Mathcad and export arrays as image files to graphics editors or o
applications. This chapter also describes how to create pictures in 
Mathcad worksheet by reference to bitmap files, and how to import
graphic images by copying them from another application and past
them into Mathcad. 

This chapter contains the following sections:

Reading and writing graphics files
Reading and writing grayscale BMP image files with READBMP and WRITEBMP 
and color BMP image files with READRGB and WRITERGB; viewing images in 
the picture operator. Additional image reading and writing functions in 
Mathcad Professional.

Creating pictures
Using the Picture command from the Insert menu to create a picture base
on a matrix or bitmap file. Pasting in a graphic image from the clipboard

Formatting pictures
Changing the positioning and size of existing pictures, and working with 
palettes of 256-color bitmaps.
585



 data. 
’s 
nipu-
s an 

write 
 and 

ns:

ap 
l. 

ger 

rre-
255. 
lish 

oose 
g 

 

file 

or 
Reading and writing graphics files

Mathcad includes functions that allow you to read in a grayscale or color image as
Once you have read an image into a Mathcad matrix, you can view it in Mathcad
picture operator or apply image processing techniques or other mathematical ma
lations. And once you finish processing a matrix, you may save the data to disk a
image for later use in Mathcad or in graphics applications. 

While the functions described in this section are designed specifically to read and 
image files, they share many of the general behaviors of the functions for reading
writing ASCII data described in Chapter 19, “Data Management.” 

Reading, viewing, and writing BMP files

To import a bitmap (BMP format) file as data into Mathcad, use one of these functio

Function Meaning

READBMP(file) Create a matrix containing a grayscale representation of the bitm
image in file. Each element in the matrix corresponds to a pixe
The value of a matrix element determines the shade of gray 
associated with the corresponding pixel. Each element is an inte
between 0 (black) and 255 (white).

READRGB(file) Create a matrix in which the color information in file is represented 
by the appropriate values of red, green, and blue. This matrix 
consists of three submatrices, each with the same number of 
columns and rows. Three matrix elements, rather than one, co
spond to each pixel. Each element is an integer between 0 and 
The three corresponding elements, when taken together, estab
the color of the pixel.

You must use all uppercase letters to type these function names; alternatively, ch
Function from the Insert menu and double-click on the function name in the scrollin
list. 

The argument you supply to READBMP or READRGB is a string expression—or a 
variable to which a string is assigned—as described in “Arguments to file access
functions” on page 454. The string can correspond to either:

■ the name of a bitmap (BMP format) file in the working directory of the Mathcad 
worksheet you’re currently working on; or

■ a full or relative path to a bitmap file located elsewhere on a local or network 
system.

Each function returns a matrix of numbers used to represent the image. 

For example, to create a matrix M  of numbers corresponding to the image in the col
image file data2.bmp , type either 
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M:=READBMP("data2.bmp")  or

M:=READRGB("data2.bmp")

In the first case M  will be a grayscale representation of the image; in the second, M  
will consist of three submatrices corresponding to the red, green, and blue compo
of the color image.

As a second example, to read the grayscale image blur.bmp  in the C:\DATA  
directory into the matrix B, pass the following string expression to READBMP:

B:=READBMP("C:\DATA\blur.bmp")

See Chapter 8, “Variables and Constants,” for more information about creating s
expressions.

To divide the matrix for a color image into its red, green, and blue components, us
formulas shown in Figure 28-1 that use the submatrix function. In this example the 
color bitmap file monalisa.bmp  is read into a grayscale matrix gray as well as the 
packed RGB matrix packed and then converted into three submatrices called red, 
green, and blue.

Figure 28-1: Reading in a color image as both grayscale and packed RGB 
matrices.

Once you have read an image file into Mathcad, you can use the picture operator to 
view it. First click in a blank part of your worksheet and then:
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■ Choose Picture from the Insert menu. 

■ Type the name of the matrix in the place-
holder at the bottom left of the picture 
operator.

■ Click outside the picture region to see the 
image.

To display an image in color, you must provide the picture operator with the name
three matrices containing the red, green and blue color values of the image. Othe
the displayed image will be in grayscale. For example, to display the image in Fi
28-1, you would choose Picture from the Insert menu and type red,green,blue  
into the placeholder:

If you want to display only the red components of the image that was used for Fi
28-1, you still must include the green and blue submatrices, but they both should co
only zeros.

Keep in mind that the colors of the image that you ultimately see may be distorte
the extent that you don't display 256 colors on your monitor. 

If you have been working with submatrices for a color file, you can recombine th
by defining an augment3(X, Y, Z) function:

X, Y, and Z are the names of the submatrices and should have the same number o
and columns. The resulting matrix will then have the same number of rows as X but 
three times the number of columns. 

Once you finish processing a matrix, you may want to save it to disk for later use
do this, use one of the following functions:

augment3 X Y Z, ,( ) augment X augment Y Z,( ),( ):=
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Function Meaning

WRITEBMP(file) Create a grayscale BMP file from the matrix.

WRITERGB(file) Create a color BMP file from a matrix in which the image is stored
in RGB format.

You can use Mathcad’s augment function (or the augment3 function defined above) to 
combine submatrices at the time you are saving a file to your disk. For example,
following saves the submatrices that were created in Figure 28-1 as one 24-bit c
image file called nucolor.bmp :

WRITERGB("nucolor.bmp"):=augment(red,augment(green,blue))

WRITEBMP and WRITERGB each take a string expression as described in “Argume
to file access functions” on page 454. The string can correspond to either:

■ the name of a bitmap (BMP format) file in the working directory of the Mathcad 
worksheet you’re currently working on; or

■ a full or relative path to a bitmap file located elsewhere on a local or network 
system.

Additional image reading and writing functions

Pro In addition to the functions for reading and writing bitmap files described above, 
Mathcad Professional includes an assortment of more specialized functions for re
images or image components, including functions for reading images in GIF, JPG, and 
TGA formats. Your choice of which function to use will depend on:

■ Whether you want to create a Mathcad matrix in which the image is separated
red, green, and blue (RGB); hue, lightness, and saturation (HLS); or hue, saturation, 
and value (HSV) components.

■ Whether you want to read in the entire image or just one component (for exam
only the red values) of the image.

The functions used to read images work in exactly the same way as READBMP described 
in the previous section, but each recognizes images in the following formats: BMP, GIF, 
JPG, and TGA. Each function a string expression as described in “Arguments to fi
access functions” on page 454. The string can correspond to either:

■ the name of an image (BMP, GIF, JPG, or TGA format) file in the working directory 
of the Mathcad worksheet you’re currently working on; or

■ a full or relative path to an image file located elsewhere on a local or network
system.

Each function returns a matrix of numbers used to represent the image.
Reading and writing graphics files 589
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Function Meaning

Pro READ_IMAGE( file) Creates a matrix containing a grayscale representation of the im
in file. To read an image in color, use one of the functions belo

Pro READ_HLS( file)
READ_HSV(file)

Creates a matrix in which the color information in file is represent-
ed by the appropriate values of hue, lightness, and saturation (HLS) 
or hue, saturation, and value (HSV).

Pro READ_RED(file)   
READ_GREEN(file) 
READ_BLUE(file)

Extracts only the red, green, or blue component from a color 
image. The result has one-third the number of columns that th
matrix returned by READ_RGB would have had.

Pro READ_HLS_HUE( file)
READ_HLS_LIGHT(file)
READ_HLS_SAT(file)

Extracts only the hue, lightness, or saturation component from
color image. The result has one-third the number of columns t
the matrix returned by READ_HLS would have had.

Pro READ_HSV_HUE(file)
READ_HSV_SAT(file)
READ_HSV_VALUE(file)

Extracts only the hue, saturation, or value component from a co
image. The result has one-third the number of columns that th
matrix returned by READ_HSV would have had.

In addition to the WRITEBMP and WRITERGB functions described in the previous 
section, Mathcad Professional has functions for creating color BMP files out of matrices 
in which the image is stored in HLS or HSV format. 

Function Meaning

Pro WRITE_HLS(file) Create a color BMP file out of a matrix in which the image is stored
in HLS format.

Pro WRITE_HSV( file) Create a color BMP file out of a matrix in which the image is stored
in HSV format.

Like WRITEBMP and WRITERGB, these functions each take a string expression as 
described in “Arguments to file access functions” on page 454. The string can co
spond to either:

■ the name of a bitmap (BMP format) file in the working directory of the Mathcad 
worksheet you’re currently working on; or

■ a full or relative path to a bitmap file located elsewhere on a local or network 
system.

To use these functions, you write an assignment expression with the left-hand s
containing the call to the WRITE_HLS or WRITE_HSV function and the right-hand side
containing a matrix expression. For example, to create the 24-bit color image file
process.bmp  in the current directory from matrices H, L , and S corresponding to 
the hue, light, and saturation components of the image, enter:

WRITE_HLS("process.bmp"):=augment(H,augment(L,S))
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Creating pictures

You can create a picture in a Mathcad worksheet in the following ways:

■ By using the picture operator and supplying it either the name of a Mathcad m
or the name of an external bitmap file as a string expression, or 

■ By pasting in a graphic image from another application via the clipboard. 

Creating a picture from a matrix

You can view any matrix in Mathcad as a picture by using the picture operator:

■ Click in a blank space in your Mathcad worksheet.

■ Choose Picture from the Insert menu.

■ Type the name of a matrix in the placeholder at the bottom of the operator.

This is most useful when you import graphics files into Mathcad as matrices as 
described in “Reading and writing graphics files” on page 586. For example, you
use the READBMP function to read a bitmap file into a matrix, and then use the pict
operator to see the picture in Mathcad. See the figure on page 588 for an examp

Creating a picture by reference to a bitmap file

To create a picture directly from a bitmap file without reading it first into a matrix, cl
in a blank space in your worksheet and then:

■ Choose Picture from the Insert menu to 
insert the picture operator. 

■ In the placeholder, type a string expres-
sion containing the name of a bitmap file 
in the current directory, or type a full 
path to a bitmap file.

■ Click outside the picture operator and the 
bitmap will appear in your worksheet.

Each time you open the worksheet or calculate the worksheet, the bitmap file wi
read into the picture operator. If you modify the source bitmap file, you must recalcu
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your worksheet to see the modified image. If you move the source bitmap file, Mat
will not be able to display the picture.

Importing graphic images from the clipboard

You can copy any image from another application to the clipboard and paste it in
Mathcad in one of the formats put on the clipboard at the time of copying. If you 
the Paste command on Mathcad’s Edit  menu to paste in an image from the clipboar
(or use drag-and-drop from another application), you will often paste a linked OLE 
object into your Mathcad worksheet, as discussed in Chapter 4, “Worksheet Man
ment.” When you double-click on a linked OLE object, you activate the application tha
created the object and are able to edit the object in your Mathcad worksheet.

This section describes using the Paste Special command on the Edit  menu to paste 
graphic images into Mathcad worksheets in noneditable formats: as pictures (meta) 
or bitmaps. A metafile, which is strictly a Windows graphic format, can be resize
Mathcad without undue loss of resolution, whereas a bitmap is usually viewed bes
at its original size. A device-independent bitmap, or DIB, is stored in a bitmap format 
that is portable to other operating systems.

To paste a graphics image from the clipboard into Mathcad, do the following:

■ Place the graphics image on the clipboard, usually via a Copy command on the Edit  
menu. Many Windows applications have this feature.

■ Click the mouse wherever you want the image in your Mathcad worksheet.

■ Choose Paste Special from the Edit  menu, and choose one of the available forma
If you do not wish to paste a linked OLE object, choose “Picture (metafile)” or 
“Device Independent Bitmap” from the list in the Paste Special dialog box.

■ Click “OK.” Mathcad creates a picture region and puts into it the image stored
the clipboard.

The format choices in the Paste Special dialog box will vary, depending on the 
application from which you originally copied a selection. 

Mathcad stores the color depth—the number of colors in the image—at the time
paste it into a worksheet. This means that you can safely resave any worksheets
contain color images on systems that have different color displays, either fewer or 
colors. The images will continue to display at the proper color depth on the syste
that created the worksheets.

When you import directly from the clipboard, the picture information is stored as p
of the Mathcad worksheet. This makes the document take up more disk space. I
means that when you copy the worksheet, the picture information travels along w
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Formatting pictures

As discussed in previous sections of this chapter, you create pictures in a Mathc
worksheet from matrices, bitmap files, or graphic images pasted from the clipboa
This section describes your options for formatting a picture once you’ve created 

Resizing pictures

To resize a picture region, do the following:

■ Click the mouse inside the picture region to select it.

■ Move the mouse pointer to one of the handles along the edge of region. The po
will change to a double-headed arrow.

■ Press and hold down the left mouse button. With the button still held, drag the m
in the direction you want the picture region to be stretched.

When you change the size of the picture region, the picture inside may be distort
you resize the picture by dragging diagonally on the handle in the lower right cor
you will preserve the aspect ratio—the ratio of height to width—of the original pictu

You can also avoid distortion by restoring the original size of the picture region:

■ Double-click on the picture itself, or choose Properties from the Format menu. 
This brings up the Properties dialog box.

■ Click on the box labeled “Display at Original Size.”

■ Click the “OK” button. Mathcad changes the size of the picture to match that of
original image.

Framing a picture

Mathcad allows you to place a border all the way around a picture region. To do 

■ Double-click on the picture itself, or choose Properties from the Format menu. 
This brings up the Properties dialog box.

■ Click on the box labeled “Show Border.”

■ Click the “OK” button. Mathcad draws a border around the picture region.

Deleting and moving pictures

Use the Edit menu commands to cut, delete, or copy a picture region.

To cut or delete a picture region:

■ Click inside the region to select it. This will place a selection box around the pic

■ Press [Ctrl ]X or choose Cut from the Edit  menu. Choose Delete from the Edit  
menu to leave the clipboard unaffected.

To copy a picture region:
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■ Click inside the region to select it. This will place a selection box around the pic

■ Press [Ctrl ]C or choose Copy from the Edit  menu.

■ Click the mouse wherever you want to place a copy of the region and press [Ctrl ]V 
or choose Paste from the Edit  menu.

To move a picture region:

■ Click inside the region to select it. This will place a selection box around the reg

■ Place the pointer on the border of the box. The pointer will turn into a small h

■ Press and hold down the mouse button.

■ Without letting go of the button, move the mouse to where you’d like the pictu
region. 

Note that unlike some applications, Mathcad treats the picture region and the im
within it as a single region, not as separate frames. Therefore, when you press [Ctrl ]C 
or [Ctrl ]X, Mathcad places both the image and the picture region into the clipbo

Controlling color palettes

If you are using a 256-color display and have color bitmaps in your Mathcad wor
sheets, Mathcad by default uses a single 256-color palette to display all the bitma
your worksheets. This is the same default color palette Mathcad uses for displayin
rest of the Mathcad screen, and is suitable for most pictures. 

This default color palette, however, may not be the exact one that any color bitma
a worksheet were designed to use. To improve the appearance of bitmaps in yo
worksheet, you can tell Mathcad to optimize its default color palette so that it cho
the best possible 256 colors to display bitmaps in the worksheet. To do so:

■ Choose Color ⇒Optimize Palette from the Format menu. Now Mathcad will 
survey the pictures in the worksheet and generate an optimal 256-color palet
use for all of them. 

■ Make sure that Color ⇒Use Default Palette in the Format menu has a check mark.
Then Mathcad will use the new default palette it generates. 

If you don’t want Mathcad to use one color palette for all color bitmaps, choose Color 
⇒Use Default Palette in the Format menu. The check mark next to this option wil
be removed, and Mathcad will use whatever color palette is best for each picture
disadvantage to unchecking Use Default Palette is that the screen may flash as you
scroll through a Mathcad worksheet and each 256-color bitmap loads a new pale
We therefore recommend that you keep a check mark next to the Color ⇒Use Default 
Palette option in the Format menu if you are working in 256-color mode. 

If your display driver supports a greater number of colors, the palette setting opti
on the Format menu are grayed out.
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