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Chapter 20
Graphs 

Mathcad graphs are both versatile and easy to use. To create a gra
click where you want to insert the graph, choose Graph⇒X-Y Plot from 
the Insert menu, and fill in the placeholders. You can modify the form
extensively, including reformatting the axes and curves and using a
variety of different types of labels.

The following sections describe the use of Mathcad graphs:

Creating a graph
Basic steps in creating and editing a graph. QuickPlots versus graphs w
you explicitly specify the range of values over which to plot.

Graphing functions
Procedures for graphing functions.

Graphing a vector
Procedures for graphing vectors.

Graphing more than one expression
Procedures for creating graphs with multiple traces.

Formatting the axes 
Procedures for modifying the formats of the x- and y-axes.

Formatting individual curves 
 Procedures for modifying the formats of curves or traces in a graph.

Setting default formats 
 Procedures for using default format settings.

Labeling your graph
Procedures for working with titles, axis labels, and other labels.

Modifying your graph's perspective 
Procedures for changing the size of the graph, zooming in on a portion o
graph, and finding coordinates in it.

Gallery of graphs
A set of sample graphs illustrating options for creating graphs.
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Creating a graph

You create X-Y graphs in Mathcad using the X-Y plot operator. The X-Y plot operator, 
like other Mathcad operators, has placeholders for you to fill in that specify express
to be computed and displayed.

You can insert the X-Y plot operator into your worksheet in one of three ways; altho
these methods are equivalent, only the first is mentioned in the rest of this chapter.
in your worksheet where you want your graph to appear and either:

■ Choose Graph⇒X-Y Plot  from the Insert menu; or

■ Press the @ key; or

■ Click on the X-Y Plot button in the Graph Palette.

The X-Y plot operator is very flexible, letting you either:

■ Create a QuickPlot based only on one or more expressions of a single variable,
dependent variable. Once you have entered the expression(s) in the placehol
the y-axis, Mathcad automatically creates the plot over a range of –10 to 10 fo
dependent variable on the x-axis.

■ Explicitly enter expressions on both the y-axis and x-axis that specify the range of
values over which to plot. Usually these expressions depend on range variable
have previously defined in your worksheet. If the range variables aren’t previo
defined, Mathcad will generate appropriate range variables for the plot.

This section outlines the difference between these two uses of the X-Y plot oper
The sections “Graphing functions” on page 468, “Graphing a vector” on page 469
“Graphing more than one expression” on page 474 describe the kinds of expres
you can plot in greater detail. See “Formatting the axes” on page 476 and “Forma
individual curves” on page 482 for an introduction to Mathcad’s plot formatting 
options.

QuickPlots

You can quickly and easily create X-Y graph from a single Mathcad expression. T
so:

■ Enter the expression or function of a 
single variable you want to plot. Make 
sure the editing lines remain in the ex-
pression. 
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■ Choose Graph⇒X-Y Plot  from the In-
sert menu.

■ Press [Enter ] or click away from the 
graph. 

Mathcad automatically produces a plot over a default range of the dependent va
on the x-axis: –10 to 10. You can change the axis range by editing the upper and l
limits on the x-axis. See “Setting limits for axes” on page 478.

To graph more than one expression using a QuickPlot:

■ Enter the expressions or functions of a 
single variable you want to plot, separat-
ed by commas. Make sure the editing 
lines remain in the expression.

■ Choose Graph⇒X-Y Plot  from the In-
sert menu.

■ Press [Enter ] or click away from the 
graph.

Mathcad produces a plot of all the expressions or functions, again over a range o
to 10. You can change the axis range by editing the upper and lower limits on thx-
axis as described in “Setting limits for axes” on page 478.

Notice that you can create a QuickPlot in one of two ways. You can either:

■ First type the expression(s) and then choose Graph⇒X-Y Plot from the Insert 
menu, in which case your expression appears automatically in the y-axis placehold-
er; or

■ First choose Graph⇒X-Y Plot  from the Insert menu and then enter the expres-
sion(s) in the y-axis placeholder.

Explicitly specifying the range on the x-axis

When you want to specify the x-axis argument or the range variable used, you can cre
a graph following these steps:

■ Click in your worksheet wherever you want the graph to appear. 

■ Choose Graph⇒X-Y Plot  from the Insert menu. Mathcad creates an empty grap
with six placeholders, three on each axis.
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To see the graph, fill in the placeholders: 

■ The placeholder at the middle of the horizontal axis holds the variable or expres
to graph against. Enter a range variable, a subscripted variable, or any other
expression involving a range variable in this placeholder.

■ The placeholder at the middle of the vertical axis holds an expression to graph. 
a range variable, subscripted variable, or any other expression involving the r
variable on the horizontal axis.

■ The other four placeholders can be used to override Mathcad's automatic cho
of axis limits. For more information about axis limits, see “Setting limits for axe
on page 478.

Mathcad graphs one point for each value of the range variable. If you don’t define
range variable in your worksheet, as described above, Mathcad automatically gen
an appropriate range for the dependent variable in your plot. Range variables ar
discussed in Chapter 11, “Range Variables.”

Graphs typically have one or more expressions involving range variables on each
Be aware that it's usually an error to use two different range variables in the same c
or trace, on a graph. If you use two range variables in the same trace, Mathcad tri
graph one point for each value of each range variable. For example, if i ranges through 
20 points and j through 30, and you try to plot yi against xj, Mathcad tries to graph a 
total of 600 points. It is, however, permissible to use different range variables in 
different traces on the same graph.

Just as with an equation, Mathcad does not process a graph until you click outsid
graph region. When Mathcad processes the graph, it draws one point for each va
each range variable in the x or y axis expressions and, unless you specify otherwise
connects them with straight lines. 

Figure 20-1 shows some typical graphs with the placeholders filled in. Note the l
that appears under the y-axis arguments. This indicates the trace type and color use
display the curve. See the section “Formatting individual curves” on page 482 to l
how to control this.

The graph in the upper left corner of Figure 20-1 is an example of a parametric plot: 
one in which the expressions you are plotting on the x-axis and y-axis are both functions 
of a single variable. If you do not explicitly define a range variable for the parame
in such a plot, Mathcad uses a default range for this variable to create the graph
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Figure 20-1: X-Y graphs of expressions, functions, and vectors.

If an expression is complex, Mathcad graphs only the real part. The imaginary p
ignored. Note that no error message will be displayed.

Working with graph regions

You can drag, cut, copy, and paste a graph just as you would any other math re
See Chapter 3, “Editing Equations,” for details. 

To delete a graph from your worksheet:

■ Press and hold down the mouse button just outside the plot.

■ With the button still pressed, drag the mouse cursor so as to enclose the gra
region in a selection rectangle.

■ Choose Cut from the Edit menu.

To move a graph, follow the instructions above for deleting it. Then click the mou
wherever you want the graph and choose Paste from the Edit menu. Alternatively, you 
can drag a plot as you would an equation. 

See “Modifying your graph's perspective” on page 488 for Mathcad’s options for
resizing graphs, zooming in on graphs, and reading coordinates from graphs.
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Graphing functions 

Each trace on a graph depends on a range variable, and Mathcad graphs one po
each value in the range variable. As mentioned in the previous section, however
Mathcad automatically generates a default range for the dependent variable of a
expression you type in the y-axis and creates the graph over it if you do not explicit
define a range variable.

If you want to specify exactly what range of values the range variable has, you c
define a range variable in your worksheet. This method is described in the follow
sections.

Graphing a function 

To graph a function over a range, as shown in Figure 20-2, do the following:

■ Define a range variable, such as x, that ranges over the values you want to grap
(The range variable need not be called x; you can use any valid Mathcad name.) 
See Chapter 11 for instructions on defining a range variable.

■ Type the expression you want to plot in the middle placeholder of the y-axis and 
type x in the middle placeholder of the x-axis.

■ Click anywhere outside the graph region to see the plot. 
 

Figure 20-2: Graphing an expression against a range variable.
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You can also define a function f(x) and place it in the middle placeholder of the y-axis. 
This is particularly useful when the expression you want to plot becomes large a
unwieldy. The second graph in Figure 20-2, above, shows the same plot as the 
graph in the figure, except that it is made with a function definition.

Using functions for polar plots

By creatively using the tools presented in this chapter, you can plot a wide variet
closed curves. The example in Figure 20-3 illustrates how to transform polar into
rectangular coordinates. This technique lets you create polar plots, or even paths
complex plane. In Figure 20-3, the equation for the cardioid in polar coordinates
given by r(θ). The equations for x(θ) and y(θ) are the usual transformation from pola
to rectangular coordinates. See Chapter 21, “Polar Plots,” for a description of Math
built-in polar plotting capabilities. 

Figure 20-3: Two functions computed independently.

Graphing a vector 

To graph the elements of a vector, you need to use the vector subscript operato
specify which elements to plot. A graph of a vector is shown in Figure 20-4. To cr
this graph, do the following:

■ Define a range variable i that references the subscript of each element you wan
plot. 
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■ Define a vector . Use the left bracket key, [ , to create the subscript.

■ Press @ to create an empty plot region.

■ Place  in the middle placeholder of the vertical axis and i in the middle placeholder 
of the horizontal axis.

■ Click anywhere outside the graph region to see the plot.

A graph created using these steps is shown in Figure 20-4. 

Figure 20-4: Graphing a vector.

Subscripts must be non-negative integers (or integers greater than or equal to ORIGIN, 
if ORIGIN≠0.) Τhis means that the x-axis variable used in a graph like Figure 20-4 ca
run through whole-number values only. If you want to graph fractional or negativ
values on the x-axis, graph a function as in Figure 20-2, or graph two vectors as 
described in the next section.

If you have a handful of data points that don't have a convenient functional relation
as in Figure 20-4 but there are too few of them for you to use data files, you might 
to use an input table to create a vector. For more information, see “Entering data
manually” on page 435.

Graphing one vector against another 

To graph all the elements of one vector against all the elements in another, ente
names of the vectors in the x- and y-axis placeholders on the graph. For example, to
create the first graph shown in Figure 20-5:

■ Define x and y as shown in the figure.

yi

yi
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■ Press @ to create an empty graph region.

■ Place  in the middle placeholder of the y-axis and  in the middle placeholder o
the x-axis.

■ Click anywhere outside the graph region to see the plot.

Mathcad plots all the elements in the vector x against the elements in the vector y. If 
the vectors are not the same length, Mathcad will plot the number of elements in
shorter vector. 

In some cases, you may prefer to explicitly tell Mathcad which elements of the vec
to plot. This is useful when you want to only plot some of elements. To plot certa
elements as opposed to all of them, you must define a range variable and use it
subscript on the vectors. The subscript references the elements to graph. A grap
produced using this method is shown in Figure 20-1. The vectors do not need to b
same length. The only requirements are: 

■ The two vector must share the same subscript. For example, you cannot plot
against  because i and j are not the same subscript.

■ Each value of the subscript must correspond to an element in each vector. F
example, if x has only two elements and y has eight elements, and the range variab
goes from 0 through 7, you will get an error.

To create the plot shown in the bottom right of Figure 20-1, do the following:

■ Define a range variable t that references on the subscript of each element you w
to plot. 

■ Define the arrays  and . Use the left bracket key, [ , to create the subscript.

■ Press @ to create an empty graph region.

■ Place  in the middle placeholder of the y-axis and  in the middle placeholder
of the x-axis.

■ Click anywhere outside the graph region to see the plot.

y x

xi
yj

vxt vyt

vyt vxt
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Figure 20-5: Graphing two vectors.

Although the x vector in Figure 20-5 is a list of evenly spaced values, this need no
the case. Only the i values are required to be evenly spaced integers. No such restric
exists for the . This allows you to plot something besides integers on the x-axis while 
still satisfying the requirement for integers as subscripts.

In Figure 20-5, the  came directly from the . Other applications might compux 
and y independently from a third variable. As long as the two vectors use the sam
range variable, you can graph them on the same graph. Figure 20-6 shows a polar
in which both x and y depend on the variables r and θ. Figure 20-6 uses vectors to do
what was done with functions in Figure 20-3. 

xi

yi xi
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Figure 20-6: Two vectors computed independently.

Note that in Figure 20-6, the range variable i must have integer values and must be us
to define a vector, namely θ, of equally spaced non-integer values. In Figure 20-3, 
however, we could define θ directly as a range variable. This is because functions 
not require integer arguments the way vectors require integer subscripts.

Graphing data

You don't have to use Mathcad to generate the vectors that you plot, as was don
the example in Figure 20-5. You can create vectors by reading in data from a dat
by pasting in the data from the clipboard, or by typing data directly into an input ta
These techniques are described in Chapter 19, “Data Management.” Once you c
vectors from data—for example, by extracting columns from a matrix—you can p
the vectors just as you would plot any vectors, as discussed in the previous section
Figure 20-7 for an example of plotting vectors from data imported from an externa
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Figure 20-7: Plotting vectors from imported data.

Graphing other expressions

The examples in Figure 20-2 through Figure 20-7 show some of the most comm
types of graphs. However, graphs are not limited to these examples. You can grap
expression against any other expression, as long as they share the same range va
For example, see Figure 20-12 for an example of graphing a constant to be used
marker on the graph of another function.

Graphing more than one expression 

You can graph several traces on the same graph. A graph can show several y-axis 
expressions against the same x-axis expression, or it can match up several y-axis 
expressions with corresponding x-axis expressions. One way to graph several expr
sions is to create a QuickPlot as described in the first section of this chapter. 

Alternatively, you can graph several y-axis expressions versus one x-axis expression, 
using a conventional graph. To do so, choose Graph⇒X-Y Plot from the Insert menu 
and enter the first y-axis expression in the y-axis placeholder followed by a comma. 
You'll see a placeholder immediately below this first expression. Enter the secon
expression here, followed by another comma to get another empty placeholder. 
the next expression. All the expressions should use the same range variable, as 
in Figure 20-8.
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Figure 20-8: Graph with multiple y-axis expressions.

To graph several independent curves on the same set of axes, enter two or mor
expressions separated by commas on the x-axis and the same number of expression
on the y-axis. Mathcad matches up the expressions in pairs—first x-axis expression 
with first y-axis expression, the second with the second, and so on. It then draws a
for each pair. Each matching pair of expressions should use the same range var
The range variable for one pair need not match the range variables for the other

You can plot up to 16 arguments on the y-axis against 1 argument on the x-axis. 

Figure 20-9 shows an example in which the range variables differ for each pair. 
however, that all traces on a graph share the same axis limits. For each axis, all
expressions and limits on that axis must have compatible units.
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Figure 20-9: Graph with multiple expressions on both axes.

Formatting the axes 

You can reformat your graph's axes, using the X-Y Axes page of the Formatting
Currently Selected X-Y Plot dialog box. 

To change a graph's format:

■ Click in the graph to select it.

■ Double-click in the graph. Alternatively, choose Graph⇒X-Y Plot  from the 
Format menu. You'll see the dialog box for formatting X-Y plots. 

■ If necessary, click the X-Y Axes tab to display the X-Y Axes page, shown bel

■ There is a complete group of settings for each axis. Change the appropriate se

■ Click “OK” to accept your changes and close the dialog box. Mathcad redraws
graph with the new settings in effect. Alternatively, click “Apply” to see the gra
redrawn without closing the dialog box. Click “Close” to close the dialog box.
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If you initiate this process by double-clicking on an axis, you'll see an equivalent di
box for that axis alone.

The rest of this section describes the settings on the X-Y Axes page of the dialog
for formatting X-Y Plots. It then provides detailed discussions about options for se
axis limits and for adding horizontal and vertical reference lines to your graph.

Axis settings

Each axis has the following settings associated with it:

Log Scale
When this box is checked, the selected axis is logarithmic and the axis limits m
be positive. The bottom-right-hand graph in Figure 20-16 on page 493 illustrat
graph with a logarithmic axis.

Grid Lines
When this box is checked, the tick marks on the selected axis are replaced by
lines. The top-right-hand graph in Figure 20-16 on page 493 illustrates a graph
uses grid lines rather than tick marks.   

Numbered
When this box is checked, the tick marks on the selected axis are numbered.

Autoscale
This controls axis limits that you don't otherwise specify. When this box is chec
Mathcad rounds the axis limit to the next major tick mark. When unchecked, 
Mathcad sets the axis limit to the data limit. For a discussion of Autoscale and
other ways to set axis limits, see “Setting limits for axes” later in this section. 

Show Markers
When this box is checked, you can add reference lines to your graph. For a 
discussion of Show Markers and another way to create horizontal and vertica
reference lines, see “Adding horizontal and vertical lines” later in this section.

Auto Grid
When this box is checked, Mathcad automatically selects the number of grid 
Formatting the axes 477
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intervals created by tick marks or grid lines on the axes. When the box is unche
you choose the number of grid intervals by typing in the box labeled “No. of Grid
Enter a number from 2 to 99. You can specify the number of grid intervals on
when Log Scale is unchecked. Figure 20-21 on page 495 illustrates the effec
Auto Grid. 

In addition to these check boxes, the X-Y Axes page contains the following:

No. of Grids
When available, this text box indicates the number of grid intervals on the assoc
axis. You can enter a number between 2 and 99, inclusive. This box is only avai
when Auto Grid and Log Scale are unchecked.

Axes Style
These buttons define the style in which the graph will show the axes. Boxed a
are crossed in the bottom left corner of the graph. Crossed axes are crossed
center of the graph. If you select None, no axes will be displayed on the grap
Figure 20-22 on page 496 illustrates the use of crossed axes. If you choose E
Scale, both axes will use the same limits.

See the section “Setting default formats” on page 483 to learn how to:

■ Quickly restore the graph to its default format settings.

■ Use a particular graph as a model for all future graphs.

Setting limits for axes

Mathcad provides the following ways to set limits for axes:

■ Automatically, with Autoscale turned on.

■ Automatically, with Autoscale turned off.

■ Manually, by entering the limits directly on the graph.

By default, a plot you create in Mathcad is autoscaled. With Autoscale on, Mathc
automatically sets each axis limit to the first major tick mark beyond the end of th
data. This will be a reasonably round number large enough to display every point b
graphed. With Autoscale off, Mathcad automatically sets the axis limits exactly at
data limits. 

Figure 20-10 shows how turning Autoscale on and then off changes the way the g
looks.
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Figure 20-10: The effects of having Autoscale turned on and off.

To turn Autoscale off and have the axis limits automatically coincide with the end
the data:

■ Click on the graph to select it and then choose Graph⇒X-Y Plot  from the Format 
menu. Mathcad displays the dialog box for formatting X-Y graphs, shown on 
page 476. Click the X-Y Axes tab if the X-Y Axes page is not displayed. (You c
also double-click on the axis itself to see a similar dialog box.) 

■ Click on Autoscale for the appropriate axis to remove the check and to toggle
Autoscale off. 

You may want to use axis limits other than those set by Mathcad. You can overr
Mathcad's automatic limits by entering limits directly on the graph. To do so:

■ Click the graph to select it. Mathcad displays four additional numbers, one by e
axis limit. These numbers are enclosed within corner symbols, as illustrated in
selected plot in Figure 20-11. 

■ To set the axis limit on the horizontal axis, click on the number underneath th
appropriate x-axis limit and type the number at which you want the axis to end. 
set an axis limit for the vertical axis, do the same thing to the number to the le
the appropriate y-axis limit.

■ Click outside the graph. Mathcad redraws it using the axis limits you specified. 
corner symbols below the limits you changed will disappear. Figure 20-11 sh
the effect of manually setting limits on a graph.
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Figure 20-11: Data limits set manually and automatically.

Adding horizontal and vertical lines 

Mathcad places linearly or logarithmically spaced tick marks or grid lines on a gra
The spaces between these markings are relatively round numbers that span the
of values on each axis. There may, however, be occasions when you need to pla
line somewhere other than where Mathcad would normally place a grid line. 

To add a horizontal or vertical line to a plot:

■ Click in the plot to select it.

■ Choose Graph⇒X-Y Plot  from the Format menu or double-click on the graph to
bring up the dialog box for formatting X-Y graphs.

■ If necessary, click on the X-Y Axes tab to display the X-Y Axes page, as shown
page 476.

■ For a vertical line, click on Show Markers in the X-axis column to add a check;
a horizontal line, click on Show Markers in the Y-axis column to add a check. C
“OK”. Mathcad shows two additional placeholders on each axis for which you h
Show Markers checked. 

■ To add a vertical line, click on one of the placeholders under the x-axis and type in 
a value at which you want a line drawn. For a horizontal line, do the same thin
one of the placeholders under the y-axis.

When you click outside the graph, Mathcad draws a dashed line at each numbe
specify. The number you type appears at the end of the line. To move the dashe
480  Chapter 20  Graphs



his 

 lines 
eed 
tant 

f the 

ession 
e 

 

nt 
click on the number in the placeholder and change it. To delete the line, delete t
number or click on Show Markers for the appropriate axis to uncheck it.

By using the Show Markers function, you can add to each axis one or two dashed
stretching across the plot. When you need to place more than two lines or you n
more control over the appearance of a line, you can add lines by plotting a cons
expression.

■ To create a horizontal line, place a range variable on the middle placeholder o
x-axis and the constant expression on the y-axis. Mathcad will plot a horizontal line 
across the plot at whatever value the constant value happens to be. The expr
you place on the y-axis need not depend on the range variable you place on thx-
axis.

■ To create a vertical reference line, reverse the roles of the x- and y-axes. Place a 
range variable on the middle placeholder of the y-axis and the constant expression
on the x-axis.

Figure 20-12 compares graphs having reference lines created by plotting consta
expressions and by using the Show Markers option.

Figure 20-12: Graphs with reference lines.
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Formatting individual curves 

You can reformat the traces on your graph, using the Traces page of the dialog b
formatting X-Y graphs.

To reformat a graph's traces:

■ Click in the graph to select it.

■ Double-click in the graph. Alternatively, choose Graph⇒X-Y Plot  from the 
Format menu. Mathcad displays the dialog box for formatting X-Y graphs.

■ If necessary, click the Traces tab to display the Traces page.

■ Click on the line in the scrolling list box for that trace. To change the name of
trace, type the new name in the text box under the “Legend Label” column. T
change the symbol or marker, line type, color, trace type, or line weight of this tr
click on the arrow beside each text box to see a drop-down list of options, and
click on the option you want. See the next section, “Trace settings,” for comp
explanations of the various options in these lists.

■ Click “OK” to accept your changes and close the dialog box. Mathcad redraws
graph with the new settings in effect. Alternatively, click “Apply” to preview you
changes without closing the dialog box.

Trace settings

A graph can have up to sixteen individual traces. Each trace is described by a lin
the scrolling list. Mathcad uses these lines as needed, assigning one for each tra
your graph. Each line has six fields: 

Legend Label
This is the name of the trace as it would appear in the legend beneath the plo
the section “Displaying or hiding arguments and legends” on page 488 for mo
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information about legends. 

Symbol
This controls whether each point on the curve is marked with a symbol. You 
mark each point with either an “×,” a “+,” a hollow box, a hollow diamond, a circle,
or no symbol at all. If you have a lot of points packed closely together, you sho
probably select “none.” Figure 20-19 on page 494 shows an example in which 
data point is marked by with an “×.” 

Line
This controls whether the line is solid, dotted, dashed, or whether it consists 
alternating dashes and dots. This feature provides a useful way to distinguish
unmarked curves in black and white printouts.

Color
This controls whether the selected trace is red, blue, green, magenta, cyan (a
blue), brown, black, or white. Mathcad ignores this on monochrome displays.

Type
This controls the type of trace that will be displayed. Mathcad can generate th
following types of plots: curves, bar graphs, stepped curves, error bars, stem gr
and points. Figure 20-17 on page 493 has examples of step graphs and erro
Figure 20-18 on page 494 has examples of stem graphs and bar graphs.

Weight
This controls the weight or thickness of the trace. Select from 1 to 9 (thinnest
thickest). Select “p” for a trace that is one device pixel wide. Although this ma
look like weight 1 on your screen, a high resolution printer will print it as a ver
fine line. This field also controls the size of the symbols marking data points, if 
have selected a symbol other than “none”. If you have selected trace type po
this field sets the weight of the dot plotted at each data point.

See “Setting default formats” on page 483 to learn how to:

■ Quickly restore the graph to its default format settings.

■ Use a particular graph as a model for all future graphs.

In addition to the scrolling list and its associated text box and lists, the Trace pag
two check boxes: Hide Arguments and Hide Legend. These are explained fully in
“Displaying or hiding arguments and legends” on page 488.

Setting default formats

Mathcad uses default settings to format the axes and traces of new graphs as you
them. You can change these defaults in two ways:

■ By saving as defaults the settings of your current graph. 
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■ By using the Setting Default Formats for X-Y Plots dialog box, if you don't wa
to use an existing graph.

Changing defaults only affects new graphs; previously existing graphs are unaffe

Copying defaults from an existing graph

One way to create a new set of defaults is to use the format settings of an existing g
The advantage of this method is that you can actually see how the format settings
as you define them.

To use the format of a particular graph as the default graph format:   

■ Click in the graph to select it.

■ Choose Graph⇒X-Y Plot from the Format menu or double-click on the selected
graph. Mathcad displays the dialog box for formatting X-Y graphs. If necessa
click on the Defaults tab to see the Defaults page. 

■ If the Use for Defaults check box doesn't contain a check, click on it to add on
When you close the dialog box, Mathcad saves these settings as your defaul
settings.

 

Setting defaults without using a graph

You don't have to use an existing graph to create or revise default formats. Instead
can use the X-Y Axes page on the dialog box for setting X-Y plot defaults. To se
defaults this way:

■ Make sure that you don't have any graphs selected.

■ Choose Graph⇒X-Y Plot  from the Format menu. You'll see the dialog box for 
setting X-Y graph defaults. The following figure shows an example of this dia
box with the X-Y Axes page displayed. 

■ Change the appropriate settings on the X-Y Axes and Traces pages.

■ Click “OK” to accept your changes and close the dialog box.
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Using default graph settings

If you want to reverse the format changes that have been made to a graph since
created, you can restore its original default settings. To restore the original defau

■ Click the Defaults tab on the dialog box for formatting X-Y graphs. (See the fig
on page 484.)

■ Click “Change to Defaults.”

■ Click “OK” to close the dialog box.

Mathcad redraws the graph, using the default format settings that were in place 
the graph was first created. 

Labeling your graph

Mathcad provides several ways to help you to identify what it is that you've plotte
You can choose to display: 

■ A title, either above or below the graph.

■ Axis labels to describe what's plotted on each axis.

■ Legends to identify the individual traces.

■ Arguments showing what you typed into the x- and y-axis place holders.

Figure 20-13 shows the relative locations of each of these types of labels on a b
axes graph and on a crossed axes graph.
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Figure 20-13: Graphs with different labels.

You can use these labels all together or in any combination. By default, Mathcad s
neither title nor axis labels, displays the arguments, and hides legends.

Working with titles 

To add a title to a graph, follow these steps:

■ Click in the graph to select it.

■ Choose Graph⇒X-Y Plot from the Format menu or double-click on the selected
graph. Mathcad displays the dialog box for formatting X-Y graphs. If necessa
click on the Labels tab. 

■ Type a title for your graph into the Title text box. 

■ Click on either the Above or Below button, depending upon where you want to
the title. Note, however, that Mathcad doesn't display the title until you click 
“Apply” or close the dialog box.

■ Make sure that the Show Title check box is checked. If it isn't, Mathcad still 
remembers the title but won't display it.

■ Click “OK” to accept your changes. Mathcad redraws the graph with the title 
place. Alternatively, click “Apply” to preview your title without closing the dialog
box.
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To edit a graph's title, follow these steps:

■ Click in the graph to select it.

■ Choose Graph⇒X-Y Plot from the Format menu or double-click on the selected
graph. Mathcad displays the dialog box for formatting X-Y graphs. If necessa
click the Labels page. (You can also double-click on the title itself to display a
equivalent dialog box.) 

■ Edit the information for the title as appropriate or backspace over the title to dele

■  Click “OK” to close the dialog box.

Labeling axes on a graph 

You can also label one or both axes of a graph in much the same way as you add
to a graph. The x-axis label appears directly below the x-axis, and the y-axis label 
appears just to the left of the y-axis. To label an axis, follow these steps:

■ Click in the graph to select it.

■ Choose Graph⇒X-Y Plot from the Format menu or double-click on the selected
graph. Mathcad displays the dialog box for formatting X-Y graphs. If necessa
click on the Labels tab to see that page, as shown in the preceding section.

■ Type the axis labels into the appropriate text boxes. 

■ To save the label name without having it appear on the graph, click X-Axis or
Axis to remove the check.

■  Click “OK” to accept your changes and close the dialog box. Mathcad redraws
graph with the new settings in effect. Alternatively, click “Apply” to preview you
changes without closing the dialog box.

To edit an axis label, follow these steps:

■ Click in the graph to select it.

■ Choose Graph⇒X-Y Plot from the Format menu or double-click on the selected
graph. Mathcad displays the dialog box for formatting X-Y graphs. If necessa
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click the Labels page. (You can also double-click on the label itself to display
equivalent dialog box.)

■ Edit the information for the title as appropriate.

■ To remove a label, delete it from the text box.

■ Click “OK” to close the dialog box.

Displaying or hiding arguments and legends

Mathcad provides both arguments and legends for identifying specific traces on a g

■ Arguments are the expressions that you typed into the placeholders of the x- and y-
axes to create the graph. By default, Mathcad displays arguments.

■ Legends are labels that appear underneath the graph containing a name and
example of the line and symbols used to draw the trace. By default, legends 
hidden.

To display or hide arguments and legends:

■ Click on the graph to select it. 

■ Choose Graph⇒X-Y Plot  from the Format menu or double-click on the graph. 
Mathcad displays the dialog box for formatting X-Y graphs, as shown below. 
necessary, click on the Traces tab. 

■ To suppress the display of the arguments, click on Hide Arguments to add a c

■ To show the legend, click on Hide Legend to remove the check.

Modifying your graph's perspective

Mathcad provides options for manipulating the presentation of your graph:

■ You can resize the graph, making it proportionally larger or smaller or stretch
the x-axis or y-axis for emphasis.

■ You can zoom in on a portion of the graph.

■ You can get the coordinates for any point that was plotted to construct the gr

■ You can get the coordinates for any location within the graph.

The rest of this section shows how to use these features.

Resizing a graph

Resizing a graph is very much like resizing a window:

■ Click in the graph to select it.
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■ Move the mouse pointer to one of the three handles along the edge of the gr
The pointer will change to a double-headed arrow.

■ Press and hold down the mouse button and move the mouse in the direction
you want the graph's dimension to change.

■ Once the graph is the right size, let go of the mouse button. 

■ Click outside the graph to deselect it.

Note that when you change the size of a graph for which the Auto Grid is set, Mat
may add or delete tick marks or grid lines or change axis limits to maintain the de
spacing.

Zooming in on a graph 

Mathcad allows you to select a region of a graph and magnify it. To zoom in on a po
of a graph, follow these steps:

■ Click in the graph to select it.

■ Choose Graph⇒Zoom from the Format menu, or click on the Zoom button on 
the Graph Palette. The X-Y Zoom dialog box appears. 

■ If necessary, reposition the X-Y Zoom dialog box so that you can see the ent
region of the graph you want to zoom.

■ In the graph region, click the mouse at one corner of the region you want to mag

■ Press and hold down the mouse button and drag the mouse. A dashed selec
rectangle emerges from the anchor point.

■ When the selection rectangle just encloses the region you want to magnify, le
of the mouse button. If necessary, you can click on the selection rectangle, ho
mouse button down, and move the rectangle to another part of the graph.
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■ The coordinates of the selected region are listed in the Min: and Max: text box
the X-Y Zoom dialog box. Click the “Zoom” button to redraw the graph. The a
limits are temporarily set to the coordinates specified in the X-Y Zoom dialog b
To make these axis limits permanent, click “Accept.” 

Before you make these axis limits permanent, you can select another region to z
by enclosing another selection rectangle around a new region. Press “Unzoom” to
the zoom you've just made. If you're working with a graph that has already been zoo
you may want to view the original graph as it was before any zooming took place
do so, click on “Full View.”

Figure 20-14 shows the effects of zooming in on a portion of a graph.

Figure 20-14: A zoomed-in region of a graph.

Getting a readout of graph coordinates 

To see a readout of graph coordinates of the specific points that make up a trace, 
these steps:

■ Click in the graph to select it.

■ Choose Graph⇒Trace from the Format menu, or click on the Trace button on th
Graph Palette, to show the X-Y Trace dialog box.
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■ If necessary, reposition the X-Y Trace dialog box so that you can see the ent
region of the graph. Note that the Track Data Points check box is checked.

■ In the graph region, click and drag the mouse along the trace whose coordina
you want to see. A dotted crosshair jumps from one point to the next as you m
the pointer along the trace.

■ If you release the mouse button, you can now use the left and right arrows to m
to the previous and next data points. Use the up and down arrows to move to 
traces.

■ As the pointer reaches each point on the trace, Mathcad displays the x and y values 
of that point in the X-Value and Y-Value boxes.

■ The x and y values of the last point selected are shown in the X-Value and Y-Va
boxes. The crosshair remains until you click outside the graph. 

To copy a coordinate to the clipboard:

■ Click “Copy X” or “Copy Y”. You can then paste that value into a math region 
a text region on your Mathcad worksheet, into a spreadsheet, or into any oth
application that allows pasting from the clipboard. 

■ Double-click on the control box in the upper-left-hand corner to close the X-Y Tr
dialog box. The crosshair will remain on your graph until you click anywhere 
outside the graph or click the “Close” button.

To see a readout of graph coordinates for any location in a graph:

■ Follow the above procedures to call up the X-Y Trace dialog box.

■ Click on Track Data Points to uncheck it.

■ In the graph region, click and drag the mouse pointer over the points whose 
coordinates you want to see. A dotted crosshair follows the pointer as you dr
over the graph. Mathcad displays the coordinates of the pointer in the X-Value
Y-Value boxes. The x and y values change continuously to reflect the current poin
position.

■ When you release the mouse button, the X-Value and Y-Value boxes show the x 
and y values of the last pixel selected.
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Figure 20-15: Reading coordinates from a graph.
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Gallery of graphs

Figure 20-16: Different graph formats on the same graph.

Figure 20-17: Step graphs and error bars from the scrolling list under “Trace 
type.”
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Figure 20-18: Stem graphs and bar graphs from the scrolling list under 
“Trace type.”

Figure 20-19: Choosing from the scrolling lists under “Line” and “Symbol.”
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Figure 20-20: Hiding and showing the legend on the same graph.

Figure 20-21:  Unchecking Auto Grid option to vary the number of tick marks.
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Figure 20-22: Using the “Crossed Axes” option to cross axes in the center of 
the plot.
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