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Chapter 2
On-line Resources

Mathcad has a full on-line Help system, but with Mathcad you can a
access mathematical and technical content located on your comput
on the World Wide Web. Mathcad gives you a direct link to the Collab-
oratory, a unique Web-based messaging system that connects you t
community of Mathcad users. Mathcad also comes with the Resource 
Center, a Mathcad Electronic Book containing an extensive collectio
of tutorials, examples, and reference information, with links to furth
resources on the World Wide Web. Additional Mathcad Electronic 
Books are available from MathSoft or your local software distributo

The following sections make up this chapter:

Internet access in Mathcad
What you need to connect to Web-based resources from within Mathca

The Collaboratory
How to retrieve and post files to the Collaboratory, a Web-based service
communicating with other Mathcad users.

Resource Center
The Electronic Book that is both a library of reference content on your desktop
and a gateway to resources on the World Wide Web.

Using Electronic Books
Opening, navigating, and annotating Mathcad Electronic Books.

Help and context sensitive help
On-line Help on product features.
39



ot on 
that 

eb.

your 

ss 

you 
em 

roxy 

the 

 you 

ithin 

 

Internet access in Mathcad

A number of the on-line Mathcad resources described in this chapter are located n
your own computer or on a local network but on the Internet, the global network 
includes the World Wide Web. When you choose Collaboratory  from the File menu, 
for example, you are requesting information from a file server on the World Wide W

To access these resources on the Internet you need:

■ Networking software to support a 32-bit Internet (TCP/IP) application. Such soft-
ware is usually part of the networking services of your operating system; see 
operating system documentation for details. 

■ A direct or dial-up connection to the Internet, with appropriate hardware and 
communications software. Consult your system administrator or Internet acce
provider for more information about your Internet connection. 

Before accessing the Internet through Mathcad, you also need to know whether 
must use a proxy server to access the Internet. If you use a proxy, ask your syst
administrator for the proxy machine's name or Internet Protocol (IP) address, as well 
as the port number (socket) you use to connect to it. You may specify separate p
servers for each of the three Internet protocols understood by Mathcad: HTTP, for the 
World Wide Web; FTP, an older file transfer protocol; and GOPHER, an older protocol 
for access to information archives. Once you have this information, choose Internet 
Setup from the File menu. Then enter this information in the appropriate places in 
Internet Setup dialog box.

The remaining information in the Internet Setup dialog box was entered at the time
installed Mathcad, but you may modify it here at any time: 

■ Your name, which will appear on any Collaboratory messages you send from w
Mathcad.

■ Your Internet electronic mail address, which will appear on any Collaboratory
messages you send from within Mathcad.
40  Chapter 2  On-line Resources
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■ The URL for the Collaboratory server you contact when you choose Collaboratory  
from the File menu.

The Collaboratory

If you have a dial-up or direct Internet connection, you can access the MathSoft 
Collaboratory server. The Collaboratory is an interactive World Wide Web service
puts you in contact with a community of Mathcad users. The Collaboratory consis
a group of forums where you can contribute files, post messages, download files
contributed by other users, and read messages posted by other Mathcad users. 
find that the Collaboratory combines some of the best features of a computer bu
board or an on-line news group with the convenience of sharing worksheets or o
files created using Mathcad.

To access the Collaboratory, choose Collaboratory  from the File menu. Mathcad 
displays the Collaboratory dialog box as shown in Figure 2-1.

Figure 2-1: Opening the Collaboratory from Mathcad. Available forums and 
topics will change over time.

■ Forums and Topics: You can post and retrieve messages from the available 
forums, which will evolve over time. Each forum contains one or more topics. C
on a forum name to display the available topics in the “Topics” scrolling list to 
right. If a title is indented, it's a reply to the previous topic.

■ Topic Information:  When you click on a topic, information about it displays in
the lower part of the Collaboratory dialog box. You’ll see the name of the file, 
format of the file, the date it was posted, its location on the Collaboratory serv
the title given to it by its author, and the author’s name. 
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■ Buttons: The “ Get,” “Send,” and “Reply” buttons are used to retrieve, post, an
reply to files on the Collaboratory, respectively. You can post and retrieve a 
worksheet, another type of file, or a text message. Use the “Refresh” button t
redisplay the list of topics and forums. The “Close” button closes the Collabora
dialog box.

Note: MathSoft maintains the Collaboratory server as a free service, open to all in the Mat
community. Be sure to read the Collaboratory Agreement posted in the top level of the 
Collaboratory for important legal information and disclaimers. Although the Collaboratory
monitored by MathSoft, it is not designed for product technical support. If you need techn
support, see the contact information that accompanied your Mathcad installation media.

Opening a worksheet or other file stored in the Collaboratory

To open a worksheet or other file stored in the Collaboratory:

■ Choose Collaboratory  from the File menu.

■ Click on the appropriate forum from the list of forums in the upper left corner 
the dialog box.

■ Once you've selected a forum, click on one of the topics shown in the scrolling
at the upper right corner of the dialog box. 

■ You'll see some additional information on that topic in the lower half of the dia
box. Examine this information to see if you want to go ahead and open the to

■ Click the “Get” button. 

Depending on the type of file, one of three things will happen. If the file is text, yo
see the text in a message box as shown below. Use the “Reply” button to reply t
message. If the file is a worksheet it will open in its own worksheet window. If the
is binary, you’ll be prompted for a place to save the file.
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Sending a worksheet to the Collaboratory

If you want to send a worksheet you’ve created, or any other file, to the Collabora

■ Choose Collaboratory  from the File menu.

■ Check the list of forums in the upper left corner of the dialog box. Click on the
forum to which you want to send your file. 

■ Click the “Send” button.

■ Click on the “Send my Current File” if the worksheet you’d like to post is curren
open. If it isn’t, click on the “Send Another File” button.

■ Enter the path to the file in the File text box. Alternatively, click the “Browse” 
button to locate the file.

■ Enter a title in the Title text box. This is the text that will appear whenever any
clicks on this file.

■ Click the “Send” button. 

You'll see your file appear in the Topics window on the upper right corner of the dia
box. The “From:” text box will contain your “User Name” as it is specified in the 
Internet Setup dialog box. Choose Internet Setup from the File menu to change the 
user name as described in the section “Internet access in Mathcad” on page 40.

Sending a text message to the Collaboratory

If you’d like to write a text message and send it to the Collaboratory:

■ Choose Collaboratory  from the File menu.

■ Check the list of forums in the upper left corner of the dialog box. Click on the
forum to which you want to send your text message. 

■ Click the “Send” button to see the Send dialog box.

■ Click on the “Send a Message” button.

■ Enter a title in the Title text box. This is the text that will appear whenever any
scrolls through the Topics list of the forum.
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■ Type your message into the Message text box, as shown below:

■ Click the “Send” button.

You'll see your message appear in the Topics window on the upper right corner o
dialog box.

Deleting a topic from the Collaboratory 

If you posted a file or a message to the Collaboratory but would like to remove it

■ Choose Collaboratory  from the File menu.

■ Check the list of forums in the upper left corner of the dialog box. Click on the
forum containing the topic you want to delete. 

■ Once you've selected the forum, click on the topic you want to delete. The to
are in the scrolling list at the upper right corner of the dialog box. 

■ Press [Del ].

After you confirm that you want to delete the topic, you'll see your topic disappear f
the Topics window on the upper right corner of the dialog box. Note that if your file
message has received any responses, you won’t be able to delete it. 

Opening a worksheet from another World Wide Web server

If you know the address of a Mathcad worksheet on the World Wide Web, you can
the Collaboratory dialog box to open that worksheet:

■ Choose Collaboratory  from the File menu.

■ In the “URL” box at the bottom, delete any address that you see and then typ
URL of the worksheet you want to open. The URL is typically of the form 
http://some.server.name/directories/worksheet.mcd 
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■ Click the “Get” button. 

The Mathcad worksheet will appear in its own worksheet window.

See “Web browsing in the Resource Center” on page 46 for a more generic meth
browsing the Web from within Mathcad.

Resource Center

If you learn best from examples, want information you can put to work immediatel
your Mathcad worksheets, or wish to access any page on the World Wide Web f
within Mathcad, choose Resource Center from the Help menu. You will see a Mathcad
Electronic Book in a custom window with its own toolbar, as shown in Figure 2-2

Figure 2-2: Resource Center for Mathcad Professional. Topics available in 
Mathcad Standard or other editions differ slightly.

The Resource Center offers:

■ A comprehensive Mathcad Electronic Book containing a collection of tutorials
examples, and reference information. Simply drag and drop information from
Resource Center into your own Mathcad worksheets.

■ Immediate access to Mathcad worksheets on MathSoft’s World Wide Web sit
other Internet sites.
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■ Access to the full Web-browsing functionality of Microsoft Internet Explorer fro
within the Mathcad environment.

Browsing the Resource Center

The Resource Center is a Mathcad Electronic Book—a hyperlinked collection of 
Mathcad worksheets. As in other hypertext systems, you move around a Mathca
Electronic Book just by clicking on icons or underlined text. You can also use the
toolbar buttons at the top of the Resource Center window. For more information a
using the toolbar buttons to move around an Electronic Book and copying informa
from the Electronic Book to your worksheets, see “Using Electronic Books” on pag

Here are brief descriptions of the topics available in the Resource Center:

■ Overview. A high level introduction to Mathcad’s computational features.

■ Tutorial . Step-by-step guidance for new users on creating math, text, and grap
regions.

■ QuickSheets. A collection of hundreds of pre-made Mathcad worksheets, from
factoring a number or computing a mortgage payment to solving a system of 
equations. The QuickSheets also contain special pages on which you can sav
text or math you want quick access to. Look for “Personal QuickSheets” in the t
of contents. Anything you enter in these sheets is automatically saved when y
close the Resource Center. Changes made to any other pages in the Resource
are discarded when you close the Resource Center.

■ Web Library . If you have Internet access, jump directly to a growing library o
Mathcad worksheets and Electronic Books on the World Wide Web. See “Ope
a worksheet from another World Wide Web server” on page 44 for informatio
about accessing other Mathcad worksheets on the Web. See also “Web brow
in the Resource Center” below.

■ Reference Tables. Look up physical constants, chemical and physical data, an
mathematical formulas you can use in your Mathcad worksheets.

■ Practical Statistics. An introduction to hypothesis testing and data analysis in 
Mathcad.

■ The Treasury Guide to Solving. In-depth discussion of methods to solve equatio
in Mathcad, excerpted from The Mathcad Treasury, the best-selling Mathcad 
Electronic Book by Paul R. Lorczak.

Pro ■ The Treasury Guide to Programming. In-depth discussion of programming 
operators and programming techniques in Mathcad Professional, also excerp
from The Mathcad Treasury.

Web browsing in the Resource Center

If you have Internet access, the Web Library button in the Resource Center conn
you to a collection of Mathcad worksheets on the World Wide Web. You can also
the Resource Center window to browse to any location on the World Wide Web 
open standard Hypertext Mark-up Language (HTML) and other Web pages, like those
46  Chapter 2  On-line Resources
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you can view with a standard Web-browsing application, in addition to Mathcad 
worksheets. You have the convenience of accessing all of the rich information reso
of the Internet without leaving the Mathcad environment.

To browse to any World Wide Web page from within the Resource Center windo

■ Click on the Web Toolbar button (the one that looks like a globe) on the Resour
Center toolbar. As shown below, an additional toolbar with an “Address” line 
appears below the Resource Center toolbar to indicate that you are now in a
browsing mode:

■ In the “Address” box type a Uniform Resource Locator (URL) for a document on 
the World Wide Web. To visit the MathSoft home page, for example, type
http://www.mathsoft.com/  . If you have Internet access and the server
available, you will load the requested page in your Resource Center window,
shown in Figure 2-3.

Figure 2-3: Browsing the World Wide Web from within the Resource Center.

The remaining buttons on the Web Toolbar let you bookmark the page for a later 
reload the current page, and interrupt the current file transfer. When you are in W
browsing mode and click with the right mouse button on the Resource Center win
Mathcad displays a context menu with commands appropriate for viewing Web pa
Resource Center 47
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Many of the buttons on the Resource Center toolbar remain active when you are
Web-browsing mode, so that you can copy, save, or print material you locate on
Web, or backtrack to pages you previously viewed. When you click on the Table
Contents button you return to the Table of Contents for the Resource Center.

You may use the Resource Center in Web-browsing mode to open Mathcad works
on the Web. Simply type the URL of a Mathcad worksheet in the “Address” box in th
Web Toolbar.

When the Resource Center window is in Web-browsing mode, Mathcad is actua
using a Web-browsing OLE control provided by Microsoft Internet Explorer. Web 
browsing in Mathcad requires Microsoft Internet Explorer version 3.02 or later to
installed on your system. Although Microsoft Internet Explorer is installed when y
install Mathcad, you can refer to Microsoft Corporation’s Web site at 

http://www.microsoft.com/  

for licensing and support information about Microsoft Internet Explorer and to do
load the latest version.

Use the buttons at the bottom of the Resource Center Table of Contents as short
the following pages on MathSoft’s World Wide Web site:

■ mathsoft.com: MathSoft home page.

■ Registration: On-line product registration form.

■ Tech Support: Technical support pages.

■ Web Store: Purchase additional MathSoft products on-line. 

Using Electronic Books

MathSoft and selected third-party publishers produce Mathcad Electronic Books
which are disk- and CD-based electronic publications that provide technical prof
sionals, professors, and students with a wide range of technical reference and e
tional content, all created with Mathcad. Electronic Books help you get more out
Mathcad, because:

■ Every page of an Electronic Book is a live Mathcad worksheet. You can chan
values, calculate results, and experiment right on the electronic “page.” 

■ If you have your own Mathcad worksheet open, you can copy working examp
and formulas from the Electronic Book simply by dragging and dropping them i
your worksheet.

The Resource Center, which comes with Mathcad, is itself an Electronic Book, a
more than 50 additional titles are now available, including the best-selling The Mathcad 
Treasury, by Paul R. Lorczak. If you are using Mathcad Professional, your Resou
48  Chapter 2  On-line Resources



out 
are 

 at 

op, 
Center includes two chapters excerpted from this Book. For more information ab
Mathcad Electronic Books and other products, contact MathSoft or your local softw
distributor or reseller, or click on the Web Store button in the Resource Center.

Opening an Electronic Book

To open an Electronic Book you have installed,

■ Choose Open Book from the Help menu.

■ Use the Open Book dialog box to locate the book. The file extension .hbk  is used 
for Mathcad Electronic Book files. The title for any book you locate is displayed
the bottom of the dialog box.

■ Click “Open.”

You may also open an Electronic Book you have installed via the File menu: 

■ Choose Open from the File menu.

■ Set the “Files of Type” box to “Mathcad Electronic Book (*.hbk).” The file 
extension .hbk  is used for Mathcad Electronic Book files.

■ Browse to find one of the available Electronic Books you have installed.

■ Click “Open.”

The Electronic Book opens in its own window with a navigational toolbar at the t
as shown in Figure 2-4. 

Figure 2-4: A Mathcad Electronic Book opens in its own window with a custom 
toolbar.
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When you click in the book with the right mouse button, you will see a Books contex
menu with commands appropriate for using your Book.

Moving around an Electronic Book

As in other hypertext systems, you click on underlined text or icons to move from
section to section. The mouse pointer automatically changes into the shape of a
when you let it hover over a hypertext link, and a message appears at the bottom 
window that tells you what will happen when you click on the link. Then, when yo
click on a link or cross-reference, you automatically open the appropriate section
display information in a pop-up window, depending on how the book is organize

You can also use the buttons on the toolbar at the top of the Electronic Book win
to navigate the Electronic Book and take advantage of the content you find there

   Button Function

Jumps to the Table of Contents, the page that displays when you first o
the Electronic Book.

Backtracks to whatever document was last viewed.

Reverses the last backtrack.

Goes backward one section in the Electronic Book.

Goes forward one section in the Electronic Book.

Displays list of documents most recently viewed.

Searches the Electronic Book for a particular term.

Copies selected regions to the clipboard.

Prints current section of the Electronic Book.

Saves current section of the Electronic Book.

Some Electronic Books show additional buttons in the toolbar. The Resource Ce
toolbar, for example, has a button that opens an additional toolbar for Web brow
in the Resource Center window, as described in “Web browsing in the Resource Ce
on page 46.

Use the key combinations [Shift ][PgDn] and [Shift ][PgUp] to move down or up 
in increments of one page within the current section of the Electronic Book. To m
one screen to the right or left, click to the right or left of the scroll box in the horizon
scroll bar. 
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Mathcad keeps a record of where you've been in the Electronic Book. When you 
on the Back button, Mathcad goes back to the last section you opened and the pag
were on when you left it. Backtracking is especially useful when you have clicke
look at a cross reference and you want to go back to the section you just came f

If you don't want to go back one section at a time, click on the History button in the 
Electronic Book toolbar. This opens a window listing all the sections you've view
since you first opened the Electronic Book. And if your Book has a Web Toolbar, 
can use the Bookmark button to save the location of a section to visit at a later d

Finding information in an Electronic Book

In addition to using the Table of Contents to find topics in the Electronic Book, yo
can search for topics or phrases. To do so:

■ Click on the Search button in the Electronic Book toolbar to open the Search dial
box shown below.

■ Type a word or phrase in the “Search for” text box. As you type, the scrolling 
displays words or phrases that closely match the letters you type. 

■ Select a word or phrase and click “Search” to see a list of topics containing th
entry and the number of times it occurs in each topic. 

■ Choose one of these topics and click on “Go To.” Mathcad opens the Electro
Book section containing the entry you want to search for. 

Click on “Next” or “Previous” to bring the next or previous occurrence of the entr
into the window. If “Next” is grayed out, the last occurrence of that word is curren
visible. If “Previous” is grayed out, the first occurrence of that word is currently visib

Note that this feature will not locate any annotations you may have saved using 
Annotate Book command, described in “Annotating an Electronic Book” on page 

Copying information from an Electronic Book

There are two ways to copy information from an Electronic Book into your Mathc
worksheet:
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■ You can use the clipboard by selecting text or equations in the Electronic Boo
using the Copy button on the toolbar in the Electronic Book window, clicking on
the appropriate spot in your worksheet and choosing Paste from the Edit menu, or

■ You can drag regions from the Book window and drop them into your worksh

To drag regions from an Electronic Book to your worksheet, first select them. To d

■ Press and hold down the mouse button to anchor one corner of the selection
rectangle.

■ Without letting go of the mouse button, move the mouse so as to enclose every
you want to select inside the selection rectangle.

■ Release the mouse button. Mathcad encloses the regions you have selected in 
selection rectangles. If you select only one region, Mathcad surrounds it with
selection box.

Now drag a copy of the selected regions into your worksheet, as shown in Figure
 

Figure 2-5: Copying selected regions from an Electronic Book to a worksheet.

To do so:

■ Place the pointer over any selected region in the Electronic Book. The pointer
turn into a small hand.

■ Hold down the mouse button. Without letting go of the button, move the mou
You will see the rectangular outlines of the selected regions move as you mov
mouse.
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■ Drag the regions in to the destination worksheet. Let go of the mouse button w
you have positioned the regions to your liking.

Printing and saving a section from an Electronic Book

To print the current section of the Electronic Book,

■ Click on the Print button in the Electronic Book toolbar.

■ Use the Print dialog box to control what pages to print and what printer to print

To save the current section of the Electronic Book,

■ Click on the Save button in the Electronic Book toolbar.

■ Use the Save As dialog box to specify a location and format for the worksheet
want to save. 

For more information about printing and saving Mathcad worksheets, see Chapt
“Worksheet Management.”

Annotating an Electronic Book

While you have an Electronic Book open, you may edit any of the math you see, 
text, and create graphs directly in the Electronic Book window. By default, when 
make changes in an Electronic Book, Mathcad remembers those changes as long
book is open. When you close the book, whatever changes you make are lost. Th
time you open that Electronic Book, it will appear as if it had never been changed a

To save a copy of your edited Electronic Book, choose Annotate Book from the context 
menu before making any changes. (Click on the Electronic Book window with the r
mouse button to see the context menu.) This places a checkmark beside the me
command to indicate that you can now save an annotated copy of your Electronic B
The original copy of your Electronic Book will, of course, remain untouched. 

As you make changes and type in your Electronic Book, you may want to mark t
regions you change. To do so, choose Highlight Changes from the Books context 
menu. After you've done so, Mathcad displays any changed regions in a different c
You can set this color by choosing Color⇒Annotation from the Format menu. To 
stop highlighting regions, choose Highlight Changes from the context menu again. 
This removes the checkmark from beside the menu command and disables this fe

Once you've made changes in your Electronic Book, choose one of the following 
the Books context menu. You will have the option of:

■ Choosing Save Section to save the changes you've made in the section you're
working on, or 

■ Choosing Save All Changes to save all changes since you last opened the boo

Once Mathcad saves an annotated copy of the Electronic Book, you'll see an as
beside the title whenever you turn to an annotated section. The next time you ope
Electronic Book, Mathcad will open the annotated rather than the original copy. 
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If you've made changes to an Electronic Book and you haven't chosen one of the above
options, you'll be given the option of saving all changes you have made or of revie
the changed sections, one at a time, and deciding whether to save or discard the c

Deleting your annotations

Once you've saved an edited copy of an Electronic Book, Mathcad will open up 
copy rather than the original unedited copy. Whenever you turn to a section that's
annotated and saved, you'll see a “*” in the title bar beside that section's title.

To see the original section, as it appeared in the original copy of the Electronic B
before you made any changes, choose View Original Section from the Books context 
menu. If you want to go back to the corresponding section in the annotated copy o
Electronic Book, choose View Edited Section from the context menu.

To delete the annotations permanently in a particular section, choose Restore Section 
from the Books context menu. To delete your annotated copy of the Electronic B
altogether, choose Restore All.

Help and context sensitive help

Mathcad provides several ways to get help on product features through a traditio
on-line Help system. To see Mathcad's on-line Help at any time, choose Mathcad Help 
from the Help menu, or press [F1].

Choose Tip of the Day from the Help menu for a series of helpful hints on using 
Mathcad. Mathcad automatically displays one of these tips whenever you start it
“Show Tips at Startup” is checked.

You can get context sensitive help while using Mathcad. For menu commands, c
on the command and read the message line at the bottom of your window. For to
or palette buttons, hold the pointer over the button momentarily to see a tool tip.

You can also get more detailed help on menu commands or on many operators 
error messages. To do so:

■ Click on an error message, a built-in function or variable, or an operator.

■ Press [F1] to bring up the relevant Help screen.

To get help on menu commands or on any of the palette buttons:

■ Press [Shift ][F1]. Mathcad changes the pointer into a question mark.

■ Choose a command from the menu. Mathcad shows the relevant Help screen

■ Click on any palette button. Mathcad displays the operator's name and a keyb
shortcut on the message line.

To resume editing, press [Esc ] or [Shift ][F1]. The pointer back into an arrow.
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