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Chapter 4
Worksheet Management

This chapter describes how to manipulate and format Mathcad wor
sheets and templates, including how to save and print worksheets,
a worksheet by electronic mail, lock regions in a worksheet, and cr
file references and hyperlinks between worksheets. It also introduc
Object Linking and Embedding (OLE) as a way of inserting other obje
into a Mathcad worksheet and embedding Mathcad worksheets or 
gions into files created by other applications. 

The following sections make up this chapter:

Worksheets and templates
How to use worksheets and templates. How to save worksheets in vario
formats.

Layout
How to adjust margins, insert page breaks, and create headers and foo

Printing
How to print all or part of a worksheet. Includes a discussion of preview
your printed output.

Mailing
How to e-mail a Mathcad worksheet.

Safeguarding your calculations
How to write-protect selected areas of your worksheet.

References and hyperlinks
How to include a reference to a worksheet inside another worksheet. Ho
make Mathcad jump to another worksheet, open a pop-up window, or lau
another application when you double-click on a region.

Using OLE
How to insert objects from other applications into a worksheet. How to em
a Mathcad worksheet or part of a worksheet into other applications.
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Worksheets and templates 

As you use Mathcad and save your work for later use, you usually are creating 
worksheets, each of which contains unique text, math, and graphic regions. You 
typically create a separate worksheet, or group of worksheets, for each of your diff
calculation procedures or projects. Mathcad uses “.mcd ” as the default file extension 
for worksheets.

When you create a new worksheet in Mathcad, you can start with the equivalent
blank piece of paper with Mathcad’s default choices for formats and layout, or you
use a template that contains customized information for laying out and formatting t
worksheet. When you create a worksheet based on a template, all of the formatt
information and any text, math, and graphic regions from the template are copied
the new worksheet. The new worksheet therefore inherits the appearance and fo
ting instructions of the template, allowing you to maintain consistency in the appear
of your work.

Mathcad comes with a variety of predefined templates for you to use as you create
Mathcad worksheets. You may extend the collection of templates by saving any of
Mathcad worksheets as a template. Mathcad uses “.mct ” as the default file extension 
for templates.

Other saving options are available in Mathcad. You can save a worksheet in rich
format (RTF), so that many word processors can open it. You can also save a work
in a format that can be read by Windows and Macintosh versions of Mathcad 6. 

Creating and saving a new worksheet

When you open Mathcad, you'll see an empty window to work in—this is the blank 
worksheet template. You can enter and format equations, graphs, text, and graphic
this space, and you can modify worksheet attributes such as the page margins, num
format, headers and footers, and text and math styles. When you want to save t
worksheet, choose either Save or Save As from the File menu. The Save As dialog box 
appears, prompting you for a file name with the extension .mcd  under which to save 
the worksheet. After the first time you save the worksheet, simply choosing Save from 
the File menu updates the saved copy of the worksheet.

The blank worksheet template is only one of the templates Mathcad provides. O
built-in templates are specific to types of worksheets you’ll be creating. For exam
there is a template for homework assignments, one for engineering reports, and 

To create a new worksheet based on a template other than the blank worksheet te

■ Choose New from the File menu. You will see a dialog box like the one below (th
exact templates available will differ depending on your version of Mathcad):
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■ Choose a template other than “Blank Worksheet.” By default Mathcad display
worksheet templates in the template  subdirectory of whatever directory you use
to install Mathcad. Click the “Browse” button to find a template in another directo
or on another drive.

■ Click “OK.”

■ Create and edit the necessary equations, text, and other regions for your work

■ Choose Save or Save As from the File menu.The Save As dialog box appears, 
prompting you for a filename with the extension .mcd  under which to save the 
worksheet. After the first time you save the worksheet, simply choosing Save from 
the File menu updates the saved copy of the worksheet.

 Creating a new template

Although Mathcad provides a variety of built-in templates, you can extend the co
tion of templates by creating your own. For example, you may want to use a tem
for a project that contains specific information in the worksheet header and foote
you may want to customize the formatting in one of the predefined templates. Th
template you create can have equations, text, and graphics in certain places. Th
template also specifies:

■ Default text properties (Chapter 5).

■ Definitions of all math styles (Chapter 6).

■ Definitions of all text styles (Chapter 5).

■ Headers and footers (see “Layout” on page 84).

■ Margins for printing (see “Printing” on page 87).

■ Numerical result formats (Chapter 6).

■ Values for Mathcad's built-in variables (Chapter 8).

■ Names of Mathcad's basic units (Chapter 9).

■ The default unit system (Chapter 9).

■ The default calculation mode (Chapter 7).
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To create a new template, first create a new worksheet having the options listed a
set the way you want. The worksheet should also contain any equations, text, an
graphics that you want in the template. The next step is to save this worksheet a
template. To do so:

■ Choose Save As from the File menu.

■ Double-click on the Template  folder in the Save As dialog.

■ In the “Files of type” drop-down list, select “Mathcad Template.”

■ Type a name for the template in the “File name” box.

■ Click “Save.” The file is saved as a Mathcad template file (with the extension .mct ) 
in the template  subdirectory by default, but you may save it in another locati
if you wish.

Your template will now be added to the list of templates available in the dialog b
that appears when you choose New from the File menu. To make a new worksheet 
based on a template you’ve created, simply choose New from the File menu and select 
your template from the list; if you did not save your template to the template  
subdirectory, you will need to browse to find the template. 

Opening a worksheet 

To work on a worksheet that you saved before, choose Open from the File menu. 
Mathcad prompts you for a name by displaying the Open dialog box. You can lo
and open a Mathcad worksheet from other directories or drives just as you woul
any other Windows application.

At the bottom of the File menu, Mathcad maintains a list of the most recently open
worksheets. You can bypass the Open dialog box by choosing from this list.

Opening a worksheet stored on the World Wide Web

If you are connected to the Internet and know the address of a Mathcad workshe
a World Wide Web server, you can open it using the URL (Uniform Resource Locator) 
text box in the Collaboratory: 

■ Choose Collaboratory  from the File menu to open the Collaboratory dialog box

■ Select the text that is in the URL text box at the bottom of the dialog box and pres
[Del ] to delete it.

■ Type the URL of the worksheet you want to open in the URL text box. This identifies 
the name of the server computer on which the worksheet is saved together wi
path to that worksheet within that computer's file system.   

MathSoft maintains a collection of linked Mathcad worksheets on its World Wide W
server. To access these, choose Resource Center from the Help menu and click on 
“Web Library.”

For more information about Internet access, the Collaboratory, and the Resourc
Center, see Chapter 2, “On-line Resources.”
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Editing a worksheet 

Edit a worksheet by opening it by using Open from the File menu and then making 
any changes you choose. Then, to overwrite the original worksheet with the revi
one, choose Save. Mathcad overwrites the original copy of the worksheet with the ne
copy that is currently shown in the worksheet window.

To make changes to an existing worksheet without modifying the original, choose Save 
As from the File menu instead. You will be prompted for a new name under which
save the worksheet. 

Modifying a template

To modify an existing worksheet template, 

■ Choose Open from the File menu.

■ In the “Files of type” drop-down list, select “Mathcad Template.”

■ Type the name of the template in the “File name” box, or browse to locate it in
dialog box. Worksheet templates are saved by default in the template  subdirec-
tory.

■ Click “Open.” The template opens in the Mathcad window.

You may now edit the template as you would modify any Mathcad worksheet. To 
your changes under the current template name, choose Save from the File menu. If you 
wanted to give a new name to the modified template, choose Save As from the File 
menu instead and enter a new name for the template in the dialog box.

Note that when you modify a template, your changes will affect only new files crea
from the modified template. The changes will not affect any worksheets created 
the template before the template was modified.

Saving your worksheet in RTF format    

In addition to saving Mathcad worksheets and templates, Mathcad can save your 
worksheet in RTF format so that a word processor capable of reading an RTF file with 
embedded graphics might be able to open it. To do so:

■ Scroll to the bottom of your worksheet to update all calculated results.

■ Choose Save As from the File menu.

■ In the Save As dialog box, choose “Rich Text Format Files” from the “Save as ty
drop-down list. 

■ Enter a file name and then click “Save.”

When you open this RTF file with a word processor such as Microsoft Word, you'll fin
all the Mathcad regions lined up one above the other at the left edge of the docum
You can then use your word processor to move these regions wherever you wan
Worksheets and templates 83



r, 
dded 

orm 
ion 

at is, 

o that 
, is 

cad 

ile 

le 

 for 
n 
e new 

 page 
riately. 

e 

d 
Once the Mathcad regions saved in an RTF file have been loaded into a word processo
you'll no longer be able to edit equations and graphs—these will display as embe
graphics in your word processor. You will, however, still be able to edit the text.

To embed Mathcad worksheets or regions in a word processing document in a f
that allows you to continue to edit the original Mathcad worksheets, see the sect
“Using OLE” on page 99.

Saving a worksheet as a Mathcad 6 file

In general, Mathcad worksheets are upwardly but not downwardly compatible. Th
worksheets created in an earlier version of Mathcad will  open in the current version, 
but files created in the current version of Mathcad will not open in earlier versions. 
Mathcad 7, however, allows you to save a worksheet as a Mathcad 6 worksheet s
it will open in Mathcad version 6 for Windows or Macintosh. The caveat, of course
that features in your worksheet new to Mathcad 7 will not be recognized in Math
6. Regions or features that won’t work in Mathcad 6 are not saved.

To save a worksheet as a Mathcad 6 worksheet:

■ Choose Save or Save As from the File menu.

■ In the “Save as type” drop-down list, select “Mathcad 6 Files” and provide a f
name.

■ Click “Save.” A message will appear warning you that certain features availab
only in Mathcad 7 will not work in Mathcad 6. 

When you open a Mathcad 7 worksheet saved as a Mathcad 6 file in Mathcad 6
Windows or Macintosh, you may see an additional warning indicating that certai
features are not supported. For a list of product features, including features that ar
in Mathcad 7, see “Mathcad features” on page 12. 

Layout

Before printing a worksheet, you may need to adjust the margins, paper options,
breaks, and headers and footers so that pages of the worksheet are printed approp
This section describes how to change these worksheet attributes. 

Once you’ve set these characteristics for a worksheet, you can easily apply thes
characteristics to future worksheets by saving your worksheet as a template, as 
described in the previous section.

Setting margins, paper size, source, and orientation 

Mathcad worksheets have four user-specifiable margins, at the left, right, top, an
bottom of the worksheet. To set these margins, choose Page Setup from the File menu. 
This brings up the Page Setup dialog box, shown below:
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The four text boxes in the lower right of this dialog box show the distances from 
margin to the corresponding edge of the actual sheet of paper on which you will 
printing. 

■ Left:  This is the distance from the left edge of the physical sheet of paper to the
edge of the print area.

■ Right:  This appears as a solid vertical line in your window. You may have to sc
to the right to see it. In addition to marking the right edge of the printed area, 
right margin serves as a wrap margin for all text regions. 

Don't confuse the solid vertical line marking the right margin with the dashed 
vertical line marking the right page boundary. This line marks the right-hand e
of the sheet of paper itself. Its location depends on your choice of printer. If y
haven't chosen a printer, you won't see this dashed line at all.

■ Top: This is the distance from the top edge of the physical sheet of paper to th
edge of the print area. If your worksheet has a header, it appears just above 
margin. 

■ Bottom: This is the distance from the bottom edge of the physical sheet of pa
to the bottom edge of the print area. If your worksheet has a footer, it appears
below this margin. 

You can also use settings in the Page Setup dialog box to change the size, sour
orientation of the paper on which you will print your worksheet:

■ Paper, Size: This should correspond to the size of the paper in your printer.

■ Paper, Source: This is the area in your printer supplying the paper.
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■ Orientation, Portrait: The paper is positioned vertically, with the longest dime
sion running from top to bottom.

■ Orientation, Landscape: The paper is positioned horizontally, with the longest
dimension running from left to right. This is useful if your worksheet is wider th
a single page.

Click on the “Printer” button in the Page Setup dialog box to access your current pr
settings. See “Printing” on page 87 for more about printing your Mathcad worksh

If you want the margin and other page setup settings in the current worksheet to be
in other worksheets, save the worksheet as a template as discussed in “Workshee
templates” on page 80.

Pagebreaks

Mathcad provides two kinds of pagebreaks:

■ Soft pagebreaks: Mathcad uses your default printer settings and your top and
bottom margins to insert these pagebreaks automatically. These show up as d
horizontal lines, and you see them as you scroll down in your worksheet. You ca
add or remove soft pagebreaks.

■ Hard pagebreaks: You can insert a hard pagebreak by placing the cursor at th
appropriate place in your worksheet and choosing Page Break from the Insert 
menu. Hard pagebreaks display as solid horizontal lines in your worksheets.

When Mathcad prints your worksheet, it begins printing on a new page wheneve
encounters either a soft or a hard pagebreak. 

To delete a hard pagebreak:

■ Drag-select the hard pagebreak as you would select any other region in your
Mathcad worksheet. A dashed selection box appears around the pagebreak.

■ Choose Cut or Delete from the Edit  menu. 

Headers and Footers

To add a header or a footer to every printed page, choose Headers/Footers from the 
Format menu. This opens the Headers/Footers dialog box shown below:
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To add a header:

■ Click on the Header radio button.

■ Type the header into one or more of the text boxes. Whatever you type into the
Center, and Right text boxes will appear left-justified, centered, and right-justi
on the page respectively.

■ To automatically insert the page number, current date, time, or filename wher
the insertion point is, click on the appropriate button below the text boxes. Math
inserts a special code into the text box. This will be replaced by the correct p
number, date, time, or filename when you print the worksheet. Note that Math
always begins numbering at page 1.

■ Make sure the Enable check box is checked. When this is unchecked, Mathc
suppresses the display of headers and footers.

To add a footer:

■ Click on the Footer radio button.

■ Follow the rest of the instructions for inserting headers.

Printing 

To print a Mathcad worksheet, choose Print  from the File menu. The dialog box you 
see will depend on the particular printer you've selected. A typical dialog box is sh
below:

The Print dialog box lets you control whether to print the entire worksheet, selec
pages, or selected regions; what printer to print on; and the number of copies to 
This section describes these various printing options in detail. 
Printing 87
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The “Properties” button in the Print dialog box gives you access to printing options
the paper, graphics, and fonts used by your printer. This allows you to change th
options just before you print. If you don’t want to print the worksheet immediately, y
can change some of these options in the Page Setup dialog box as described in “L
on page 84. 

Choosing what to print

You can choose to print the entire worksheet, selected pages, or even just selec
regions. To control what Mathcad prints, click on one of the following radio button
the Print dialog box: 

■ All:  Click this button to print all pages in the worksheet. 

■ Pages: Click this button to print a range of pages. Then fill in the two text boxes
indicate your selection. If you've selected a plotter as your output device, you'll 
be able to print one page; the text box beside “To:” will be grayed out.

■ Selection: Click this button to print only the currently selected regions. If the butt
is gray, you have not selected any regions with the dashed rectangle.

If you find more pages than you expect coming out of the printer, keep in mind th
Mathcad worksheets may be wider than a sheet of paper as well as longer. See “Print
wide worksheets” below.

Choosing what to print on

By default, Mathcad sends its output to whatever printer you installed as a defau
printer under your operating system. The installed printer is shown in the “Name” d
down list. You may send your output to any printer you have installed under you
operating system; simply choose another printer from the “Name” drop-down list
redirect your output to a file, click the “Print to File” checkbox.

Printing wide worksheets

Because Mathcad worksheets can be wider than a sheet of paper, the idea of a 
is not as clear as it would be in, for example, a word processor. You can scroll a
to the right as you like in a Mathcad worksheet and place equations, text, and gra
wherever you like. As you scroll horizontally, however, you will see dashed vertic
lines appearing to indicate the right margins of successive “pages” correspondin
the settings for your printer. The sections of the worksheet separated by the das
vertical line will print on separate sheets of paper, yet the page number at the bo
of the Mathcad window does not change as you scroll to the right.

You can think of the worksheet as being divided into vertical strips as shown in Fig
4-1. Mathcad begins printing at the top of the left-most strip and continues until i
reaches the last region in this strip. It then goes to the top of the adjacent strip and
every page down to the last region in that strip. This procedure is repeated until 
everything in the worksheet has been printed. Note that certain layouts will prod
one or more blank pages. 
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Figure 4-1: Mathcad divides very wide worksheets into strips for printing.

You can control whether or not Mathcad prints the entire worksheet or just the le
most strip shown in Figure 4-1. To do so, choose Page Setup from the File menu to 
open the Page Setup dialog box. Then:

■ To suppress printing of anything to the right of the right margin, click in the “Pr
single page width” box to put a check in it.

■ To print all the regions in the worksheet, even those to the right of the right mar
click in the “Print single page width” box to uncheck it.

As mentioned earlier in this section, you can ask Mathcad to print a range of pag
the worksheet by typing the page range in the Print dialog box. The page numbe
the dialog box refer only to horizontal divisions. For example, if your worksheet lo
like that shown in Figure 4-1, and you ask Mathcad to print page 2, you will see 
sheets of paper corresponding to the lower-left and lower-right quadrants in Figur

To print only the lower left-hand page shown in Figure 4-1:

■ Choose Print  from the File menu.

■ Type “2” in the boxes next to the words “From” and “To.” This suppresses print
of the upper-left and upper-right quadrants.

■ Choose Page Setup from the File menu and make sure there is a check in the “Pr
single page width” box. This suppresses printing of the lower-right quadrant.

■ Click on “OK.”

Note that this makes it impossible to print the upper- or lower-right quadrants by
themselves.
Printing 89
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Print preview

To check your worksheet's layout before printing, choose Print Preview from the File 
menu. The Print Preview window displays the current section of your worksheet,
miniature, as it will appear when printed. See Figure 4-2. 

Figure 4-2: Previewing the printed output.

To print your worksheet from this screen, click on the “Print” button at the top of 
window. Click “Close” to go back to the main worksheet screen. The remaining but
at the top of the Print Preview screen give you more control over the preview:

■ Next Page: Click this button to preview the next page of the worksheet. If this
button is gray, there are no further pages in the worksheet.

■ Prev Page: Click this button to preview the previous page of the worksheet. If t
button is gray, there are no preceding pages in the worksheet.

■ Zoom In: Click this button to magnify a portion of the worksheet.

■ Zoom Out: Click this button to cancel any magnification so that you see your
document in the normal size used in the Print Preview screen.

■ Two Page or One Page: Click “Two Page” to show two pages of the worksheet 
a time, as was done in Figure 4-2. Click “One Page” to show only one.

Although you can use the “Zoom In” and “Zoom Out” buttons to magnify the 
worksheet, you can also magnify the worksheet by moving the cursor onto the 
90  Chapter 4  Worksheet Management
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previewed page so that the cursor changes to a magnifying glass. Then click the m
You can click again to magnify your worksheet even more. Once you’re at the 
maximum magnification, clicking on the page de-magnifies it.

You cannot edit the current page or change its format in the Print Preview scree
edit the page or change its format, return to the normal worksheet view by clicking
“Close” button. You can then edit the worksheet or change its format as describe
the previous section, “Layout.”

Mailing

If you’re connected to a mail system that’s compatible with Microsoft Mail, you’ll b
able to use Mathcad to direct that system to send an electronic mail message an
current Mathcad worksheet. This saves you the work of opening a separate mai
application to e-mail a Mathcad worksheet.

Mathcad supports any electronic mail system compatible with Microsoft’s Mail A
(MAPI). When you use Mathcad to send a worksheet by electronic mail, the recip
of the message will receive the worksheet as a file attached to an ordinary e-ma
message, provided that the recipient’s mail system uses the same encoding tech
as yours.

To send a Mathcad worksheet by electronic mail:

■ Open the worksheet you want to send.

■ Choose Send from the File menu.

Once you do so, your mail system will launch and create a new message with yo
worksheet as an attachment. You should then enter the text of your mail messag
address of the recipient, and any other information allowed by your mail system.

The settings in your mail system determine how Mathcad worksheets are attach
the mail message. We recommend that you use an encoding method such as MIME or 
UUENCODE, if available, to attach Mathcad worksheets to mail messages.

If you’re not connected to a MAPI-compatible mail system, the Send command on the 
File menu will be grayed out, but you can send a Mathcad worksheet by manual
making it an attachment to a mail message.

Safeguarding your calculations

The ease with which you can alter a Mathcad worksheet can present a problem. I
too easy to alter a worksheet and to change things which are not meant to be cha
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For example, if you've developed and thoroughly tested a set of equations, you m
want to prevent anyone from tampering with them.

To avoid this, you may want to safeguard these equations by locking them up in 
a way that you'll still be able to use them even though nobody will be able to cha
them.  

Pro You can use Mathcad Professional to lock a set of equations. To do so:

■ You designate a particular area in your worksheet as a lockable area.

■ You place the calculations that you want to safeguard into that lockable area

■ You lock the area.

Once an equation is safely inside a locked area, nobody will be able to edit it. Th
equation will, however, continue to affect other equations in the document. For 
example, if you define a function inside a locked area, you'll still be able to use th
function anywhere below and to the right of its definition. You will not, however, 
able to change the function’s definition itself.

The remainder of this section describes how to specify the beginning and the en
the lockable area as well as how to lock and unlock that area once you've create

Specifying the lockable area

A lockable area is designated by two lines as shown in Figure 4-3. The open pad
above and below these lines indicate that the area is now unlocked. As long as thi
remains unlocked, you can edit equations and text within it as freely as you wou
anywhere else in the worksheet. 

To designate a lockable area:

■ Choose Lock Regions⇒Set Lock Area from the Format menu. Mathcad inserts 
a pair of lines like those in Figure 4-3. These mark the boundaries of the lock
area.

■ Select either of these boundary lines just as you'd select any region: by dragg
the mouse across the line or by shift-clicking on the line itself.

■ Once you've selected the boundary line, drag it just as you'd drag any other re

You should position the boundaries so that there's enough space between them
whatever equations you want to lock. You can have any number of lockable area
your worksheet. The only restriction is that you cannot have one lockable area in
another.
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Figure 4-3: The area between the two lines is a lockable area. The first pair 
is still unlocked; the second pair was locked on the date shown.

Locking up the calculations    

Once you've placed whatever equations you want to lock up inside the lockable 
you are ready to lock it up. You'll be able to lock it up either with or without a passw
To do so:

■ Click in the lockable area.

■ Choose Lock Regions⇒Lock Area from the Format menu.

■ You'll see a dialog box asking you if you want to set a password. Click “Yes” 
you want to require a password to unlock the area. Otherwise click “No.”

■ If you clicked “Yes,” you'll be prompted for a password. Type any combination
letters and numbers. Keep in mind that the password is case sensitive.

Once locked, the locked area looks like the lower pair of lines in Figure 4-3. The 
and time the area was last locked is shown above and below the boundary lines

Locking without a password is useful when you just want to prevent yourself from
absent-mindedly changing something, and you don't want to worry about having
remember a password. When a region is locked without a password, anyone wil
able to unlock it by simply choosing Lock Regions⇒Unlock Area from the Format 
menu.

Locking with a password is useful when you want to prevent unauthorized chang
a worksheet. When you choose this option, make sure you remember your pass
Safeguarding your calculations 93
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If you forget your password, you may find yourself permanently locked out of tha
lockable area.

Unlocking the calculations    

If you want to make changes to an equation inside a locked area, you'll have to un
it first. To do so:

■ Click on one of the boundary lines of the region you want to unlock. Mathcad
highlights the boundary line.

■ Choose Lock Regions⇒Unlock Area from the Format menu.

■ If a password is required, you'll be prompted for the password. 

Once an area is unlocked, you'll be able to make whatever changes you want to 
freely as you would anywhere else in your worksheet.

Deleting a lockable area

You can delete a lockable area just as you would any other region. To do so: 

■ Make sure the area is unlocked. You cannot delete a locked area.

■ Select either of the two lines indicating the extent of the locked area by dragg
the mouse across it.

■ Choose Cut from the Edit  menu.

References and hyperlinks

Mathcad allows you to establish connections between Mathcad worksheets in tw
ways. One type of connection allows you to reference one worksheet from another—
that is, to access the computational machinery in the other worksheet without ope
it or typing its equations or definitions directly in the current worksheet. Mathcad a
allows you to set up hyperlinks between Mathcad worksheets—that is, to create 
“hotspots” in your Mathcad worksheets that, when you double-click on them, bring
other Mathcad worksheets. You can also create simple hyperlinks in Mathcad w
sheets in order to view arbitrary file types, such as word processing documents,
files, or animation files. These connections are explored in more detail below. 

Pro Mathcad Professional also gives you MathSoft’s MathConnex application to link 
Mathcad worksheets and other computational components to create heterogene
computational systems. In MathConnex you draw “wires” between components, s
ifying which computational outputs from one component become the inputs for th
next component. In this way you chain together computation procedures from Mat
worksheets and other sources. See the MathConnex Getting Start Guide for more 
information. And for general information about establishing OLE links between Math-
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cad and other applications, see the section “Using OLE” on page 99 and Chapte
“Data Management.”

Making equations of one worksheet available in another   

There may be times when you want to use formulas and calculations from one Mat
worksheet inside another. You can, of course, simply open both worksheets and
Copy and Paste from the Edit  menu to move whatever you need to move, or drag
regions from one worksheet and drop them in the other. However, when entire 
worksheets are involved, this method may be cumbersome or may result in unnece
clutter, obscuring the main computations of your worksheet.

A simple way to make formulas from one worksheet available in another one is to in
a reference in the current worksheet. When you insert a reference to a worksheet,
won’t see the formulas of the referenced worksheet, but the current worksheet be
as if you could. 

To insert a reference to a worksheet:

■ Click the mouse wherever you want to insert the reference. Make sure you clic
empty space and not in an existing region. The cursor should look like a cros

■ Choose Reference from the Insert menu. You'll see the following dialog box:

■ Click the “Browse” button to locate and select a worksheet. Alternatively, you m
type the complete path to a worksheet in the empty text box. For example, yo
would type c:\Program Files\MathSoft\Mathcad\conform.mcd  to 
insert a reference to the file conform.mcd  located in the Mathcad  folder. You 
can also enter an Internet address (URL) to insert a reference to a Mathcad file tha
is located on the World Wide Web. 

■ Click “OK” to insert the reference into your worksheet.

To indicate that a reference has been inserted, Mathcad pastes a small icon whe
you had the crosshair as shown in Figure 4-4. The path to the referenced worksh
to the right of the icon. All definitions in the referenced worksheet will be availabl
below or to the right of this icon. If you double-click on this icon, Mathcad opens 
referenced worksheet in its own window for editing. You can move or delete this 
just as you would any other Mathcad region.

By default, the location of the referenced file is stored in the worksheet as an abs
system path (or URL). This means that if you copy the main worksheet and the 
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referenced worksheet to a different file system with a different directory structure
Mathcad will not be able to locate the referenced file. If you want the location of 
referenced file to be stored relative to the Mathcad worksheet containing the refer
however, click the “Use relative path for reference” box in the Insert Reference di
box. This allows the reference to be valid even if you move the referenced file an
main worksheet, but keep the relative directory structure between the two the same. T
use a relative path, the two worksheets must be on the same local or network dr
you specify a relative path, Mathcad displays a capital “R” in parentheses at the e
the path for the reference in your worksheet.

Figure 4-4: An icon representing a referenced worksheet, here from the World 
Wide Web. Definitions in the referenced worksheet are available below and 
to the right of this icon.

This mechanism will work for worksheets stored on a local or network drive or on
World Wide Web. Of course, if you move the referenced worksheet after having 
inserted a reference to it in another worksheet, Mathcad will display an error mes
in the main worksheet indicating that it can no longer find the referenced worksh

If you edit the contents of a referenced file so that any calculations change, you 
re-open any worksheets that contain references to that file for any calculations to up
The calculations in those worksheets do not update automatically.

Creating hyperlinks between worksheets

You can create a hyperlink from any Mathcad region, such as a text region or a gra
element, to any Mathcad worksheet or template. When you or a reader double-c
on this hyperlink, Mathcad will display the Mathcad worksheet designated by the
hyperlink. In this way you can connect groups of related worksheets into a form sim
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to Mathcad’s Electronic Books, or simply cross-reference a related Mathcad works
from within the current worksheet.

You have two options for the display of the linked worksheet when you double-c
on the hyperlink:

■ The hyperlinked worksheet can open in a complete Mathcad worksheet wind
that overlays the current worksheet window and that allows you to edit its cont
as you would any other worksheet, or

■ The hyperlinked worksheet can open in a small pop-up window that simply disp
the contents of the worksheet, but does not allow you to edit its contents.

In either case the worksheet that contains the original hyperlink remains open fo
to view and edit. Mathcad can follow a hyperlink to any worksheet, whether it is sto
on a local drive, a network drive, or the World Wide Web. 

To create a hyperlink, you must specify:

■ What to double-click on in order to go to another worksheet. This is the “gatew
and it can be a piece of text, an equation, or a graphics region.

■ What worksheet to go to. This is the “target worksheet.”

First, specify the gateway by doing one of the following:

■ Select a piece of text, or 

■ Click anywhere in an equation or graphics region, or

■ Place the insertion point anywhere within an entire text region.

The next step is to specify the target. To do so:

■ Choose Hyperlink ⇒New from the Insert menu. You'll see the following dialog 
box:

■ Click the “Browse” button to locate and select the target worksheet. Alternativ
you may type the complete path to a worksheet in the empty text box at the to
the dialog box. For example, type c:\Program Files\MathSoft\Math-
cad\conform.mcd  to insert a hyperlink to the file conform.mcd  located in 
the Mathcad  folder. You can also enter an Internet address (URL) to create a 
hyperlink to a file on the World Wide Web. 
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■ Click the “Use relative path for hyperlink” box to store the location of the targe
worksheet relative to the Mathcad worksheet containing the hyperlink. This all
the hyperlink to be valid even if you move the target file and the worksheet 
containing the hyperlink, but keep the relative directory structure between the
the same. If you want the location of the target worksheet to be absolute inst
do not click the box for using a relative path. See the previous section, “Maki
equations of one worksheet available in another,” for more information about
relative and absolute paths.

■ Click the “Display as pop-up document” checkbox if you want the target worksh
to open in a small pop-up window when you double-click on the gateway.

■ If you want a message to appear on the status line at the bottom of the window 
the mouse hovers over the gateway to the hyperlink, type the message in the
box at the bottom of the Insert Hyperlink dialog box.

■ Click “OK.” 

Mathcad then establishes the hyperlink. If you used selected text as the gateway
Mathcad underlines the text and makes it bold to indicate the existence of a hype
Other gateways won’t be marked in any way, but if you use a graphic element a
“button” for the gateway, the existence of the hyperlink may be obvious. Mathcad
also now change the mouse pointer to a “hand” cursor when you hover over the gat
and any message you specified will appear on the status line at the bottom of the w
when the cursor is over the gateway.

When you double-click on the gateway to the hyperlink, Mathcad opens the targ
worksheet in the kind of window (either pop-up or full) you specified. You close a p
up window by clicking on the close box in the upper right corner. 

To change any aspects of a hyperlink—for example, if you move the target works
and still want the hyperlink to work—click anywhere in the gateway and choose 
Hyperlink ⇒Edit  from the Insert menu. Then you can change the name or location
the target worksheet, whether the target worksheet displays in a pop-up window
whether the location of the target file is stored as a relative or absolute path. You
also change the status bar message assigned to the hyperlink.

To remove a hyperlink, simply click anywhere in the gateway and choose Hyper-
link ⇒Erase from the Insert menu. Mathcad will remove all traces of the link.

Creating hyperlinks to files other than Mathcad worksheets

The methods described in the previous section will create a hyperlink not only fro
one Mathcad worksheet to another, but also from a Mathcad worksheet to any o
file type, either on a local or network drive or on the World Wide Web. Use this fea
to create more full-featured “Electronic Books” or compound documents that con
not only Mathcad worksheets but word processing files, animation files—any file t
that you want. 

You can create a hyperlink to any file type for which you have an appropriate “view
application. When you double-click on a hyperlink to a file other than a Mathcad 
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worksheet, you launch either the application that created the file or an application
is associated with a file of that type in the Windows Registry. You do not have th
option of displaying such hyperlinked files within a pop-up window in the Mathca
application frame.

For example, to create a hyperlink from a Mathcad worksheet to an animation (AVI ) file: 

■ Specify a gateway in your Mathcad worksheet as described in the previous se

■ Choose Hyperlink ⇒New from the Insert menu. 

■ In the Insert Hyperlink dialog box, type the path or URL to the AVI  file, or use the 
“browse” button to locate it on your file system.

■ If you want a message to appear on the status line at the bottom of the window 
the mouse hovers over the gateway to the hyperlink, type the message in the
box at the bottom of the Insert Hyperlink dialog box.

■ Click “OK” when you are done.

Now when you double-click on the gateway, you will launch the Windows Media
Player or a comparable application that can play AVI  files, and you will see the 
animation.

Warning about hyperlinks from regions other than text

Although the gateway to a target worksheet can be any region, such as an equat
plot, there are two significant disadvantages to using a region other than selected

■ When you use text as a gateway, Mathcad makes the selected text bold and 
underlined to indicate that a hyperlink exists there. No corresponding indicatio
possible when you choose something other than selected text as a gateway.

■ The hyperlink preempts the normal response to double-clicking on the region.
example, if you choose a plot as a gateway, you will no longer be able to dou
click on that plot to open a formatting dialog box.

For these reasons, we recommend that you use either selected text or an embe
graphic as a gateway to another worksheet. 

Using OLE

As you develop a Mathcad worksheet, you may want to embellish it or extend its
functionality by inserting objects, which are elements you create in another applicati
such as a word processor or a drawing package. Conversely, you may want to in
Mathcad worksheets or regions from a Mathcad worksheet into another applicati
OLE (Object Linking and Embedding) technology in Microsoft Windows makes it 
possible not only to insert static pictures of such objects into your applications (o
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Mathcad objects into other applications), but to insert the objects in such a way t
they can be fully edited in their originating applications. 

You insert objects into Mathcad, which is an OLE2-compatible application, by using 
the Object command from the Insert menu, by drag-and-drop, or by copying and 
pasting. Each of these methods is explained in detail in this section. The method
choose depends on whether you want to create the object on the fly, whether the 
has already been created, or whether you want the object to be an entire file. Yo
edit objects in a Mathcad worksheet simply by double-clicking on them, causing in-
place activation of the originating application in most cases.

In general, you can also use these methods to insert Mathcad objects into other
applications and edit them inside those applications. However, the details depen
the extent to which the application receiving a Mathcad object supports OLE2. This 
section, therefore, focuses on inserting objects into Mathcad and only briefly tou
on inserting Mathcad objects into other OLE2-compatible applications. 

For information about using Mathcad’s components for importing and exporting d
as well as establishing dynamic connections with other applications, see Chapte
“Data Management.” If you would like to import or export graphic files such as bitm
into your Mathcad worksheets, turn to Chapter 28, “Importing and Exporting Gra
ics.”

Embedded vs. linked objects

Objects can be either embedded in or linked to a Mathcad worksheet. For you to link
an object, the object must exist in a saved file. An object that you embed, on the 
hand, may be created at the time of insertion or it may be part of a saved file. Th
difference between an embedded object and a linked object is only important whe
want to edit it. When you edit an embedded object, any changes you make to the 
will affect it only in the context of the Mathcad worksheet. The original object in t
source application, if there is one, is left undisturbed. When you edit a linked obj
on the other hand, any changes you make to the object will affect the actual file 
containing the object. 

Inserting an object into a worksheet

One way to insert an object from another application into Mathcad is to use the Object 
command from the Insert menu. Using this method, you can insert an object that y
create on the fly at the time you are inserting it, or you can insert an entire file th
you’ve already created.

To insert an object or a saved file, you should first:

■ Click in a blank area of your worksheet where you would like to insert the obj
Make sure that you see the crosshair.

■ Choose Object from the Insert menu to bring up the Insert Object dialog box. B
default the “Create New” radio button is selected:
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■ Click the “Display as Icon” checkbox if you want an icon, rather than the actu
object, to appear in your worksheet. The icon is typically the icon of the applica
that created the object.

Then, to create a new object:

■ Select an application from the “Object Type” list in which to create the object. T
available object types will depend on the applications you have installed on y
system.

■ Click “OK.” 

The source application opens so that you can create the object. When you are fin
working to create the object, close the source application. The object you created
be embedded in your Mathcad worksheet.

If you want to insert a previously created file:

■ Click the “Create from File” radio button in the Insert Object dialog box. The dia
box will then look like this:

■ Type the path to the object file or use the “Browse” button to locate it.

■ Click the “Link” checkbox to insert a linked object. Otherwise, the object will b
embedded.

■ Click “OK.”
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The object will then be either linked or embedded in your Mathcad worksheet.

Pasting an object into a worksheet

Instead of inserting an object through the Insert Object dialog box, you can copy
object from a source application to the clipboard and paste it into Mathcad. This me
is particularly useful when you’ve already created the object in another application
you don’t want to insert an entire file. 

To insert an embedded or linked object into a worksheet via the clipboard:

■ Open the source application containing the object.

■ Copy the object to the clipboard in the source application. You typically do this
choosing Copy from the Edit  menu, or by pressing [Ctrl ]C.

■ Click in the Mathcad worksheet where you’d like to place the object. 

■ Choose Paste or Paste Special from Mathcad’s Edit  menu. 

If you choose Paste, the object will be pasted in your Mathcad worksheet in a form
that depends on what the source application has placed on the clipboard. The be
may differ depending on whether you have selected a math placeholder or are p
into a blank space in the worksheet. Mathcad will create one of the following:

■ A matrix, if you are pasting numeric data from the clipboard into an empty ma
placeholder. (See Chapter 19, “Data Management.”)

■ A text region, if you are pasting text that does not contain numeric data exclusiv

■ A bitmap or picture (metafile), if the originating application generates graphics.
(See Chapter 28, “Importing and Exporting Graphics.”)

■ An embedded object, if the originating application supports OLE. 

If you choose Paste Special from the Edit  menu, you have the option of pasting the
object in one of the available formats, which depend on the object you’ve copied
Typically you can choose to paste the object as an embedded or linked OLE object (if 
the object was stored in a saved file in an OLE-compatible source application), a picture
(metafile), or a bitmap. 

Dragging and dropping an object into a worksheet

A third way to insert an OLE object into a Mathcad worksheet is to drag it from the
source application and drop it into the worksheet. This is very similar to copying 
pasting, but does not allow you to create a link to an object. To do so:

■ Open both Mathcad and the source application and arrange the two windows
by side on the screen.

■ Select the object in the source application, usually by drag-selecting.
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■ Hold the mouse button down. For some applications, it may be necessary to 
the [Ctrl ] key and hold the mouse button down to ensure that the object will
copied (rather than cut) from the source application.

■ Drag the cursor onto a blank space in the Mathcad worksheet.

■ Let go of the mouse button to drop the object into the worksheet.

Editing an object

To edit either an embedded or linked object in a Mathcad worksheet, double-clic
object. Mathcad’s menus and toolbars will change to those of the source applica
and a hatched border will surround the object so that you can edit it. This OLE editing 
mechanism is called in-place activation. For example, you can use in-place activ
to edit objects created by Microsoft Office 95 or 97 applications such as Excel an
Word inside Mathcad.

If the source application does not support in-place activation inside Mathcad, the
behavior will differ. In the case of an embedded object, a copy of the object is pla
into a window from the other application. If the object is linked, the source applica
opens the file containing the object. 

Editing a link

If you’ve inserted a linked object into a Mathcad worksheet, you can update the 
eliminate it, or change the source file to which the object is linked. To do so, cho
Links  from the Edit  menu. You’ll see the following dialog box:

Choose the link you want to edit from the list of links. Then make any of the follow
changes:

Automatic:  Click this radio button to make the link update whenever you open th
worksheet and any time the source information changes while the worksheet is o

Manual:  Click this radio button to make the link update only when you press the
“Update Now” button.

Update Now: Click this button to update a manual link.

Open Source: Opens the application in which the linked object was created.
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Change Source: Links the object with a different source file. The new source file mu
have been created in the same application as the original source file.

Break Link:  Breaks the link between an object’s original source and the copy of 
object in the worksheet.

Inserting Mathcad objects into other applications

Just as you can insert objects into a Mathcad worksheet from other OLE2-compatible 
applications, you can insert Mathcad objects—either entire Mathcad worksheets
selected Mathcad regions—into other applications. The methods of doing so are n
the same as those outlined in the previous section for inserting objects into Math
They depend, however, on the extent to which the other applications support OLE2. 

For example, you may use any of the three methods of inserting OLE objects (choosing 
Object from the receiving application’s Insert menu, copying and pasting, and drag
and-drop) to insert Mathcad objects into Microsoft Office 95 or 97 applications.

Once you’ve inserted a Mathcad object into another application, you can edit it b
double-clicking on it. If the application supports in-place activation, as Microsoft Off
applications do, the menus and toolbars will change to Mathcad’s so that you can
the object without exiting the application and launching Mathcad. Figure 4-5 sho
the in-place activation of a Mathcad object inside Microsoft Word.

Figure 4-5: In-place activation of a Mathcad object inside Microsoft Word, 
giving you access to Mathcad’s menus, toolbar, and palettes.
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