Перехватываемые ошибки ядра Microsoft Jet и DAO

Перехватываемые ошибки ядра Microsoft Jet

Перехватываемые ошибки ядра базы данных Microsoft® Jet могут возникать как при выполнении приложения в среде разработки, так и при выполнении автономного исполняемого файла приложения. Для проверки ошибок и отклика на перехватываемые ошибки пользователь имеет возможность использовать объект Error.

Код Сообщение

2420 Число содержит синтаксическую ошибку.

2421 Дата содержит синтаксическую ошибку.

2422 Строка содержит синтаксическую ошибку.

2423 Недопустимое использование '.', '!' или ()'.

2424 Неизвестное имя.

2425 Неизвестное имя функции.

2426 Функция недоступна в выражениях.

2427 Объект не имеет значения.

2428 Недопустимые аргументы статистической функции по подмножеству.

2429 Оператор In требует наличия скобок: ().

2430 За оператором Between отсутствует оператор And.

2431 Ошибка синтаксиса (отсутствует оператор).

2432 Ошибка синтаксиса (запятая).

2433 Ошибка синтаксиса.

2434 Ошибка синтаксиса (отсутствует оператор).

2435 Непарная правая скобка: ).

2436 Отсутствует ), ] или элемент.

2437 Недопустимое использование символов вертикальной черты.

2438 Ошибка синтаксиса.

2439 Неверное число аргументов функции.

2440 Требуются скобки после функции IIF: ().

2442 Недопустимое использование скобок.

2443 Недопустимое использование оператора Is.

2445 Слишком сложное выражение.

2446 Недостаточно памяти при вычислениях.

2447 Недопустимое использование '.', '!' или ()'.

2448 Не удается задать значение.

3000 Зарезервированная ошибка <элемента>; сообщение для данной ошибки отсутствует.

3001 Ошибочный аргумент.

3002 Невозможно начать сеанс.

3003 Транзакция не может быть запущена; слишком большое число вложенных транзакций.

3005 <Имя базы данных > не является допустимым именем базы данных.

3006 Для базы данных <имя> установлен монопольный доступ.

3007 Не удается открыть библиотечную базу данных <имя>.

3008 Таблица <имя> уже открыта другим пользователем для монопольного доступа или открыта в интерактивном режиме и не может быть изменена в программе.

3009 Не удается блокировать таблицу <имя> при открытии; она в данное время используется. Подождите, пока таблица освободится, и повторите операцию.

3010 Таблица <имя> уже существует.

3011 Объект <имя> не найден ядром базы данных Microsoft Jet. Проверьте существование объекта и правильность имени и пути.

3012 Объект <имя> уже существует.

3013 Не удается переименовать файл устанавливаемого драйвера ISAM.

3014 Открытие большего числа таблиц невозможно.

3015 Не найден индекс.

3016 Поле не помещается в записи.

3017 Слишком большая длина поля.

3018 Не удается найти поле.

3019 Недопустимая операция без текущего индекса.

3020 Вызов метода Update или CancelUpdate без предварительного вызова метода AddNew или Edit.

3021 Текущая запись отсутствует.

3022 Изменения не были успешно завершены из-за повторяющихся значений в индексе, ключевых полях или связях. Измените данные в поле или полях, содержащих повторяющиеся значения, удалите индекс или переопределите его, чтобы разрешить повторяющиеся значения, и повторите попытку.

3023 Методы AddNew или Edit уже используются.

3024 Не удается найти файл <имя>.

3025 Открытие дополнительных файлов невозможно.

3026 Недостаточно места на диске.

3027 Обновление невозможно. База данных или объект доступны только для чтения.

3028 Не удается запустить приложение. Системная база данных отсутствует или открыта с монопольным доступом другим пользователем.

3029 Недопустимое имя учетной записи или пароль.

3030 <Имя записи> не является допустимым именем учетной записи.

3031 Неверный пароль.

3032 Невозможно выполнение данной операции.

3033 Отсутствуют разрешения на использование объекта <имя>. Необходимые разрешения должны быть предоставлены системным администратором или пользователем, создавшим объект.

3034 Попытка занесения или свертывания транзакции без предварительного вызова BeginTrans.

3036 Достигнут максимальный размер базы данных.

3037 Открытие дополнительных таблиц или запросов невозможно.

3039 Не удается создать индекс; уже определено слишком много индексов.

3040 Ошибка ввода/вывода при чтении диска.

3041 Не удается открыть базу данных, созданную в предыдущей версии приложения.

3042 Не хватает дескрипторов файлов MS-DOS.

3043 Дисковая или сетевая ошибка.

3044 Строка <путь> задает ошибочный путь. Проверьте, что путь задан правильно и имеется подключение к серверу, на котором находятся файлы.

3045 Невозможно использовать <имя>; файл уже используется.

3046 Сохранение невозможно; блокировка другим пользователем.

3047 Слишком большая длина записи.

3048 Открытие дополнительных баз данных невозможно.

3049 Открытие базы данных <имя> невозможно. Вероятно, это не база данных приложения пользователя, или ее файл поврежден.

3050 Блокировка файла невозможна.

3051 Файл <имя> не может быть открыт ядром базы данных Microsoft Jet. Файл уже открыт другим пользователем для монопольного доступа или требуется разрешение на просмотр данных.

3052 Достигнуто максимальное число блокировок файлов общего доступа. Увеличьте значение параметра реестра MaxLocksPerFile.

3053 Запущено слишком много задач-клиентов.

3054 Слишком много полей Memo или объектов ActiveX.

3055 Недопустимое имя файла.

3056 Не удается восстановить эту базу данных.

3057 Невозможно выполнение данной операции для присоединенных или связанных таблиц.

3058 Индекс или ключ не может содержать пустое значение (Null).

3059 Операция прервана пользователем.

3060 Недопустимый тип данных для параметра <параметр>.

3061 Слишком мало параметров. Требуется <число>.

3062 Повторение выходного псевдонима <имя>.

3063 Повторение получателя <имя>.

3064 Не удается открыть запрос на изменение <имя>.

3065 Невозможен запуск запроса на выборку.

3066 Запрос должен иметь хотя бы одно поле для вывода.

3067 В качестве входных данных запрос должен иметь хотя бы одну таблицу или запрос.

3068 Недопустимое имя псевдонима.

3069 Не допускается применение запроса на изменение <имя> в качестве источника строк.

3070 <Имя> не распознается ядром базы данных Microsoft Jet как допустимое имя поля или выражение.

3071 Выражение неверно введено или является слишком сложным для расчета. Например, числовое выражение может содержать слишком много элементов. Попытайтесь упростить выражение, определив его части как переменные.

3072 Несоответствие типов при создании условия на значения для таблицы или ограничения CHECK для столбца.

3073 В операции должен использоваться обновляемый запрос.

3074 Невозможно повторение имени таблицы <имя> в предложении FROM.

3075 <Сообщение> в выражении запроса <выражение>.

3076 <Имя> в выражении для условия отбора.

3077 <Сообщение> в выражении.

3078 Ядро базы данных Microsoft Jet не может найти входную таблицу или запрос <имя>. Проверьте существование таблицы или запроса и правильность имени.

3079 Ссылка на поле <имя> может относиться к полям нескольких таблиц, перечисленных в предложении FROM инструкции SQL.

3080 Связанная таблица <имя> отсутствует в предложении FROM.

3081 Объединение не может содержать несколько таблиц с одинаковым именем <имя>.

3082 Операция JOIN <операция> содержит ссылку на несвязанную таблицу.

3083 Невозможно использование внутреннего запроса отчета.

3084 Невозможно добавление данных с помощью запроса на изменение.

3085 Неопределенная функция <имя> в выражении.

3086 Невозможно удаление записей из указанных таблиц.

3087 Слишком много выражений в предложении GROUP BY.

3088 Слишком много выражений в предложении ORDER BY.

3089 Слишком много выражений в предложении DISTINCT.

3090 Результирующая таблица не должна иметь более одного поля счетчика.

3091 Предложение HAVING <имя> без выборки или группировки.

3092 Нельзя использовать предложение HAVING в инструкции TRANSFORM.

3093 Предложение ORDER BY <предложение> конфликтует с DISTINCT.

3094 Предложение ORDER BY <предложение> конфликтует с предложением GROUP BY.

3095 Невозможно использование статистической функции в выражении <выражение>.

3096 Невозможно использование статистической функции в предложении WHERE <предложение>.

3097 Невозможно использование статистической функции в предложении ORDER BY <предложение>.

3098 Невозможно использование статистической функции в предложении GROUP BY <предложение>.

3099 Невозможно использование статистической функции в операции JOIN <операция>.

3100 Для поля ключа связи <имя> невозможно задание значения Null.

3101 В таблице <имя> ядром базы данных Microsoft Jet не найдены записи с совпадающим ключевым полем <имя>.

3102 Циклическая ссылка, связанная с <запросом>.

3103 Псевдоним <имя> из списка определений SELECT запроса привел к возникновению циклической ссылки.

3104 Невозможно более одного раза задать заголовок столбца <значение> перекрестного запроса.

3105 В инструкции SELECT INTO <инструкция> пропущено имя результирующего поля.

3106 В инструкции UPDATE <инструкция> пропущено имя результирующего поля.

3107 Записи не могут быть добавлены; отсутствует разрешение на вставку данных для объекта <имя>.

3108 Записи не могут быть изменены; отсутствует разрешение на обновление данных для объекта <имя>.

3109 Записи не могут быть удалены; отсутствует разрешение на удаление данных для объекта <имя>.

3110 Не удается прочитать описания; отсутствует разрешение на чтение описания для объекта <имя>.

3111 Создание невозможно; отсутствует разрешение на изменение макета для таблицы или запроса <имя>.

3112 Записи не могут быть прочитаны; отсутствует разрешение на чтение данных для <имя>.

3113 Невозможно обновить поле <имя>; необновляемое поле.

3114 При отборе уникальных значений в <инструкции> нельзя использовать поля Memo, объекта OLE и гиперссылки.

3115 Поле Memo, объекта OLE и гиперссылки не может присутствовать в аргументе статистической функции в <инструкции>.

3116 Поле Memo, объекта OLE и гиперссылки не может присутствовать в условии отбора <условие> для статистической функции.

3117 Невозможна сортировка по полям Memo, объекта OLE и гиперссылки в <предложении>.

3118 Невозможно объединение с полем Memo, объекта OLE и гиперссылки <имя>.

3119 Невозможна группировка по полю Memo, объекта OLE и гиперссылки в <предложении>.

3120 Невозможна группировка по полям, выбранным с помощью символа '*' <имя таблицы>.

3121 Невозможна группировка по полям, выбранным с помощью символа '*'.

3122 Попытка выполнить запрос, который не включает указанное выражение <имя> как часть статистической функции или группы.

3123 Невозможно использование символа '*' в перекрестном запросе.

3124 Невозможен ввод из внутреннего запроса отчета <имя>.

3125 <Имя> не является допустимым именем. Проверьте, что оно представляет допустимый параметр или псевдоним, не содержит недопустимые символы или знаки препинания, а также не является слишком длинным.

3126 Недопустимое использование скобок с именем <имя>.

3127 Инструкция INSERT INTO содержит неизвестное имя поля: <имя поля>. Проверьте, что имя задано без ошибок, и повторите операцию.

3128 Необходимо указать таблицу, содержащую удаляемые записи.

3129 Ошибочная инструкция SQL; предполагалось 'DELETE', 'INSERT', 'PROCEDURE', 'SELECT' или 'UPDATE'.

3130 Ошибка синтаксиса в инструкции DELETE.

3131 Ошибка синтаксиса в предложении FROM.

3132 Ошибка синтаксиса в предложении GROUP BY .

3133 Ошибка синтаксиса в предложении HAVING.

3134 Ошибка синтаксиса в инструкции INSERT INTO.

3135 Ошибка синтаксиса в операции JOIN.

3136 Ошибочное или пропущенное зарезервированное слово или аргумент в предложении LEVEL или неверная пунктуация.

3137 После инструкции SQL пропущена точка с запятой (;).

3138 Ошибка синтаксиса в предложении ORDER BY.

3139 Ошибка синтаксиса в предложении PARAMETER.

3140 Ошибка синтаксиса в предложении PROCEDURE.

3141 Ошибочное или пропущенное зарезервированное слово или аргумент в инструкции SELECT или неверная пунктуация.

3142 За инструкцией SQL следуют другие знаки.

3143 Ошибка синтаксиса в инструкции TRANSFORM.

3144 Ошибка синтаксиса в инструкции UPDATE.

3145 Ошибка синтаксиса в предложении WHERE.

3146 ODBC — ошибка вызова.

3151 ODBC — ошибка подключения к <имя>.

3154 ODBC — не удается найти DLL <имя>.

3155 ODBC — вставка для присоединенной (связанной) таблицы <имя> не выполнена.

3156 ODBC — удаление для присоединенной (связанной) таблицы <имя> не выполнено.

3157 ODBC — обновление для присоединенной (связанной) таблицы <имя> не выполнено.

3158 Сохранение записи невозможно; установлена блокировка другим пользователем.

3159 Недопустимая закладка.

3160 Таблица не открыта.

3161 Не удается дешифровать файл.

3162 Попытка присвоить значение Null переменной, не принадлежащей к типу Variant.

3163 Выполнение операции невозможно; объем данных велик для поля. Попытайтесь вставить меньшее количество данных.

3164 Не удается обновить поле.

3165 Не удается открыть файл .inf.

3166 Не удается найти затребованный файл Memo Xbase.

3167 Запись удалена.

3168 Недопустимый файл .inf.

3169 Инструкция SQL не может быть выполнена ядром базы данных Microsoft Jet, так как содержит поле с недопустимым типом данных.

3170 Не удается найти устанавливаемый драйвер ISAM.

3171 Не удается найти сетевой путь или имя пользователя.

3172 Не удается открыть файл Paradox.net.

3173 Не удается открыть таблицу 'MSysAccounts' в файле системной базы данных.

3174 Не удается открыть таблицу 'MSysGroups' в файле системной базы данных.

3175 Дата выходит за пределы допустимого диапазона или имеет ошибочный формат.

3176 Не удается открыть файл <имя>.

3177 Недопустимое имя таблицы.

3179 Обнаружен ошибочный конец файла.

3180 Невозможна запись в файл <имя>.

3181 Недопустимый диапазон.

3182 Недопустимый формат файла.

3183 Недостаточно места на временном диске.

3184 Выполнение запроса невозможно; не удается найти присоединенную (связанную) таблицу.

3185 Инструкция SELECT INTO для удаленной базы данных осуществляет попытку создать слишком много полей.

3186 Сохранение невозможно; блокировка пользователем <имя> на машине <имя>.

3187 Чтение невозможно; блокировка пользователем <имя> на машине <имя>.

3188 Обновление невозможно; блокировка другим сеансом данной машины.

3189 Таблица <имя> блокирована с монопольным доступом пользователем <имя> на машине <имя>.

3190 Определено слишком много полей.

3191 Нельзя определить поле более одного раза.

3192 Не удается найти выходную таблицу <имя>.

3196 База данных <имя> уже используется другим пользователем или процессом. Повторите операцию, когда база данных снова станет доступной.

3197 Процесс остановлен ядром базы данных Microsoft Jet, так как другой пользователь пытается одновременно изменить те же данные.

3198 Невозможно начать сеанс. Уже запущено слишком много сеансов.

3199 Не удается найти ссылку.

3200 Удаление или изменение записи невозможно. В таблице <имя> имеются связанные записи.

3201 Невозможно добавление или изменение записи. Для обеспечения целостности данных необходимо наличие связанной записи в таблице <имя>.

3202 Сохранение невозможно; блокировка другим пользователем.

3203 В выражении <выражение> нельзя указывать подчиненный запрос.

3204 База данных уже существует.

3205 Слишком много заголовков столбцов <значение> для перекрестной таблицы.

3206 Невозможно создать связь поля с этим же полем.

3207 Операция не поддерживается для таблиц Paradox без ключевых полей.

3208 Недопустимое значение параметра «Deleted» в записи Xbase реестра Windows.

3210 Слишком длинная строка подключения.

3211 Таблица <имя> не может быть заблокирована ядром базы данных. Она уже используется другим пользователем или процессом.

3212 Блокировка таблицы <имя> невозможна; используется пользователем <имя> на машине <имя>.

3213 Недопустимое значение параметра «Date» в записи Xbase реестра Windows.

3214 Недопустимое значение параметра «Mark» в записи Xbase реестра Windows.

3216 Параметр <имя> задан вместо имени таблицы.

3217 Параметр <имя> задан вместо имени базы данных.

3218 Обновление невозможно; установлена блокировка.

3219 Недопустимая операция.

3220 Ошибочная таблица сортировки.

3222 Запрос не может иметь параметр 'База данных' (Database).

3223 Недопустимое имя параметра <имя>, имеющее слишком большую длину или содержащее недопустимые символы.

3227 Недопустимое значение параметра «Century» в записи Xbase реестра Windows.

3228 Выбранная языковая настройка не поддерживается операционной системой.

3230 Устаревший файл блокировок Paradox.

3231 ODBC — слишком большое поле; произошло усечение данных.

3232 ODBC — создание таблицы невозможно.

3234 ODBC — время ожидания для выполнения удаленного запроса истекло.

3235 ODBC — тип данных не поддерживается сервером.

3238 ODBC — данные выходят за пределы допустимого диапазона.

3239 Слишком много пользователей.

3242 Недопустимая ссылка в инструкции SELECT.

3243 Ни одно из имен импортируемых полей не совпадает с именами полей таблицы-получателя.

3244 Невозможен импорт электронной таблицы, защищенной паролем.

3245 Невозможно выделить имена полей из первой строки импортируемой таблицы.

3246 Операция не поддерживается в транзакциях.

3247 ODBC — было изменено описание связанной таблицы.

3248 Недопустимое значение параметра «NetworkAccess» в реестре Windows.

3249 Недопустимое значение параметра «PageTimeout» в реестре Windows.

3250 Невозможно построение ключа.

3251 Операция не поддерживается для объектов этого типа.

3252 Невозможно открыть форму: базовый запрос содержит определяемую пользователем функцию, задающую или получающую значение свойства RecordsetClone.

3254 ODBC — блокировка всех записей невозможна.

3256 Не найден индексный файл.

3257 Ошибка синтаксиса в описании WITH OWNERACCESS OPTION.

3258 Невозможно выполнить инструкцию SQL, так как запрос содержит неоднозначные внешние связи. Для указания связи, выполняемой первой, создайте отдельный запрос и включите его в инструкцию SQL.

3259 Недопустимый тип данных поля.

3260 Обновление невозможно; блокировка установлена пользователем <имя> на машине <имя>.

3261 Таблица <имя> блокирована с монопольным доступом пользователем <имя> на машине <имя>.

3262 Блокировка таблицы невозможна.

3263 Недопустимый объект Database.

3264 Поля не определены — невозможно добавление объектов Tabledef или Index.

3265 Элемент не обнаружен в данном семействе.

3266 Добавление невозможно. Поле является частью семейства Fields.

3267 Свойство может быть определено, только если это поле является частью семейства Fields объекта Recordset.

3268 Невозможно задание данного свойства, если объект является частью семейства.

3269 Добавление невозможно. Индекс является частью семейства Indexes.

3270 Свойство не найдено.

3271 Недопустимое значение свойства.

3272 Объект не является семейством.

3273 Метод неприменим к данному объекту.

3274 Формат внешней таблицы отличается от предполагаемого.

3275 Непредвиденная ошибка драйвера внешней базы данных <номер ошибки>.

3276 Недопустимая ссылка на объект Database.

3277 Индекс не может содержать более десяти полей.

3278 Не выполнена инициализация ядра базы данных Microsoft Jet.

3279 Инициализация ядра базы данных Microsoft Jet уже выполнена.

3280 Невозможно удаление поля, являющегося частью индекса или необходимого системе.

3281 Удаление индекса или таблицы невозможно. Объект является текущим индексом или используется для установления связи.

3282 Операция не поддерживается для таблицы, содержащей данные.

3283 Ключ уже существует.

3284 Индекс уже существует.

3285 Недопустимое определение индекса.

3286 Формат файла Memo не соответствует указанному формату внешней базы данных.

3287 Невозможно создание индекса для данного поля.

3288 Индекс Paradox не является первичным.

3289 Ошибка синтаксиса в предложении CONSTRAINT.

3290 Ошибка синтаксиса в инструкции CREATE TABLE.

3291 Ошибка синтаксиса в инструкции CREATE INDEX.

3292 Ошибка синтаксиса при определении поля.

3293 Ошибка синтаксиса в инструкции ALTER TABLE.

3294 Ошибка синтаксиса в инструкции DROP INDEX.

3295 Ошибка синтаксиса в инструкции DROP TABLE или DROP INDEX.

3296 Не поддерживается выражение объединения.

3297 Невозможен импорт таблицы или запроса. Записи не обнаружены, или все записи содержат ошибки.

3298 Существует несколько таблиц с данным именем. Укажите владельца в формате 'владелец.таблица'.

3299 Ошибка согласования спецификации ODBC <сообщение>. Сообщите о данной ошибке разработчику используемого приложения.

3300 Не удается установить связь.

3301 Выполнение операции невозможно; возможности данной версии недоступны в базах данных старого формата.

3302 Невозможно изменить условие на значение для таблицы в то время, когда условия используются.

3303 Удаление данного поля невозможно. Оно является частью одной или нескольких связей.

3304 Необходимо ввести код учетной записи, содержащий от 4 до 20 символов и цифр.

3305 Недопустимая строка подключения в запросе к серверу.

3306 Из подчиненного запроса, который не использует ключевое слово EXISTS, возвращается не более одного поля. Укажите в инструкции SELECT подчиненного запроса возвращение только одного поля.

3307 В таблицах или запросах, выбранных в запросе на объединение, не совпадает число столбцов.

3308 Недопустимый аргумент TOP запроса на выборку.

3309 Значение свойства имеет слишком большой размер.

3310 Данное свойство не поддерживается для внешних источников данных или для баз данных, созданных в предыдущей версии ядра Microsoft Jet.

3311 Указанное свойство уже определено.

3312 Нельзя задавать условия на значения или значения по умолчанию для системных или присоединенных (связанных) таблиц.

3313 Невозможно задать выражение условия на значения для этого поля.

3314 Поле <имя> не может содержать значение Null, так как свойство Required имеет значение True. Введите значение в поле.

3315 Поле <имя> не допускает ввод пустых строк.

3316 <Текст условия на значение уровня таблицы>.

3317 Одно или несколько из введенных значений нарушают условие на значение <правило>, заданное для <имя>. Введите значение, допускаемое выражением для данного поля.

3318 Значения, указанные в предложении TOP, не допускаются в запросах на удаление записей или в отчетах.

3319 Ошибка синтаксиса в запросе на объединение.

3320 <Ошибка> в выражении условия на значение уровня таблицы.

3321 Не задана база данных в строке подключения или в предложении IN.

3322 Перекрестный запрос содержит один или несколько недопустимых заголовков столбцов.

3323 Не допускается использование этого запроса в качестве источника строк.

3324 Данный запрос является управляющим запросом и его нельзя использовать в качестве источника строк.

3325 Запрос к серверу, свойство 'Возврат записей' (ReturnsRecords) которого имеет значение 'Истина', не вернул ни одной записи.

3326 Этот результирующий набор записей не является обновляемым.

3327 Значение поля <имя> определяется выражением и не редактируется.

3328 Таблица <имя> доступна только для чтения.

3329 Запись в таблице <имя> удалена другим пользователем.

3330 Запись в таблице <имя> заблокирована другим пользователем.

3331 Для изменения записи в данном поле ее необходимо предварительно сохранить.

3332 Невозможно вести значение в пустое поле, участвующее во внешнем объединении на стороне «один».

3333 Записям таблицы <имя> не соответствуют никакие записи со стороны «один».

3334 Возможно представление только в формате версии 1.0.

3337 Недопустимое значение параметра инициализации DataCodePage.

3340 Запрос <имя> поврежден.

3341 Текущее поле после обновления должно содержать подходящий ключ связи <имя> со стороны «один» внешнего объединения. Введите на стороне «один» запись с требуемым значением ключа связи, а затем создайте запись с тем же значением ключа в таблице на стороне «только многие»

3342 Ошибочное поле Memo, объекта OLE или гиперссылки в подчиненном запросе <имя>.

3343 Нераспознаваемый формат базы данных <имя файла>.

3344 Имя поля <имя> в выражении для условия на значение или в значении по умолчанию в таблице <имя> не распознается ядром базы данных.

3345 Недопустимая или неизвестная ссылка на поле <имя>.

3346 Не совпадает число значений запроса и число результирующих полей.

3347 Невозможно добавить записи; результирующий набор не содержит ключа для таблицы <имя>.

3348 Невозможно добавить записи; результирующий набор не содержит ключа связи для таблицы <имя>.

3349 Переполнение числового поля.

3350 Недопустимый объект для данной операции.

3351 В выражение ORDER BY <выражение> включены поля, не выбранные в запросе. Выражение ORDER BY может содержать только поля, затребованные в первом запросе.

3352 В инструкции INSERT INTO <инструкция> отсутствует имя результирующего поля.

3354 Данный подчиненный запрос должен возвращать не более одной записи.

3355 Ошибка синтаксиса в значении по умолчанию.

3356 Попытка открыть базу данных, открытую пользователем <имя> на машине <имя> для монопольного доступа. Повторите попытку, когда база данных освободится.

3357 Данный запрос не является правильно заданным управляющим запросом.

3358 Не удается открыть файл рабочей группы ядра Microsoft Jet.

3359 Запрос к серверу должен содержать по крайней мере один символ.

3360 Слишком сложный запрос.

3361 В подчиненном запросе не допускаются объединения.

3362 Обновление/удаление строки влияет на несколько строк присоединенной таблицы. Повтор значений в уникальном индексе.

3363 Записи не могут быть добавлены; отсутствуют соответствующие записи со стороны «один».

3364 В предложении SELECT запроса на объединение не допускается использование поля Memo, объекта OLE или гиперссылки <имя>.

3365 Невозможно установить значение данного свойства для внешних объектов.

3366 Невозможно добавить связь, не определив поля.

3367 Добавление объекта невозможно. Он уже входит в семейство.

3368 Отношение должно быть задано для одинакового количества полей с одинаковыми типами данных.

3370 Невозможно изменение структуры таблицы <имя>. База данных доступна только для чтения.

3371 Не удается найти таблицу или ограничение.

3372 Индекс <имя> не существует в таблице <имя>.

3373 Не удается создать связь. Указанная таблица <имя> не имеет ключевых полей.

3374 Указанные поля не имеют уникального индекса в таблице <имя>.

3375 Таблица <имя> уже имеет индекс с именем <имя>.

3376 Таблица <имя> не существует.

3377 Отношение <имя> для таблицы <имя> не существует.

3378 Связь <имя> уже существует в текущей базе данных.

3379 Невозможно обеспечить целостность данных. Данные таблицы <имя> нарушают условия для связи с таблицей <имя>.

3380 Поле <имя> уже существует в таблице <имя>.

3381 Поле <имя> отсутствует в таблице <имя>.

3382 Слишком длинное поле <имя>.

3383 Невозможно удалить поле <имя>. Оно является частью одной или нескольких связей.

3384 Невозможно удаление встроенного свойства.

3385 Свойства, определяемые пользователем, не допускают задание пустых значений (Null).

3386 Перед использованием данного метода необходимо задать значение свойства <имя>.

3388 Неизвестная функция <имя> в выражении условия на значение или в значении по умолчанию для <имя>.

3389 Поддержка запроса недоступна.

3390 Имя учетной записи уже существует.

3393 Невозможно выполнить объединение, группировку, сортировку или отбор по индексу. Слишком длинное значение, используемое для поиска или сортировки.

3394 Сохранение свойства невозможно; свойство схемы.

3396 Невозможно выполнить каскадную операцию. Наличие в таблице <имя> связанных записей приведет к нарушению целостности данных.

3397 Невозможно выполнить каскадную операцию. Необходимо наличие связанных записей в таблице <имя>.

3398 Невозможно выполнить каскадную операцию. Каскадная операция приведет к появлению пустого ключевого поля в таблице <имя>.

3399 Невозможно выполнить каскадную операцию. Это приведет к появлению повторяющихся значений в ключевом поле таблицы <имя>.

3400 Невозможно выполнить каскадную операцию. Операция приведет к повторному обновлению поля <имя> в таблице <имя>.

3401 Невозможно выполнить каскадную операцию. Операция приведет к появлению недопустимого пустого (Null) значения в поле <имя>.

3402 Невозможно выполнить каскадную операцию. Операция приведет к появлению недопустимой пустой строки в поле <имя>.

3403 Невозможно выполнить каскадную операцию. <текст сообщения>.

3404 Невозможно выполнить каскадную операцию. Введенное значение не соответствует условию на значения <правило>, заданному для <имя>.

3405 Ошибка <текст> в условии на значение.

3406 Ошибка <текст сообщения> в выражении для свойства DefaultValue. Задайте значение свойства с помощью допустимого выражения.

3407 Таблица 'MSysConf' на сервере имеет неверный формат. Обратитесь к системному администратору.

3408 Вызвано слишком много сеансов FastFind.

3409 Недопустимое имя поля <имя> при определении индекса или связи.

3411 Ошибочное значение. Невозможно выполнить каскадную операцию в таблице <имя>; значение велико для поля <имя>.

3412 Невозможно выполнить каскадное обновление таблицы, так как таблица используется другим пользователем.

3413 Невозможно выполнить каскадную операцию над таблицей <имя>, которая в данный момент занята пользователем <имя> на компьютере <имя>.

3414 Невозможно выполнить каскадную операцию над таблицей <имя>, которая в данный момент используется.

3415 Допустим ввод пустой строки только в текстовое поле или поле Memo.

3416 <Предупреждение о зарезервированной ошибке>

3417 Запрос на изменение не может использоваться как источник строк.

3418 Не удается открыть таблицу <имя>. Таблица открыта другим пользователем с помощью иного сетевого управляющего файла или с другим типом блокировки.

3419 Не удается открыть таблицу Paradox 4.x или 5.x, так как для параметра ParadoxNetStyle в реестре Windows задано значение «3.x».

3420 Неверный или не заданный объект.

3421 Ошибка преобразования типа данных.

3422 Невозможно изменение структуры таблицы. Таблица открыта другим пользователем.

3423 Не допускается использование ODBC для импорта, экспорта или присоединения таблицы из внешней базы данных Microsoft Jet или базы данных ISAM.

3424 Создание базы данных невозможно; недопустимая национальная настройка.

3428 Обнаружена ошибка в базе данных. Для исправления восстановите и сожмите базу.

3429 Несовместимая версия устанавливаемого драйвера ISAM.

3430 При загрузке драйвера ISAM для Microsoft Excel не удается выполнить инициализацию OLE.

3431 Это не файл Microsoft Excel версии 5.0.

3432 Ошибка при открытии файла Microsoft Excel версии 5.0.

3433 Недопустимое значение параметра в записи Excel в разделе Engines реестра Windows.

3434 Не удается дополнить именованный диапазон.

3435 Невозможно удалить ячейки электронной таблицы.

3436 Ошибка при создании файла.

3437 Переполнение электронной таблицы.

3438 Экспортируемые данные не соответствуют формату, описанному в файле Schema.ini.

3439 Попытка присоединения или импорта файла слияния Microsoft Word. Допускается только экспорт таких файлов.

3440 Попытка присоединения или импорта пустого текстового файла. Файл должен содержать данные.

3441 Разделитель полей, указанный в спецификации текстового файла, совпадает с разделителем целой и дробной частей чисел или ограничителем текстовых полей.

3442 В спецификации <имя> текстового файла имеется недопустимый параметр <имя>.

3443 В спецификации <имя> текстового файла с фиксированной длиной записей не задана ширина столбцов.

3444 В спецификации <имя> текстового файла с фиксированной длиной записей для столбца <имя столбца> не задана ширина.

3445 Обнаружена ошибочная версия файла библиотеки <имя>.

3446 Отсутствует файл Jet VBA (VBAJET.dll для 16-разрядных версий или VBAJET32.dll для 32-разрядных версий). Переустановите приложение, возвратившее ошибку.

3447 Ошибка инициализации при вызове файла Jet VBA (VBAJET.dll для 16-разрядных версий или VBAJET32.dll для 32-разрядных версий). Переустановите приложение, возвратившее ошибку.

3448 Неудачный вызов системной функции OLE. Переустановите приложение, возвратившее ошибку.

3449 Отсутствует код языка в строке подключения.

3450 Ошибка синтаксиса в запросе. Неполное предложение в запросе.

3451 Недопустимая ссылка в запросе.

3452 Невозможно изменение структуры базы данных для этой реплики.

3453 Невозможно установление или обновление связи между реплицируемой и локальной таблицами.

3455 Невозможно сделать базу данных реплицируемой.

3456 Невозможно сделать реплицированным объект <имя> в контейнере <имя>.

3457 Невозможно установить значение свойства KeepLocal для объекта, который уже является реплицируемым.

3458 Невозможно установить значение свойства KeepLocal для базы данных; оно задается только для объектов базы данных.

3459 Если база данных была сделана реплицируемой, это невозможно отменить.

3460 Предпринимаемая операция вступает в конфликт с существующей операцией над репликой.

3461 Устанавливаемое или удаляемое свойство репликации доступно только для чтения, и его невозможно изменить.

3462 Сбой при загрузке библиотеки.

3463 Невозможно найти библиотеку <имя>.

3464 Несоответствие типа данных в выражении условия отбора.

3465 Используемый диск недоступен для чтения.

3468 Отказ доступа при обращении к общему банку данных <имя>.

3469 Заполнен диск общего банка данных <имя>.

3470 Сбой диска при обращении к общему банку данных <имя>.

3471 Сбой при записи в файл журнала синхронизатора.

3472 Переполнен диск в пути <имя>.

3473 Сбой диска при доступе к файлу журнала <имя>.

3474 Невозможно открыть для записи файл журнала <имя>.

3475 Нарушение прав доступа при попытке открыть файл журнала <имя> в монопольном режиме записи.

3476 Недопустимый путь к общему банку данных <имя>.

3477 Ошибка синтаксиса в адресе <имя> общего банка данных.

3478 Эта реплика не является частичной репликой.

3479 Невозможно сделать частичную реплику основной репликой набора.

3480 Недопустимая связь <имя> в выражении фильтра частичной реплики.

3481 Недопустимое имя таблицы <имя> в выражении фильтра частичной реплики.

3482 Недопустимое выражение фильтра для частичной реплики.

3483 Задан недопустимый пароль общего банка данных <имя>.

3484 Синхронизатор использовал недопустимый пароль для записи в конечный общий банк данных.

3485 Невозможно сделать реплицируемым объект, так как эта база данных не является реплицируемой.

3486 Невозможно добавить в таблицу второе поле счетчика для кода реплики.

3487 Не удается преобразовать базу данных, для которой предпринимается попытка репликации.

3488 Заданное значение не является кодом реплики ни для одной реплики набора.

3489 Не удается реплицировать заданный объект из-за нехватки ресурсов.

3490 Невозможно создание новой реплики, так как объект <имя> в контейнере <имя> не удается сделать реплицируемым.

3491 Для преобразования базы данных в реплицируемую необходимо открыть ее с монопольным доступом.

3492 Произошел сбой синхронизации, так как изменения структуры невозможно применить к одной из реплик.

3493 Невозможно задать параметр реестра для синхронизатора.

3494 Невозможно загрузить указанный параметр реестра для синхронизатора.

3495 Отсутствуют запланированные сеансы обмена между двумя синхронизаторами.

3496 Диспетчеру репликации не удается найти поле «ExchangeID» в таблице «MSysExchangeLog».

3497 Невозможно задать расписание работы синхронизатора.

3499 Невозможно загрузить сведения о полном пути для реплики из набора.

3500 Не допускается указание двух различных синхронизаторов для обработки одной реплики.

3502 Основная реплика или реплика не была обработана синхронизатором.

3503 В системном реестре для синхронизатора отсутствует значение для требуемой записи.

3504 Код синхронизатора не совпадает с существующим кодом в таблице «MSysTranspAddress».

3505 Попытка удалить или получить информацию о фильтре частичной реплики, отсутствующем в таблице «MsysFilters».

3506 Синхронизатору не удается открыть журнал.

3507 Сбой при записи в журнал синхронизатора.

3508 Отсутствует активный транспорт для синхронизатора.

3509 Невозможно найти допустимый транспорт для синхронизатора.

3510 Подготовленная для обмена реплика в данное время используется в другом сеансе обмена.

3512 Сбой при чтении общего банка данных.

3513 Сбой при записи в общий банк данных.

3514 Синхронизатор не может найти ни одного планового или запрашиваемого обмена для обработки.

3515 Системные часы на данном компьютере не читаются ядром базы данных Microsoft Jet.

3516 Указанный синхронизатор не настроен на поддержку косвенной синхронизации, а конечная реплика недоступна для прямой синхронизации.

3517 Синхронизатор не может найти сообщение для обработки.

3518 Невозможно найти синхронизатор в таблице «MSysTranspAddress».

3519 Сбой при отправке сообщения.

3520 Имя или код реплики не соответствует обрабатываемой в данное время реплике.

3521 Невозможно синхронизировать две реплики, поскольку общая точка для запуска синхронизации отсутствует.

3522 Синхронизатор не может найти запись конкретного обмена в таблице «MSysExchangeLog».

3523 Синхронизатор не может найти конкретный номер версии в таблице «MSysSchChange».

3524 Последовательности изменений структуры реплики и основной реплики не совпадают.

3525 Синхронизатор не имеет доступа к базе данных сообщений.

3526 Имя, выбранное для системного объекта, уже используется.

3527 Синхронизатор или диспетчер репликации не может найти системный объект.

3528 Отсутствуют новые данные для чтения в общей памяти синхронизатора или диспетчера репликации.

3529 Синхронизатор или диспетчер репликации обнаружил непрочитанные данные в общей памяти. Существующие данные будут перезаписаны.

3530 Синхронизатор уже обслуживает клиента.

3531 Превышен период ожидания события.

3532 Не удается инициализировать синхронизатор.

3533 После остановки процесса все еще существует использованный системный объект.

3534 Синхронизатор выполнил поиск, но не нашел ни одного системного события для отчета клиенту.

3535 Клиент выдал запрос синхронизатору на прекращение операции.

3536 Синхронизатор получил недопустимое сообщение для обрабатываемой реплики.

3537 Клиент синхронизатора отсутствует и не может получить уведомление.

3538 Невозможна инициализация синхронизатора, поскольку запущено слишком много приложений.

3539 Произошла системная ошибка или достигнут предел страничного файла.

3540 Достигнут предел страничного файла, или файл поврежден.

3541 Не удается нормально остановить синхронизатор, и он остается в активном состоянии.

3542 Процесс прерван при попытке завершить клиента синхронизатора.

3543 Синхронизатор не был установлен.

3544 Синхронизатор уже запущен.

3545 Попытка синхронизировать реплики из различных наборов реплик.

3546 Предпринимается попытка выполнить недопустимый тип обмена.

3547 Синхронизатор не может найти реплику из правильного набора для завершения обмена.

3548 Коды GUID не совпадают, или не удается обнаружить запрашиваемый код GUID.

3549 Задано слишком длинное имя файла.

3550 Отсутствует индекс для столбца GUID.

3551 Не удается удалить указанный параметр реестра для синхронизатора.

3552 Размер параметра реестра превышает допустимый предел.

3553 Не удается создать код GUID.

3555 Все допустимые псевдонимы реплик уже используются.

3556 Недопустимый путь к результирующему банку общих данных.

3557 Недопустимый адрес для конечного общего банка данных.

3558 Ошибка ввода/вывода на диске для результирующего банка общих данных.

3559 Ошибка записи из-за заполнения результирующего диска.

3560 Две синхронизируемые реплики имеют одинаковый код.

3561 Обе синхронизируемые реплики имеют статус основной реплики.

3562 Нет доступа к результирующему общему банку данных.

3563 Общий сбой при обращении к локальному общему банку данных.

3564 Синхронизатор не может найти исходный файл сообщений.

3565 Нарушение доступа к исходному общему банку данных, так как база данных сообщений открыта другим приложением.

3566 Сетевая ошибка ввода/вывода.

3567 Сообщение из общего банка данных принадлежит ошибочному синхронизатору.

3568 Синхронизатор не может удалить файл.

3569 Реплика была логически удалена из набора реплик и более недоступна.

3570 Фильтры, определяющие частичную реплику, не синхронизованы между собой.

3571 Попытка задать столбец частичной реплики нарушила правило, поддерживающее частичные реплики.

3572 Ошибка ввода/вывода при чтении или записи в каталог TEMP.

3573 Каталог, в котором запрошен список реплик, не является управляемым каталогом.

3574 Код данной реплики был переприсвоен во время процедуры перемещения или копирования.

3575 Переполнение диска, для которого выполняется попытка записи.

3576 Открываемая база данных уже используется другим приложением.

3577 Невозможно обновление системного столбца репликации.

3578 Сбой репликации базы данных; невозможно определить, открыта ли база данных в монопольном режиме.

3579 Не удается создать системные таблицы репликации, необходимые для репликации базы данных.

3580 Не удается добавить строки, необходимые для репликации базы данных.

3581 Невозможно открыть системную таблицу репликации <имя>, так как она уже используется.

3582 Невозможно создание новой реплики, так как объект <имя> в контейнере <имя> не удается сделать реплицируемым.

3583 Невозможно сделать реплицированным объект <имя> в контейнере <имя>.

3584 Не хватает памяти для завершения операции.

3585 Невозможно реплицировать таблицу; превышено максимальное разрешенное число столбцов.

3586 Ошибка синтаксиса в выражении фильтра для таблицы <имя> в частичной реплике.

3587 Недопустимое выражение для свойства ReplicaFilter.

3588 Ошибка при оценке выражения фильтра частичной реплики.

3589 Выражение фильтра частичной реплики содержит неизвестную функцию.

3590 Нарушение правил для частичных реплик.

3591 Недопустимый путь <полный_путь> к файлу журнала.

3592 Невозможно сделать реплицируемой защищенную базу данных или защитить паролем реплицируемую базу данных.

3593 В наборе реплик не разрешается изменять атрибут основной реплики данных.

3594 Не допускается изменение атрибута основной реплики данных в наборе реплик. Изменение данных разрешено только в основной реплике.

3595 Системные таблицы реплики повреждены, и реплика не должна более использоваться.

3600 В статистических выражениях нельзя использовать значения типа GUID.

3605 Не допускается синхронизация с нереплицируемой базой данных. База данных <имя> не является основной или частичной репликой.

3607 Невозможно удаление свойства репликации, так как оно доступно только для чтения.

3608 Слишком большая длина записи для индексированной таблицы Paradox.

3609 Обнаружен повторяющийся индекс в адресуемом поле главной таблицы.

3610 В запросе на создание таблицы <имя> имеется ссылка на одну таблицу и как на источник, и как на получателя данных.

3611 Невозможно выполнение инструкций определения данных с присоединенными источниками данных.

3612 Многоуровневое предложение GROUP BY не допускается в подчиненном запросе.

3613 Не допускается создание связи между присоединенными таблицами ODBC.

3614 Не допускается использование типа GUID в выражениях для условия поиска в методах Find.

3615 Несоответствие типов в выражении JOIN.

3616 Обновление данных в присоединенной (или связанной) таблице не поддерживается данным драйвером ISAM.

3617 Удаление данных в присоединенной (или связанной) таблице не поддерживается данным драйвером ISAM.

3618 Не удается создать таблицу исключений при импорте/экспорте.

3619 Невозможно добавление записей в таблицу исключений.

3620 Потеряна связь с Excel для просмотра присоединенных листов.

3621 Невозможно изменение пароля базы данных, открытой для общего доступа.

3622 Необходимо использование параметра dbSeeChanges с OpenDatabase при доступе к таблице SQLServer, которая имеет столбец IDENTITY.

3623 Нет доступа к присоединенному файлу FoxPro 3.0 <имя файла>.

3624 Чтение невозможно. Блокировка другим сеансом на данной машине.

3625 Спецификация текстового файла <имя> не существует. Невозможен импорт, экспорт или присоединение с помощью этой спецификации.

3626 Ошибка при выполнении операции. В таблице <имя> слишком много индексов. Удалите несколько индексов из указанной таблицы и повторите попытку.

3627 Невозможно найти исполняемый файл синхронизатора (mstran40.exe).

3628 Реплика-партнер не обрабатывается синхронизатором.

3629 Синхронизатор <имя> также использует банк данных файловой системы <имя>.

3630 Синхронизатор <имя> также использует банк данных файловой системы <имя>.

3631 Недопустимое имя таблицы в фильтре.

3632 Транспортный протокол Интернета не включен на удаленном синхронизаторе.

3633 Не удается загрузить библиотеку <имя>.

3634 Невозможно создать реплику с помощью частичной реплики.

3635 Невозможно создать частичную реплику системной базы данных.

3636 Не удается заполнить реплику или изменить фильтр реплики из-за конфликтов реплики или ошибок в данных.

3637 Невозможно использовать перекрестный запрос с непостоянными столбцами как подчиненный запрос.

3638 Невозможно реплицировать базу данных, используемую управляющей программой.

3639 Невозможно создать реплику системной базы данных.

3640 Размер буфера подкачки недостаточен для запрашиваемых данных.

3641 В наборе записей осталось меньше записей, чем запрашивается.

3642 Операция отменена.

3643 Одна из записей в наборе записей была удалена в другом процессе.

3645 Один из параметров связи неверен.

3646 Заданная длина строки меньше суммы ширины столбцов.

3647 Запрашиваемый столбец не возвращается в наборе записей.

3648 Невозможно выполнить синхронизацию частичной реплики с другой частичной репликой.

3649 Кодовая страница для языка не указана или не найдена.

3650 Либо слишком медленно выполняются операции Интернета, либо имеются неполадки в настройке диспетчера репликации на сервере Интернета.

3651 Неверный адрес Интернета.

3652 Ошибка входа в Интернет.

3653 Неверная настройка Интернета.

3656 Ошибка при расчете выражения для частичной реплики.

3657 Ошибка в логическом выражении для фильтра таблицы <имя>.

3658 Двоичный столбец <имя> нельзя использовать в логическом фильтре.

3659 Связь <имя> не наложена. Необходимо наложить связь в выражении для фильтра частичной реплики.

3660 Затребованный обмен не выполнен из-за <описание>.

3661 Затребованный обмен не выполнен из-за <описание>.

3663 Для этой операции требуется другая библиотека указателей.

3664 Еще не завершен асинхронный вызов OpenConnection; до завершения вызова ссылки на возвращаемый объект Connection невозможны.

3665 Невозможно изменить системный объект репликации <имя>.

3666 Невозможно изменить системный объект репликации <имя>.

3667 Другая операция не позволяет выполнить эту операцию.

3668 Невозможно выполнить эту операцию, так как отсутствует активное подключение.

3672 Сбой при загрузке библиотеки RDOCURS.DLL.

3673 Эта таблица содержит ячейки, которые находятся вне диапазона ячеек, определенного в электронной таблице.

3674 Невозможно найти или загрузить библиотеку Интернета (wininet.dll).

3675 Сбой при чтении дескриптора Интернета. Повторите попытку.

3676 Сбой при записи дескриптора Интернета. Повторите попытку.

3677 Сбой при выполнении запроса HTTP на запуск синхронизатора Интернета или сервера Интернета. Выполните настройку синхронизатора Интернета на сервере Интернета с помощью диспетчера репликации.

3678 Сбой при подключении к службе на сервере Интернета. Проверьте, что служба FTP выполняется на сервере и поддерживает анонимные подключения.

3679 Сбой при открытии файла с помощью службы FTP. Проверьте, что имеется разрешение на чтение банка данных FTP.

3680 Сбой при получении файла с сервера с помощью FTP. Проверьте, что имеется разрешение на чтение банка данных FTP.

3681 Сбой при попытке поместить файл на сервер с помощью FTP. Проверьте, что имеется разрешение на запись для банка данных FTP.

3682 Сбой при удалении файла на сервере с помощью FTP. Проверьте, что имеются разрешение на чтение и запись для банка данных FTP.

3683 Неожиданное закрытие синхронизатора Интернета на сервере. Чтобы разобраться в причинах неполадок, просмотрите таблицу хронологии репликации реплики-партнера на сервере Интернета.

3684 Нет подходящей реплики для выполнения обмена.

3685 Неверный адрес HTTP.

3686 Недопустимый путь или имя реплики.

3689 Недопустимый синтаксис SQL - ожидаемый элемент: Привилегии.

3700 Недопустимая точность для типа данных decimal.

3701 Недопустимый масштаб для типа данных decimal.

3702 Ширина текстового столбца Unicode должна задаваться четным числом байтов.

3703 Операция не поддерживается для реплицированных баз данных, которые не были преобразованы к текущей версии.

3704 Попытка открыть базу данных, открытую пользователем <имя> на машине <имя> для монопольного доступа. Повторите попытку, когда база данных освободится.

3705 Невозможно реплицировать таблицу <имя>: слишком много столбцов.

3706 Невозможно реплицировать таблицу <имя>: слишком много индексов.

3707 Параметры каскадных процессов для новой ссылки конфликтуют с существующей ссылкой <имя>.

3708 Ошибка синтаксиса в инструкции TRANSACTION. Ожидается TRANSACTION, WORK или ничего.

3709 Ключ поиска не найден ни в одной записи.

3710 Не найдена папка MAPI или адресная книга.

3711 Восстановлены реплицированные данные. Эта строка восстановлена из поврежденной реплицированной базы данных. Проверьте правильность содержимого записи, а затем вставьте запись или удалите конфликтующую запись.

3713 Конфликт одновременного обновления. Данная запись также обновлена в другой реплике. Данная запись отвергнута в конфликте. Либо снова отправьте обновление, либо удалите конфликтующую запись.

3714 Таблица блокирована. Данная запись не будет занесена при синхронизации, так как таблица блокирована другим пользователем. Повторите отправку конфликтующей записи.

3715 Нарушение уникальности ключа. Значение ключа данной записи совпадает со значением ключа в другой записи; допускаются только уникальные значения. Либо измените значение ключа в конфликтной записи или в отобранной записи, а затем повторите отправку записи, либо удалите конфликтующую запись.

3716 Нарушение условий на значение на уровне таблицы. Эта запись содержит значение, не отвечающее ограничениям на значения на уровне таблицы. Либо обновите значение поля, нарушающее условие на значение, а затем снова отправьте запись, либо удалите конфликтующую запись.

3717 Конфликт удаления и нарушения условий целостности данных. Запись с первичным ключом была удалена в другой реплике, поэтому ссылающаяся на нее запись была отвергнута. Либо создайте новый первичный ключ, удовлетворяющий условиям целостности данных, а затем повторите отправку обновленной записи, либо удалите конфликтующую запись.

3718 Конфликт обновления и нарушения условий целостности данных. Запись с первичным ключом была обновлена в другой реплике, поэтому ссылающаяся на нее запись была отвергнута. Либо создайте запись с новым первичным ключом, удовлетворяющим условиям целостности данных, измените значение внешнего ключа в конфликтующей записи соответственно действительному значению первичного ключа, а затем повторите отправку обновленной записи, либо удалите конфликтующую запись.

3719 Нарушение внешнего ключа является следствием участия в конфликте репликации записи с неверным первичным ключом. Либо создайте запись с новым первичным ключом, удовлетворяющим условиям целостности данных, измените значение внешнего ключа в конфликтующей записи соответственно действительному значению первичного ключа, а затем повторите отправку обновленной записи, либо удалите конфликтующую запись.

3720 Невозможно изменить поле <имя>. Оно является частью одной или нескольких связей.

3721 Недопустимый синтаксис SQL - ожидается имя CONSTRAINT.

3722 Недопустимый синтаксис SQL - ожидаемый элемент: DEFAULT.

3723 Недопустимый синтаксис SQL - ожидаемый элемент: COMPRESSION после WITH.

3724 Недопустимый синтаксис SQL - ожидаемый элемент: UPDATE или DELETE.

3725 Недопустимый синтаксис SQL - ожидаемый элемент: CASCADE, SET NULL или NO ACTION.

3726 Недопустимый синтаксис SQL - ожидаемый элемент: NULL.

3727 Недопустимый синтаксис SQL: допускается только одно правило обновления и/или одно правило удаления.

3728 Недопустимый синтаксис SQL - ожидаемый элемент: AS.

3729 Недопустимый синтаксис SQL - ожидаемый элемент: SELECT.

3730 VIEW не может содержать параметр.

3731 Число указанных псевдонимов должно совпадать с числом выводящихся столбцов.

3732 После EXECUTE ожидается имя запроса.

3733 Неизвестный пользователь перевел базу данных в состояние, не позволяющее ее открыть или блокировать.

3734 Пользователь <имя> на компьютере <имя> перевел базу данных в состояние, не позволяющее ее открыть или блокировать.

3736 Конфликт обновления/удаления. Эта обновленная запись была удалена в другой реплике. Либо снова вставьте эту конфликтующую запись, либо удалите ее.

3737 Невозможно создать реплику этого типа по данной исходной реплике.

3738 Синхронизация локальных или анонимных реплик должна выполняться только с их назначенным разветвителем.

3740 Невозможно добавить новый столбец в конфликтную таблицу <имя>. Удалите ненужные столбцы и выполните сжатие базы данных.

3741 Недопустимый синхронизатор. Синхронизация локальных или анонимных реплик должна выполняться только с их назначенным разветвителем.

3742 Превышен период ожидания функции Интернета.

3743 Реплика не была синхронизована за период автономности набора реплик.

3745 Общая длина имени сервера Интернета, общего ресурса HTTP и псевдонима FTP не должна быть более 252 символов.

3746 Ошибка синтаксиса в запросе. Значение параметра.

3747 Параметр не имеет значения по умолчанию.

3748 Параметр <имя> не имеет значения по умолчанию.

3749 Объект не является сохраненной процедурой.

3750 Объект <имя> не является сохраненной процедурой.

3751 Затребована блокировка строки, но БД находится в режиме блокировки страницы.

3752 Затребована блокировка страницы, но БД находится в режиме блокировки строки.

3753 Невозможно создать реплику с помощью реплики Jet SQL.

3754 Невозможно выполнить удаление из реплики, в которой удаление запрещено.

3755 Ограничение CHECK <имя> не существует.

3756 Ограничение CHECK <имя> уже существует.

3757 Не удается загрузить библиотеки сортировки JET.

3758 Масштаб значения decimal приводит к усечению данных.

3759 Масштаб значения decimal приводит к усечению данных.

3760 Масштаб значения decimal приводит к переполнению.

3761 Точность поля типа decimal слишком мала для добавляемого значения.

3762 Недопустимый синтаксис SQL - ожидаемый элемент: ACTION.

3763 Сбой операций с репликой из-за параллельного изменения схемы. Повторите попытку.

3765 Ошибка синтаксиса в предложении ограничения CHECK.

3766 В представлениях допускаются только простые запросы SELECT.

3767 Невозможно сделать реплицируемой таблицу <имя>, так как ее не удается открыть для монопольного доступа.

3768 В операции FastFind возможен поиск только по ссылкам на столбцы.

3769 Невозможно переименовать таблицу конфликтов.

3770 Определение счетчика вне допустимого диапазона.

3771 Локальную или анонимную реплику невозможно сделать основной репликой.

3772 Если нет разрешений администратора, реплика должна иметь приоритет в диапазоне 0 - <число>.

3773 Невозможно удалить один или несколько объектов <имя>.

3775 Невозможно загрузить библиотеку Jet SQL Server - MSRPJT40.dll.dll

3777 Незаконная операция над репликой Jet SQL Server.

3778 Для данного набора реплик SQL/Jet указана неверная или поврежденная база данных Jet.

3779 Невозможно изменить режим отслеживания на уровне столбцов для объектов, которые уже сделаны реплицируемыми.

3780 Недопустимый синтаксис SQL - ожидается имя представления.

3781 Недопустимый синтаксис SQL - ожидается имя процедуры.

3784 База данных уже реплицирована.

3785 Недопустимый синтаксис SQL - ожидаемый элемент: DATABASE

3786 Недопустимый синтаксис SQL - ожидаются привилегии на базу данных, такие как CREATEDB или CONNECT.

3787 Эта операция не разрешена в подчиненных запросах.

3788 Невозможно создать индекс для папки или адресной книги MAPI.

3789 Недопустимое ограничение на уровне столбца.

3798 Ограничения CHECK не допускаются в реплицированных базах данных.

3799 Не удается найти поле <имя>.

3800 <Имя> не является индексом данной таблицы.

3801 Объект <имя> нельзя использовать в предложении ограничения CHECK.

3802 Ошибка при вычислении ограничения CHECK для <имя>. <Дополнительные сведения.>

3803 Невозможно завершить операцию DDL над данной таблицей, так как на нее имеется ссылка в ограничении <имя> в таблице <имя>.

3804 На данном компьютере не установлены клиенты MAPI. Установите на компьютер клиент MAPI, например Outlook.

3805 Ограничения CHECK таблицы <имя> не будут переведены в данную таблицу. Ограничения CHECK можно создавать только в инструкциях SQL DLL.

3806 Невозможно задать множественные атрибуты NULL, NOT NULL.

3807 Запрос <имя> содержит неоднозначное имя столбца, конфликтующее с корреляционным именем (псевдонимом) <имя>. Либо задайте полное имя столбца, либо измените корреляционное имя (псевдоним).

3808 Для этой операции требуется системная база данных формата версии 4.x или более поздней.


Слишком сложное выражение. (Ошибка 2445)

Слишком сложное выражение для ядра базы данных Microsoft Jet. Попробуйте упростить выражение.


Не удается открыть таблицу Paradox 4.x или 5.x, так как для параметра ParadoxNetStyle в реестре Windows задано значение «3.x». (Ошибка 3419)

Внешняя таблица Paradox не может быть открыта ядром базы данных Microsoft Jet из-за несогласования версии таблицы и значения параметра ParadoxNetStyle в реестре Microsoft® Windows®.

Чтобы исправить ошибку

  1. Закройте ваше приложение.
  2. Запустите редактор реестра, найдите запись \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox и выделите параметр ParadoxNetStyle.
  3. Выберите в меню Правка команду Изменить.
  4. Введите значение 4.x в поле Значение.
  5. Значения параметра ParadoxNetStyle должны быть одинаковыми у всех пользователей, работающих с базой данных в режиме общего доступа.
  6. Снова запустите ваше приложение.
  7. Попытайтесь снова открыть таблицу.


Не удается восстановить эту базу данных. (Ошибка 3056)

База данных повреждена или не является базой данных Microsoft Jet. Восстановите поврежденную базу данных Microsoft® Jet по резервной копии или создайте новую базу данных.


Операция отменена. (Ошибка 3642)

Выполнение запроса прервано в источнике данных. Некоторые из отобранных строк могут быть потеряны. Попытайтесь повторить запрос.


Отсутствуют разрешения на использование объекта <имя>. Необходимые разрешения должны быть предоставлены системным администратором или пользователем, создавшим объект. (Ошибка 3033)

Пользователь не имеет необходимых разрешений на указанный объект. Для изменения присвоенных разрешений обратитесь к системному администратору или к создателю объекта.


Имя учетной записи уже существует. (Ошибка 3390)

Данная проблема связана с системой защиты. Сделана попытка создать учетную запись пользователя с именем, которое уже существует. Проверьте имена пользователей в семействе Users или повторите попытку с другим именем.


Запрашиваемый столбец не возвращается в наборе записей. (Ошибка 3647)

Один из затребованных столбцов недоступен.


Не удается добавить строки, необходимые для репликации базы данных. (Ошибка 3580)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Невозможно использование статистической функции в выражении <выражение>. (Ошибка 3095)

Не допускается использование статистической функции в данном выражении.


Невозможно использование статистической функции в предложении GROUP BY <предложение>. (Ошибка 3098)

Не допускается использование статистической функции в предложении GROUP BY инструкции SQL.


Невозможно использование статистической функции в операции JOIN <операция>. (Ошибка 3099)

Не допускается использование статистической функции в операции JOIN инструкции SQL.


Невозможно использование статистической функции в предложении ORDER BY <предложение>. (Ошибка 3097)

Не допускается использование статистической функции в предложении ORDER BY инструкции SQL.


Невозможно использование статистической функции в предложении WHERE <предложение>. (Ошибка 3096)

Не допускается использование статистической функции в предложении WHERE инструкции SQL.


В выражении <выражение> нельзя указывать подчиненный запрос. (Ошибка 3203)

Указанное выражение содержит подчиненный запрос или другое выражение, функционально эквивалентное подчиненному запросу.

Возможная причина:

  • Используется инструкция SELECT, включающая статистическую функцию, которая обрабатывает результаты выполнения другой статистической функции. Такая ошибка возникает, например, при выполнении следующей инструкции:

    TRANSFORM Sum([СуммаЗаказа]) AS Сумма1

    SELECT Sum([Сумма1]) AS Сумма2, КодЗаказа, Sum([Сумма2]) AS Выражение1

    FROM Заказы

    GROUP BY КодЗаказа

    PIVOT НазваниеПолучателя;

    Параметр <выражение> в сообщении об ошибке будет содержать выражение Sum([Noiia2]) из предложения SELECT, поскольку данная ссылка содержит псевдоним, используемый в той же инструкции SELECT, и фактически определяет подчиненный запрос относительно выражения Sum([Noiia1]).


В статистических выражениях нельзя использовать значения типа GUID. (Ошибка 3600)

Инструкция SQL не может содержать столбец с типом данных GUID, участвующий в статистических операциях, таких как MAX, MIN, SUM и т.д.


Все допустимые псевдонимы реплик уже используются. (Ошибка 3555)

Набор реплик может содержать не более 32 768 реплик. Это число уже достигнуто. Начните новый набор реплик.


Инициализация ядра базы данных Microsoft Jet уже выполнена. (Ошибка 3279)

Попытка инициализации уже инициализированного ядра базы данных Microsoft Jet.


Методы AddNew или Edit уже используются. (Ошибка 3023)

Текущие изменения не были сохранены или отменены, и предпринимается попытка добавить запись или изменить другую запись. Воспользуйтесь методом Rollback или Update, а затем примените метод AddNew или Edit.


Разделитель полей в спецификации текстового файла совпадает с десятичным разделителем или ограничителем текстовых полей. (Ошибка 3441)

Разделитель полей, указанный в спецификации текстового файла, совпадает с разделителем целой и дробной частей чисел или ограничителем текстовых полей. (Ошибка 3441)

Совпадают два или более разделителя, указанных в настройке «Text ISAM»:

  • TxtDelimiter
  • NumberDecimalSymbol
  • CurrencyDecimalSymbol
  • Format


Ошибка синтаксиса. (Ошибка 2438)

Введенное выражение имеет недопустимый синтаксис. Например, пропущен операнд или оператор, введен недопустимый символ или запятая, или введенный текст не заключен в кавычки ("). Убедитесь, что выражение задано правильно.


Дата содержит синтаксическую ошибку. (Ошибка 2421)

Синтаксически недопустимое значение типа Date. Ошибка возникает при неправильном задании даты. Например, недопустимым является значение 31.09.94 (в сентябре только 30 дней).


Недопустимое использование '.', '!' или ()'. (Ошибка 2423)

Неправильное использование разделителей в выражении. Для ссылок на свойства объекта доступа к данным (DAO) рекомендуется использовать синтаксис .имяСвойства.


Требуются скобки после функции IIF: (). (Ошибка 2440)

Аргументы функции IIf должны быть заключены в скобки, как показано в следующем примере:

IIf(выражение, часть_true, часть_false)


Оператор In требует наличия скобок: (). (Ошибка 2429)

При записи инструкции SQL с оператором In необходимо заключать список проверяемых элементов в скобки. Например, чтобы проверить значение на совпадение с одним из значений заданного набора, воспользуйтесь предложением WHERE запроса SQL следующего вида:

WHERE Штат In ('TX', 'CA', 'WA')

В данной конструкции проверяется, содержит ли поле "Штат" одно из сокращений, которые представляют штаты Texas, California и Washington.


Недопустимое использование оператора Is. (Ошибка 2443)

Оператор Is используется для проверки, имеет ли выражение значение Null. Допускается использование оператора Is в выражении только со словами NULL или NOT NULL.


Таблица 'MSysConf' на сервере имеет неверный формат. Обратитесь к системному администратору. (Ошибка 3407)

Таблица «MSysConf», создаваемая на сервере для управления передачей сообщений между ядром базы данных Microsoft Jet и присоединенным источником данных ODBC, должна иметь определенный формат.


Число содержит синтаксическую ошибку. (Ошибка 2420)

В данном месте требуется число. Это может быть связано с наличием нечислового значения в числовой части выражения.


Недопустимый диапазон. (Ошибка 3181)

Попытка импортировать недопустимый диапазон ячеек электронной таблицы.


Строка содержит синтаксическую ошибку. (Ошибка 2422)

Введенное выражение включает недопустимую строку. Убедитесь, что выражение задано правильно.


Недопустимое использование символов вертикальной черты. (Ошибка 2437)

Введенное выражение содержит недопустимые символы вертикальной черты (|). Убедитесь, что выражение задано правильно.


Недопустимое имя таблицы. (Ошибка 3177)

Введенное имя не соответствует стандартным правилам именования. Введите новое имя и повторите операцию.


Двоичный столбец <имя> нельзя использовать в логическом фильтре. (Ошибка 3658)

Непредвиденная ошибка. За дополнительными сведениями обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Недопустимый формат файла. (Ошибка 3182)

Возможные причины:

  • Файл, для которого предпринимается попытка чтения или присоединения (связывания), поврежден. Восстановите файл по резервной копии на диске и повторите операцию.
  • Нераспознаваемый формат файла. Если это файл Btrieve, dBASE или Paradox, запустите программу Setup для установки устанавливаемого драйвера ISAM, а затем вновь выполните присоединение этого файла.


$Ошибка в логическом выражении для фильтра таблицы <имя>. (Ошибка 3657)

Непредвиденная ошибка. За дополнительными сведениями обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Невозможно выполнить синхронизацию частичной реплики с другой частичной репликой. (Ошибка 3648)

База данных, с которой выполняется попытка синхронизации, является частичной репликой. Не допускается синхронизация частичной реплики с другой частичной репликой, поскольку вторая реплика может не содержать все записи, указывающие фильтру первой частичной реплики.


За оператором Between отсутствует оператор And. (Ошибка 2430)

При использовании оператора Between для проверки, попадает ли значение выражения в указанный диапазон, необходимо задать верхний и нижний пределы диапазона, разделенные зарезервированным словом And. Например, для проверки диапазона кодов от "Б" до "Ж" воспользуйтесь строкой:

WHERE ИмяПоля Between "Б" And "Ж"


Синхронизатор не имеет доступа к базе данных сообщений. (Ошибка 3525)

База данных сообщений недоступна для синхронизатора. Скорее всего, файл базы данных используется другой программой или другим пользователем (пользователям не рекомендуется открывать базы данных сообщений синхронизатора). Закройте все приложения, которые могут использовать эту базу данных.


Невозможно создать реплику этого типа по данной исходной реплике. (Ошибка 3737)

Создать реплику с другой степенью видимости можно только по глобальной реплике. Например, по локальной реплике можно создать только другую локальную реплику, а по анонимной реплике можно создать только другую анонимную реплику. По глобальным репликам можно создавать глобальные, локальные и анонимные реплики.


Невозможно создать частичную реплику системной базы данных. (Ошибка 3635)

Сделана попытка создать частичную реплику, источником которой является файл рабочей группы. Репликация файлов системных баз данных невозможна.


Невозможно создать реплику с помощью частичной реплики. (Ошибка 3634)

Сделана попытка создать реплику, источником которой является частичная реплика. Репликация частичных реплик невозможна.


Невозможно найти библиотеку <имя>. (Ошибка 3463)

Проверьте, что инструкция PATH содержит путь к указанной библиотеке динамической компоновки или переустановите диспетчер репликации (или приложение).


Синхронизатор не может найти запись конкретного обмена в таблице «MSysExchangeLog». (Ошибка 3522)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Невозможно найти исполняемый файл синхронизатора (mstran40.exe). (Ошибка 3627)

Файл Mstran40.exe не найден на указанном пути при попытке запустить синхронизатор.


Синхронизатор или диспетчер репликации не может найти системный объект. (Ошибка 3527)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Синхронизатор не может найти конкретный номер версии в таблице «MSysSchChange». (Ошибка 3523)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Невозможно сделать реплицированным объект <имя> в контейнере <имя>. (Error 3583)

Невозможно сделать реплицированным объект <имя> в контейнере <имя>. (Ошибка 3583)

Объект (таблицу, форму, отчет, модуль или макрос) из указанного контейнера невозможно сделать реплицированным.

Примером объекта, для которого невозможна репликация, является содержащая 253 или большее количество полей. Поскольку при репликации необходимо добавить не менее трех полей, это приведет к превышению предельного количества 255 полей.


Невозможно изменить системный объект репликации <имя>. (Ошибка 3665)

Попытка выполнить недопустимую операцию, такую как удаление системной таблицы, переименование системной таблицы или удаление системного столбца репликации во внутреннем системном объекте.


Невозможно изменить системный объект репликации <имя>. (Ошибка 3666)

Попытка выполнить недопустимую операцию, такую как удаление системной таблицы, переименование таблицы или удаление столбца репликации во внутреннем системном объекте.


Не удается запустить приложение. Системная база данных отсутствует или открыта с монопольным доступом другим пользователем. (Ошибка 3028)

Для обеспечения целостности данных в базах данных, созданных с помощью ядра Microsoft Jet, приложению необходимо прочитать файл базы данных Microsoft® Jet System.mdw. Проверьте, что этот файл находится в каталоге, заданном в реестре Windows в разделе \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet в записи SystemDB.


Не удается переименовать файл устанавливаемого драйвера ISAM. (Ошибка 3013)

Попытка переименовать таблицу Btrieve, dBASE или Paradox, но невозможно переименование файла, содержащего эту таблицу.

Возможные причины:

  • Файл был определен с доступом только для чтения в операционной системе или в сети.
  • У пользователя отсутствуют привилегии записи в этот файл в сетевой среде.


Не удается открыть файл Paradox.net. (Ошибка 3172)

Не удается открыть файл Paradox.net.

Возможные причины:

  • В разделе реестра \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox указано недопустимое значение параметра ParadoxNetPath. Эта ошибка возникает, если используется внешняя база данных Paradox, а значение ParadoxNetPath указывает на несуществующий каталог. Закройте приложение, исправьте недопустимую запись и повторите операцию.
  • Значение параметра реестра ParadoxNetPath указывает на сетевой диск, подключение к которому отсутствует. Проверьте, что сетевой диск доступен, и повторите операцию.


Невозможно добавить в таблицу второе поле счетчика для кода реплики. (Ошибка 3486)

Изменяемая таблица уже содержит одно поле счетчика, имеющее размер «Код репликации» (или GUID). Если в таблицу требуется добавить второе поле счетчика для кода реплики, которое будет служить внешним ключом, используйте для него числовой тип данных.


Достигнут максимальный размер базы данных. (Ошибка 3036)

Для добавления данных в эту базу необходимо сначала уменьшить ее размер путем удаления данных. Базы данных Microsoft® Jet версии 3.X и более ранние имеют максимальный размер 1,07 Гбайт. Максимальный размер базы данных Microsoft® Jet версии 4.0 равен 2,14 Гбайт.


Произошел сбой синхронизации, так как изменения структуры невозможно применить к одной из реплик. (Ошибка 3492)

Была предпринята попытка обновления структуры одной из реплик базы данных ядром базы данных Microsoft Jet. Ниже перечислены несколько причин, по которым обновление структуры базы данных может оказаться невозможным:

  • попытка обновления объекта, уже открытого в реплике;
  • определение для реплики связи, внешний ключ которой содержит ссылку не несуществующий первичный ключ.

Дополнительные сведения о сбое синхронизации можно найти в таблице «MSysSchemaProb» либо в основной реплике, либо в реплике, для которой выполнялась синхронизация.


Невозможно начать сеанс. (Ошибка 3002)

Попытка выполнить операцию, которая требует открытия нового сеанса, но уже достигнуто предельное число сеансов, которые могут быть запущены одновременно. Дождитесь завершения или остановите другие операции и повторите данную.


Невозможно построение ключа. (Ошибка 3250)

При создании первичного индекса ядро базы данных Microsoft Jet не может построить ключ. Проверьте правильность имен ключевых полей и отсутствие записей с повторяющимися значениями данного ключа.

Такая ошибка возникает при вызове метода Seek и передачи в него значения поля, не являющегося частью индекса. Предположим, например, что требуется вызвать метод Seek для объекта Recordset, в текущем индексе которого используется поле "Фамилия" из базовой таблицы. Если конструкция вызова метода имеет вид:

rstEmployees.Seek "=", "Иванов", "Иван"

ядро Microsoft Jet сделает попытку создать ключ по двум полям. Однако, поскольку индекс создан по одному из полей, попытка окажется неудачной и приведет к возникновению ошибки.


Невозможно изменение пароля базы данных, открытой для общего доступа. (Ошибка 3621)

Для изменения пароля базы данных необходимо открыть ее с монопольным доступом.


Невозможно изменение структуры базы данных для этой реплики. (Ошибка 3452)

Изменение структуры базы данных допускается только для основной реплики. Изменяемая реплика не является основной репликой набора реплик. Перейдите к основной реплике и внесите необходимые изменения.


Не удается преобразовать базу данных, для которой предпринимается попытка репликации. (Ошибка 3487)

Реплицируемыми можно сделать только базы данных, созданные с помощью ядра базы данных Microsoft Jet версии 3.0 или более поздней. Несмотря на то что база данных может быть открыта с помощью устанавливаемого драйвера ISAM, ее нельзя сделать реплицируемой. Для преобразования баз данных, созданных более ранними версиями Microsoft Jet, в новый формат воспользуйтесь командой Преобразовать (меню Сервис Microsoft Access). Базу данных другого формата следует экспортировать в новую базу данных Microsoft Jet и повторно выполнить операцию.


Не удается создать код GUID. (Ошибка 3553)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Невозможно создать реплику системной базы данных. (Ошибка 3639)

Попытка репликации файла рабочей группы. Запрещенная операция.


Не удается удалить указанный параметр реестра для синхронизатора. (Ошибка 3551)

Необходимо изменить настройку синхронизатора для данного компьютера.

Чтобы настроить синхронизатор

  1. Запустите диспетчер репликации.
  2. Выберите команду Configure Microsoft Replication Manager в меню Сервис диспетчера репликации.
  3. Выполняйте указания мастера.


Сбой репликации базы данных; невозможно определить, открыта ли база данных в монопольном режиме. (Ошибка 3578)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Невозможно установление или обновление связи между реплицируемой и локальной таблицами. (Ошибка 3453)

Была предпринята попытка установления или обновления связи между реплицируемой и не реплицируемой таблицами. Репликация не допускает установление связи между:

  • реплицированной и локальной таблицами;
  • двумя локальными таблицами, которые пользователь пытается сделать реплицируемыми;
  • двумя таблицами, имеющими разные значения свойства KeepLocal.

Удалите связь между двумя таблицами перед выполнением данной операции.


Ошибка при вычислении ограничения CHECK для <имя>. <Дополнительные сведения.> (Ошибка 3802)

Непредвиденная ошибка. За дополнительными сведениями обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Диспетчеру репликации не удается найти поле "ExchangeID" в таблице "MSysExchangeLog". (Ошибка 3496)

Диспетчеру репликации не удается найти поле «ExchangeID» в таблице «MSysExchangeLog». (Ошибка 3496)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Синхронизатор не может найти исходный файл сообщений. (Ошибка 3564)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Указанный синхронизатор не настроен. (Ошибка 3516)

Указанный синхронизатор не настроен на поддержку косвенной синхронизации, а конечная реплика недоступна для прямой синхронизации. (Ошибка 3516)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Невозможно найти синхронизатор в таблице «MSysTranspAddress». (Ошибка 3518)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Невозможно найти допустимый транспорт для синхронизатора. (Ошибка 3509)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Не удается загрузить библиотеку <имя>. (Ошибка 3633)

Указанная библиотека динамической компоновки либо не зарегистрирована, либо не находится на заданном пути.


Не удается блокировать таблицу <имя> при открытии; она в данное время используется. Подождите немного и повторите операцию. (Ошибка 3009)

Не удается блокировать таблицу <имя> при открытии; она в данное время используется. Подождите, пока таблица освободится, и повторите операцию. (Ошибка 3009)

Общий доступ к таблице невозможен из-за ее блокировки с монопольным доступом другим пользователем, либо монопольный доступ к таблице невозможен вследствие блокировки другим пользователем общего доступа к таблице. Возвращается имя пользователя, установившего действующую в настоящее время блокировку.


Не удается открыть файл .inf. (Ошибка 3165)

Попытка присоединить (связать) таблицу dBASE, но не удается открыть или создать связанный файл .inf со сведениями об индексах этой таблицы.

Возможные причины:

  • Не хватает места на диске для создания файла .inf.
  • Пользователь не имеет привилегий записи на этот сетевой диск в сетевой среде.


Невозможно сделать базу данных реплицируемой. (Ошибка 3455)

Сбой при попытке ядра базы данных Microsoft Jet сделать базу данных реплицируемой. Сбой операции из-за недостатка ресурсов. Проверьте, что общее число полей после репликации не превышает 255, а размер записи не превышает 2048 байт.


Невозможно сделать частичную реплику основной репликой набора. (Ошибка 3479)

Укажите другую реплику, которую следует сделать основной репликой набора.


Если база данных была сделана реплицируемой, это невозможно отменить. (Ошибка 3459)

Если база данных была сделана реплицируемой путем задания значения «T» ее свойства Replicable или преобразования с помощью портфеля Microsoft® Windows®, Microsoft Access или диспетчера репликации, это невозможно отменить. Задание с помощью объектов доступа к данным (DAO) значения «F» (как и любого другого значения) свойства Replicable для этой базы данных не оказывает на нее никакого влияния. Если требуется использовать копию базы данных, не обладающей свойствами, полями, таблицами и другими характеристиками, связанными с репликацией, откройте резервную копию этой базы данных, созданную до ее преобразования.


Не удается открыть файл <имя>. (Ошибка 3176)

Не удается открыть указанный текстовый файл или файл электронной таблицы. Используется недопустимая спецификация файла, доступ к этому файлу осуществляет другой пользователь, или отсутствуют привилегии чтения этого файла. Подождите, пока другой пользователь завершит использование этого файла, и повторите операцию, или обратитесь к системному администратору или администратору сети.


Невозможно открыть для записи файл журнала <имя>. (Ошибка 3474)

Проверьте, что у вас имеются разрешения на запись в файл протокола.


Попытка присоединения или импорта файла слияния Microsoft Word. Допускается только экспорт таких файлов. (Ошибка 3439)

Попытка присоединения или импорта файла слияния Microsoft® Word. Допускается только экспорт таких файлов.


Невозможно сделать реплицируемой защищенную базу данных или защитить паролем реплицируемую базу данных. (Ошибка 3592)

Если база данных защищена паролем, удалите его.


Не удается заполнить реплику или изменить фильтр реплики из-за конфликтов реплики или ошибок в данных. (Ошибка 3636)

Сделана попытка изменить фильтр частичной реплики или заполнить частичную реплику, в которой имеются конфликты или ошибки данных. Для продолжения работы необходимо устранить конфликты или исправить ошибки. Это позволит избежать потери сведений о конфликте и обеспечит корректное исправление ошибок.


Невозможно загрузить сведения о полном пути для реплики из набора. (Ошибка 3499)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Невозможно загрузить указанный параметр реестра для синхронизатора. (Ошибка 3494)

Необходимо изменить настройку синхронизатора для данного компьютера.

Чтобы настроить синхронизатор

  1. Запустите диспетчер репликации.
  2. Выберите команду Configure Microsoft Replication Manager в меню Сервис диспетчера репликации.
  3. Выполняйте указания мастера.


Не удается задать значение. (Ошибка 2448)

Попытка присвоить значение объекту, доступному только для чтения или не имеющему значения.


Невозможно установить значение свойства KeepLocal для объекта, который уже является реплицируемым. (Ошибка 3457)

Невозможно установить значение свойства KeepLocal для объекта, который уже является реплицированным. Задание свойства KeepLocal для локального объекта после того, как база данных стала реплицируемой, не оказывает никакого влияния на этот объект. Чтобы объект нельзя было сделать реплицируемым для остальных реплик данного набора, задайте для этого объекта значение «F» свойства Replicable.


Не допускается изменение атрибута основной реплики данных в наборе реплик. Изменение данных разрешено только в основной реплике. (Ошибка 3594)

Возможность изменения данных во всех репликах набора или только в основной реплике определяется при первом преобразовании базы данных в основную реплику. После преобразования базы данных этот атрибут изменить невозможно.


В наборе реплик не разрешается изменять атрибут основной реплики данных. (Ошибка 3593)

Не допускается изменение атрибута основной реплики данных в наборе реплик. (Ошибка 3593)

Возможность изменения данных во всех репликах набора или только в основной реплике определяется при первом преобразовании базы данных в основную реплику. После преобразования базы данных этот атрибут изменить невозможно.


Невозможно задать параметр реестра для синхронизатора. (Ошибка 3493)

Необходимо изменить настройку синхронизатора для данного компьютера.

Чтобы настроить синхронизатор

  1. Запустите диспетчер репликации.
  2. Выберите команду Configure Microsoft Replication Manager в меню Сервис диспетчера репликации.
  3. Выполняйте указания мастера.


Невозможно обновление системного столбца репликации. (Ошибка 3577)

Была предпринята попытка обновления столбца, который является системным и доступен только для чтения.


Операция не поддерживается для таблиц Paradox без ключевых полей. (Ошибка 3207)

Запустите приложение, в котором была создана таблица, и определите ключ. После этого повторите операцию.


Сбой при записи в файл журнала синхронизатора. (Ошибка 3471)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Невозможна запись в файл <имя>. (Ошибка 3180)

Попытка экспорта данных в указанный текстовый файл или файл электронной таблицы, который не допускает изменения.

Возможные причины:

  • Другой пользователь в данное время осуществляет доступ к этому файлу. Дождитесь, когда другой пользователь завершит использование файла, и повторите операцию.
  • Файл был определен с доступом только для чтения в операционной системе или в сети. Отмените ограничение доступа и повторите операцию.
  • У пользователя отсутствуют привилегии записи в этот файл в сетевой среде.

Возможно, требуется обратиться к системному или сетевому администратору.


Эта таблица содержит ячейки, которые находятся вне диапазона ячеек, определеного в электронной таблице. (Ошибка 3673)

Эта таблица содержит ячейки, которые находятся вне диапазона ячеек, определенного в электронной таблице. (Ошибка 3673)

Неверно сформирован файл читающейся электронной таблицы. Он содержит данные вне диапазона, указанного в заголовочной части файла. Драйвер электронной таблицы не может считать данные без ошибок.

Возможно, файл не является файлом электронной таблицы или поврежден. Попробуйте прочитать файл в исходном приложении электронной таблицы, а затем снова запишите его в другой файл. Возможно, ошибки будут исправлены в исходном приложении.


Невозможно изменить поле <имя>. (Ошибка 3720)

Невозможно изменить поле <имя>. Оно участвует в одной или нескольких связях. (Ошибка 3720)

Эта ошибка возникает при попытке изменить имя или определение первичного ключа, на который ссылаются внешние ключи. Для того чтобы изменить определение ключа или имена столбцов, входящих в первичный ключ, необходимо предварительно удалить все ссылки на этот ключ во внешних ключах. Обычно такая ошибка возникает при использовании инструкции ALTER TABLE ALTER COLUMN.


Ограничение CHECK <имя> не существует. (Ошибка 3755)

Эта ошибка возникает, когда при использовании синтаксиса ALTER TABLE ALTER COLUMN пользователь пытается применить инструкцию DROP к несуществующему ограничению CHECK. Эта ошибка также может иметь место при попытке использовать Microsoft® OLE DB Provider для Jet для получения информации о несуществующем ограничении CHECK.


Ошибка синтаксиса в предложении CHECK CONSTRAINT. (Ошибка 3765)

Ошибка синтаксиса в предложении ограничения CHECK. (Ошибка 3765)

Такая ошибка возникает при попытке использовать инструкции SQL DLL для определения ограничения CHECK. Ее причиной является неверная ссылка на таблицу или имя столбца в условии поиска (инструкции SELECT) в предложении CHECK.


Ограничение CHECK <имя> уже существует. (Ошибка 3756)

Эта ошибка возникает, когда при использовании синтаксиса ALTER TABLE ALTER COLUMN пользователь использовать для ограничения CHECK имя, уже существующее в данной таблице. При использовании программы Microsoft OLE DB Provider для Jet эта ошибка может также возникать при попытке добавить ограничение CHECK, имя которого совпадает с именем другого ограничения CHECK в этой таблице.


Клиент выдал запрос синхронизатору на прекращение операции. (Ошибка 3535)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Результирующая таблица не должна иметь более одного поля счетчика. (Ошибка 3090)

Попытка запустить запрос, в результате выполнения которого создается таблица с несколькими полями типа счетчика. Измените запрос, чтобы он включал только одно поле счетчика.


Невозможно создание индекса для данного поля. (Ошибка 3287)

Сделана попытка создать индекс для поля Memo или объекта OLE. Укажите другое поле и повторите операцию.

Эта ошибка возникает также при попытке создания индекса для байтового поля таблицы Btrieve.


В таблицах или запросах, выбранных в запросе на объединение, не совпадает число столбцов. (Ошибка 3307)

Для двух таблиц или запросов, объединенных в операции UNION, должно создаваться одинаковое число столбцов. Удалите столбцы из инструкции SELECT, содержащей лишние столбцы, или добавьте недостающие столбцы в другую инструкцию SELECT.

Примечание. Вместо имен недостающих столбцов в инструкцию SELECT могут быть включены константы. Например, в следующем запросе на объединение в первой инструкции SELECT заполняются три столбца, а во второй один столбец заполняется значениями поля, а два других – константами. Запрос возвращает названия всех стран из таблиц «Сотрудники» и «Регионы». Из таблицы «Сотрудники» возвращаются также фамилии и имена сотрудников. Если название страны берется из таблицы «Регионы», то в запросе возвращаются пустые (Null) значения в столбцах «Имя» и «Фамилия».

SELECT Страна, Имя, Фамилия FROM Сотрудники

UNION SELECT Страна, NULL, NULL FROM Регионы;


Поле не помещается в записи. (Ошибка 3016)

Попытка импорта или вставки поля слишком большого размера. Попробуйте разделить поле на меньшие части и выполните импорт или вставку этих данных в несколько полей, или измените тип данных этого поля.

Размер записи ограничен величиной 2K, за исключением полей Memo и объектов OLE .


Нельзя определить поле более одного раза. (Ошибка 3191)

Попытка создать таблицу, несколько полей которой имеют одинаковое имя. Каждое имя поля таблицы должно быть уникальным.


Удаление данного поля невозможно. Оно участвует в одной или нескольких связях. (Ошибка 3303)

Попытка удалить поле, для которого в базе данных определены связи. Для удаления поля необходимо предварительно удалить связи.


Невозможно удаление поля, являющегося частью индекса или необходимого системе. (Ошибка 3280)

Невозможно удалить поле, являющееся частью индекса, необходимо сначала удалить индекс.


Unable to change Column Level Tracking Property on objects that are already Replicable. (Error 3779)

Невозможно изменить режим отслеживания на уровне столбцов для объектов, которые уже сделаны реплицируемыми. (Ошибка 3779)

После того как объект сделан реплицируемым, невозможно изменить режим отслеживания на уровне столбцов. Для изменения режима отслеживания объект должен быть снова преобразован в локальный. Затем можно изменить режим и снова сделать объект реплицируемым.


Не удается найти поле. (Ошибка 3018)

Возможные причины:

  • Указанное поле не существует.
  • Имя поля задано с ошибками. Проверьте, что не пропущены символы подчеркивания ( _ ) или другая пунктуация и отсутствуют начальные пробелы.
  • Введен недопустимый идентификатор поля. Например, [Моя таблица]_[Мое поле] вместо МояТаблица![Мое поле].
  • Имя поля, содержащее пробелы, не заключено в прямые скобки.


Не удается найти поле <имя>. (Ошибка 3799)

Ссылка на несуществующий столбец.


Операция JOIN <операция> содержит ссылку на несвязанную таблицу. (Ошибка 3082)

Попытка выполнить инструкцию SQL, содержащую недопустимое объединение. Эта ошибка возникает при попытке создать объединение на основе поля, которое не находится ни в одной из связываемых таблиц. Такая ошибка возникает, например, в следующей инструкции:

SELECT Авторы.Имя, Названия.ISBN

FROM Авторы, Названия, ИменаАвторов,

Авторы INNER JOIN Названия ON Авторы.Код = ИменаАвторов.ISBN;

Ошибка возникает из-за того, что объединение включает таблицы «Авторы» и «Названия», но связываемые поля находятся в таблицах «Авторы» и «ИменаАвторов».


Не удается обновить поле, поскольку соответствующая запись или таблица заблокирована другим пользователем или процессом. (Ошибка 3164)

Не удается обновить поле. (Ошибка 3164)

Возможные причины:

  • Попытка обновить поле записи или таблицы, которая в данное время заблокирована другим пользователем. Дождитесь, когда другой пользователь завершит работу с записью или таблицей, и повторите операцию.
  • В Microsoft® Access попытка изменить значение элемента управления, свойство Locked которого имеет значение Yes («Да»).


Невозможно реплицировать таблицу; превышено максимальное разрешенное число столбцов. (Ошибка 3585)

В таблице превышено максимальное разрешенное число столбцов. Если в таблице имеется менее 251 столбца, то сжатие базы данных может вернуть доступные столбцы, которые пока учитываются при расчете предела.


Слишком большая длина поля. (Ошибка 3017)

Возможные причины:

  • Попытка определить или создать текстовое поле, длина которого превышает 254 символа. Используйте число от 1 до 254 и повторите операцию, или создайте для данных поле Memo.
  • Попытка определить параметр запроса, длина которого превышает 255 символов.


Ширина текстового столбца Unicode должна задаваться четным числом байтов. (Ошибка 3702)

Данные сохраняются в базе данных с помощью набора символов Unicode, в котором каждый символ представляется двухбайтовым словом. Текстовые столбцы должны описываться с шириной, представленной четным числом байтов, чтобы они могли содержать точное число символов Unicode.

  • Если это сообщение об ошибке появляется при создании базы данных, следует исправить программу, в которой предпринимается попытка создания базы данных.
  • Если это сообщение появляется при выполнении, то вероятно, база данных повреждена и нуждается в сжатии или восстановлении.


Общая длина имени сервера Интернета, общего ресурса HTTP и псевдонима FTP не должна быть более 252 символов. (Ошибка 3745)

Указанные косвенные значения или значения Интернет приводят к превышению предела 252 символов. Необходимо сократить имя, которое приводит к нарушению предела.


Чтение невозможно. Блокировка другим сеансом на данной машине. (Ошибка 3624)

Была предпринята попытка чтения записи на странице размера 2K базы данных, заблокированной другим пользователем. Подождите, пока другой пользователь закончит работу с записью, и повторите попытку.


Чтение невозможно; блокировка пользователем <имя> на машине <имя>. (Ошибка 3187)

Попытка считать информацию на странице базы данных, которая в данное время заблокирована указанным пользователем. Дождитесь, пока другой пользователь завершит работу, и повторите операцию.


Сбой операций с репликой из-за параллельного изменения схемы. Повторите попытку. (Ошибка 3763)

Возможно, во время операции с репликой были созданы новые объекты в основной реплике, не позволяющие продолжить эту операцию. Попробуйте выполнить эту операцию еще раз.


Параметры каскадных процессов для новой ссылки конфликтуют с существующей ссылкой <имя>. (Ошибка 3707)

Эта ошибка возникает, если операция CASCADE определена для столбца, для которого уже имеется операция CASCADE другого типа. Например, если уже указана операция CASCADE DELETE, то пользователь не сможет добавить операцию CASCADE UPDATE. Чтобы применить требуемую операцию CASCADE, необходимо удалить исходное ограничение CONSTRAINT. Это делается с использованием синтаксиса ALTER TABLE ALTER COLUMN или DROP CONSTRAINT.


Невозможно добавить новый столбец в конфликтную таблицу <имя>. Удалите ненужные столбцы и выполните сжатие базы данных. (Ошибка 3740)

Превышено предельное число столбцов таблицы конфликтов. Разработайте основную таблицу с меньшим числом столбцов.


Невозможно переименовать таблицу конфликтов. (Ошибка 3769)

Таблица конфликтов является системной таблицей, которую переименовать невозможно. Чтобы исключить конфликты из реплики, можно удалить содержимое таблицы конфликтов и удалить саму таблицу конфликтов.


Слишком длинная строка подключения. (Ошибка 3210)

Длина строки подключения в предложении IN инструкции SQL не должна превышать 255 символов. Внесите исправления и повторите операцию.


Недопустимая или неизвестная ссылка на поле <имя>. (Ошибка 3345)

Неверная ссылка на поле в выражении или ссылка на несуществующее поле. Проверьте, правильно ли указано имя поля.


Блокировка файла невозможна. (Ошибка 3050)

Операционная система запрещает ядру Microsoft® Jet создание файла блокировок (.LDB) в том каталоге, где находится файл базы данных (.MDB). Для открытия базы данных необходимо обладать привилегиями записи в каталог, содержащий эту базу данных. Кроме того, данная ошибка может возникнуть при использовании средства пассивного завершения работы/управления подключением, когда база данных открыта в монопольном режиме.


Обновление невозможно; установлена блокировка. (Ошибка 3218)

Попытка обновления данных, находящихся на заблокированной странице.

Возможные причины:

  • Попытка сохранить запрос, с которым работает другой пользователь. Для того чтобы сохранить запрос, подождите, пока другой пользователь закончит работу, или укажите другое имя запроса и повторите операцию.
  • Сделана попытка вызвать метод Edit для страницы данных, содержащей открытую или заблокированную запись.


Определение счетчика вне допустимого диапазона. (Ошибка 3770)

Эта ошибка возникает при попытке создать столбец с типом данных IDENTITY или COUNTER и указать необязательные начальное значение и инкремент. Начальное значение и инкремент должны находиться в допустимом диапазоне значений с типом данных LONG.


Ошибка при создании файла. (Ошибка 3436)

Ошибка при попытке создать файл Microsoft® Excel, текстовый файл или файл устанавливаемого драйвера ISAM Lotus.

Возможные причины:

  • нехватка места на диске;
  • сбой в сети.


Для этой операции требуется другая библиотека указателей. (Ошибка 3663)

Тип указателя, выбранный при открытии набора записей, не поддерживает затребованную операцию. Либо повторно откройте набор записей с подходящим типом указателя, либо выполните операцию, подходящую для текущего типа указателя. Это ошибка возникает только при использовании ODBCDirect.


Открываемая база данных уже используется другим приложением. (Ошибка 3576)

Если вы пытались открыть базу данных для монопольного доступа, то возможно, она уже открыта другим приложением. Если вы пытались открыть базу данных для общего доступа, возможно, она уже открыта другим приложением для монопольного доступа. Закройте все другие приложения, использующие эту базу данных, и попробуйте открыть ее еще раз.


Обнаружена ошибка в базе данных. Для исправления восстановите и сожмите базу. (Ошибка 3428)

В базе данных обнаружена неизвестная ошибка, в результате чего база данных отмечена как поврежденная.

Чтобы исправить ошибку

  1. Закройте базу данных.
  2. Восстановите базу данных с помощью метода RepairDatabase. В Microsoft® Access для восстановления базы данных следует выбрать в меню Сервис команду Служебные программы и подкоманду Восстановить.
  3. Выполните сжатие базы данных с помощью метода CompactDatabase. В Microsoft Access для сжатия базы данных следует выбрать в меню Сервис команду Служебные программы и подкоманду Сжать.

Внимание! Оба действия являются обязательными.


База данных уже существует. (Ошибка 3204)

Попытка создать или переименовать базу данных с использованием существующего имени. Введите другое имя и повторите операцию.


Переполнение электронной таблицы. (Ошибка 3437)

Сделана попытка добавить записи в файл Lotus 1-2-3 или Microsoft® Excel версии 3.0 или 4.0, однако файл заполнен. Файлы этих типов могут содержать не более 16 384 записей.


База данных <имя> уже используется другим пользователем или процессом. Повторите операцию, когда база данных снова станет доступной. (Ошибка 3196)

Указанная база данных в данное время используется в монопольном режиме другим пользователем или в другом сеансе. Дождитесь, когда другой пользователь или сеанс завершит работу с этой базой данных, и повторите операцию.


<Имя базы данных > не является допустимым именем базы данных. (Ошибка 3005)

Заданное имя базы данных не соответствует стандартным правилам именования файлов. Задано слишком длинное имя для буфера, который содержит путь и имя файла. Введите новое имя и повторите операцию.


Для базы данных <имя> установлен монопольный доступ. (Ошибка 3006)

Попытка использовать базу данных, которая в данное время открыта другим пользователем с монопольным доступом. Подождите, пока другой пользователь завершит работу с этой базой данных, и повторите операцию.


Невозможно сделать реплицируемым объект, так как эта база данных не является реплицируемой. (Ошибка 3485)

Невозможно сделать реплицируемым объект, если содержащая его база данных не является реплицируемой. Чтобы сделать базу данных реплицируемой:

  • перетащите ее в портфель Microsoft® Windows®;
  • с помощью программ объектов доступа к данным (DAO) задайте значение «T» для свойства Replicable или значение True для свойства ReplicableBool;
  • используйте Microsoft Access;
  • используйте диспетчер репликации.

После того как база данных станет реплицируемой, станут реплицируемыми и все содержащиеся в ней объекты, за исключением тех, для которых установлено значение «F» свойства KeepLocal.


Не удается открыть библиотечную базу данных <имя>. (Ошибка 3007)

Указанная база данных является внутренней библиотечной базой данных ядра Microsoft Jet, и она не может быть открыта пользователем.


База данных уже реплицирована. (Ошибка 3784)

База данных уже реплицирована и не может быть реплицирована еще раз. Если в базе данных имеются локальные объекты, которые требуется сделать реплицируемыми, то следует в основной реплике задать для свойства «Replicable» значение «True».


Системные таблицы реплики повреждены, и реплика не должна более использоваться. (Ошибка 3595)

Указанная реплика повреждена. При восстановлении реплики ядром базы данных Microsoft Jet возможно изменение одной или нескольких системных таблиц. Удалите эту реплику и замените ее новой репликой.


Для данного набора реплик SQL/Jet указана неверная или поврежденная база данных Jet. (Ошибка 3778)

Для данного набора реплик SQL/Jet указана неверная или поврежденная база данных Jet. (Ошибка 3778) (Ошибка 3778)

Указанная база данных Microsoft® Jet является неверной или отсутствует по одной из следующих причин.

  • Путь к источнику данных, заданный на сервере ссылок SQL Server, указывает для данной публикации на неверную реплику. Реплика была заменена, повреждена или создана неверно.
  • Отсутствующая или неверная строка разветвителя.
  • Указанная база данных не является реплицируемой.

Решением является повторная инициализация подписчика Jet с помощью средств повторной инициализации SQL Server.


Процесс остановлен ядром базы данных Microsoft Jet, так как другой пользователь пытается одновременно изменить те же данные. (Ошибка 3197)

Эта ошибка возникает в многопользовательской среде.

Обновляемые данные уже изменены другим пользователем. Эта ошибка возникает, когда несколько пользователей открывают таблицу или создают объект Recordset с использованием нежесткой блокировки. Другой пользователь изменил некоторые данные в промежуток времени между вызовом текущим пользователем метода Edit и метода Update.

Чтобы перезаписать изменения, проделанные другим пользователем, вновь вызовите метод Update.


Дата выходит за пределы допустимого диапазона или имеет ошибочный формат. (Ошибка 3175)

Распознаются только даты от 30 декабря 1899 г. до 30 декабря 9999 г.

Возможные причины:

  • Введенная дата выходит за пределы допустимого диапазона.
  • Правильная дата задается в формате, который не удается распознать. Проверьте правильность введенной даты и повторите операцию.


Попытка открыть базу данных, открытую пользователем <имя> на компьютере <имя>. Повторите попытку, когда база данных освободится. (Ошибка 3704)

Эта ошибка возникает, когда база данных открыта для монопольного доступа и не может использоваться совместно. Эта ошибка возникает также, когда пользователь создал новую базу данных в DAO, ADO или Microsoft® Access и не закрыл базу данных. Другие пользователи могут открывать базу данных, но они получат это сообщение об ошибке.


Выполнение операции невозможно; возможности данной версии недоступны в базах данных старого формата. (Ошибка 3301)

База данных была сохранена в формате предыдущей версии ядра Microsoft Jet, не поддерживающего данную характеристику. Необходимо либо преобразовать базу данных в формат ядра Microsoft® Jet версии 2.0 или 3.0, либо исключить из данной операции не поддерживаемую характеристику.


Ошибка синтаксиса в инструкции ALTER TABLE. (Ошибка 3293)

Введена инструкция SQL, содержащая неверную инструкцию ALTER TABLE.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Ошибка синтаксиса при определении поля. (Ошибка 3292)

Ошибка синтаксиса при описании поля в инструкции CREATE TABLE или ALTER TABLE.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Поле <имя> уже существует в таблице <имя>. (Ошибка 3380)

Имя одного поля введено дважды. Исправьте программу так, чтобы каждое поле имело уникальное имя. Проверьте также, существует ли имя поля в семействе Fields.


Невозможно удалить поле <имя>. Оно участвует в одной или нескольких связях. (Ошибка 3383)

Попытка удалить поле, для которого в базе данных определены связи. Для удаления поля необходимо предварительно удалить связи.


Поле <имя> отсутствует в таблице <имя>. (Ошибка 3381)

Указанное поле не существует в указанной таблице. Проверьте правильность имени поля. Проверьте также, существует ли имя поля в семействе Fields.


Указанные поля не имеют уникального индекса в таблице <имя>. (Ошибка 3374)

Поля адресуемой таблицы в предложении CONSTRAINT не образуют уникальный индекс.


Слишком длинное поле <имя>. (Ошибка 3382)

Текстовые поля в таблицах Microsoft® FoxPro® не могут содержать более 254 символов, а максимальный размер текстовых полей в таблицах Microsoft Jet составляет 255 символов. Измените размер поля.


Ошибка синтаксиса в предложении CONSTRAINT. (Ошибка 3289)

Введена инструкция SQL, содержащая неверное предложение CONSTRAINT.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Ошибка синтаксиса в инструкции CREATE INDEX. (Ошибка 3291)

Введена инструкция SQL, содержащая неверную инструкцию CREATE INDEX.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Ошибка синтаксиса в инструкции CREATE TABLE. (Ошибка 3290)

Введена инструкция SQL, содержащая неверную инструкцию CREATE TABLE.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Отношение должно быть задано для одинакового количества полей с одинаковыми типами данных. (Ошибка 3368)

В предложении CONSTRAINT, используемом для создания связи, указано разное число полей связываемых таблиц или включены поля с различающимися типами данных. Проверьте число полей в предложении CONSTRAINT и их типы данных и повторите попытку.


Ошибка синтаксиса в инструкции DROP INDEX. (Ошибка 3294)

Введена инструкция SQL, содержащая неверную инструкцию DROP INDEX.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Ошибка синтаксиса в инструкции DROP TABLE или DROP INDEX. (Ошибка 3295)

Введена инструкция SQL, содержащая неверную инструкцию DROP.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Таблица <имя> уже имеет индекс с именем <имя>. (Ошибка 3375)

Попытка создать уже существующий индекс.


Индекс <имя> не существует в таблице <имя>. (Ошибка 3372)

Указанный индекс не существует в указанной таблице. Проверьте правильность имен в программе или проверьте, содержится ли указанный индекс в семействе Indexes.


Невозможно обеспечить целостность данных. Данные таблицы <имя> нарушают условия для связи с таблицей <имя>. (Ошибка 3379)

Сделана попытка создать связь с помощью предложения CONSTRAINT в инструкции ALTER TABLE, однако имеющиеся в двух таблицах данные противоречат условиям целостности данных. Например, в подчиненной таблице могут иметься записи, для которых нет соответствующих записей в главной таблице.

Для создания связи необходимо изменить данные таким образом, чтобы для каждой подчиненной записи существовала соответствующая ей главная запись.


Не удается создать связь. Указанная таблица <имя> не имеет ключевых полей. (Ошибка 3373)

Предложение CONSTRAINT содержит ссылку на таблицу, не имеющую ключа. Для создания связи необходимо существование первичного ключа в главной (адресуемой) таблице. Кроме того, в связи допускается адресация полей, образующих уникальный индекс.


Не удается найти таблицу или ограничение. (Ошибка 3371)

Указанная таблица или связь не существует. Укажите правильное имя таблицы или ограничения.


Невозможно изменение структуры таблицы <имя>. База данных доступна только для чтения. (Ошибка 3370)

Не допускается изменение таблиц в базе данных, доступной только для чтения.


Связь <имя> уже существует в текущей базе данных. (Ошибка 3378)

Для каждой связи, добавляемой в базу данных с помощью управляющего запроса, необходимо указать уникальное имя. Проверьте, существует ли указанное имя в семействе Relations.


Отношение <имя> для таблицы <имя> не существует. (Ошибка 3377)

В базе данных отсутствует указанная связь. Проверьте, существует ли указанное имя в семействе Relations.


Невозможно завершить операцию DDL над данной таблицей, так как на нее имеется ссылка в ограничении <имя> в таблице <имя>. (Ошибка 3803)

Непредвиденная ошибка. За дополнительными сведениями обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Таблица <имя> не существует. (Ошибка 3376)

Указанная таблица не существует. Проверьте, содержится ли имя таблицы в семействе TableDefs.


Масштаб значения decimal приводит к переполнению. (Ошибка 3760)

Эта ошибка возникает в столбце с типом данных DECIMAL при обновлении или вставке данных, превышающих значения определенные масштабом.


Точность поля типа decimal слишком мала для добавляемого значения. (Ошибка 3761)

Эта ошибка возникает в столбце с типом данных DECIMAL при обновлении или вставке данных, не соответствующих определенному значению точности.


Масштаб значения decimal приводит к усечению данных. (Ошибка 3758)

Эта ошибка возникает в столбце с типом данных DECIMAL при обновлении или вставке данных, не соответствующих определенным значениям масштаба и точности.


Не удается дешифровать файл. (Ошибка 3161)

При попытке получить доступ к зашифрованной таблице Btrieve или Paradox задан неверный пароль. Введите правильный пароль и повторите операцию.


Масштаб значения decimal приводит к усечению данных. (Ошибка 3759)

Эта ошибка возникает в столбце с типом данных DECIMAL при обновлении или вставке данных, не соответствующих определенным значениям масштаба и точности.


Ошибка синтаксиса в значении по умолчанию. (Ошибка 3355)

Возможные причины:

  • В выражение, определяющее значение по умолчанию в условии на значение на уровне таблицы, включено имя неизвестной функции.
  • Синтаксически неверное выражение, определяющее значение по умолчанию в условии на значение на уровне таблицы.


Сбой при удалении файла на сервере с помощью FTP. (Ошибка 3682)

Сбой при удалении файла на сервере с помощью FTP. Проверьте, что имеются разрешение на чтение и запись для банка данных FTP. (Ошибка 3682)

Не удается удалить файл на сервере Интернета. Проверьте, что сервер выполняется и что общая папка FTP сконфигурирована для доступа правами на чтение/запись.


Удаление данных в присоединенной (или связанной) таблице не поддерживается данным драйвером ISAM. (Ошибка 3617)

Используемый устанавливаемый драйвер ISAM не поддерживает удаление записей во внешних таблицах. Однако разрешается добавление записей.


Невозможно удалить один или несколько объектов <имя>. (Ошибка 3773)

Эта ошибка возникает, когда при использовании синтаксиса DROP TABLE и указании таблицы, которая не существует или открыта другим пользователем.


Конфликт удаления и нарушения условий целостности данных. (Ошибка 3717)

Запись с первичным ключом была удалена в другой реплике, поэтому ссылающаяся на нее запись была отвергнута. Либо создайте новый первичный ключ, удовлетворяющий условиям целостности данных, а затем повторите отправку обновленной записи, либо удалите конфликтующую запись.


Локальную или анонимную реплику невозможно сделать основной репликой. (Ошибка 3771)

Локальную или анонимную реплику основной реплики невозможно сделать основной репликой, так как такие реплики не содержат всю системную информацию о наборе реплик. Подходящими являются только глобальные реплики основной реплики. Новую основную реплику следует создавать только в том случае, когда текущая основная реплика повреждена или необходимо ее переместить.


Нет доступа к результирующему общему банку данных. (Ошибка 3562)

Проверьте, имеются ли разрешения для диска, на котором находится результирующий банк данных.


Другая операция не позволяет выполнить эту операцию. (Ошибка 3667)

Эта ошибка обычно означает, что над объектом выполняется асинхронная операция; до завершения или отмены асинхронной операции другие операции невозможны.


Попытка синхронизировать реплики из различных наборов реплик. (Ошибка 3545)

Невозможно синхронизировать реплики из разных наборов реплик. Проверьте, что подлежащие синхронизации реплики указаны правильно.


Переполнение диска, для которого выполняется попытка записи. (Ошибка 3575)

На указанном диске недостаточно места для завершения текущей операции. Удалите с него ненужные файлы. Объем свободного места на диске должен превышать общий объем файлов, подлежащих обработке.


Используемый диск недоступен для чтения. (Ошибка 3465)

Если была предпринята попытка доступа к гибкому диску, проверьте, что защелка дисковода закрыта. Если была предпринята попытка доступа к жесткому диску, возможно, он содержит поврежденный сектор.


Дисковая или сетевая ошибка. (Ошибка 3043)

Внутренняя ошибка диска или дисковода не позволяет выполнить чтение или запись на диск.

Возможные причины:

  • Предпринята попытка использовать сетевой диск, когда сеть временно занята или потеряно подключение к сети. Проверьте сетевое подключение и повторите операцию.
  • Сбой диска или дисковода.


Ошибка ввода/вывода на диске для результирующего банка общих данных. (Ошибка 3558)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Сбой диска при доступе к файлу журнала <имя>. (Ошибка 3473)

Возможно, диск, на котором находится файл журнала, содержит поврежденный сектор.

Чтобы указать другой диск для размещения файла журнала, откройте диспетчер репликации и выберите в меню Сервис команду Configure Microsoft Replication Manager. Или повторно выполните установку приложения, использующего репликацию.


Сбой диска при обращении к общему банку данных <имя>. (Ошибка 3470)

Возможно, диск содержит поврежденный сектор.


Недостаточно места на диске. (Ошибка 3026)

Доступного места на диске не хватает для предпринимаемой операции. Удалите с диска ненужные файлы, сожмите базу данных и повторите операцию.


Произошла системная ошибка или достигнут предел страничного файла. (Ошибка 3539)

Системный вызов, сделанный синхронизатором, привел к возникновению системной ошибки. Завершите работу, выключите компьютер, а затем включите его снова.


Невозможна группировка по полям, выбранным с помощью символа '*' <имя таблицы>. (Ошибка 3120)

Попытка выполнить инструкцию SELECT, которая группирует или суммирует все поля отдельной таблицы, выбранные с помощью символа звездочки ( * ). Эта ошибка возникает, например, при вводе следующей инструкции SQL:

SELECT Заказы.* FROM Заказы GROUP BY СпособДоставки;


Отказ доступа при обращении к общему банку данных <имя>. (Ошибка 3468)

Проверьте, имеются ли разрешения на доступ к этому банк данных.


Ошибка синтаксиса в адресе <имя> общего банка данных. (Ошибка 3477)

Восстановите общий банк данных. Откройте диспетчер репликации и выберите в меню Сервис команду Configure Microsoft Replication Manager. Или повторно выполните установку приложения, использующего репликацию.


Заполнен диск общего банка данных <имя>. (Ошибка 3469)

Для завершения текущей операции недостаточно места на диске общего банка данных. Удалите с него ненужные файлы.


Синхронизатор использовал недопустимый пароль для записи в конечный общий банк данных. (Ошибка 3484)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Обнаружен ошибочный конец файла. (Ошибка 3179)

Попытка выполнить импорт файла, содержащего метку конца файла в непредвиденном месте.

Возможные причины:

  • Импортируемый файл поврежден. Восстановите импортируемый файл по резервной копии и повторите операцию.
  • Используемая спецификация импорта/экспорта не соответствует данным импортируемого файла. Измените спецификацию и повторите операцию.


Невозможно выполнить каскадную операцию над таблицей <имя>. (Ошибка 3413)

Невозможно выполнить каскадную операцию над таблицей <имя>, которая в данный момент занята пользователем <имя> на компьютере <имя>. (Ошибка 3413)

Эта ошибка возникает, когда определена условия целостности данных в одной из следующих операций: CASCADE DELETE, UPDATE или NULL. Ошибка возникает, когда вносятся изменения в таблицу, содержащую адресуемый первичный ключ, а одна или несколько внешних таблиц с ключом открыты в режиме, который не позволяет открывать их в режиме общего доступа для чтения/записи.


Общий сбой при обращении к локальному общему банку данных. (Ошибка 3563)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Ошибка при оценке выражения фильтра частичной реплики. (Ошибка 3588)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Ошибка при расчете выражения для частичной реплики. (Error 3656)

Ошибка при расчете выражения для частичной реплики. (Ошибка 3656)

Неверное выражение в логическом фильтре, используемом для отбора записей частичной реплики. Фильтр реплики может иметь следующие значения:

Значение | Описание
Строка | Условие, которому должны удовлетворять записи, отбираемые в реплицируемую таблицу. Эта строка аналогична предложению WHERE инструкции SQL, однако, в нее нельзя включать подчиненные запросы, статистические функции (такие как Count) или функции, определяемые пользователем.
True | Репликация всех записей.
False | (По умолчанию). Ни одна из записей не участвует в репликации.


(Ошибка 3072)

Несоответствие типов при создании условия на значения для таблицы или ограничения CHECK для столбца. (Ошибка 3072)

Например, условие на значение на уровне таблицы, содержащее ссылку на числовой тип данных, должно включать числовое предложение условия. Данная ошибка возвращается в случае использования строкового предложения условия.


Превышен период ожидания события. (Ошибка 3531)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Потеряна связь с Excel для просмотра присоединенных листов. (Ошибка 3620)

Потеряна связь с Microsoft® Excel для просмотра присоединенных листов. Возможно, сеанс Microsoft Excel был завершен.


Не удается создать таблицу исключений при импорте/экспорте. (Ошибка 3618)

При импорте или экспорте во внешний файл возникла ошибка. Чтобы сообщить об ошибке, драйвер импорта/экспорта попытался создать таблицу ошибок в базе данных Microsoft® Access, но не смог этого сделать.


Невозможно добавление записей в таблицу исключений. (Ошибка 3619)

При импорте или экспорте во внешний файл возникла ошибка. Чтобы сообщить об ошибке, драйвер импорта/экспорта попытался добавить строку в таблицу ошибок в базе данных Microsoft® Access, но не смог этого сделать.


Затребованный обмен не выполнен из-за <описание>. (Error 3661)

Затребованный обмен не выполнен из-за <описание>. (Ошибка 3661)

Обмен был отменен.


Неожиданное закрытие синхронизатора Интернета. (Ошибка 3683)

Неожиданное закрытие синхронизатора Интернета на сервере. Чтобы разобраться в причинах неполадок, просмотрите таблицу хронологии репликации реплики-партнера на сервере Интернета. (Ошибка 3683)

Недопустимый ответ сервера Интернета. Повторите операцию.


Не допускается указание двух различных синхронизаторов для обработки одной реплики. (Ошибка 3500)

Используйте допустимый код удаленного синхронизатора в запросе на обмен.


Предпринимается попытка выполнить недопустимый тип обмена. (Ошибка 3546)

Требуемый обмен не может быть выполнен из-за недопустимого аргумента типОбмена в методе Synchronize. Укажите в программе допустимый тип обмена.


Попытка открыть базу данных, открытую пользователем <имя> на машине <имя> для монопольного доступа. (Ошибка 3356)

Попытка открыть базу данных, открытую пользователем <имя> на машине <имя> для монопольного доступа. Повторите попытку, когда база данных освободится. (Ошибка 3356)

Возможные причины:

  • Попытка открыть базу данных, которая уже открыта с монопольным доступом пользователем <имя>. Невозможно открыть базу данных, пока она не будет закрыта другим пользователем.
  • Попытка открыть с монопольным доступом базу данных, которая уже открыта с общим (немонопольным) доступом пользователем <имя>. Пока другой пользователь не закроет базу данных, ее можно открыть только с общим доступом.


Синхронизатор или диспетчер репликации обнаружил непрочитанные данные в общей памяти. Существующие данные будут перезаписаны.

Синхронизатор или диспетчер репликации обнаружил непрочитанные данные в общей памяти. Существующие данные будут перезаписаны. (Ошибка 3529)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


После EXECUTE ожидается имя запроса. (Ошибка 3732)

После EXECUTE ожидается имя запроса. (Ошибка 3732) (Ошибка 3732)

Такая ошибка возникает при выполнении инструкции EXECUTE. После EXECUTE требуется действительный сохраненный запрос (представление или процедура).


Инструкция SQL не может быть выполнена ядром базы данных Microsoft Jet, так как содержит поле с недопустимым типом данных. (Ошибка 3169)

Попытка выполнить инструкцию SQL, содержащую поле, которое имеет недопустимый тип данных.

Возможные причины:

  • В выражение включено недопустимое в данном случае поле Memo или поле объекта OLE.
  • Используется числовая статистическая функция, например Sum или StDev, в которой предпринимается попытка выполнить вычисления над текстовым полем. Выберите другую статистическую функцию.


Неопределенная функция <имя> в выражении. (Ошибка 3085)

Введено выражение SQL, включающее процедуру Function, имя которой не удается распознать. Проверьте, что эта функция существует и может использоваться в выражениях SQL, а также, что имя в выражении задано без ошибок.


Непарная правая скобка: ). (Ошибка 2435)

Введенное выражение содержит слишком много закрывающих скобок. Удалите скобки, которые не имеют соответствующих открывающих скобок.


Сбой при загрузке библиотеки RDOCURS.DLL. (Ошибка 3672)

Непредвиденная ошибка. За дополнительными сведениями обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Сбой при чтении общего банка данных. (Ошибка 3512)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Ошибка записи из-за заполнения результирующего диска. (Ошибка 3559)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Сбой при записи в общий банк данных. (Ошибка 3513)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Сбой при записи в журнал синхронизатора. (Ошибка 3507)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


В операции FastFind возможен поиск только по ссылкам на столбцы. (Ошибка 3768)

В методе FIND DAO не допускаются ссылки на столбцы на основании параметров или выражений.


Операция не поддерживается для объектов этого типа. (Ошибка 3251)

Делается попытка выполнить метод или присвоить значение свойству, которые, в принципе, являются применимыми для таких объектов, но не поддерживаются конкретным экземпляром объекта. Например, метод Edit, в общем, может вызываться для объектов Recordset, но не поддерживается объектами Recordset типа статического набора записей. Эта ошибка возникает также при попытке выполнить операцию, которая не является разрешенной из-за типа или состояния объекта, например, при вызове метода MovePrevious для объекта Recordset типа статического набора записей с последовательным доступом. Некоторые операции также могут не поддерживаться при доступе к источникам данных Microsoft Jet или ODBC.


Файл <имя> не может быть открыт ядром базы данных Microsoft Jet. Файл уже открыт другим пользователем для монопольного доступа или требуется разрешение на просмотр данных. (Ошибка 3051)

Возможные причины:

  • Для просмотра данных в файле необходимо иметь разрешение на чтение данных в указанном файле. Для изменения разрешений обратитесь к системному администратору или к создателю таблицы или запроса.
  • Попытка открыть указанный файл с монопольным доступом, но файл уже открыт другим пользователем.


Попытка присоединения или импорта пустого текстового файла. Файл должен содержать данные. (Ошибка 3440)

Попытка присоединения или импорта пустого текстового файла. Импорт и присоединение допускается только для текстовых файлов, содержащих данные. (Ошибка 3440)

Сделана попытка присоединить или импортировать пустой текстовый файл. Импорт и присоединение допускается только для текстовых файлов, содержащих данные.


Сохранение невозможно; блокировка другим пользователем. (Ошибка 3046)

Попытка сохранить сведения на странице базы данных, которая в данное время заблокирована другим пользователем. Для сохранения изменений дождитесь завершения работы другого пользователя, а затем повторите операцию.


Задано слишком длинное имя файла. (Ошибка 3549)

Используйте более короткое имя файла.


Не удается найти файл <имя>. (Ошибка 3024)

Возможные причины:

  • Указанный файл не существует.
  • Имя файла задано с ошибками. Проверьте, что не пропущены символы подчеркивания ( _ ) или другая пунктуация и отсутствуют начальные пробелы.
  • Сетевое подключение прервано или не было установлено.


Невозможно использовать <имя>; файл уже используется. (Ошибка 3045)

Указанный файл используется в данное время другим пользователем или в другом сеансе. Подождите, пока другой пользователь закончит работу или завершится сеанс работы с этим файлом, и повторите операцию.


В спецификации <имя> текстового файла имеется недопустимый параметр <имя>. (Ошибка 3442)

Один из параметров спецификации текстового файла для текстового драйвера ISAM содержит ошибку. Спецификация может быть задана следующим образом:

  • В Microsoft® Access эти значения задаются с помощью мастера по присоединению таблиц (для вызова которого следует выбрать в меню Файл команду Внешние данные и подкоманду Связь с таблицами). Они доступны также для просмотра в системных таблицах «MSysIMEXSpec» и «MSysIMEXColumns».
  • Для других приложений, использующих ядро Microsoft Jet, эти значения запоминаются в файле Schema.ini.


Не удается открыть базу данных, созданную в предыдущей версии приложения. (Ошибка 3041)

Предпринята попытка получить доступ к базе данных, которая имеет устаревший формат. Выполните сжатие базы данных и повторите операцию.


<Сообщение> в выражении. (Ошибка 3077)

Введено недопустимое выражение; причина объясняется в сообщении. Проверьте, что имена полей и пунктуация не содержат ошибок, и повторите операцию.


Нарушение внешнего ключа. (Ошибка 3719)

Нарушение внешнего ключа является следствием участия в конфликте репликации записи с неверным первичным ключом. Либо создайте запись с новым первичным ключом, удовлетворяющим условиям целостности данных, а затем повторите отправку обновленной записи, измените значение внешнего ключа в конфликтующей записи соответственно действительному значению первичного ключа, а затем повторите отправку обновленной записи, либо удалите конфликтующую запись.


Сбой при подключении к службе FTP . (Ошибка 3678)

Сбой при подключении к службе на сервере Интернета. Проверьте, что служба FTP выполняется на сервере и поддерживает анонимные подключения. (Ошибка 3678)

Невозможно открыть подключение FTP. Проверьте, что сервер Интернета и служба FTP выполняются и что служба FTP поддерживает анонимные подключения.


Функция недоступна в выражениях. (Ошибка 2426)

Введена функция, которую нельзя использовать в таком выражении. Не допускается использование в выражениях функций DoEvents, LBound, UBound, Spc и Tab.


<Предупреждение о зарезервированной ошибке> (Ошибка 3416)

Данная ошибка возникла в приложении, выпущенном после данной версии ядра базы данных Microsoft Jet. Обратитесь в службу поддержки пользователей продуктов Microsoft.


Сбой при получении файла с сервера с помощью FTP. (Ошибка 3680)

Сбой при получении файла с сервера с помощью FTP. Проверьте, что имеется разрешение на чтение банка данных FTP. (Ошибка 3680)

Не удается получить файл с сервера Интернета. Проверьте, что сервер выполняется и что общая папка FTP сконфигурирована для доступа правами на чтение/запись. Возможно, файл, который вы пытаетесь загрузить, был удален.


Коды GUID не совпадают, или не удается обнаружить запрашиваемый код GUID. (Ошибка 3548)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Нельзя использовать предложение HAVING в инструкции TRANSFORM. (Ошибка 3092)

Для задания условия отбора воспользуйтесь предложением WHERE.


Предложение HAVING <имя> без выборки или группировки. (Ошибка 3091)

Эта ошибка происходит, если в запросе вычисляются идентификаторы в инструкции SELECT. Причиной ошибки является отсутствие предложения GROUP BY перед предложением HAVING или наличие в предложении HAVING ссылки на столбец, не являющийся статистической функцией. Например, данная ошибка происходит в инструкции «SELECT столбец1 FROM таблица1 HAVING столбец1 > 20». Правильной инструкцией будет «SELECT столбец1 FROM таблица1 GROUP BY столбец1 HAVING столбец1 > 20». Аналогично, правильной инструкцией является «SELECT столбец1, count(столбец2) FROM таблица1 GROUP BY столбец1 HAVING count(столбец1) > 20».


Сбой при выполнении запроса HTTP. (Ошибка 3677)

Сбой при выполнении запроса HTTP на запуск синхронизатора Интернета или сервера Интернета. Выполните настройку синхронизатора Интернета на сервере Интернета с помощью диспетчера репликации. (Ошибка 3677)

Сбой при попытке отправить запрос на сервер Интернета. Запрос может принадлежать к одному из следующих типов:

  • попытка открыть и прочитать файл через Интернет;
  • запрос на удаление файла через Интернет;
  • попытка запустить процесс синхронизации MSTRAI40.exe на сервере Интернета.


Ошибка синтаксиса (запятая). (Ошибка 2432)

В выражении или инструкции неправильно используется запятая, или отсутствует запятая в качестве разделителя аргументов.


Недопустимые аргументы статистической функции по подмножеству. (Ошибка 2428)

Введен недопустимый аргумент статистической функции. Для получения сведений об аргументах функций выберите нужную функцию в разделе Статистические функции SQL.


Недопустимое значение параметра «Century» в разделе Xbase реестра Windows. (Ошибка 3227)

Недопустимое значение параметра Century в разделе Xbase реестра Microsoft® Windows.

Чтобы исправить параметр «Century»:

  1. Закройте ваше приложение.
  2. Запустите редактор реестра, найдите раздел \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase и выделите параметр Century.
  3. Выберите в меню Правка команду Изменить.
  4. Исправьте значение параметра Century в поле «Значение».
  5. Снова запустите приложение и повторите операцию.


Выбранная языковая настройка не поддерживается операционной системой. (Ошибка 3228)

Недопустимое значение параметра CollatingSequence в разделе Paradox реестра Microsoft® Windows.

Чтобы исправить параметр «CollatingSequence»:

  1. Закройте ваше приложение.
  2. Запустите редактор реестра, найдите раздел \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox и выделите параметр CollatingSequence.
  3. Выберите в меню Правка команду Изменить.
  4. Укажите ascii или International в поле «Значение».
  5. Снова запустите приложение и повторите операцию.


Недопустимое ограничение на уровне столбца. (Ошибка 3789)

Обычно такая ошибка возникает при использовании инструкции CREATE TABLE или ALTER TABLE ALTER COLUMN. Хотя в ANSI SQL допускается создание ограничений CHECK в рамках определения таблицы, Microsoft® Jet требует, чтобы пользователь создавал ограничение CHECK отдельно от определения COLUMN. Для этого следует вводить ключевое слово CHECK после запятой. Например, следующий синтаксис является правильным, поскольку ограничение CHECK определяется отдельно от столбца и следует за запятой:

CREATE TABLE Заказы (КодЗаказа IDENTITY (100,10) CONSTRAINT пкЗаказы PRIMARY KEY, КодЗаказчика LONG CONSTRAINT вкЗаказчикиКодЗаказчика REFERENCES Заказчики (КодЗаказчика), Сальдо DOUBLE, CONSTRAINT ПревышениеКредитногоПределаЗаказчика CHECK (КодЗаказчика IN (SELECT КодЗаказчика FROM Заказчики C WHERE C.КодЗаказчика = Заказы.КодЗаказчика AND C.КредитныйПредел >= (SELECT SUM(Сальдо)FROM Заказы O WHERE O.КодЗаказчика = Заказы.КодЗаказчика))));.


Недопустимое значение параметра инициализации DataCodePage. (Ошибка 3337)

Недопустимое значение параметра DataCodePage для используемого внешнего источника данных. Этот параметр находится в реестре Microsoft® Windows® в разделе \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engine\<внешний источник данных ISAM>.

Допустимыми являются следующие значения:

  • OEM — Данные сохраняются в кодировке OEM; выполняются преобразования OEM в ANSI и ANSI в OEM.
  • ANSI — Данные сохраняются в кодировке ANSI; преобразования OEM в ANSI и ANSI в OEM не выполняются.


Недопустимое значение параметра «Date» в разделе Xbase реестра Windows. (Ошибка 3213)

Недопустимое значение параметра Date в разделе Xbase реестра Microsoft® Windows.

Чтобы исправить параметр «Date»:

  1. Закройте ваше приложение.
  2. Запустите редактор реестра, найдите раздел \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase и выделите параметр Date.
  3. Выберите в меню Правка команду Изменить.
  4. Исправьте значение параметра Date в поле «Значение».
  5. Снова запустите приложение и повторите операцию.


Недопустимое значение параметра «Deleted» в разделе Xbase реестра Windows. (Ошибка 3208)

Недопустимое значение параметра Deleted в разделе Xbase реестра Microsoft® Windows.

Чтобы исправить параметр «Deleted»:

  1. Закройте ваше приложение.
  2. Запустите редактор реестра, найдите раздел \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase и выделите параметр Deleted.
  3. Выберите в меню Правка команду Изменить.
  4. Исправьте значение параметра Deleted в поле «Значение».
  5. Снова запустите приложение и повторите операцию.


Попытка выполнить запрос, который не включает указанное выражение <имя> как часть статистической функции или группы. (Ошибка 3122)

Попытка выполнить запрос, который не включает указанное выражение как часть статистической функции или группы.

Возможная причина:

  • Статистическая функция не была указана в инструкции TRANSFORM.


Недопустимое значение параметра в записи Excel в разделе Engines реестра Windows. (Ошибка 3433)

Один из параметров в записи \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Excel реестра Microsoft® Windows® имеет недопустимое значение. Проверьте и исправьте все параметры в данной записи реестра.


Недопустимое значение параметра «Mark» в разделе Xbase реестра Windows. (Ошибка 3214)

Недопустимое значение параметра Mark в разделе Xbase реестра Microsoft® Windows.

Чтобы исправить параметр «Mark»:

  1. Закройте ваше приложение.
  2. Запустите редактор реестра, найдите раздел \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase и выделите параметр Mark.
  3. Выберите в меню Правка команду Изменить.
  4. Исправьте значение параметра Mark в поле «Значение».
  5. Снова запустите приложение и повторите операцию.


Недопустимое значение параметра «NetworkAccess» в реестре Windows. (Ошибка 3248)

Недопустимое значение параметра NetworkAccess в реестре Microsoft® Windows.

Чтобы завершить операцию:

  1. Закройте ваше приложение.
  2. Запустите редактор реестра и найдите параметр NetworkAccess.

    В зависимости от того, какой устанавливаемый драйвер ISAM используется, недопустимая запись находится в разделе \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase.

  3. Выберите в меню Правка команду Изменить.
  4. Укажите значение On или Off в поле «Значение».
  5. Снова запустите приложение и повторите операцию.


Недопустимая операция. (Ошибка 3219)

Возможные причины:

  • Попытка записать значение свойства, которое допускает только чтение. Для того чтобы узнать, доступно ли свойство для чтения/записи, см. раздел справки для данного свойства.
  • Попытка использовать метод или свойство, неприменимые к данному типу объектов Recordset. Методы и свойства, применимые к объектам Recordset разных типов, перечислены в разделе справки Объект Recordset, семейство Recordsets - Общие сведения.
  • Попытка добавить свойство в семейство Properties объекта, который не поддерживает определяемые пользователем свойства.
  • Попытка применить метод Update к объекту Recordset, доступному только для чтения.


Невозможно открыть форму: базовый запрос содержит определяемую пользователем функцию, задающую или получающую значение свойства RecordsetClone. (Ошибка 3252)

Эта ошибка может возникать в Microsoft® Access при попытке создать форму на базе запроса, включающего функцию, определяемую пользователем.


Недопустимая ссылка в запросе. (Ошибка 3451)

Эта ошибка возникает, когда определены параметры с нераспознаваемыми типами данных.


Не удается установить связь. (Ошибка 3300)

Попытка создать недопустимую связь. Например, таблицы могут находиться в разных базах данных.


Незаконная операция над репликой Jet SQL Server. (Ошибка 3777)

Многие операции с репликами Microsoft® Jet SQL выполнить невозможно. Например, пользователь не может удалить или переименовать таблицу; добавить, удалить или переименовать столбец в таблице; сделать локальную таблицу реплицируемой; выполнить обмен с другим подписчиком Jet в наборе реплик Jet SQL; а также выполнить обмен с публикацией SQL любым способом, кроме прямой синхронизации.


Недопустимое значение параметра «PageTimeout» в реестре Windows. (Ошибка 3249)

Недопустимое значение параметра PageTimeout в реестре Microsoft® Windows.

Чтобы завершить операцию:

  1. Закройте ваше приложение.
  2. Запустите редактор реестра и найдите параметр PageTimeout.

    В зависимости от того, какой устанавливаемый драйвер ISAM используется, недопустимая запись находится в разделе \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase.

  3. Выберите в меню Правка команду Изменить.
  4. Укажите новое значение в поле «Значение».
  5. Снова запустите приложение и повторите операцию.


Несовместимая версия устанавливаемого драйвера ISAM. (Ошибка 3429)

Сделана попытка использовать старую версию устанавливаемого драйвера ISAM с текущей версией ядра базы данных Microsoft Jet. Снова запустите программу установки, чтобы установить нужную версию драйвера ISAM.


Ошибка синтаксиса в запросе. Неполное предложение в запросе. (Ошибка 3450)

Такая ошибка возникает при попытке сохранить сохраненный запрос (представление или процедуру).


Текущее поле после обновления должно содержать подходящий ключ связи <имя> со стороны «один» внешнего объединения. (Ошибка 3341)

Попытка ввести в связанное поле таблицы на стороне «только многие», участвующей во внешнем объединении, значение, отсутствующее в связанном поле на стороне «один».

Сообщение содержит следующую инструкцию. Введите на стороне «один» запись с требуемым значением ключа связи, а затем создайте запись с тем же значением ключа в таблице на стороне «только многие».


Слишком большая длина записи для индексированной таблицы Paradox. (Ошибка 3608)

Максимальная длина записи в индексированной таблице Paradox составляет 1350 байт. Попытайтесь уменьшить размер текстовых или Memo полей.


Индекс уже существует. (Ошибка 3284)

Не допускается существование в таблице двух индексов с одинаковыми именами. Переименуйте один из индексов.


Индекс Paradox не является первичным. (Ошибка 3288)

Сделана попытка создать индекс для таблицы Paradox, в которой не определены другие индексы. Первый индекс, созданный в таблице Paradox, должен быть первичным индексом (ключом).

Возможные действия:

  • Переопределите индекс как первичный индекс.
  • Если создаваемый индекс не является первичным индексом, сначала создайте первичный индекс.


Ключ уже существует. (Ошибка 3283)

Сделана попытка определить в таблице второй первичныйключ. Каждая таблица может иметь только один ключ. Удалите ссылку на второй ключ.


Удаление индекса или таблицы невозможно. Объект является текущим индексом или используется для установления связи. (Ошибка 3281)

Если индекс или таблица используется при установлении связи, то перед удалением индекса или таблицы необходимо удалить связь. Если данный индекс указан как текущий индекс в свойстве Index, то перед удалением этого индекса необходимо указать в свойстве Index имя другого индекса.


Недопустимое определение индекса. (Ошибка 3285)

Возможные причины:

Одно поле используется дважды в индексе или связи, что не допускается в базах данных с ядром Microsoft Jet.

Создана связь между полями с несовместимыми типами данных. В базах данных Microsoft® Jet допускается установление связи только между полями с одинаковыми типами данных, а также связь поля счетчика с полями типа «Числовой», имеющими размер «Длинное целое».


Не найден индекс. (Ошибка 3015)

Попытка использовать значение, которое не является индексом. Для определения допустимых имен индексов просмотрите семейство Indexes объекта TableDef.


<Имя> не является индексом данной таблицы. (Ошибка 3800)

Неверное имя использовано при ссылке на индекс.


Недопустимый файл .inf. (Ошибка 3168)

Попытка доступа к таблице dBASE, но ее связанный файл .inf имеет недопустимый формат или поврежден. Проверьте, что указаны правильные индексы, и вновь присоедините таблицу.


Не найден индексный файл. (Ошибка 3256)

При попытке доступа к таблице dBASE не найден один из индексов, перечисленных в связанном с таблицей файле .inf. Возможно, индекс переименован, перемещен или удален. Необходимо либо снова присоединить таблицу, либо использовать текстовый редактор (например, блокнот Microsoft® Windows®) для обновления файла .inf.


Ядро базы данных Microsoft Jet не может найти входную таблицу или запрос <имя>. Проверьте существование таблицы или запроса и правильность имени. (Ошибка 3078)

Возможные причины:

  • Указанная таблица или запрос не существует.
  • Имя таблицы или запроса задано с ошибками. Проверьте, что не пропущены символы подчеркивания ( _ ) или другая пунктуация и отсутствуют начальные пробелы.


Инструкция INSERT INTO содержит неизвестное имя <имя поля>. Проверьте, что имя задано без ошибок, и повторите операцию. (Ошибка 3127)

Инструкция INSERT INTO содержит неизвестное имя поля: <имя поля>. Проверьте, что имя задано без ошибок, и повторите операцию. (Ошибка 3127).

Попытка использовать инструкцию INSERT INTO с именем поля, которое не существует в выходной таблице. Проверьте, что имя задано без ошибок, и повторите операцию.


Не удается найти устанавливаемый драйвер ISAM. (Ошибка 3170)

Не удается найти файл библиотеки динамической компоновки (DLL) устанавливаемого драйвера ISAM. Этот файл требуется для присоединения (связывания) внешних таблиц (отличных от таблиц баз данных ODBC или Microsoft Jet). Каталоги всех драйверов ISAM указываются в записях реестра Microsoft® Windows. Эти записи автоматически создаются при установке приложения. При изменении каталога этих драйверов необходимо исправить программу установки приложения для отражения этих изменений в записях реестра.

Возможные причины:

  • Недопустимая запись в реестре. Эта ошибка возникает, например, если используется внешняя база данных Paradox, а запись реестра для Paradox указывает на несуществующий каталог или диск. Закройте приложение, исправьте реестр Windows и повторите операцию.
  • Одна из записей реестра указывает на сетевой диск, подключение к которому отсутствует. Проверьте, что сеть доступна, и повторите операцию.


Не хватает памяти для завершения операции. (Ошибка 3584)

Попытка сделать базу данных реплицируемой была прервана вследствие нехватки памяти. Завершите работу с другими приложениями и еще раз выполните эту операцию.


Удаление или изменение записи невозможно. В таблице <имя> имеются связанные записи. (Ошибка 3200)

Попытка выполнения операции, нарушающей условия целостности данных для связанных таблиц. Например, такая ошибка возникает при попытке удалить или изменить запись в таблице, находящейся на стороне «один» отношения «один-ко-многим», если в таблице имеются связанные записи на стороне «многие».

Для того чтобы удалить или изменить запись, необходимо предварительно удалить связанные записи в таблице на стороне «многие».


Невозможно добавление или изменение записи. Для обеспечения целостности данных необходимо наличие связанной записи в таблице <имя>. (Ошибка 3201)

Попытка выполнения операции, нарушающей условия целостности данных для связанных таблиц. Например, такая ошибка возникает при попытке вставить или изменить запись в таблице, находящейся на стороне «многие» отношения «один-ко-многим», если в таблице на стороне «один» отсутствует запись, связанная с добавляемой или изменяемой записью.

Для того чтобы добавить или изменить запись, необходимо предварительно добавить в таблицу на стороне «один» запись, содержащую то же значение в связующем поле.


Зарезервированная ошибка <элемента>; сообщение для данной ошибки отсутствует. (Ошибка 3000)

Произошла непредвиденная ошибка. Указанный код демонстрирует условия, при которых может возникать данная ошибка. За дополнительными сведениями обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Невозможно найти или загрузить библиотеку Интернета (wininet.dll). (Ошибка 3674)

Файл wininet.dll не найден на указанном пути. Повторите программу установки.


Превышен период ожидания функции Интернета. (Ошибка 3742)

Период ожидания операции Интернета превышен до ее завершения. Увеличьте значения периодов ожидания в реестре. Значения параметров реестра сохраняются в разделе: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Transporter


Сбой при чтении декриптора Интернета. (Ошибка 3675)

Сбой при чтении дескриптора Интернета. Повторите операцию. (Ошибка 3675)

Ошибка Интернета при чтении файла или чтении ответа из операции Интернета.


Сбой при записи декриптора Интернета. (Ошибка 3676)

Сбой при записи дескриптора Интернета. Повторите операцию. (Ошибка 3676)

Ошибка Интернета при записи в файл.


Слишком медленная операция Internet. (Ошибка 3650)

Либо слишком медленно выполняются операции Интернета, либо имеются неполадки в настройке диспетчера репликации на сервере Интернета. (Ошибка 3650)

Сбой из-за слишком медленной скорости передачи при подключении к Интернету.


Ошибка входа в Интернет. (Ошибка 3652)

Сервер не распознает данные, указанные при попытке регистрации.


Неверная настройка Internet. (Ошибка 3653)

Неверная настройка Интернета. (Ошибка 3653)

Причиной неполадок является настройка Интернета.


Настройка удаленного синхронизатора не обеспечивает удаленную синхронизацию. (Ошибка 3632)

Транспортный протокол Интернета не включен на удаленном синхронизаторе. (Ошибка 3632)

Настройка текущего удаленного синхронизатора не обеспечивает выполнение удаленной синхронизации.


Операция не поддерживается в транзакциях. (Ошибка 3246)

Попытка выполнить операцию, которая не поддерживается в транзакции. Транзакция может быть как явной, начатой с помощью инструкции BeginTrans, так и неявной, создаваемой ядром базы данных Microsoft Jet, например, при удалении нескольких записей в одной операции.


<Имя записи> не является допустимым именем учетной записи. (Ошибка 3030)

Указано недопустимое имя учетной записи (имя пользователя). Имена пользователей могут содержать от 1 до 20 знаков и могут включать символы алфавита, расширенного набора символов, цифры, пробелы и специальные знаки, за следующими исключениями:

  • Знаки " / \ [ ] | < > + = ; , : ? *
  • Начальные пробелы
  • Непечатаемые знаки

Имена пользователей задаются без учета регистра.


Недопустимый адрес для конечного общего банка данных. (Ошибка 3557)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Недопустимая закладка. (Ошибка 3159)

Попытка установить закладку на недопустимую строку.

Эта ошибка может возникать при установке свойства Bookmark для неверной строки или строки, которая не была сохранена после предыдущего чтения свойства Bookmark. Например, эта ошибка возникает в следующей программе:

Sub SetBookmark()

    Dim dbs As Database

    Dim rstEmployees As Recordset

    Dim strPlaceholder As String

    Set dbs = OpenDatabase("Борей.mdb")

    Set rstEmployees = _

        dbs.OpenRecordset _

        ("Сотрудники", dbOpenDynaset)

    strPlaceholder = "1"

    rstEmployees.Bookmark = strPlaceholder    ' Недопустимая закладка.

End Sub


Выполнение операции невозможно; объем данных велик для поля. Попытайтесь вставить меньшее количество данных. (Ошибка 3163)

Размер поля, в которое выполняется вставка данных, недостаточен для этих данных. Попытайтесь вставить меньшее количество данных.


Недопустимое описание поля <имя> при определении индекса или связи. (Ошибка 3409)

Возможные причины:

  • Неверно указано имя поля. Проверьте правильность имени поля.
  • Используется поле типа Memo или объекта OLE, не допускающее индексирование.


Недопустимый тип данных поля. (Ошибка 3259)

В свойстве Type объекта Field указан недопустимый тип данных поля. Выберите один из допустимых типов данных, перечисленных в разделе справки для свойства Type.


Отсутствует код языка в строке подключения. (Ошибка 3449)

Не найден код языка в строке подключения.


Открытие базы данных <имя> невозможно. Вероятно, это не база данных приложения пользователя, или ее файл поврежден. (Ошибка 3049)

Возможные причины:

  • Попытка открыть базу данных, не являющуюся базой данных Microsoft Jet, например базу данных или таблицу Btrieve, dBASE или Paradox. Попробуйте вместо этого присоединить (связать) базу данных или таблицу к существующей базе данных Microsoft® Jet.
  • Попытка выполнить импорт или присоединение базы данных или таблицы Paradox, но не удается найти соответствующий файл .px. Проверьте, что файл .px находится в том же каталоге, что и база данных или таблица Paradox, и повторите операцию.
  • Если указанная база данных является базой данных Microsoft Jet, она повреждена. Попробуйте восстановить эту базу данных. Если базу данных не удается восстановить, восстановите ее по резервной копии или создайте новую базу данных.


Недопустимая ссылка на объект Database. (Ошибка 3276)

Указанный объект Database не был открыт с помощью метода OpenDatabase или был изменен и более не является правильным объектом.


Нераспознаваемый формат базы данных <имя файла>. (Ошибка 3343)

Возможные причины:

  • Указанное имя файла не представляет базу данных с ядром Microsoft Jet.
  • Указанное имя файла соответствует устройству, например принтеру или консоли.
  • Файл .mdb имеет неверную заголовочную часть или неизвестный порядок сортировки.
  • Должна быть занесена транзакция. выполняемая другим пользователем, но не найден файл блокировок.
  • При занесении транзакции сделана попытка записать значение типа Long с размером, превышающим максимальный размер страницы 2K.
  • Повреждена база данных. Выполните сжатие базы данных и повторите попытку.


Невозможно выполнение инструкций определения данных с присоединенными источниками данных. (Ошибка 3611)

Ядро базы данных Microsoft Jet не может создать индекс для присоединенной (или связанной) таблицы ISAM или для таблицы ODBC, уже имеющей уникальный индекс.


Недопустимый путь к результирующему банку общих данных. (Ошибка 3556)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Задан недопустимый пароль общего банка данных <имя>. (Ошибка 3483)

Чтобы указать пароль, запустите диспетчер репликации. Выберите в меню Сервис команду Configure Microsoft Replication Manager и снова введите пароль для общего банка данных.


Недопустимый путь к общему банку данных <имя>. (Ошибка 3476)

Проверьте, что путь к общему банк данных указан правильно.

Откройте диспетчер репликации и выберите в меню Сервис команду Configure Microsoft Replication Manager. Или повторно выполните установку приложения, использующего репликацию.


Недопустимое имя файла. (Ошибка 3055)

Попытка использовать имя файла, которое не соответствует правилам именования операционной системы. Переименуйте файл и повторите операцию.


Недопустимое выражение фильтра для частичной реплики. (Ошибка 3482)

В значении свойства ReplicaFilter задана недопустимая строка.


Недопустимая связь <имя> в выражении фильтра частичной реплики. (Ошибка 3480)

Укажите допустимую связь.


Не допускается использование типа GUID в выражениях для условия поиска в методах Find. (Ошибка 3614)

В выражениях, определяющих условия поиска в методах Find, не допускается использование идентификаторов GUID.


Неверный адрес HTTP. (Ошибка 3685)

Указанный адрес HTTP является недопустимым для данного набора реплик. Указанный адрес HTTP не соответствует ни одному значению в поле «InternetAddress» системной таблицы «MSysTranspAddress».


Запрос <имя> нельзя использовать в предложении ограничения CHECK. (Ошибка 3801)

Объект <имя> нельзя использовать в предложении ограничения CHECK. (Ошибка 3801)

Обычно такая ошибка возникает при использовании инструкции CREATE TABLE или ALTER TABLE ALTER COLUMN и предложения ограничения CHECK. Причиной ошибки является попытка ссылки в предложении CHECK на связанную таблицу или не представление/процедуру/сохраненный запрос.


Неверный адрес Интернета. (Ошибка 3651)

Затребован неверный или недоступный адрес Интернета. Проверьте адрес и повторите попытку.


Создание базы данных невозможно; недопустимая национальная настройка. (Ошибка 3424)

Недопустимое значение аргумента порядок. Проверьте, что значение аргумента порядок задается с помощью одной из допустимых констант доступа к данным (DAO).


Недопустимое имя учетной записи или пароль. (Ошибка 3029)

Задано недопустимое имя учетной записи (имя пользователя) или пароль.

Имена пользователей

Имена пользователей могут содержать от 1 до 20 знаков и могут включать символы алфавита, расширенного набора символов, цифры, пробелы и специальные знаки, за следующими исключениями:

  • Знаки " / \ [ ] | < > + = ; , : ? *
  • Начальные пробелы
  • Непечатаемые знаки

Имена пользователей задаются без учета регистра.

Пароли

Пароли могут содержать не более 14 знаков и не должны содержать непечатаемые знаки. Пароли задаются с учетом регистра.


Недопустимое имя. Проверьте, что оно представляет допустимый параметр или псевдоним, не содержит недопустимые символы или знаки препинания, а также не является слишком длинным. (Ошибка 3125)

<Имя> не является допустимым именем. Проверьте, что оно не содержит недопустимые символы или знаки препинания, а также не является слишком длинным. (Ошибка 3125)

Указанное имя не соответствует стандартным правилам именования или не представляет допустимый параметр или псевдоним. Проверьте, не содержит ли имя недопустимые символы или знаки препинания, и что это имя не является слишком длинным.


Недопустимый объект для данной операции. (Ошибка 3350)

Метод RefreshLink вызван для объекта, не являющегося присоединенной (связанной) таблицей. Объект перестает существовать после его уничтожения, а также после закрытия или выхода из текущей области определения связанного с ним объекта доступа к данным (DAO).


Невозможно выполнение данной операции. (Ошибка 3032)

Возможные причины:

  • Попытка удалить единственную учетную запись пользователя в группе «Admins». Группа «Admins» должна содержать хотя бы одну учетную запись пользователя. Если необходимо удалить эту запись, создайте новую учетную запись и добавьте ее в группу «Admins», или добавьте существующую учетную запись в группу «Admins», а затем удалите учетную запись.
  • Попытка поместить пользователя в группу, к которой пользователь уже принадлежит, с помощью добавления объекта Group в семейство Groups объекта User, в котором уже имеется объект Group с тем же именем, или добавления объекта User в семейство Users объекта Group, в котором уже имеется объект User с тем же именем.


Ошибочный аргумент. (Ошибка 3001)

Попытка выполнить операцию, включающую подпрограмму из библиотеки динамической компоновки (DLL), один из аргументов которой имеет недопустимое значение. Проверьте введенное выражение и убедитесь, что заданы правильные аргументы, и повторите операцию.

Эта ошибка возникает также при попытке использовать взаимно исключающие константы в аргументе метода, например, при указании как dbConsistent, так и dbInconsistent в аргументе параметры метода OpenRecordset.


Неверный пароль. (Ошибка 3031)

Введен неверный пароль. Пароли могут содержать не более 14 знаков и не должны содержать непечатаемые знаки. Пароли задаются с учетом регистра.


Строка <путь> задает ошибочный путь. Проверьте, что путь задан правильно и имеется подключение к серверу, на котором находятся файлы. (Ошибка 3044)

Возможные причины:

  • Задана недопустимая спецификация файла, которая содержит неверный путь. Например, задан несуществующий путь, или элемент описания пути задан с ошибкой.
  • Указанный файл находится на сетевом диске, а сеть отключена. Проверьте, что сеть доступна, и повторите операцию.


Необходимо ввести код учетной записи, содержащий от 4 до 20 символов и цифр. (Ошибка 3304)

Код учетной записи должен содержать не менее 4 и не более 20 знаков.


Недопустимая точность для типа данных decimal. (Ошибка 3700)

Точность и масштаб для типа данных DECIMAL должны иметь значения от 0 до 28. Например, такую ошибку возвращает следующая инструкция SQL: CREATE TABLE foo (foo DECIMAL(38,0));


Недопустимый путь или имя реплики. (Ошибка 3686)

Синхронизатор, определяемый адресом HTTP, не может обработать имя базы данных, указанное в адресе URL.


Недопустимый масштаб для типа данных decimal. (Ошибка 3701)

Значение масштаба для типа данных DECIMAL всегда должно быть меньше или равняться значению точности. Например, такую ошибку возвращает следующая инструкция SQL: CREATE TABLE foo (foo DECIMAL(10,12));


Недопустимый объект Database. (Ошибка 3263)

Указанный объект Database не был открыт с помощью метода OpenDatabase или был изменен и более не является правильным объектом.


Недопустимое имя таблицы <имя> в выражении фильтра частичной реплики. (Ошибка 3481)

Проверьте, что в выражении используется правильное имя таблицы.


Недопустимое имя таблицы в фильтре. (Ошибка 3631)

Недопустимая ссылка на таблицу в логическом фильтре. В логическом фильтре допускается только ссылка на таблицу, к которой применяется фильтр.


Недопустимый аргумент TOP запроса на выборку. (Ошибка 3308)

Недопустимый параметр в предложении TOP инструкции SELECT. Значение, указанное после зарезервированного слова TOP, должно быть положительным целым. При одновременном использовании зарезервированного слова PERCENT это значение не должно превышать 100.


Код синхронизатора не совпадает с существующим кодом в таблице «MSysTranspAddress». (Ошибка 3504)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Невозможно создать реплику с помощью реплики Jet SQL. (Ошибка 3753)

Реплика Microsoft® Jet SQL поддерживает звездообразную топологию, в которой публикация SQL является разветвителем, а подписчик Jet транслятором. Если требуются дополнительные реплики Jet, необходимо создать новую подписку по публикации SQL.


Не поддерживается выражение объединения. (Ошибка 3296)

Возможные причины:

  • Результаты выполнения инструкции SQL, содержащей множественные объединения, зависят от порядка выполнения объединений. Для того чтобы указать, какое из объединений необходимо выполнить первым, следует создать отдельный запрос, в котором выполняется первое объединение, а затем включить этот запрос в инструкцию SQL.
  • Инструкция ON в операции JOIN является неполной или содержит слишком много таблиц. Попробуйте включить инструкцию ON в предложение WHERE.


Ключ связи. (Ошибка 3348)

Невозможно добавить записи; результирующий набор не содержит ключа связи для таблицы <имя>. (Ошибка 3348)

Непредвиденная ошибка. За дополнительными сведениями обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Связанная таблица <имя> отсутствует в предложении FROM. (Ошибка 3080)

Добавьте имя указанной таблицы в предложение FROM запроса и повторите операцию.


Данное свойство не поддерживается для внешних источников данных или для баз данных, созданных в предыдущей версии ядра Microsoft Jet. (Ошибка 3310)

Попытка присвоить или считать значение свойства, не поддерживаемого конкретным объектом в базе данных, сохраненной либо в версии ядра базы данных Microsoft® Jet 1.x или 2.x, либо во внешнем источнике данных. См. список поддерживаемых объектом свойств в разделе справки данного объекта «Общие сведения».


Невозможно установить значение свойства KeepLocal для базы данных; оно задается только для объектов базы данных. (Ошибка 3458)

Значение «T» свойства KeepLocal устанавливается для отдельных объектов базы данных, которые не следует делать реплицируемыми. Это свойство невозможно задать для всей базы данных.


Изменения не были успешно завершены из-за повторяющихся значений в индексе, ключевых полях или связях. (Ошибка 3022)

Попытка ввести повторяющееся значение в поле, которое является ключом или уникальным индексом, не допускающим наличия повторяющихся значений.

Сообщение содержит следующую инструкцию. Измените данные в поле или полях, которые содержат повторяющиеся значения, удалите индекс или переопределите его, чтобы он допускал наличие повторяющихся значений, и повторите операцию.


Невозможно выполнение данной операции для присоединенных или связанных таблиц. (Ошибка 3057)

Выполните импорт данных из этой таблицы и повторите операцию.


Синхронизация локальных или анонимных реплик должна выполняться только с их назначенным разветвителем. (Ошибка 3738)

Исходная реплика является локальной или анонимной; предпринимается попытка обмена с неверной репликой-разветвителем. Синхронизация локальных и анонимных реплик может выполняться только с глобальной репликой, по которой они были созданы.


Таблица блокирована. (Ошибка 3714)

Таблица блокирована. Данная запись не будет занесена при синхронизации, так как таблица блокирована другим пользователем. Повторите отправку конфликтующей записи. (Ошибка 3714)

Повторите синхронизацию реплик, когда таблица освободится.


Переполнен диск в пути <имя>. (Ошибка 3472)

Чтобы увеличить объем свободного места на диске, удалите с него ненужные файлы.


Недопустимый путь <полный_путь> к файлу журнала. (Ошибка 3591)

Проверьте, что этот файл находится в каталоге, заданном в параметре Logfile в записи HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Transporter в реестре Microsoft® Windows® или снова выполните настройку синхронизатора на вашем компьютере.

Чтобы настроить синхронизатор

  1. Запустите диспетчер репликации.
  2. Выберите команду Configure Microsoft Replication Manager в меню Сервис диспетчера репликации.
  3. Выполняйте указания мастера.


Каталог, в котором запрошен список реплик, не является управляемым каталогом. (Ошибка 3573)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Невозможно реплицировать таблицу <имя>: слишком много столбцов. (Ошибка 3705)

Не удается сделать таблицу реплицируемой, так как невозможно добавить системные столбцы репликации. Добавление этих столбцов приведет к превышению предельного числа столбцов. Уменьшите число столбцов в таблице перед ее преобразованием в реплицируемую.


Невозможно реплицировать таблицу <имя>: слишком много индексов. (Ошибка 3706)

Не удается сделать таблицу реплицируемой, так как невозможно добавить системные индексы репликации. Добавление этих индексов приведет к превышению предельного числа столбцов.


Не найдена папка MAPI или адресная книга. (Ошибка 3710)

Не найдена папка MAPI или адресная книга. (Ошибка 3710) (Ошибка 3710)

Драйвер Microsoft® Outlook/Exchange не может найти запрошенную папку или адресную книгу.

  • Проверьте, что имеется доступ и разрешения на хранилище данных MAPI, в котором сохраняется папка или адресная книга.
  • Проверьте, что сведения о подключении не являются специфическими для конкретного расположения, например, не включают назначения дисков с другого компьютера.
  • Проверьте правильность имени папки или адресной книги.


Невозможно создать индекс для папки или адресной книги MAPI. (Ошибка 3788)

Многие папки и адресные книги Microsoft® Outlook/Exchange являются системными компонентами, которые не могут быть изменены пользователем. Эта ошибка указывает, что предпринимается попытка создать индекс для объекта, такого как глобальный список адресов или общая папка, на который у вас нет разрешений.


Недостаточно памяти при вычислениях. (Ошибка 2446)

Недостаточно памяти для завершения данного вычисления в приложении. Убедитесь, что имеется достаточно оперативной памяти и задан файл подкачки достаточно размера. Возможно, для освобождения достаточной памяти требуется завершить другие программы, удалить рисунок рабочего стола, а также ненужные резидентные программы или драйверы устройств.


Нарушение доступа к исходному общему банку данных, так как база данных сообщений открыта другим приложением. (Ошибка 3565)

Закройте базу данных сообщений. Пользователи не должны самостоятельно открывать базу данных сообщений.


Сообщение из общего банка данных принадлежит ошибочному синхронизатору. (Ошибка 3567)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Не удается найти затребованный файл Memo Xbase. (Ошибка 3166)

Попытка доступа к файлу dBASE (.dbf), но не удается найти связанный файл Memo (.dbt). Проверьте, что файл .dbt находится в том же каталоге, что и файл .dbf, а затем повторите операцию.


Ошибка синтаксиса (отсутствует оператор). (Ошибка 2431)

Отсутствует оператор в выражении или инструкции.


Ошибка синтаксиса (отсутствует оператор). (Ошибка 2434)

Отсутствует оператор в выражении или инструкции.


Отсутствует ), ] или элемент. (Ошибка 2436)

Во введенном выражении отсутствует закрывающая круглая или квадратная скобка или символ вертикальной черты. Убедитесь, что выражение задано правильно.


Невозможно задать множественные атрибуты NULL, NOT NULL. (Ошибка 3806)

Непредвиденная ошибка. За дополнительными сведениями обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Элемент не обнаружен в данном семействе. (Ошибка 3265)

Неудачная попытка сослаться на объект в семействе по имени объекта.

Возможные причины:

  • Объект отсутствует в семействе. Перед ссылкой на объект проверьте, что объект добавлен в семейство.
  • В семействе имеется несколько объектов с одинаковыми именами; ссылка по имени является неоднозначной. Попытайтесь сослаться на объект по его порядковому номеру в семействе (например, Recordsets(3)).


Для этой операции требуется системная база данных формата версии 4.x или более поздней. (Ошибка 3808)

При использовании Microsoft® OLE DB Provider для Jet и средств защиты необходимо, чтобы база данных системы защиты имела формат файла версии Jet 4.x. Для этого следует выполнить сжатие существующей базы данных системы защиты или создать новую базу данных с помощью Microsoft OLE DB Provider для Jet.


Не удается открыть <таблицу>. Таблица открыта другим пользователем с помощью иного сетевого управляющего файла или с другим типом блокировки. (Ошибка 3418)

Не удается открыть таблицу <имя>. Таблица открыта другим пользователем с помощью иного сетевого управляющего файла или с другим типом блокировки. (Ошибка 3418)

Внешняя таблица Paradox не может быть открыта ядром базы данных Microsoft Jet из-за несогласованности ваших настроек инициализации и настроек открывшего таблицу пользователя. Значения параметров ParadoxNetPath и ParadoxNetStyle в записи \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox реестра Microsoft® Windows® должны быть одинаковыми у всех пользователей, работающих с базой данных в режиме общего доступа. Согласуйте ваши настройки инициализации с другими пользователями, работающими с базой данных, и попытайтесь снова открыть таблицу.


Сетевая ошибка ввода/вывода. (Ошибка 3566)

Возникла ошибка в результате взаимодействия данного компьютера и сети. Проверьте, правильно ли работает сеть и хорошо ли сетевой кабель подключен к данному компьютеру. Завершите работу, отключите компьютер, а затем включите его снова.


Невозможно создание новой реплики, так как объект <имя> в контейнере <имя> не удается сделать реплицируемым. (Ошибка 3582)

Не удается сделать базу данных реплицируемой, так как невозможно реплицировать указанный объект. Например, невозможно реплицировать таблицу, если превышено максимальное разрешенное число индексов. Во избежание возникновения этой ошибки необходимо перед репликацией проверять, что объекты базы данных удовлетворяют требованиям репликации.


Невозможно выполнить эту операцию, так как отсутствует активное подключение. (Ошибка 3668)

Следующая операция невозможна без открытого подключения к объекту. Проверьте подключение и повторите операцию.


Отсутствует активный транспорт для синхронизатора. (Ошибка 3508)

Необходимо изменить настройку диспетчера репликации.

Чтобы настроить синхронизатор

  1. Запустите диспетчер репликации.
  2. Выберите команду Configure Microsoft Replication Manager в меню Сервис диспетчера репликации.
  3. Выполняйте указания мастера.


Допустим ввод пустой строки только в текстовое поле или поле Memo. (Ошибка 3415)

Попытка ввести пустую строку в поле, имеющее тип данных, отличный от типов «Текстовый» или «Поле MEMO». Вы имеете возможность ввести в поле пустое (Null) значение.


Не удается найти сетевой путь или имя пользователя. (Ошибка 3171)

В реестре Microsoft® Windows в разделе \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox имеются недопустимые параметры. Исправьте недопустимые записи и повторите операцию.


Ограничения CHECK таблицы <имя> не будут переведены в данную таблицу. Ограничения CHECK можно создавать только в инструкциях SQL DLL. (Ошибка 3805)

Непредвиденная ошибка. За дополнительными сведениями обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Недопустимая операция без текущего индекса. (Ошибка 3019)

Определите объект Index и повторите операцию.


Текущая запись отсутствует. (Ошибка 3021)

Эта ошибка возникает вследствие неудачной попытки применения одного из методов Find или метода Seek, когда базовый объект Recordset не содержит записей или эта запись была удалена. Перейдите к другой записи или выделите другую запись и повторите операцию. Если объект Recordset является пустым, пользователь не может установить позицию текущей записи. Проверьте значения свойств BOF и EOF.


Не задана база данных в строке подключения или в предложении IN. (Ошибка 3321)

Ядро базы данных Microsoft Jet не может установить подключение к внешней базе данных ISAM, так как в строке подключения не указано имя базы данных. При подключении к внешнему источнику данных имя указывать необходимо.

Возможные причины:

  • В строке подключения, указанной в предложении FROM инструкции SELECT, пропущен параметр DATABASE=.
  • В предложении IN инструкции SELECT имеется аргумент, определяющий тип базы данных (указывающий отбор данных из внешней базы данных), однако пропущен аргумент, определяющий имя базы данных.


Синхронизатор не может найти ни одного планового или запрашиваемого обмена для обработки. (Ошибка 3514)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Отсутствует индекс для столбца GUID. (Ошибка 3550)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


В инструкции INSERT INTO <инструкция> отсутствует имя результирующего поля. (Ошибка 3352)

Выражение в предложении SELECT инструкции INSERT INTO не позволяет определить имя или имена выходных полей.


В системном реестре для синхронизатора отсутствует значение для требуемой записи. (Ошибка 3503)

Необходимо изменить настройку синхронизатора для данного компьютера.

Чтобы настроить синхронизатор

  1. Запустите диспетчер репликации.
  2. Выберите команду Configure Microsoft Replication Manager в меню Сервис диспетчера репликации.
  3. Выполняйте указания мастера.


На данном компьютере не установлены клиенты MAPI. Установите клиент MAPI, например Outlook, на компьютере. (Ошибка 3804)

На данном компьютере не установлены клиенты MAPI. Установите на компьютер клиент MAPI, например Outlook. (Ошибка 3804)

Драйвер IISAM Microsoft® Outlook/Exchange использует API сообщений (MAPI) для получения сведений о папке или адресной книге. Для установки MAPI на компьютер необходимо установить одно из клиентских приложений электронной почты Microsoft, которое использует MAPI, например, клиент Outlook, Outlook Express или клиент Exchange. Без этого драйвер IISAM Outlook/Exchange работать не будет.


Ни одно из имен импортируемых полей не совпадает с именами полей таблицы-получателя. (Ошибка 3243)

Должно совпадать по крайней мере одно имя поля в таблице, из которой производится импорт, и в таблице, в которую добавляются записи.


Синхронизатор не может найти сообщение для обработки. (Ошибка 3517)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Открытие дополнительных таблиц или запросов невозможно. (Ошибка 3037)

Достигнуто максимальное число таблиц и запросов, которые могут быть открыты одновременно. Закройте одну или несколько таблиц или запросов, а затем повторите операцию.


Не хватает дескрипторов файлов MS-DOS. (Ошибка 3042)

Закройте несколько файлов, другие приложения или увеличьте число доступных дескрипторов файлов MS-DOS.

Чтобы увеличить число дескрипторов:

  1. Измените файл CONFIG.sys с помощью блокнота Microsoft® Windows® или другого текстового редактора. Файл CONFIG.sys обычно расположен в корневом каталоге загрузочного диска. Если файл CONFIG.sys отсутствует в системе, его необходимо создать, включив в него строку, упомянутую во втором пункте.
  2. Найдите строку FILES = x, где x — некоторое число. Увеличьте число файлов, указанных в команде FILES; точное число введенных дескрипторов зависит от запущенных приложений и числа файлов, открытых в данное время. Если другие приложения открывают несколько файлов, то, возможно, требуется указать большее число дескрипторов файлов.

    При увеличении числа дескрипторов файлов следует помнить, что каждый дескриптор требует дополнительной памяти. Для получения дополнительных сведений обратитесь к руководству по операционной системе.

  3. Закройте Microsoft Windows.
  4. Перезагрузите систему и повторите операцию.


Не удается открыть таблицу 'MSysAccounts' в файле системной базы данных. (Ошибка 3173)

Данная операция требует наличия файла System.mdw, который содержит параметры защиты и настройки для таблиц базы данных Microsoft Jet.

Возможные причины:

  • В реестре Microsoft® Windows в разделе \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet значение параметра SystemDB указывает на сетевой диск, подключение к которому отсутствует. Проверьте, что сетевой диск доступен, и повторите операцию.
  • Файл System.mdw поврежден. Если имеется резервная копия файла System.mdw, поместите ее в каталог, указанный в параметре реестра SystemDB.


Не удается открыть таблицу 'MSysGroups' в файле системной базы данных. (Ошибка 3174)

Данная операция требует наличия файла System.mdw, который содержит параметры защиты и настройки для таблиц базы данных Microsoft Jet.

Возможные причины:

  • В реестре Microsoft® Windows в разделе \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet значение параметра SystemDB указывает на сетевой диск, подключение к которому отсутствует. Проверьте, что сетевой диск доступен, и повторите операцию.
  • Файл System.mdw поврежден. Если имеется резервная копия файла System.mdw, поместите ее в каталог, указанный в параметре реестра SystemDB.


Отсутствуют новые данные для чтения в общей памяти синхронизатора или диспетчера репликации. (Ошибка 3528)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Отсутствуют запланированные сеансы обмена между двумя синхронизаторами. (Ошибка 3495)

Расписание обмена между двумя синхронизаторами было удалено или была предпринята попытка задать расписание обмена синхронизатора данного компьютера с самим собой. Задайте правильное расписание обмена с помощью диспетчера репликации.


В инструкции SELECT INTO <инструкция> пропущено имя результирующего поля. (Ошибка 3105)

Введите имя результирующего поля в указанную инструкцию и повторите операцию.


В спецификации <имя> текстового файла с фиксированной длиной записей не задана ширина столбцов. (Ошибка 3443)

Параметр, задающий ширину полей, указанный в спецификации текстового файла для текстового драйвера ISAM, не задает ширину столбца. Спецификация может быть задана следующим образом:

  • В Microsoft® Access эти значения задаются с помощью мастера по присоединению таблиц (для вызова которого следует выбрать в меню Файл команду Внешние данные и подкоманду Связь с таблицами).
  • Для других приложений, использующих ядро Microsoft Jet, эти значения запоминаются в файле Schema.ini.


Спецификация текстового файла <имя> не существует. Невозможен импорт, экспорт или присоединение с помощью этой спецификации. (Ошибка 3625)

При попытке приложения Microsoft® Access выполнить импорт, экспорт или связывание с текстовым файлом оказалось, что используемое имя таблицы спецификаций не существует в таблице MSysIMEXSpecs базы данных. Следует заново создать связь с помощью правильной таблицы спецификаций.


Заданное значение не является кодом реплики ни для одной реплики набора. (Ошибка 3488)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Синхронизатор не может найти реплику из правильного набора для завершения обмена. (Ошибка 3547)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Формат внешней таблицы отличается от предполагаемого.

Формат внешней таблицы отличается от предполагаемого. (Ошибка 3274)

Формат таблицы был изменен после ее присоединения (связывания). Снова присоедините таблицу и повторите операцию.


Невозможен импорт таблицы или запроса. Записи не обнаружены, или все записи содержат ошибки. (Ошибка 3297)

Таблица или запрос, которые требуется импортировать, не найдены ядром базы данных Microsoft Jet, или в указанном источнике не обнаружены записи, или все записи содержат ошибки. Проверьте указанный путь и повторите попытку.


Не выполнена инициализация ядра базы данных Microsoft Jet. (Ошибка 3278)

Не выполнена инициализация ядра базы данных.

Возможные причины:

  • Конфликт с другим приложением, использующим ядро базы данных Microsoft Jet. Закройте все приложения и снова запустите собственное.
  • Ошибка при установке или настройке. Переустановите ваше приложение.


Попытка занесения или свертывания транзакции без предварительного вызова BeginTrans. (Ошибка 3034)

Попытка занесения или свертывания еще не начатой транзакции. (Ошибка 3034)

Попытка занесения или свертывания транзакции, которая не была запущена с помощью инструкции BeginTrans.


Нет доступа к присоединенному файлу FoxPro 3.0 <имя файла>. (Ошибка 3623)

Была предпринята попытка доступа к присоединенному файлу Microsoft® FoxPro 3.0 (.dbf). Доступ к присоединенным файлам может быть получен только с помощью контейнера базы данных FoxPro, к которому они присоединены.


В инструкции UPDATE <инструкция> пропущено имя результирующего поля. (Ошибка 3106)

Введите имя результирующего поля в указанную инструкцию и повторите операцию.


Объект не имеет значения. (Ошибка 2427)

Введенное выражение содержит идентификатор для объекта, который не имеет значения. (Объекты могут иметь значение свойства по умолчанию или возвращать метод по умолчанию).

Убедитесь, что выражение задано правильно.


Для поля ключа связи <имя> невозможно задание значения Null. (Ошибка 3100)

При объединении таблиц связываемые поля не должны содержать значений Null. Выберите другие поля или введите данные в эти поля и повторите операцию.


Попытка присвоить значение Null переменной, не принадлежащей к типу Variant. (Ошибка 3162)

Попытка присвоить значение Null переменной, которая не имеет тип данных Variant. С помощью инструкции Dim опишите переменную с типом Variant и повторите операцию.


Индекс или ключ не может содержать пустое значение (Null). (Ошибка 3058)

Возможные причины:

  • Попытка добавить значение Null в ключевое поле.
  • Предпринята попытка добавить новую запись, но не было введено значение в ключевое поле.
  • Выполнен запрос, в котором предпринимается попытка ввести в ключевое поле значение Null.


Число указанных псевдонимов должно совпадать с числом выводящихся столбцов. (Ошибка 3731)

Такая ошибка возникает при попытке создать представление с помощью SQL DDL. Причиной ошибки является отличие числа определенных корреляционных имен или псевдонимов от числа столбцов в инструкции SELECT. Например, эта ошибка возникает в следующей инструкции: CREATE VIEW foo (col1, col2) AS SELECT col1 FROM table1.


Переполнение числового поля. (Ошибка 3349)

Содержимое поля Btrieve слишком велико для данного приложения.


Невозможно создание новой реплики, так как объект <имя> в контейнере <имя> не удается сделать реплицируемым. (Ошибка 3490)

Была предпринята попытка обновления структуры одной из реплик базы данных ядром базы данных Microsoft Jet. Сбой операции при попытке работы с объектом и контейнером, которые указаны в сообщении об ошибке.


Объект <имя> уже существует. (Ошибка 3012)

Попытка создать объект с именем, которое уже имеется в этой базе данных. Выберите другое имя и повторите операцию.


Не удается реплицировать заданный объект из-за нехватки ресурсов. (Ошибка 3489)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Объект <имя> не найден ядром базы данных Microsoft Jet. Проверьте существование объекта и правильность имени и пути. (Ошибка 3011)

Возможные причины:

  • Указанный объект не существует.
  • Имя объекта задано с ошибками. Проверьте, что не пропущены символы подчеркивания ( _ ) или другая пунктуация и отсутствуют начальные пробелы.
  • Возможно, при попытке открыть таблицу Btrieve неверно заданы пути в файле определения данных File.ddf. Проверьте, что файлы данных (.dat) находятся в указанных каталогах.


Невозможно сделать реплицированным объект <имя> в контейнере <имя>. (Error 3456)

Невозможно сделать реплицированным объект <имя> в контейнере <имя>. (Ошибка 3456)

Сбой при попытке ядра базы данных Microsoft Jet сделать объект реплицируемым. Сбой операции из-за недостатка ресурсов для работы с объектом. Если объект является таблицей, проверьте, что общее число полей после репликации не превышает 255, а размер записи не превышает 2048 байт. Если число полей или размер записи превышает указанное ограничение, уменьшите размер записи.


Объект не является сохраненной процедурой. (Ошибка 3749)

Эта ошибка возникает при использовании ключевого слова EXECUTE с последующей передачей несуществующего имени процедуры или представления или передачей имени основной таблицы.


Недопустимое использование '.', '!' или '()'. (Ошибка 2447)

Неправильное использование разделителей в выражении. Для ссылки на свойство объекта доступа к данным (DAO) рекомендуется использовать синтаксис .имяСвойства.


Устаревший файл блокировок Paradox. (Ошибка 3230)

Попытка использовать таблицу Paradox, которой соответствует устаревший файл блокировок (.lck). Удалите файл .lck и повторите операцию.


Ошибка согласования спецификации ODBC <сообщение>. Сообщите о данной ошибке разработчику используемого приложения. (Ошибка 3299)

Причиной данной ошибки может быть ряд проблем, связанных с используемым драйвером ODBC. Запишите номер ошибки, указанной в сообщении, и обратитесь к разработчику приложения, который в свою очередь может обратиться к поставщику драйвера.


Ошибка при открытии файла Microsoft Excel версии 5.0. (Ошибка 3432)

Ошибка OLE при открытии файла Microsoft® Excel версии 5.0.


При загрузке драйвера ISAM для Microsoft Excel не удается выполнить инициализацию OLE. (Ошибка 3430)

При загрузке устанавливаемого драйвера ISAM для Microsoft® Excel не удается инициализировать программирование OLE. Проведите переустановку файлов DLL OLE.


Это не файл Microsoft Excel версии 5.0. (Ошибка 3431)

Сделана попытка прочитать файл в формате Microsoft® Excel версии 5.0, однако файл имеет другой формат.


Один из параметров связи неверен. (Ошибка 3645)

Тип данных или тип привязки в структуре привязки, переданный в метод GetRows или GetRowsEx, имеет недопустимое значение или недопустимую длину для указанного типа данных.

Проверьте структуру привязки.


Одна из записей в наборе записей была удалена в другом процессе. (Ошибка 3643)

Несколько записей объекта Recordset были удалены после выполнения запроса. Необходимо обновить объект Recordset и повторить запрос.


Еще не завршен асинхронный вызов OpenConnection. (Ошибка 3664)

Еще не завершен асинхронный вызов OpenConnection; до завершения вызова ссылки на возвращаемый объект Connection невозможны. (Ошибка 3664)

Непредвиденная ошибка. За дополнительными сведениями обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Для преобразования базы данных в реплицируемую необходимо открыть ее с монопольным доступом. (Ошибка 3491)

Была предпринята попытка сделать реплицируемой базу данных, открытую с общим доступом. Закройте базу данных и снова откройте ее с монопольным доступом, а затем сделайте ее реплицируемой.


Сбой при открытии файла с помощью службы FTP. (Ошибка 3679)

Сбой при открытии файла с помощью службы FTP. Проверьте, что имеется разрешение на чтение банка данных FTP. (Ошибка 3679)

Не удается открыть файл на сервере Интернета. Проверьте, что сервер выполняется и что общая папка FTP сконфигурирована для доступа правами на чтение/запись.


Операция прервана пользователем. (Ошибка 3059)

Операция была прервана до ее нормального завершения. Некоторые данные могут быть потеряны.


Предпринимаемая операция вступает в конфликт с существующей операцией над репликой. (Ошибка 3460)

Другой пользователь или другое приложение уже выполняет ту же операцию над репликой из этого набора реплик. Повторите операцию позже.


Операция не поддерживается для реплицированных баз данных, которые не были преобразованы к текущей версии. (Ошибка 3703)

Данная реплика была создана в предыдущей версии Microsoft® Jet. Для выполнения любой операции репликации необходимо предварительно сжать и/или преобразовать набор реплик.


Эта операция не разрешена в подчиненных запросах. (Ошибка 3787)

Непредвиденная ошибка. За дополнительными сведениями обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Предложение ORDER BY <предложение> конфликтует с DISTINCT. (Ошибка 3093)

Создана инструкция SQL с предикатом ALL, DISTINCT или DISTINCTROW и предложением ORDER BY, которое содержит поле, не записанное в инструкции SELECT. Удалите зарезервированное слово DISTINCT или указанное поле из предложения ORDER BY.


Предложение ORDER BY <предложение> конфликтует с предложением GROUP BY. (Ошибка 3094)

Эта ошибка возникает при создании запроса на выборку, когда поля для группировки указываются после полей для сортировки, для которых группировка не задана. Например, создана инструкция SQL с непоследовательно указанным полем в предложении ORDER BY. Переместите указанное поле в левую часть несгруппированных полей или удалите это поле из предложения ORDER BY.


В выражение ORDER BY <выражение> включены поля, не выбранные в запросе. (Ошибка 3351)

В выражение ORDER BY <выражение> включены поля, не выбранные в запросе. Допускается включение в выражение ORDER BY только полей, затребованных в первом запросе. (Ошибка 3351)

В выражение ORDER BY запроса на объединение включены поля, не указанные в запросе. Допускается включение в выражение ORDER BY только полей, затребованных в первом запросе.


Псевдоним <имя> из списка определений SELECT запроса привел к возникновению циклической ссылки. (Ошибка 3103)

Указанный псевдоним создал неразрешенную ссылку. Эта ошибка может возникать при вводе следующей инструкции SQL, в которой «A» является циклической ссылкой:

SELECT A + B AS C, C + D AS E, E + F AS A
FROM МояТаблица;

SELECT Неделя1 + Неделя2 as Часы, Часы + Сверхурочные as Всего, Всего + Оплата as Неделя1 FROM ОплатаСотрудников


Не удается найти выходную таблицу <имя>. (Ошибка 3192)

Попытка использовать инструкцию INSERT INTO с указанием таблицы, которая не существует. Проверьте, что имя задано правильно, и повторите операцию.

При попытке создать таблицу с помощью запроса на создание таблицы пользуйтесь инструкцией SELECT INTO.


Достигнут предел страничного файла, или файл поврежден. (Ошибка 3540)

Действия синхронизатора привели к возникновению системной ошибки. Завершите работу, выключите компьютер, а затем включите его снова.


Затребована блокировка страницы, но БД находится в режиме блокировки строки. (Ошибка 3752)

Эта ошибка возникает, когда пользователь указывает открытие базы данных в режиме блокировки только страниц, но другой пользователь уже открыл базу данных в режиме блокировки строк/страниц.


Параметр <имя> не имеет значения по умолчанию. (Ошибка 3748)

Эта ошибка возникает при использовании процедур. Причиной ошибки является попытка использовать значение по умолчанию для параметра, для которого такое значение не определено. Во избежание появления этой ошибки определите значение по умолчанию в процедуре или передайте значение параметра.


Параметр не имеет значения по умолчанию. (Ошибка 3747)

Эта ошибка возникает при использовании процедур. Причиной ошибки является попытка использовать значение по умолчанию для параметра, для которого такое значение не определено. Во избежание появления этой ошибки определите значение по умолчанию в процедуре или передайте значение параметра.


Размер параметра реестра превышает допустимый предел. (Ошибка 3552)

Длина каждого параметра в реестре Microsoft® Windows® ограничена. Длина используемого значения превышает разрешенную. Проверьте, чему равняется максимальная допустимая длина устанавливаемого параметра.


Ошибка синтаксиса в выражении фильтра для таблицы <имя> в частичной реплике. (Ошибка 3586)

Проверьте правильность синтаксиса данного выражения.


Фильтры, определяющие частичную реплику, не синхронизованы между собой. (Ошибка 3570)

После последнего заполнения частичной реплики в ней были изменены фильтры. Необходимо снова заполнить частичную реплику либо с помощью мастера частичной репликации, либо с помощью метода PopulatePartial в программе VBA.


Реплика-партнер не обрабатывается синхронизатором. (Ошибка 3628)

Попытка выполнить синхронизацию с репликой, которая не обрабатывается синхронизатором.


Недопустимый синхронизатор. (Ошибка 3741)

Недопустимый синхронизатор. Синхронизация локальных или анонимных реплик должна выполняться только с их назначенным разветвителем. (Ошибка 3741)

Указанный синхронизатор является недопустимым для данного набора реплик или не является синхронизатором разветвителя для локальной или анонимной реплики. Синхронизация локальных и анонимных реплик может выполняться только с глобальной репликой-разветвителем, по которой они были созданы.


Невозможен импорт электронной таблицы, защищенной паролем. (Ошибка 3244)

Откройте приложение, в котором была сохранена электронная таблица, сохраните таблицу без пароля и повторите попытку импорта.


Обновление невозможно. База данных или объект доступны только для чтения. (Ошибка 3027)

Попытка сохранить изменения в базе данных, которая была открыта с доступом только для чтения.

База данных может оказаться доступной только для чтения по одной из следующих причин:

  • Для открытия базы данных с доступом только для чтения был использован метод OpenDatabase.
  • В программе Microsoft® Visual Basic был использован элемент управления Data и для свойства ReadOnly задано значение True.
  • Файл базы данных определен с доступом только для чтения в операционной системе или в сети.
  • Файл базы данных записан на носитель с доступом только для чтения.
  • Пользователь не имеет привилегий записи в этот файл базы данных в сетевой среде.
  • При работе с защищенной базой данных для баз данных, таблиц или полей могут быть установлены права доступа только для чтения. Возможно, текущий пользователь не имеет доступа к этим данным под таким именем и с таким паролем.

Закройте базу данных, снимите ограничение доступа только для чтения и вновь откройте файл с доступом для чтения/записи.


Невозможно выполнить удаление из реплики, в которой удаление запрещено. (Ошибка 3754)

Репликой с запрещенным удалением называют реплику, в макете которой определено, что пользователям запрещено удалять записи. Если требуется выполнить удаление, необходимо использовать реплику, в которой удаление разрешается.


Первичный ключ. (Ошибка 3347)

Невозможно добавить записи; результирующий набор не содержит ключа для таблицы <имя>. (Ошибка 3347)

Непредвиденная ошибка. За дополнительными сведениями обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Недопустимый синтаксис SQL - ожидается имя процедуры. (Ошибка 3781)

Эта ошибка возникает при попытке создать или уничтожить процедуру с помощью инструкций SQL DDL CREATE PROCEDURE или DROP PROCEDURE. Она появляется, если не указано допустимое имя. Например, эта ошибка возникает в следующей инструкции: DROP PROCEDURE.


Процесс прерван при попытке завершить клиента синхронизатора. (Ошибка 3542)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Указанное свойство уже определено. (Ошибка 3311)

Попытка добавить новый объект Property в семейство, уже содержащее свойство с таким именем. Проверьте правильность значения свойства Name нового объекта Property или обратитесь к разделу справки существующего свойства с тем же именем для проверки, следует ли создавать новый объект Property.


Размер значения свойства не должен превышать 2 Кбайт. (Ошибка 3309)

Значение свойства имеет слишком большой размер. (Ошибка 3309)

Попытка присвоить свойству объекта значение, превосходящее максимально допустимый размер 2 Кбайт. Необходимо уменьшить размер значения.


Сохранение свойства невозможно; свойство схемы. (Ошибка 3394)

Попытка установить или изменить свойство схемы. Для того чтобы установить или удалить это свойство, следует при создании нового свойства схемы задать значение True для четвертого аргумента метода CreateProperty.


Сбой при попытке поместить файл на сервер с помощью FTP. (Ошибка 3681)

Сбой при попытке поместить файл на сервер с помощью FTP. Проверьте, что имеется разрешение на запись для банка данных FTP. (Ошибка 3681)

Не удается поместить файл на сервер Интернета. Проверьте, что сервер выполняется и что общая папка FTP сконфигурирована для доступа правами на чтение/запись.


<Имя> в выражении для условия отбора. (Ошибка 3076)

Введено недопустимое выражение; причина объясняется в сообщении. Проверьте, что имена полей и пунктуация не содержат ошибок, и повторите операцию.


Невозможно более одного раза задать заголовок столбца <значение> перекрестного запроса. (Ошибка 3104)

При создании перекрестного запроса с фиксированными заголовками столбцов задаваемые значения должны быть уникальными. Измените один или несколько повторяющихся заголовков столбцов и повторите операцию.


Запрос <имя> содержит неоднозначное имя столбца, конфликтующее с корреляционным именем (псевдонимом) <имя>. (Ошибка 3807)

Либо задайте полное имя столбца, либо измените корреляционное имя (псевдоним). В инструкции SQL SELECT используется корреляционное имя (псевдоним), которое используется в одной из основных таблиц в предложении FROM данной инструкции. В предыдущих версиях Microsoft® Jet в такой ситуации возвращались неверные результаты. Во избежание изменения результирующего набора записей возвращается это сообщение об ошибке.

Данная инструкция SQL SELECT будет работать самостоятельно при использовании программы Microsoft OLE DB Provider для Jet или выполняться с помощью компонентов ADO. Если эта инструкция SQL SELECT используется в любой части Microsoft Access вне ADO с помощью Microsoft OLE DB Provider для Jet, пользователь должен заменить корреляционное имя (псевдоним) на любое имя, отличное от имени столбца в основной таблице.

Примером может служить следующая инструкция: CREATE TABLE Заказы (ДатаРазмещения DATE, СтоимостьДоставки DOUBLE);. Следующая инструкция SQL SELECT будет возвращать ошибку: SELECT ДатаРазмещения AS A1, СтоимостьДоставки + СтоимостьДоставки AS ДатаРазмещения. Чтобы обойти это затруднение, следует заменить псевдоним «ДатаРазмещения» на любое другое имя или выполнить этот запрос через ADO с помощью Microsoft OLE DB Provider для Jet.


Ссылка на поле <имя> может относиться к полям нескольких таблиц, перечисленных в предложении FROM инструкции SQL. (Ошибка 3079)

Ссылка на поле может относиться к полям нескольких таблиц, перечисленных в предложении FROM инструкции SQL. В следующем примере поле «КодЗаказа» имеется как в таблице «Заказы», так и в таблице «Заказано».

SELECT КодЗаказа

FROM Заказы, Заказано;

Поскольку в инструкции не указывается, к какой таблице принадлежит данное поле «КодЗаказа», возникает ошибка. Для завершения операции задайте полную ссылку на поле с указанием имени таблицы. Например:

SELECT Заказы.КодЗаказа

FROM Заказы, Заказано;


Невозможно выполнить инструкцию SQL, так как запрос содержит неоднозначные внешние связи. Для указания связи, выполняемой первой, создайте отдельный запрос и включите его в инструкцию SQL. (Ошибка 3258)

Невозможно выполнить инструкцию SQL, так как запрос содержит неоднозначные внешние связи. Для того чтобы указать, что одно из объединений необходимо выполнить первым, следует создать отдельный запрос, в котором выполняется первое объединение, а затем включить этот запрос в инструкцию SQL. (Ошибка 3258)

Попытка выполнить инструкцию SQL, содержащую множественные объединения, результаты выполнения которой зависят от порядка выполнения объединений. Например, эта ошибка может возникнуть при выполнении следующей инструкции SQL:

SELECT * FROM Клиенты, Заказы, Заказано,

Клиенты LEFT JOIN Заказы

ON Клиенты.КодКлиента = Заказы.КодКлиента,

Заказы INNER JOIN Заказано

ON Заказы.КодЗаказа = Заказано.КодЗаказа;

Выполнение этой инструкции приведет к ошибке, поскольку порядок объединений является неоднозначным. Для того чтобы указать, что одно из объединений необходимо выполнить первым, следует создать отдельный запрос, в котором выполняется первое объединение, а затем включить этот запрос в инструкцию SQL. Следующие примеры показывают, как следует разбить этот запрос, чтобы операция внутреннего объединения INNER JOIN выполнялась до операций левого LEFT JOIN и правого RIGHT JOIN объединения:

Запрос1

SELECT * FROM Заказы, Заказано,

Заказы INNER JOIN Заказано

ON Заказы. КодЗаказа = Заказано.КодЗаказа;

Запрос2

SELECT * FROM Клиенты, Запрос1,

Клиенты LEFT JOIN Запрос1

ON Клиенты.КодКлиента = Заказы.КодКлиента;


Недопустимое использование скобок с именем <имя>. (Ошибка 3126)

Указанное имя не может заключаться в скобки, или имеются непарные скобки. Проверьте наличие парных скобок и повторите операцию.


Недопустимая ссылка в инструкции SELECT. (Ошибка 3242)

Недопустимая ссылка на поле или таблицу в инструкции SELECT. Например, ссылка отсутствует или задана с ошибками.


Перекрестный запрос содержит один или несколько недопустимых заголовков столбцов. (Ошибка 3322)

Неправильный список элементов, определяющих заголовки столбцов перекрестного запроса (предложение PIVOT в инструкции TRANSFORM).

Возможные причины:

  • Пустой список. В предложении PIVOT за ключевым словом IN должно следовать по крайней мере одно значение в квадратных скобках.
  • Пустое значение в списке. Две стоящие подряд запятые (,,) определяют пустое значение.
  • Список содержит имя поля, длина которого превышает 64 знака.

Исправьте предложение PIVOT и повторите запрос.


Невозможно удаление записей из указанных таблиц. (Ошибка 3086)

Не удается завершить удаление данных из одной или нескольких таблиц.

Возможные причины:

  • Отсутствуют разрешения на изменение таблицы. Для изменения разрешений обратитесь к системному администратору или создателю таблицы.
  • База данных была открыта только для чтения. База данных может оказаться доступной только для чтения по одной из следующих причин:
    • Для открытия базы данных с доступом только для чтения был использован метод OpenDatabase.
    • Файл базы данных определен с доступом только для чтения в операционной системе сервера базы данных или в сети.
    • Пользователь не имеет привилегий записи в этот файл базы данных в сетевой среде.
    • В программе Microsoft® Visual Basic использован элемент управления Data, и для свойства ReadOnly задано значение True.

Для удаления данных закройте базу данных, устраните ограничение доступа и вновь откройте файл с доступом для чтения и записи.


Невозможно вести значение в пустое поле, участвующее во внешнем объединении на стороне «один». (Ошибка 3332)

Непредвиденная ошибка. За дополнительными сведениями обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Невозможно обновить поле <имя>; необновляемое поле. (Ошибка 3113)

Возможные причины:

  • Указанное поле является частью объекта TableDef или объекта Recordset типа динамического набора, который не является обновляемым. Например, эта ошибка возникает при попытке обновить поле счетчика.
  • Выполнен запрос, который включает обновляемый и необновляемый объекты Tabledef, и предпринимается попытка обновить одно из полей-результатов запроса (результирующего объекта Recordset типа динамического набора).


Запрос не может иметь параметр 'База данных' (Database). (Ошибка 3222)

Измените тип данных поля для этого параметра в запросе с параметрами на допустимый тип данных и повторите операцию.


Повторение выходного псевдонима <имя>. (Ошибка 3062)

Попытка выполнить инструкцию SQL, которая имеет несколько совпадающих псевдонимов. Эта ошибка возникает, например, в следующей инструкции SQL:

SELECT Фамилия AS Имя, Отчество AS Имя FROM Сотрудники;

Измените один или несколько псевдонимов и повторите операцию.


Повторение получателя <имя>. (Ошибка 3063)

Попытка выполнить запрос, содержащий несколько результирующих полей с одинаковыми именами.

Возможная причина:

  • Создана инструкция SQL, включающая инструкцию INSERT INTO, SELECT...INTO или UPDATE, в которой указанное имя поля встречается более одного раза.

Удалите повторяющиеся имена полей или псевдонимы для имен результирующих полей и повторите операцию.


Невозможно использовать перекрестный запрос с непостоянными столбцами как подчиненный запрос. (Ошибка 3637)

Попытка выполнения сортировки в перекрестной таблице с переменными заголовками столбцов. Необходимо сохранить результаты запроса, а затем выполнить сортировку с помощью кнопок "Сортировка по возрастанию" или "Сортировка по убыванию".


Выражение неверно введено или является слишком сложным для расчета. Например, числовое выражение может содержать слишком много элементов. Попытайтесь упростить выражение, определив его части как переменные. (Ошибка 3071)

Возможные причины:

  • Введенное выражение имеет недопустимый синтаксис. Например, отсутствует операнд или оператор, введен недопустимый знак или запятая или введен текст, не заключенный в прямые кавычки ( " ). Проверьте, что выражение набрано без ошибок.
  • Введено слишком сложное выражение. Например, числовое выражение, возможно, содержит слишком много сложных компонентов. Упростите выражение, определив некоторые компоненты как переменные.


Значение поля <name> определяется выражением и не редактируется. (Ошибка 3327)

Например, если при создании сохраненного запроса или представления использовался столбец, заполняемый с помощью выражения, то обновление такого столбца невозможно. Такая ошибка возникает, например, в следующей инструкции: CREATE VIEW Клиентура AS SELECT (Имя & Фамилия) AS Тест FROM Клиент, если за ней следует инструкция UPDATE Тест FROM Клиентура.


<Сообщение> в выражении запроса <выражение>. (Ошибка 3075)

Введено недопустимое выражение; причина объясняется в сообщении. Проверьте, что имена полей и пунктуация не содержат ошибок, и повторите операцию.


Для изменения записи в данном поле ее необходимо предварительно сохранить. (Ошибка 3331)

Эта ошибка возникает при попытке пользователя изменить строку, полученную на основе представления или сохраненного запроса, которые используют две и более таблиц.


Невозможно добавление данных с помощью запроса на изменение. (Ошибка 3084)

Попытка запустить запрос на добавление с использованием в качестве источника данных запроса на изменение. Замените запрос на изменение запросом на выборку и повторите операцию.


Недопустимое имя псевдонима. (Ошибка 3068)

Введенный псевдоним не соответствует стандартным правилам именования. Введите новое имя и повторите операцию.


Запрос на изменение не может использоваться как источник строк. (Ошибка 3417)

Возможная причина:

  • Запрос служит источником строк (записей) для запроса на изменение или управляющего запроса.


Не допускается применение запроса на изменение <имя> в качестве источника строк. (Ошибка 3069)

Не допускается использование имени запроса на изменение. Вместо этого воспользуйтесь именем запроса на выборку. Для запуска запроса на изменение воспользуйтесь методом Execute вместо включения имени запроса на изменение в предложение FROM.


Невозможен ввод из внутреннего запроса отчета <имя>. (Ошибка 3124)

Попытка использования инструкции SQL, которая включает неявную ссылку на отключенный внутренний запрос отчета.


Недопустимое имя параметра <имя>, имеющее слишком большую длину или содержащее недопустимые символы. (Ошибка 3223)

Длина имени параметра превышает 64 знака или имя содержит недопустимые символы. Исправьте имя и повторите операцию.


Не удается открыть запрос на изменение <имя>. (Ошибка 3064)

Попытка открыть запрос на изменение с помощью устаревшего метода OpenQueryDef, применимого только к запросам на выборку. Для выполнения запроса на изменение лучше всего воспользоваться методом Execute объекта QueryDef.


Запрос <имя> поврежден. (Ошибка 3340)

Ссылка на не определенное имя запроса. Проверьте список запросов в семействе QueryDefs и укажите правильное имя запроса.


Данный запрос является управляющим запросом и его нельзя использовать в качестве источника строк. (Ошибка 3324)

Попытка выполнить запрос на изменение или управляющий запрос без вызова метода Execute.


Невозможно использование внутреннего запроса отчета. (Ошибка 3083)

Попытка использования инструкции SQL, которая включает неявную ссылку на отключенный внутренний запрос отчета. Удалите недопустимую ссылку и повторите операцию.


Невозможен запуск запроса на выборку. (Ошибка 3065)

Попытка выполнить метод Execute с запросом на выборку. Метод Execute допускается для использования только с запросами на изменение. В отличие от запросов на изменение, запросы на выборку содержат инструкцию SELECT и могут возвращать записи.


Данный запрос не является правильно заданным управляющим запросом. (Ошибка 3357)

Данный запрос не является правильно заданным управляющим запросом.


Не допускается использование этого запроса в качестве источника строк. (Ошибка 3323)

Возможные причины:

Запрос служит источником строк (записей) для запроса на изменение или управляющего запроса.


Объект Recordset не является обновляемым. (Ошибка 3326)

Этот результирующий набор записей не является обновляемым. (Ошибка 3326)

Попытка изменить значение поля, присоединенного к статическому объекту Recordset. Ядро базы данных Microsoft Jet не допускает изменения полей статического набора записей.


Несоответствие типов в выражении JOIN. (Ошибка 3615)

В выражении JOIN задается объединение двух таблиц по полям с несовместимыми типами данных. Например, данная ошибка возникает при попытке создать объединение для поля Memo и текстового поля.


Невозможно выполнить объединение, группировку, сортировку или отбор по индексу. Слишком длинное значение. (Ошибка 3393)

Невозможно выполнить объединение, группировку, сортировку или отбор по индексу. Слишком длинное значение, используемое для поиска или сортировки. (Ошибка 3393)

Максимальная общая длина полей, используемых для объединения, группировки или сортировки составляет 255 байт. Необходимо уменьшить число объединяемых, группируемых или сортируемых полей или использовать типы данных и размеры полей, требующие меньше места.


Поле Memo или поле объекта OLE не могут присутствовать в аргументе статистической функции в <инструкции>. (Ошибка 3115)

Поля Memo, объекта OLE и гиперссылки не могут присутствовать в аргументе статистической функции в <инструкции>. (Ошибка 3115)

Невозможно включение поля Memo или поля объекта OLE в статистическую функцию.


При отборе уникальных значений в <инструкции> нельзя использовать поле Memo и поле объекта OLE. (Ошибка 3114)

При отборе уникальных значений в <инструкции> нельзя использовать поля Memo, объекта OLE и гиперссылки. (Ошибка 3114)

Удалите из инструкции зарезервированное слово DISTINCT, или поле Memo, или поле объекта OLE.


Невозможна группировка по полю Memo, объекта OLE или гиперссылки в <предложении>. (Ошибка 3119)

Предложение GROUP BY инструкции SQL не должно включать поле Memo и поле объекта OLE.


Поле Memo и поле объекта OLE не могут присутствовать в условии отбора <условие> для статистической функции. (Ошибка 3116)

Поля Memo, объекта OLE и гиперссылки не могут присутствовать в условии отбора <условие> для статистической функции. (Ошибка 3116)

Предложение HAVING инструкции SQL не должно включать поле Memo и поле объекта OLE.


Невозможно объединение с полем Memo или полем объекта OLE <имя>. (Ошибка 3118)

Невозможно объединение с полем Memo, объекта OLE или гиперссылки <имя>. (Ошибка 3118)

Невозможно объединение полей Memo или объекта OLE. Поле, используемое для логического связывания двух или более таблиц, должно иметь другой тип данных, например текстовый или целочисленный.


Невозможна сортировка по полю Memo или полю объекта OLE в <предложении>. (Ошибка 3117)

Невозможна сортировка по полям Memo, объекта OLE и гиперссылки в <предложении>. (Ошибка 3117)

Предложение ORDER BY инструкции SQL не должно включать поле Memo и поле объекта OLE.


В предложении SELECT запроса на объединение не допускается использование поля Memo или поля объекта OLE <имя>. (Ошибка 3364)

В предложении SELECT запроса на объединение не допускается использование поля Memo, объекта OLE или гиперссылки <имя>. (Ошибка 3364)

Поле, указанное в предложении SELECT инструкции SQL запроса на объединение, имеет тип данных поля Memo или объекта OLE. Эти типы данных являются недопустимыми для данной операции.


Ошибочное поле Memo или поле объекта OLE в подчиненном запросе <имя>. (Ошибка 3342)

Ошибочное поле Memo, объекта OLE или гиперссылки в подчиненном запросе <имя>. (Ошибка 3342)

Не допускается возвращение полей Memo или объектов OLE в подчиненном запросе, а также сравнение полей Memo или объектов OLE в выражениях.


Многоуровневое предложение GROUP BY не допускается в подчиненном запросе. (Ошибка 3612)

В подчиненном запросе SQL не допускается указание более одного поля в предложении GROUP BY.


Слишком мало параметров. Требуется <число>. (Ошибка 3061)

Для этого запроса с параметрами требуется указать иное количество параметров. Обеспечьте требуемое число параметров и вновь запустите запрос.

В некоторых случаях данное сообщение возникает, когда в качестве запроса с параметрами интерпретируются неизвестные имена полей или выражения. Проверьте, что имена полей, содержащие пробелы или знаки пунктуации, заключены в квадратные скобки [ ].


Записи не могут быть удалены; отсутствует разрешение на удаление данных для объекта <имя>. (Ошибка 3109)

Для удаления данных необходимо иметь разрешение на удаление данных для указанной таблицы или запроса. Для изменения разрешений обратитесь к системному администратору или к создателю таблицы или запроса.


Необходимо указать таблицу, содержащую удаляемые записи. (Ошибка 3128)

Попытка выполнить запрос на удаление записей, в котором не указано имя таблицы, содержащей записи для удаления.

Возможная причина:

  • Не введен символ звездочки для каждой таблицы в предикатах ALL, DISTINCT, DISTINCTROW. Вместо этого были введены имена полей (например, Клиенты.Адрес вместо Клиенты.*).


В качестве входных данных запрос должен иметь хотя бы одну таблицу или запрос. (Ошибка 3067)

В базах данных Microsoft Jet данная ошибка возникает, если при создании запроса не выбрано имя таблицы. Выберите хотя бы одну таблицу или запрос.

В базах данных ODBCDirect данная ошибка возникает при попытке выполнить запрос, который не содержит инструкцию SQL. Включите хотя бы один запрос или вызов сохраненной процедуры в свойство SQL объекта QueryDef.


Записи не могут быть добавлены; отсутствует разрешение на вставку данных для объекта <имя>. (Ошибка 3107)

Для вставки данных необходимо иметь разрешение на вставку данных в указанную таблицу или запрос. Для изменения разрешений обратитесь к системному администратору или к создателю таблицы или запроса.


Записи не могут быть добавлены; отсутствуют соответствующие записи со стороны «один». (Ошибка 3363)

Эта ошибка возникает в случае изменения сохраненного запроса или представления, содержащего две или более таблиц. Эта ошибка может произойти при попытке сохранить строку представления, полученного путем объединения таблицы клиентов (на стороне «один») с таблицей заказов (на стороне «многие»). Если задать только сведения о заказе, не вводя информации о таблице клиентов, например значения ключа, будет возвращена данная ошибка.


Запрос должен иметь хотя бы одно результирующее поле. (Ошибка 3066)

Данная ошибка возникает, если не были указаны имена результирующих полей при создании запроса. Задайте хотя бы одно результирующее поле.


Не удается прочитать описания; отсутствует разрешение на чтение описания для объекта <имя>. (Ошибка 3110)

Для чтения описания данных необходимо иметь разрешение на чтение описания для указанной таблицы или запроса. Для изменения разрешений обратитесь к системному администратору или к создателю таблицы или запроса.


Записи не могут быть прочитаны; отсутствует разрешение на чтение данных для <имя>. (Ошибка 3112)

Для просмотра данных необходимо иметь разрешение на чтение данных для указанной таблицы или запроса. Для изменения разрешений обратитесь к системному администратору или к создателю таблицы или запроса.


Записи не могут быть изменены; отсутствует разрешение на обновление данных для объекта <имя>. (Ошибка 3108)

Для замены данных необходимо иметь разрешение на обновление данных для указанной таблицы или запроса. Для изменения разрешений обратитесь к администратору рабочей группы или создателю таблицы или запроса.


Создание невозможно; отсутствует разрешение на изменение макета для таблицы или запроса <имя>. (Ошибка 3111)

Попытка создать указанную таблицу или запрос, однако у пользователя отсутствует необходимое разрешение на изменение макета. Для изменения разрешений обратитесь к системному администратору или создателю запроса.


Поддержка запроса недоступна. (Ошибка 3389)

Попытка указать условия целостности данных для объекта Relation, входящего в объект QueryDef; такая операция не поддерживается.

Задайте для свойства Attributes объекта Relation значение dbRelationDontEnforce.


В операции должен использоваться обновляемый запрос. (Ошибка 3073)

Попытка запустить, открыть или изменить запрос, который не является обновляемым.

Возможные причины:

  • Попытка запустить запрос, в котором предпринимается попытка обновить необновляемое поле. Например, создан запрос, в котором предпринимается попытка обновить поле на стороне «один» отношения «один-ко-многим».
  • Попытка использовать устаревший метод OpenQueryDef для запроса, находящегося в базе данных, открытой с доступом только для чтения.

База данных может быть доступной только для чтения по одной из следующих причин:

  • База данных была открыта только для чтения с помощью метода OpenDatabase или элемента управления Data Visual Basic.
  • Файл базы данных определен с доступом только для чтения в сетевой операционной системе.
  • Пользователь не имеет привилегий записи в этот файл базы данных в сетевой среде.

Закройте базу данных, снимите ограничение доступа только для чтения и вновь откройте файл с доступом для чтения/записи.

  • Отсутствуют разрешения на внесение изменений в запрос. Для изменения разрешений обратитесь к системному администратору или создателю таблицы или запроса.


Параметр <имя> задан вместо имени базы данных. (Ошибка 3217)

Создан запрос с параметрами, в котором указан недопустимый тип параметра. Такая ошибка возникает, например, в следующей инструкции:

PARAMETERS Параметр1 Text;

SELECT КодКлиента

FROM Клиенты IN Параметр1;

Параметр1 является текстовым параметром, однако в предложении FROM требуется имя базы данных.

Укажите тип параметра «Database» вместо «Text» и повторите операцию.


Параметр <имя> задан вместо имени таблицы. (Ошибка 3216)

Создан запрос с параметрами, в котором указан недопустимый тип параметра. Такая ошибка возникает, например, в следующей инструкции:

PARAMETERS Параметр1 Text;

INSERT INTO Параметр1

SELECT *

FROM Клиенты;

Параметр1 является текстовым параметром, однако в инструкции INSERT INTO требуется имя таблицы.

Укажите тип параметра «TableID» вместо «Text» и повторите операцию.


Недопустимый тип данных для параметра <параметр>. (Ошибка 3060)

Попытка использовать аргумент с типом данных, который вступает в конфликты с типом данных, определенным для этого параметра. Например, предпринята попытка использовать строковое выражение, когда для параметра требуется числовой аргумент. Воспользуйтесь аргументом, который имеет правильный тип данных, а затем повторите операцию.


Запись в таблице <имя> удалена другим пользователем. (Ошибка 3329)

Запись в таблице <имя> удалена другим пользователем. (Ошибка 3329) (Ошибка 3329)

Попытка отредактировать строку, уже удаленную другим пользователем. Такие ошибки можно предотвратить, если все пользователи этой базы данных будут применять жесткую блокировку.


Запись в таблице <имя> заблокирована другим пользователем. (Ошибка 3330)

Попытка обновить строку или страницу, которая в данный момент заблокирована другим пользователем. Ядро Microsoft® Jet версии 4.0 разрешает пользователям открывать базу данных в режиме, допускающем блокировку на уровне строк. Этот режим позволяет значительно уменьшить частоту появления данной ошибки.


В запросе на создание таблицы <имя> имеется ссылка на одну таблицу и как на источник, и как на получателя данных. (Ошибка 3610)

Одна из таблиц-источников в инструкции SELECT INTO указана также как таблица-получатель. Удалите эту таблицу из списка источников или переименуйте таблицу-получатель.


Таблица <имя> доступна только для чтения. (Ошибка 3328)

Эта ошибка возникает при попытке обновить столбец таблицы, открытой другим пользователем только для чтения.


Слишком сложный запрос. (Ошибка 3360)

Слишком сложный запрос. Необходимо уменьшить количество полей в предложении SELECT или количество подчиненных запросов или таблиц в объединении.


Слишком много выражений в DISTINCT. (Ошибка 3089)

Создана инструкция SQL, которая имеет предикат ALL, DISTINCT или DISTINCTROW более чем с 10 выражениями. Удалите зарезервированное слово DISTINCT или некоторые поля, записанные в предикате DISTINCT.


Слишком много выражений в предложении GROUP BY. (Ошибка 3087)

Создана инструкция SQL со списком из более 10 полей в предложении GROUP BY. Удалите некоторые поля, записанные в предложении GROUP BY.


Слишком много выражений в предложении ORDER BY. (Ошибка 3088)

Создана инструкция SQL, в которой предложение ORDER BY содержит более 10 выражений. Удалите некоторые поля, записанные в предложении ORDER BY.


Слишком много заголовков столбцов <значение> для перекрестной таблицы. (Ошибка 3205)

Выполняется инструкция SQL, в которой делается попытка создать слишком много столбцов. Указанное значение представляет столбец, ставший причиной ошибки.

Можно уменьшить количество столбцов путем добавления условий в предложение WHERE или, если инструкция не содержит предложение WHERE, добавить его.


Значения, указанные в предложении TOP, не допускаются в запросах на удаление записей или в отчетах. (Ошибка 3318)

Отбор набора значений с помощью предложения TOP инструкции SELECT в запросах на удаление или в отчетах не допускается.


Циклическая ссылка, связанная с <запросом>. (Ошибка 3102)

Попытка выполнить запрос, данные которого зависят от него самого. Например, эта ошибка возникает при выполнении следующих запросов:

Запрос1

SELECT * FROM Сотрудники, Запрос2;

Запрос2

SELECT * FROM Запрос1;

Переопределите запросы для устранения зависимости.


<Имя> не распознается ядром базы данных Microsoft Jet как допустимое имя поля или выражение. (Ошибка 3070)

Указанное имя не распознается как имя поля или допустимое выражение. В запросе эта ошибка может возникать в том случае, если введено имя, содержащее неверную ссылку на базу данных, таблицу или поле.

Возможные причины ошибки в Microsoft® Access:

  • Параметр перекрестного запроса или базового запроса для перекрестного запроса или диаграммы не определен явным образом в диалоговом окне Параметры запроса. Выполните следующие действия:
    • В запросе, который содержит параметр, определите параметр и его тип данных в диалоговом окне Параметры запроса. Далее:
    • В запросе, который содержит параметр, определите свойство Заголовки столбцов (ColumnHeadings).
  • Неверная ссылка на базу данных, таблицу или поле в запросе любого типа. Например, такая ошибка возникнет, если имя поля «Зарплата» введено в выражение с опечаткой [Заплата]*1,1.


Записям таблицы <имя> не соответствуют никакие записи со стороны «один». (Ошибка 3333)

Непредвиденная ошибка. За дополнительными сведениями обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Не совпадает число значений запроса и число результирующих полей. (Ошибка 3346)

Либо указано недостаточное количество полей-получателей в инструкции INSERT INTO (в запросе на добавление), либо количество выходных полей в списках VALUES или SELECT превышает количество полей в таблице-получателе. Укажите правильное число полей.


Сохранение невозможно; блокировка другим пользователем. (Ошибка 3202)

Возможная причина:

  • Попытка сохранить на странице базы данных размером 2K запись, заблокированную другим пользователем. Подождите, пока другой пользователь закончит работу с записью, и повторите попытку.


Ошибка ввода/вывода при чтении диска. (Ошибка 3040)

Не удается прочитать диск из-за внутренней ошибки диска или дисковода.

Возможные причины:

  • Попытка прочитать сетевой диск, когда сеть временно занята или потеряно подключение к сети. Проверьте сетевое подключение и повторите операцию.
  • Сбой диска или дисковода.


Синхронизатор получил недопустимое сообщение для обрабатываемой реплики. (Ошибка 3536)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Запись удалена. (Ошибка 3167)

Ссылка на запись, удаленную данным или другим пользователем в сетевой среде. Перейдите к другой записи и повторите операцию.


Сохранение записи невозможно; установлена блокировка другим пользователем. (Ошибка 3158)

Попытка сохранить запись, находящуюся на странице базы данных, которая в данное время заблокирована другим пользователем. Для сохранения изменений дождитесь, пока другой пользователь завершит работу с записью, и повторите операцию.


Попытка вызвать метод Update или CancelUpdate или попытка обновить поле в наборе записей без предварительного вызова метода AddNew или Edit. (Ошибка 3020)

Вызов метода Update или CancelUpdate без предварительного вызова метода AddNew или Edit. (Ошибка 3020)

В базе данных с ядром Microsoft Jet был вызван метод Update или CancelUpdate без вызова метода AddNew или Edit перед записью данных в запись.

В базе данных ODBCDirect данная ошибка возникает при попытке записи данных в запись без предварительного вызова метода AddNew или Edit.


Слишком большая длина записи. (Ошибка 3047)

Попытка определить или импортировать таблицу, длина записей которой превышает допустимую величину 2K. Эта ошибка возникает при вводе данных, а не при определении структуры таблицы. Переопределите таблицу, уменьшив длину некоторых полей или удалив ненужные поля.


Восстановлены реплицированные данные. (Ошибка 3711)

Восстановлены реплицированные данные. Эта строка восстановлена из поврежденной реплицированной базы данных. Проверьте правильность содержимого записи, а затем вставьте запись или удалите конфликтующую запись. (Ошибка 3711)

При восстановлении реплики любые новые записи, которые существовали в поврежденной реплике, добавляются в конфликтную таблицу восстановленной реплики. Это обеспечивает возможность просмотра данных перед их вставкой.


Не удается найти ссылку. (Ошибка 3199)

Не удается найти заданную ссылку на файл, таблицу или поле. Проверьте, что ссылка задана без ошибок, и повторите операцию.


Связь <имя> не наложена. (Ошибка 3659)

Связь <имя> не наложена. Необходимо наложить связь в выражении для фильтра частичной реплики. (Ошибка 3659)

Попытка применить фильтр в частичной реплике к таблице, в которой существует не наложенная связь. Наложите связь в основной реплике, а затем повторите попытку применения фильтра и заполнения частичной реплики.


Обнаружен повторяющийся индекс в адресуемом поле главной таблицы. (Ошибка 3609)

При создании связи между таблицами адресуемое поле главной таблицы должно иметь уникальный индекс. Более подробное описание см. в разделах справки для объекта Index и свойства Primary.


Ограничения CHECK не допускаются в реплицированных базах данных. (Ошибка 3798)

Перед репликацией базы данных или таблицы удалите любые ограничения CHECK.


Попытка удалить или получить информацию о фильтре частичной реплики, отсутствующем в таблице «MsysFilters». (Ошибка 3505)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Код данной реплики был переприсвоен во время процедуры перемещения или копирования. (Ошибка 3574)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Устанавливаемое или удаляемое свойство репликации доступно только для чтения, и его невозможно изменить. (Ошибка 3461)

Большинство свойств, связанных с репликацией, предназначены для внутреннего пользования и доступны разработчику только для чтения. Исключите из программы инструкции, изменяющие значение этого свойства.


Основная реплика или реплика не была обработана синхронизатором. (Ошибка 3502)

Была предпринята попытка получения сведений об основной реплике или реплике, которая не была обработана синхронизатором.


Реплика была логически удалена из набора реплик и более недоступна. (Ошибка 3569)

Была предпринята попытка использовать реплику, логически удаленную из набора реплик вследствие того, что она не была синхронизирована в течение определенного числа дней или была синхронизована со второй основной репликой. Эту реплику необходимо физически удалить с компьютера.

Если логически удаленная реплика содержит данные, которые не были синхронизированы ни с какой другой репликой этого набора, самостоятельно введите недостающие данные в другую реплику этого набора. Чтобы определить, какие записи содержат не синхронизированные данные, проверьте поле «s_Generation» в каждой таблице. Нулевое значение в этом поле указывает, что запись является новой и еще не была синхронизирована ни с какой другой репликой в наборе. Чтобы сделать видимым значение поля «s_Generation», откройте Microsoft® Access, в меню Сервис выберите команду Параметры и установите флажок Системные объекты на вкладке Вид.

Если логически удаленная реплика является основной репликой набора, сравните ее структуру со структурой другой реплики набора, чтобы определить наличие не синхронизированных изменений структуры.


Имя или код реплики не соответствует обрабатываемой в данное время реплике. (Ошибка 3520)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Подготовленная для обмена реплика в данное время используется в другом сеансе обмена. (Ошибка 3510)

Любая основная реплика или реплика может одновременно участвовать только в одном сеансе синхронизации. Несмотря на невозможность вовлечения заблокированной реплики во второй сеанс обмена, пользователь может продолжать ее использование. Подождите несколько минут и попробуйте повторно выполнить обмен.


Эта реплика не является частичной репликой. (Ошибка 3478)

Была предпринята попытка получить сведения о фильтре или другой характеристике частичной реплики. Однако указанная реплика не является частичной. С помощью диспетчера репликации просмотрите свойства этой реплики и убедитесь, что она не является частичной.


Если нет разрешений администратора, реплика должна иметь приоритет в диапазоне 0 - <число>. (Ошибка 3772)

Если нет разрешений администратора, реплика должна иметь значение приоритета в диапазоне от 0 до значения приоритета реплики, по которой создается новая реплика.


Обе синхронизируемые реплики имеют статус основной реплики. (Ошибка 3561)

Удалите одну из основных реплик.


Две синхронизируемые реплики имеют одинаковый код. (Ошибка 3560)

Выберите другую конечную реплику для синхронизации в наборе реплик.


Невозможно удаление свойства репликации, так как оно доступно только для чтения. (Ошибка 3607)

Проверьте, правильно ли указано свойство, подлежащее удалению.


Не удается создать системные таблицы репликации, необходимые для репликации базы данных. (Ошибка 3579)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Невозможно синхронизировать две реплики, поскольку общая точка для запуска синхронизации отсутствует. (Ошибка 3521)

С момента последней синхронизации двух реплик из набора реплик прошло слишком много времени. Ядро базы данных Microsoft Jet не может найти общую точку для запуска процесса синхронизации содержимого или структуры базы данных.


Затребованный обмен не выполнен из-за <описание>. (Error 3660)

Затребованный обмен не выполнен из-за <описание>. (Ошибка 3660)

Определите причины сбоя по регистрационному журналу обмена. При работе с диспетчером репликации можно открыть журнал, щелкнув реплицированный объект правой кнопкой мыши. Можно также использовать команду Synchronization History из меню Вид (View).

При выполнении репликации в Microsoft® Access можно открыть таблицу хронологии репликации в режиме таблицы. Эта таблица является скрытым объектом. Для вывода ее значка в окне базы данных следует установить флажок Системные объекты на вкладке Вид в диалоговом окне Параметры, которое открывается командой Параметры из меню Сервис.


Реплика не была синхронизована за период автономности набора реплик. (Ошибка 3743)

Если для реплики истек период автономности, невозможно выполнить синхронизацию изменений этой реплики и других реплик в наборе реплик. Если реплика не была синхронизована с другой репликой за период автономности, то при следующей попытке синхронизации эта реплика будет удалена из набора. Период автономности задается, когда база данных в первый раз делается реплицируемой. Если репликация базы данных выполняется с помощью диспетчера репликации, объектов доступа к данным (DAO) или объектов (ADO), по умолчанию задается период автономности 60 дней. При репликации базы данных с помощью Microsoft® Access или портфеля по умолчанию задается период автономности 1000 дней.


Ошибочное значение. Невозможно выполнить каскадную операцию в таблице <имя>; значение велико для поля <имя>. (Ошибка 3411)

Ошибочное значение. Невозможно выполнить каскадную операцию в таблице <имя>; значение слишком велико для поля <имя>. (Ошибка 3411)

Попытка сохранить значение в ключевом поле, включенном в связь.

В Microsoft® Access такая ситуация возникает при включении для связи параметра Каскадное обновление связанных полей или при указании в программе объекта доступа к данным (DAO) значения dbRelationUpdateCascade для свойства Attributes объекта Relation. При включении любого из этих параметров приложение автоматически предпринимает попытку обновления связующих полей в связанной таблице.

Для того чтобы иметь возможность сохранить изменения в данном поле, длина текста, введенного в это поле, не должна превышать размер поля в связанной таблице, которое ваше приложение обновляет автоматически. В данном случае связанное поле имеет меньший размер, чем обновляемое вами поле. Во избежание подобных ошибок в дальнейшем следует задать для свойства Size обоих связанных полей одинаковые значения.


Невозможно выполнить каскадную операцию. Это приведет к появлению повторяющихся значений ключа в таблице <имя>. (Ошибка 3399)

Невозможно выполнить каскадную операцию. Каскадная операция приведет к появлению повторяющихся значений ключа в таблице <имя>. (Ошибка 3399)

Попытка выполнить каскадную операцию, которая приведет к появлению повторяющихся значений ключа в указанной таблице, настройка которой запрещает повторение значений ключа. Проверьте обновляемые значения и исправьте их таким образом, чтобы исключить появление повторяющихся значений ключа.


Невозможно выполнить каскадную операцию. Это приведет к появлению пустого ключа в таблице <имя>. (Ошибка 3398)

Невозможно выполнить каскадную операцию. Каскадная операция приведет к появлению пустого ключевого поля в таблице <имя>. (Ошибка 3398)

Попытка выполнить каскадную операцию, которая приведет к появлению пустых (Null) значений в ключевом поле указанной таблицы, настройка которой запрещает значения Null. Проверьте обновляемые значения и исправьте их таким образом, чтобы исключить появление значений Null.


Невозможно выполнить каскадную операцию над таблицей <имя>, которая в данный момент используется. (Ошибка 3414)

Попытка сохранить значение в поле первичного ключа, включенном в связь.

В Microsoft® Access такая ситуация возникает при включении для связи параметра Каскадное обновление связанных полей или при указании в программе объекта доступа к данным (DAO) значения dbRelationUpdateCascade для свойства Attributes объекта Relation. При включении любого из этих параметров приложение автоматически предпринимает попытку обновления связующих полей в связанной таблице.

Связанное поле обновить нельзя, так как оно открыто или заблокировано на вашем компьютере. Для сохранения записи необходимо закрыть связанную таблицу.


Невозможно выполнить каскадную операцию, которая приведет к появлению недопустимой пустой строки в поле <имя>. (Ошибка 3402)

Невозможно выполнить каскадную операцию. Операция приведет к появлению недопустимой пустой строки в поле <имя>. (Ошибка 3402)

Попытка выполнить каскадную операцию, которая приведет к появлению пустой строки в указанном поле, настройка которого не допускает пустых строк. Проверьте обновляемые значения и исправьте их, чтобы обеспечить отсутствие пустых строк в этом поле.


Невозможно выполнить каскадную операцию, которая приведет к появлению недопустимого пустого (Null) значения в поле <имя>. (Ошибка 3401)

Невозможно выполнить каскадную операцию. Операция приведет к появлению недопустимого пустого (Null) значения в поле <имя>. (Ошибка 3401)

Попытка выполнить каскадную операцию, которая приведет к появлению пустого (Null) значения в указанном поле, настройка которого не допускает пустых значений. Проверьте обновляемые значения и исправьте их, чтобы обеспечить отсутствие значений Null в этом поле.


Невозможно выполнение каскадной операции. Введенное значение не соответствует условию на значения <правило> для <имя>. (Ошибка 3404)

Невозможно выполнить каскадную операцию. Введенное значение не соответствует условию на значения <правило>, заданному для <имя>. (Ошибка 3404)

Попытка выполнить каскадную операцию, которая приведет к появлению значений, противоречащих условию на значение поля. Проверьте обновляемые значения и исправьте их, чтобы обеспечить соблюдение условий на значение.


Невозможно выполнение каскадной операции: <текст сообщения>. (Ошибка 3403)

Невозможно выполнить каскадную операцию: <текст сообщения>. (Ошибка 3403)

Попытка выполнить каскадную операцию, которая приведет к появлению недопустимых данных. Проверьте обновляемые значения и исправьте их, чтобы обеспечить соблюдение условий на значение.


Невозможно выполнить каскадную операцию, которая приведет к повторному обновлению поля <имя> в таблице <имя>. (Ошибка 3400)

Невозможно выполнить каскадную операцию. Операция приведет к повторному обновлению поля <имя> в таблице <имя>. (Ошибка 3400)

Попытка выполнить каскаднуюdadefcascade операцию, которая не может быть завершена, поскольку она приведет к двум независимым обновлениям одного указанного поля. Проверьте обновляемые значения и исправьте их, чтобы обеспечить выполнение одного из следующих условий:

  • Поле обновляется только один раз.
  • Если поле должно обновиться несколько раз, результаты каждого обновления должны совпадать.


Невозможно выполнить каскадную операцию. Наличие в таблице <имя> связанных записей приведет к нарушению целостности данных. (Ошибка 3396)

Попытка выполнить каскадную операцию, нарушающую условия целостности данных для указанной таблицы. Проверьте удаляемые или обновляемые значения и исправьте их в соответствии с условиями целостности данных.


Невозможно выполнить каскадную операцию. Необходимо наличие связанных записей в таблице <имя>. (Ошибка 3397)

Попытка выполнить каскадную операцию, нарушающую условия целостности данных. Эти условия требуют, чтобы в указанной таблице существовали связанные записи. Проверьте удаляемые или обновляемые значения и исправьте их в соответствии с условиями целостности данных.


Невозможно выполнить каскадное обновление таблицы, так как таблица используется другим пользователем. (Ошибка 3412)

Попытка сохранить значение в поле первичного ключа, включенном в связь.

В Microsoft® Access такая ситуация возникает при включении для связи параметра Каскадное обновление связанных полей или при указании в программе объекта доступа к данным (DAO) значения dbRelationUpdateCascade для свойства Attributes объекта Relation. При включении любого из этих параметров приложение автоматически предпринимает попытку обновления связующих полей в связанной таблице.

Связанное поле обновить нельзя из-за конфликта с блокировкой, наложенной другим пользователем. Для сохранения записи необходимо подождать, пока освободится связанная таблица.


Недопустимая строка подключения в запросе к серверу. (Ошибка 3305)

Строка подключения в запросе к серверу должна начинаться с элемента "ODBC;".


ODBC - слишком большое поле; произошло усечение данных. (Ошибка 3231)

Попытка выполнить операцию с источником данных ODBC, результатом которой оказалось слишком большое поле. Содержимое поля будет усечено по максимальной возможной длине.


ODBC - создание таблицы невозможно. (Ошибка 3232)

Неудачная попытка создать таблицу при экспорте таблицы в базу данных ODBC. Такая ошибка возникает, если база данных ODBC допускает только чтение или если пользователь не имеет прав на создание таблиц в этой базе данных. Измените условие «только для чтения» или обратитесь к системному администратору или лицу, создавшему базу данных, для получения прав на создание таблиц.


ODBC - удаление для присоединенной (связанной) таблицы <имя> не выполнено. (Ошибка 3156)

Попытка с помощью подключения ODBC удалить данные из базы данных ODBC; невозможно завершение этой операции удаления.

Возможные причины:

  • Удаление данных приводит к нарушению условий на значения.
  • База данных ODBC доступна только для чтения, или пользователь не имеет разрешения на удаление данных из этой базы данных. Измените условие «только для чтения» или обратитесь к администратору или владельцу базы данных для получения прав на создание таблиц.
  • База данных ODBC находится на сетевом диске, подключение к которому отсутствует. Проверьте, что сеть доступна, и повторите операцию.


ODBC - блокировка всех записей невозможна. (Ошибка 3254)

Делается попытка блокировки всех записей в базе данных ODBC при подключении ODBC.


Не допускается использование ODBC для импорта, экспорта или присоединения таблицы из внешней базы данных Microsoft Jet или базы

Не допускается использование ODBC для импорта, экспорта или присоединения таблицы из внешней базы данных Microsoft Jet или базы данных ISAM. (Ошибка 3423)

Попытка выполнить импорт, экспорт или присоединение для таблицы внешней базы данных Microsoft Jet или внешней базы данных ISAM (например, dBASE, Microsoft® FoxPro®, Paradox или Btrieve), однако в качестве источника данных указана <База данных SQL>. Необходимо указать соответствующий тип источника данных для присоединения.


ODBC - вставка для присоединенной (связанной) таблицы <имя> не выполнена. (Ошибка 3155)

Попытка с помощью подключения ODBC вставить данные в базу данных ODBC; невозможно завершение этой операции вставки.

Возможные причины:

  • Вставка приводит к нарушению условий на значения.
  • База данных ODBC доступна только для чтения, или пользователь не имеет разрешения для вставки данных в эту базу данных. Измените условие «только для чтения» или обратитесь к администратору или владельцу базы данных для получения прав на создание таблиц.
  • База данных ODBC находится на сетевом диске, подключение к которому отсутствует. Проверьте, что сеть доступна, и повторите операцию.


ODBC - ошибка подключения к <имя>. (Ошибка 3151)

Не удается выполнить с помощью ODBC подключение к указанной базе данных ODBC или таблице. Если доступ к базе данных ODBC осуществляется через сетевое подключение, проверьте, что сеть доступна, и повторите операцию.


Выполнение запроса невозможно; не удается найти присоединенную (связанную) таблицу. (Ошибка 3184)

Возможные причины:

  • Присоединенная таблица более не существует, была переименована или перемещена. Вновь присоедините таблицу и повторите операцию.
  • Присоединенная (связанная) таблица находится на сетевом диске, подключение к которому отсутствует. Проверьте, что сеть доступна, а затем вновь выполните запрос.


ODBC - было изменено описание связанной таблицы. (Ошибка 3247)

Описание или структура присоединенной (связанной) таблицы были изменены после создания связи. Удалите связь и снова выполните присоединение таблицы.


ODBC - не удается найти DLL <имя>. (Ошибка 3154)

Попытка выполнить с помощью подключения ODBC операцию, для которой требуется указанная библиотека динамической компоновки (DLL).

Возможные причины:

  • Файл DLL находится на сетевом диске, но сетевое подключение отсутствует. Проверьте, что сеть доступна, и повторите операцию.
  • Файл DLL не был правильно установлен. Переустановите драйвер ODBC и повторите операцию.


Обновление/удаление строки влияет на несколько строк присоединенной таблицы. Повтор значений в уникальном индексе. (Ошибка 3362)

Запрос на обновление или запрос на удаление записей затрагивает более одной записи в присоединенной таблице SQL. Допускается обновление или удаление записей по одной.


Необходимо использование параметра dbSeeChanges с OpenRecordset при доступе к таблице SQLServer, которая имеет столбец IDENTITY. (Ошибка 3622)

Создаваемые сервером значения IDENTITY не отражаются на стороне клиента, если не используется такое свойство DAO, как dbSeeChanges.


ODBC - время ожидания для выполнения удаленного запроса истекло. (Ошибка 3234)

Возможно, неверно установлен сервер ODBC или не активизировано сетевое подключение. Попробуйте увеличить значение свойства QueryTimeout.


ODBC - ошибка вызова. (Ошибка 3146)

ODBC – ошибка вызова. (Ошибка 3146)

Предпринимается попытка с помощью подключения ODBC выполнить операцию над данными из источника данных ODBC. Эта ошибка может возникать, если источник данных ODBC находится на сетевом диске, подключение к которому отсутствует. Проверьте, что сеть доступна, и повторите операцию.


Существует несколько таблиц с данным именем. Укажите владельца в формате 'владелец.таблица'. (Ошибка 3298)

Во внешнем источнике данных ODBC содержатся несколько таблиц с указанным именем. Для того чтобы избавиться от неопределенности, укажите владельца нужной таблицы с использованием синтаксиса владелец.таблица.


Инструкция SELECT INTO для удаленной базы данных осуществляет попытку создать слишком много полей. (Ошибка 3185)

База данных Microsoft Jet поддерживает до 255 полей в каждой таблице, а другая база данных поддерживает меньшее число полей. Инструкция SELECT...INTO создает таблицу с большим числом полей, чем поддерживается удаленной базой данных. Уменьшите число столбцов, создаваемых инструкцией SELECT INTO, и повторите операцию.


ODBC - тип данных не поддерживается сервером. (Ошибка 3235)

Сервер ODBC не поддерживает тип данных SQL, поддерживаемый ядром базы данных или вашим приложением. Данные на сервер не помещены.


ODBC - обновление для присоединенной (связанной) таблицы <имя> не выполнено. (Ошибка 3157)

Попытка с помощью подключения ODBC обновить данные в базе данных ODBC; невозможно завершение этой операции обновления.

Возможные причины:

  • Обновление данных приводит к нарушению условий на значения.
  • База данных ODBC доступна только для чтения, или пользователь не имеет разрешения на обновление данных в этой базе данных. Измените условие «только для чтения» или обратитесь к администратору или владельцу базы данных для получения прав на создание таблиц.
  • База данных ODBC находится на сетевом диске, подключение к которому отсутствует. Проверьте, что сеть доступна, и повторите операцию.


ODBC - данные выходят за пределы допустимого диапазона. (Ошибка 3238)

При попытке чтения или записи данных в базе данных ODBC через подключение ODBC обнаружены данные, выходящие за пределы допустимого диапазона.


Затребована блокировка строки, но БД находится в режиме блокировки страницы. (Ошибка 3751)

Эта ошибка возникает, когда пользователь указывает открытие базы данных в режиме блокировки строк/страниц, но другой пользователь уже открыл базу данных в режиме блокировки только страниц.


Невозможно изменить условие на значение для таблицы в то время, когда условия используются. (Ошибка 3302)

Запись в данной таблице была изменена другим пользователем или в другом сеансе и является в настоящий момент заблокированной. Не допускается изменение условий на значение в таблице с заблокированной записью.

Если запись блокирована вами в другом сеансе вашего приложения, сохраните запись, а затем внесите необходимые изменения. Если запись блокирована другим пользователем, подождите, пока он закончит работу, и сохраните измененные условия на значение.


Синхронизатор <имя> также использует банк данных файловой системы <имя>. (Ошибка 3630)

Каждый синхронизатор должен иметь уникальный банк данных файловой системы. Использование одного банка данных несколькими синхронизаторами может привести к потере сообщений и неполному обмену. Приложение не может создать сигнальный файл, так как он уже открыт другим диспетчером.


Сохранение невозможно; блокировка пользователем <имя> на машине <имя>. (Ошибка 3186)

Возможные причины:

  • Попытка сохранить на странице базы данных размером 2K запись, заблокированную другим пользователем. Подождите, пока другой пользователь закончит работу с записью, и повторите попытку.


Последовательности изменений структуры реплики и основной реплики не совпадают. (Ошибка 3524)

Синхронизатор не может синхронизировать две реплики из набора реплик, поскольку последовательности изменения структуры двух реплик не совпадают. Причиной этого различия может быть существование в этом наборе двух основных реплик или восстановление основной реплики по слишком старой резервной копии.


Ключ поиска не найден ни в одной записи. (Ошибка 3709)

Эта ошибка возникает, когда выполняется инструкция ISAM SEEK, а в индексе нет ни одного совпадающего значения.


Имя, выбранное для системного объекта, уже используется. (Ошибка 3526)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Невозможно создать связь поля с этим же полем. (Ошибка 3206)

Попытка создать отношение поля с самим собой. Выберите другое поле в главной или подчиненной таблице и повторите попытку.


Невозможно загрузить библиотеку Jet SQL Server - MSRPJT40.dll. (Ошибка 3775)

Попытка выполнить операцию между подписчиком Microsoft® Jet и публикацией SQL. Файл msrpjt40.dll отсутствует на указанном пути или не зарегистрирован.


Обновление невозможно; блокировка другим сеансом данной машины. (Ошибка 3188)

Попытка обновить информацию на странице базы данных, которая в данное время заблокирована другим сеансом. Дождитесь, пока другой сеанс будет завершен или закройте его, и повторите операцию.


В подчиненном запросе не допускаются объединения. (Ошибка 3361)

Не допускается использование операции объединения UNION в выражении подчиненного запроса. Для того чтобы использовать запрос на объединение в подчиненном запросе, необходимо сначала создать запрос на объединение, а затем сохранить его как запрос с именем. После этого следует включить имя сохраненного запроса в выражение для подчиненного запроса.


Достигнуто максимальное число блокировок файлов общего доступа. (Ошибка 3052)

Достигнуто максимальное число блокировок файлов общего доступа. Увеличьте значение параметра реестра MaxLocksPerFile. (Ошибка 3052)

Превышено максимально допустимое число блокировок набора записей. Это число определяется параметром реестра MaxLocksPerFile. По умолчанию задается значение 9500. Для его изменения следует вызвать либо редактор реестра Regedit.exe, либо метод SetOption.

Превышение этого предела в приложении может также зависеть от следующих факторов:

  • объем доступной памяти;
  • размеры записей в наборе записей:
  • ограничения, налагаемые сетевой операционной системой.


Нарушение прав доступа при попытке открыть файл журнала <имя> в монопольном режиме записи. (Ошибка 3475)

Закройте файл журнала во всех остальных приложениях.


В представлениях допускаются только простые запросы SELECT. (Ошибка 3766)

Такая ошибка возникает при попытке создать представление с помощью SQL DDL. Причиной ошибки является попытка включить параметры или инструкции подчиненного запроса в определение представления.


Из подчиненного запроса, который не использует ключевое слово EXISTS в предложении FROM главного запроса, возвращается более одного поля. Укажите в инструкции SELECT подчиненного запроса возвращение только одного поля. (Ошибка 3306)

Непредвиденная ошибка. За дополнительными сведениями обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Данный подчиненный запрос должен возвращать не более одной записи. (Ошибка 3354)

Подчиненный запрос данного типа должен возвращать не более одной записи. Исправьте инструкцию SELECT в подчиненном запросе и укажите в ней возвращение одной записи.


Не удается загрузить библиотеки сортировки JET. (Ошибка 3757)

Microsoft® Jet использует для операций сравнения и индексирования две библиотеки DLL, MSWSTR10.DLL и MSWDAT10.DLL. Проверьте правильность указания путей при загрузке библиотек.

Если эти библиотеки были удалены или повреждены другим приложением, необходимо их переустановить.


Невозможно реплицировать базу данных, используемую программой, под управлением которой выполняются изменения. (Ошибка 3638)

Невозможно реплицировать базу данных, используемую управляющей программой. (Ошибка 3638)

База данных, для которой выполняется попытка репликации, управляется программой, которая не поддерживает репликацию. Для репликации базы данных необходимо отключить ее от управляющей программы.


Экспортируемые данные не соответствуют формату, описанному в файле Schema.ini. (Ошибка 3438)

Проверьте, что экспортируемые данные соответствуют формату, описанному в файле Schema.ini.


Блокировка таблицы <имя> невозможна; используется пользователем <имя> на машине <имя>. (Ошибка 3212)

Нельзя заблокировать таблицу, с которой работает другой пользователь. Подождите завершения транзакции, выполняемой другим пользователем, и повторите операцию.


Таблица <имя> блокирована с монопольным доступом пользователем <имя> на машине <имя>. (Ошибка 3189)

Доступ к указанной таблице невозможен, так как она заблокирована другим пользователем с монопольными правами доступа. Обратитесь к этому пользователю или дождитесь, когда он снимет блокировку, и повторите операцию.


Запрос к серверу, свойство 'Возврат записей' (ReturnsRecords) которого имеет значение 'Истина', не вернул ни одной записи.

Запрос к серверу, свойство 'Возврат записей' (ReturnsRecords) которого имеет значение 'Истина', не вернул ни одной записи. (Ошибка 3325)

В запросе к серверу не возвращаются записи, несмотря на значение «Да» (True) свойства Возврат записей (ReturnsRecords). Если запрос к серверу не возвращает записей, следует задать для свойства Возврат записей (ReturnsRecords) значение «Нет» (False).


Недопустимый синтаксис SQL - ожидаемый элемент: ACTION. (Ошибка 3762)

Такая ошибка возникает при определении условия целостности данных с помощью инструкции CREATE TABLE или инструкции ALTER TABLE ALTER COLUMN. Ее причиной может быть отсутствие ключевого слова ACTION после ключевого слова NO. Например, если опустить ключевые слова BOLD ON, следующая инструкция приведет к ошибке:

CREATE TABLE Заказано (КодЗаказа LONG CONSTRAINT внкЗаказыКодЗаказа REFERENCES Заказы (КодЗаказа) ON UPDATE CASCADE ON DELETE NO ACTION, ЭлементСтроки LONG, КодТовара LONG CONSTRAINT внкТоварыКодТовара REFERENCES Товары (КодТовара), Количество LONG);


Недопустимый синтаксис SQL - ожидаемый элемент: AS (Ошибка 3728)

Такая ошибка возникает при определении или создании представления или процедуры с помощью SQL DDL. К такой ошибке приведет синтаксис: CREATE VIEW имя представления SELECT. Во избежание ошибок используйте следующий синтаксис: CREATE VIEW имя представления AS SELECT.


За инструкцией SQL следуют другие знаки. (Ошибка 3137)

За инструкцией SQL следуют другие знаки. (Ошибка 3142)

Вслед за точкой с запятой (;) в инструкции SQL были введены другие данные. Данная ошибка возникает, например, в инструкции «SELECT * FROM table1; корзина». Для предотвращения этой ошибки удалите все знаки, расположенные после точки с запятой (;).


Недопустимый синтаксис SQL - ожидаемый элемент: COMPRESSION после WITH. (Ошибка 3723)

Обычно такая ошибка возникает при использовании инструкции CREATE TABLE или ALTER TABLE ALTER COLUMN. Ее причиной является ссылка на один из синонимов NATIONAL CHARACTER для типа столбца без использования ключевого слова COMPRESSION после ключевого слова WITH. Ниже приводится правильная инструкция SQL: CREATE TABLE foo (foo NCHAR WITH COMP);. Следующая инструкция SQL возвращает ошибку: CREATE TABLE foo (foo NCHAR WITH);.


Недопустимый синтаксис SQL - ожидается имя CONSTRAINT. (Ошибка 3721)

Когда условие целостности данных определяется в инструкции SQL DDL с помощью ключевого слова CONSTRAINT, требуется имя ограничения. Если вводить имя ограничения нежелательно, не следует использовать ключевое слово CONSTRAINT. Пример такой ошибки: CREATE TABLE Клиенты (CLstNm TEXT(50), CFrstNm TEXT(25), CONSTRAINT PRIMARY KEY (CFrstNm, CLstNm));.

Чтобы исправить ошибку, добавьте имя после ключевого слова CONSTRAINT:

CREATE TABLE Клиенты (CLstNm TEXT(50), CFrstNm TEXT(25), CONSTRAINT ключКлиенты PRIMARY KEY (CFrstNm, CLstNm));.

Или не пользуйтесь ключевым словом CONSTRAINT:

CREATE TABLE Клиенты (CLstNm TEXT(50), CFrstNm TEXT(25), PRIMARY KEY (CFrstNm, CLstNm));.


Недопустимый синтаксис SQL - ожидаемый элемент: Database. (Ошибка 3785)

Непредвиденная ошибка. За дополнительными сведениями обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Недопустимый синтаксис SQL - ожидаются привилегии на базу данных, такие как CREATEDB или CONNECT. (Ошибка 3786)

Непредвиденная ошибка. За дополнительными сведениями обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Недопустимый синтаксис SQL - ожидаемый элемент: DEFAULT. (Ошибка 3722)

Обычно такая ошибка возникает при использовании инструкции ALTER TABLE ALTER COLUMN. Ее причиной является отсутствие ключевого слова DEFAULT после ключевых слов USER или NULL или литерала.


Ошибка синтаксиса в инструкции DELETE. (Ошибка 3130)

Введенная инструкция SQL содержит недопустимую инструкцию DELETE.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Недопустимый синтаксис SQL - ожидаемый элемент: CASCADE, SET NULL или NO ACTION. (Error 3725)

Недопустимый синтаксис SQL - ожидаемый элемент: CASCADE, SET NULL или NO ACTION. (Ошибка 3725)

Такая ошибка возникает при определении условия целостности данных с помощью инструкции CREATE TABLE или инструкции ALTER TABLE ALTER COLUMN. Причиной ошибки является отсутствие за ключевым словом UPDATE или DELETE одного из следующих ключевых слов: CASCADE, SET NULL или NO ACTION.


Недопустимый синтаксис SQL - ожидаемый элемент: NULL. (Ошибка 3726)

Такая ошибка возникает при использовании инструкции DDL, относящейся к индексу. Ее причиной может быть отсутствие ключевого слова NULL после следующих ключевых слов: CREATE INDEX, WITH PRIMARY или IGNORE.


Ошибка синтаксиса в предложении FROM. (Ошибка 3131)

Введенная инструкция SQL содержит недопустимое предложение FROM.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Ошибка синтаксиса в предложении GROUP BY. (Ошибка 3132)

Введенная инструкция SQL содержит недопустимое предложение GROUP BY.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Ошибка синтаксиса в предложении HAVING. (Ошибка 3133)

Введенная инструкция SQL содержит недопустимое предложение HAVING.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Ошибка синтаксиса в инструкции INSERT INTO. (Ошибка 3134)

Введенная инструкция SQL содержит недопустимую инструкцию INSERT INTO.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Запрос к серверу должен содержать по крайней мере один символ. (Ошибка 3359)

Строка SQL запроса к серверу должна содержать по крайней мере один символ.


Ошибка синтаксиса в операции JOIN. (Ошибка 3135)

Введенная инструкция SQL содержит недопустимую операцию объединения. Это может быть внутреннее объединение, внешнее объединение или самообъединение.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Ошибочное или пропущенное зарезервированное слово или аргумент в предложении LEVEL или неверная пунктуация. (Ошибка 3136)

Введенная инструкция SQL содержит недопустимое предложение.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Не допускается создание связи между присоединенными таблицами ODBC. (Ошибка 3613)

Ядро базы данных Microsoft Jet не может создать связь для присоединенных (или связанных) таблиц в источнике данных ODBC.


После инструкции SQL пропущена точка с запятой (;). (Ошибка 3137)

Вслед за инструкцией SQL указаны недопустимые элементы. Данная ошибка возвращается, например, инструкцией «SELECT столбец1 FROM таблица1 корзина». Правильной инструкцией будет «SELECT столбец1 FROM таблица1; корзина».


Недопустимый синтаксис SQL: допускается только одно правило обновления и/или одно правило удаления. (Ошибка 3727)

Такая ошибка возникает при определении условия целостности данных с помощью инструкций SQL DDL. Ее причиной может быть отсутствие ключевого слова NULL или DEFAULT после ключевого слова SET.


Ошибка синтаксиса в предложении ORDER BY. (Ошибка 3138)

Введенная инструкция SQL содержит недопустимое предложение ORDER BY.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Ошибка синтаксиса в описании WITH OWNERACCESS OPTION. (Ошибка 3257)

Возможные причины:

  • Описание WITH OWNERACCESS OPTION является неполным или содержит пробел между словами OWNER и ACCESS.
  • Описание помещено в неверную позицию в инструкции SQL. Например:

    SELECT * WITH OWNERACCESS OPTION FROM [Моя таблица];

    Описание WITH OWNERACCESS OPTION должно находиться в конце инструкции SQL. Обычно его помещают после предложения ORDER BY, если это предложение включается в инструкцию:

    SELECT * FROM [Моя таблица] WITH OWNERACCESS OPTION;


Ошибка синтаксиса в предложении PARAMETER. (Ошибка 3139)

Введена инструкция SQL с неверным описанием PARAMETERS.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Недопустимый синтаксис SQL - ожидаемый элемент: Privileges (Ошибка 3689)

Недопустимый синтаксис SQL - ожидаемый элемент: Привилегии. (Ошибка 3689)

Эта ошибка возникает при использовании ключевых слов GRANT или REVOKE. Не указана привилегия. Допустимыми являются привилегии SELECT, UPDATE, DELETE и INSERT.


Ошибка синтаксиса в предложении PROCEDURE. (Ошибка 3140)

Введенная инструкция SQL содержит недопустимое предложение PROCEDURE.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Недопустимый синтаксис SQL - ожидаемый элемент: SELECT. (Ошибка 3729)

Такая ошибка возникает при попытке создать представление с помощью SQL DDL. Следующая инструкция возвращает ошибку: CREATE VIEW имяПредставления AS. Во избежание ошибок используйте действительную инструкцию SELECT после ключевого слова AS.


Ошибочное или пропущенное зарезервированное слово или аргумент в инструкции SELECT или неверная пунктуация. (Ошибка 3141)

Введенная инструкция SQL содержит недопустимую инструкцию SELECT.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Ошибочная инструкция SQL; предполагалось 'DELETE', 'INSERT', 'PROCEDURE', 'SELECT' или 'UPDATE'. (Ошибка 3129)

Не удается интерпретировать инструкцию SQL, так как она не начинается с одного из указанных зарезервированных слов.


Ошибка синтаксиса в инструкции TRANSFORM. (Ошибка 3143)

Введенная инструкция SQL содержит недопустимую инструкцию TRANSFORM.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Ошибка синтаксиса в запросе на объединение. (Ошибка 3319)

Ошибка синтаксиса в строке SQL запроса на объединение.

Возможные причины:

  • Ошибка в зарезервированном слове или в имени аргумента.
  • Пропущено зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Недопустимый синтаксис SQL - ожидаемый элемент: UPDATE или DELETE. (Ошибка 3724)

Такая ошибка возникает при определении условия целостности данных с помощью инструкции CREATE TABLE или инструкции ALTER TABLE ALTER COLUMN. Причиной ошибки является использование ключевого слова CASCADE без предшествующего UPDATE или DELETE.


Ошибка синтаксиса в инструкции UPDATE. (Ошибка 3144)

Введенная инструкция SQL содержит недопустимую инструкцию UPDATE.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Недопустимый синтаксис SQL - ожидается имя представления. (Ошибка 3780)

Эта ошибка возникает при попытке создать или уничтожить представление с помощью инструкций SQL DDL CREATE VIEW или DROP VIEW. Она появляется, если не указано допустимое имя. Например, эта ошибка возникает в следующей инструкции: CREATE VIEW AS SELECT * FROM Таблица1.


Ошибка синтаксиса в предложении WHERE. (Ошибка 3145)

Введенная инструкция SQL содержит недопустимое предложение WHERE.

Возможные причины:

  • Пропущено или неверно указано зарезервированное слово или имя аргумента.
  • Неверная пунктуация.


Невозможно использование символа '*' в перекрестном запросе. (Ошибка 3123)

Попытка выполнить запрос, который группирует или суммирует поля, выбранные с помощью символа звездочки ( * ). Выберите конкретные поля и повторите операцию.


Невозможна группировка по полям, выбранным с помощью символа '*'. (Ошибка 3121)

Попытка выполнить инструкцию SELECT, которая группирует или суммирует все поля из всех таблиц, выбранные с помощью символа звездочки ( * ).

Возможная причина:

  • Создана инструкция SQL, которая включает статистическую функцию или предложение GROUP BY, которые ссылаются на поле, выбранное с помощью символа звездочки. Эта ошибка возникает, например, при вводе следующей инструкции SQL:

    SELECT * FROM Заказы GROUP BY СпособДоставки;


Пользователь <имя> на компьютере <имя> перевел базу данных в состояние, не позволяющее ее открыть или блокировать. (Ошибка 3734)

Такая ошибка возникает, когда используется пассивное управление отключением или подключением. Эта ошибка указывает, что другой пользователь перевел базу данных в состояние, не позволяющее другим пользователям открывать ее.


Неизвестный пользователь перевел базу данных в состояние, не позволяющее ее открыть или блокировать. (Ошибка 3733)

Такая ошибка возникает, когда используется пассивное управление отключением или подключением. Эта ошибка указывает, что другой пользователь перевел базу данных в состояние, не позволяющее другим пользователям открывать ее. Она связана с ошибкой #3734 и возвращается, когда Microsoft® Jet не может определить, какой пользователь применяет пассивное управление отключением или подключением.


Объект <имя> не является сохраненной процедурой. (Ошибка 3750)

Эта ошибка возникает при использовании ключевого слова EXECUTE с последующей передачей несуществующего имени процедуры или представления или передачей имени основной таблицы.


Нет подходящей реплики для выполнения обмена. (Ошибка 3684)

По указанному адресу HTTP нет подходящей реплики для выполнения обмена.


Не допускается синхронизация с нереплицируемой базой данных. База данных <имя> не является основной или частичной репликой.

Не допускается синхронизация с нереплицируемой базой данных. База данных <имя> не является основной или частичной репликой. (Ошибка 3605)

Была предпринята попытка синхронизации реплицируемой и нереплицируемой или двух нереплицируемых баз данных. Только реплики, производные от одной и той же реплицируемой базы данных, могут быть синхронизированы.

Если одна из указанных баз данных уже является реплицируемой, создайте вторую базу данных как производную от нее реплику.

Если ни одна из указанных баз данных не является реплицируемой, выберите одну из них для использования в качестве основной реплики в наборе реплик. Откройте базу данных с помощью Microsoft® Access, выберите в меню Сервис команду Репликация и подкоманду Создать дополнительную реплику. Если Microsoft Access недоступен, однако доступен портфель Microsoft Windows® 95, перетащите базу данных в портфель, чтобы создать ее реплику. Не пытайтесь сделать реплицируемой вторую исходную базу данных, а затем синхронизовать две базы данных. Чтобы синхронизация завершилась успешно, вторая база данных должна быть репликой первой базы данных.


Синхронизатор <имя> также использует банк данных файловой системы <имя>. (Ошибка 3629)

Каждый синхронизатор должен иметь уникальный банк данных файловой системы. Использование одного банка данных несколькими синхронизаторами может привести к потере сообщений и неполному обмену.

Невозможно создать сигнальный файл, так как он уже открыт другим диспетчером.


Ошибка синтаксиса в запросе. Значение параметра. (Ошибка 3746)

Эта ошибка возникает при следующих условиях:

  • в запросах или процедурах с параметрами используется параметр с недопустимым типом данных;
  • процедуре и именованному параметру не предшествует символ @;
  • после символа @ передан недопустимый параметр;
  • после параметра отсутствует знак равенства (=);
  • зарезервированные слова используются как параметры без правильных управляющих символов.


Ошибка синтаксиса в инструкции TRANSACTION. (Ошибка 3708)

Ошибка синтаксиса в инструкции TRANSACTION. Ожидается TRANSACTION, WORK или ничего. (Ошибка 3708)

При выполнении транзакций исключительно через Microsoft® Jet (а не через модели объектов, такие как DAO или ADO) необходимо использовать следующий синтаксис: BEGIN/ROLLBACK TRANSACTION, WORK или ничего. Данная ошибка возникает, если за BEGIN или ROLLBACK следуют любые другие символы.


Не удается открыть файл рабочей группы ядра Microsoft Jet. (Ошибка 3358)

Сделана попытка выполнить задачу, затрагивающую систему защиты базы данных; однако при этом не удается найти необходимую системную базу данных (обычно, это файл System.mdw).


Системные часы на данном компьютере не читаются ядром базы данных Microsoft Jet. (Ошибка 3515)

Системные часы компьютера используются ядром базы данных Microsoft Jet для некоторых внутренних процессов. Попытка считать показания системных часов завершилась неудачно. Завершите работу и перезагрузите компьютер.


После остановки процесса все еще существует использованный системный объект. (Ошибка 3533)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Невозможно открыть системную таблицу репликации <имя>, так как она уже используется. (Ошибка 3581)

Системная таблица, необходимая для завершения данной операции, уже используется. Подождите несколько минут и попробуйте повторно выполнить данную операцию.


Невозможно удалить ячейки электронной таблицы. (Ошибка 3435)

Невозможно удалить данные в указанном диапазоне ячеек электронной таблицы. Возможно, ячейки содержат формулы или являются защищенными.


Таблица <имя> уже существует. (Ошибка 3010)

Попытка создать или переименовать таблицу с использованием имени, которое уже имеется в этой базе данных. Выберите другое имя и повторите операцию.

В многопользовательской базе данных эта ошибка может возникать также в том случае, если после удаления таблицы другой пользователь создал таблицу с тем же именем, а затем была предпринята попытка отменить удаление этой таблицы. Для восстановления таблицы другой пользователь должен сначала удалить или переименовать новую таблицу.


Таблица <имя> уже открыта другим пользователем для монопольного доступа или открыта в интерактивном режиме и не может быть изменена в программе. (Ошибка 3008)

Попытка использовать таблицу, которая в данное время открыта другим пользователем с монопольным доступом, или обработать в программе таблицу, открытую с помощью интерфейса пользователя. Учтите соответствующее условие и повторите операцию.


Не удается дополнить именованный диапазон. (Ошибка 3434)

При добавлении строк в именованный диапазон ячеек электронной таблицы Microsoft® Excel версии 5.0 обнаружены непустые ячейки. Нельзя переписать значения этих ячеек в операции добавления.


Блокировка таблицы <имя> невозможна; используется пользователем <имя> на машине <имя>. (Ошибка 3262)

Не удается блокировать таблицу. (Ошибка 3262)

Сделана попытка блокировать таблицу при ее открытии, однако таблица в данный момент используется и не может быть заблокирована. Подождите, пока таблица освободится, и повторите операцию.


Таблица <имя> не может быть заблокирована ядром базы данных. Она уже используется другим пользователем или процессом. (Ошибка 3211)

Для того чтобы завершить данную операцию, необходимо заблокировать таблицу, с которой работает другой пользователь. Подождите, пока другой пользователь закончит работу с таблицей, и повторите операцию.


Таблица <имя> блокирована с монопольным доступом пользователем <имя> на машине <имя>. (Ошибка 3261)

Попытка использовать таблицу, открытую для монопольного доступа другим пользователем. Подождите, пока другой пользователь закончит работу с таблицей, и повторите операцию.


Операция не поддерживается для таблицы, содержащей данные. (Ошибка 3282)

Для присоединенной (связанной) таблицы, содержащей данные, невозможно добавить поле или создать индекс. После занесения данных в таблицу не допускается изменение макета или индексов таблицы. Создайте новую таблицу с измененным макетом и переместите в нее данные с помощью запроса на изменение.


Невозможно изменение структуры таблицы. Таблица открыта другим пользователем. (Ошибка 3422)

Структура таблицы не может быть изменена ядром базы данных Microsoft Jet, так как таблица открыта другим пользователем. Подождите, пока таблица будет закрыта, и повторите попытку изменения таблицы.


Таблица не открыта. (Ошибка 3160)

Попытка выполнить операцию над таблицей, которая не была открыта. Откройте таблицу и повторите операцию.


Невозможно сделать реплицируемой таблицу <имя>, так как ее не удается открыть для монопольного доступа. (Ошибка 3767)

Закройте все открытые экземпляры этой таблицы и повторите попытку.


Невозможно повторение имени таблицы <имя> в предложении FROM. (Ошибка 3074)

Невозможно указать имя этой таблицы в списке более одного раза. Удалите дополнительные вхождения имени таблицы или воспользуйтесь псевдонимом. Если предпринимается попытка выполнить объединение таблицы с этой же таблицей, воспользуйтесь псевдонимом для изменения второй ссылки на эту таблицу.


Запущено слишком много задач-клиентов. (Ошибка 3053)

Одновременно запущено слишком много копий программы Microsoft® Visual Basic или приложений Visual Basic. Закройте один или несколько экземпляров.


Ошибка ввода/вывода при чтении или записи в каталог TEMP. (Ошибка 3572)

Попытка доступа к каталогу TEMP данного компьютера привела к возникновению ошибки. Проверьте, правильно ли указан путь к этому каталогу.


Недостаточно места на временном диске. (Ошибка 3183)

Попытка выполнить операцию, для которой на временном диске требуется больше места, чем доступно. Каталог для временного диска определяется при запуске системы значением переменной TEMP среды DOS.

Например, выполняется попытка создать запрос, создающий временные файлы, которые превышают по размеру объем временного диска. Уменьшите размер временных файлов за счет доступа к меньшему количеству данных одновременно или увеличьте размер временного диска.

Для увеличения доступного объема памяти на временном диске воспользуйтесь одним из следующих способов:

  • Выберите меньшее количество записей. Объекты Recordset типа динамического набора записей, объекты с последовательным доступом и объекты типа статического набора записей записывают свои ключевые поля и данные на временный диск.
  • Выберите для временного диска другой диск.
  • Если временный диск является электронным диском, увеличьте размер этого диска или переместите его на жесткий диск.
  • Освободите место на диске, удаляя из базы данных лишние данные или ненужные таблицы, запросы, формы, макросы и модули.
  • Освободите некоторое место, сжимая базу данных для устранения из нее удаленных записей.
  • Если все еще требуется дополнительное место, попробуйте удалить с диска другие неиспользуемые файлы.


Размер буфера подкачки недостаточен для запрашиваемых данных. (Ошибка 3640)

Размер буфера подкачки недостаточен для строк, указанных при выполнении метода GetRows или GetRowsEx.


Кодовая страница для языка не указана или не найдена. (Ошибка 3649)

Попытка открыть базу данных, созданную с языковой настройкой, которая не поддерживается на данном компьютере. Необходимо определить, для какого языка была создана база данных, а затем установить поддержку этого языка на вашем компьютере. Для баз данных, создаваемых средствами DAO, языковая настройка задается в аргументе «порядок» метода CreateDatabase. Для баз данных, создаваемых в Microsoft® Access, языковая настройка задается с помощью параметра «Порядок сортировки базы данных» на вкладке Общие в диалоговом окне Параметры, которое открывается командой Параметры из меню Сервис.

Поддержку языка можно установить с помощью окна Язык и стандарты панели управления.


В наборе записей осталось меньше записей, чем запрашивается. (Ошибка 3641)

Достигнут конец объекта Recordset.


Заданная длина строки меньше суммы ширины столбцов. (Ошибка 3646)

В параметре, задающем длину строки, указано недостаточно места для присоединения столбцов.


Имя поля <имя> в выражении для условия на значение или в значении по умолчанию в таблице <имя> не распознается ядром базы

Имя поля <имя> в выражении для условия на значение или в значении по умолчанию в таблице <имя> не распознается ядром базы данных. (Ошибка 3344)

Неверная ссылка на поле в выражении или ссылка на несуществующее поле. Проверьте, правильно ли указано имя поля.


Ошибка <текст сообщения> в выражении для свойства DefaultValue. Задайте значение свойства с помощью допустимого выражения. (Ошибка 3406)

Недопустимое выражение, с помощью которого задается значение свойства Значение по умолчанию (DefaultValue). Исправьте выражение, определяющее значение свойства.


Ошибка <текст> в условии на значение. (Ошибка 3405)

Не удается правильно определить значение выражения по причинам, указанным в сообщении об ошибке. Например, если в сообщении об ошибке указано рассогласование типов, то значение свойства противоречит типу данных поля.


<Ошибка> в выражении условия на значение уровня таблицы. (Ошибка 3320)

Ошибка в выражении, определяющем условие на значение на уровне таблицы, или в выражении, определяющем значение по умолчанию. Возможны ошибки синтаксиса или ошибки другого типа.


Неизвестная функция <имя> в выражении условия на значение или в значении по умолчанию для <имя>. (Ошибка 3388)

Ссылка на функцию, которая либо неизвестна (из-за недопустимого или неверно указанного имени), либо имеет тип, противоречащий значениям свойств Условие на значение (ValidationRule) или Значение по умолчанию (DefaultValue). Не допускаются функции, определяемые пользователем, и статистические функции SQL.


Невозможно задать выражение условия на значения для этого поля. (Ошибка 3313)

Попытка задать значение свойства, определяющего условие на значение для поля (например, для поля счетчика или объекта OLE), не поддерживающего данный тип свойства. Определите условие на значение для поля другого типа или, если в таблицу еще не помещены данные, измените тип поля.


Нельзя задавать условия на значения или значения по умолчанию для системных или присоединенных (связанных) таблиц. (Ошибка 3312)

Попытка задать для свойства таблицы, поля или другого объекта Значение по умолчанию (DefaultValue), Условие на значение (ValidationRule), Сообщение об ошибке (ValidationText) или Обязательное поле (Required) значение, недопустимое в данном приложении. Например, такая ошибка возникает при попытке задать значение свойства системного объекта.


Поле <имя> не допускает ввод пустых строк. (Ошибка 3315)

Значение False (Нет) свойства данного поля Пустые строки (AllowZeroLength) запрещает ввод пустых строк. Введите в поле другое значение.


Поле <имя> не может содержать значение Null, так как свойство Required имеет значение True. Введите значение в поле. (Ошибка 3314)

Значение True (Да) свойства данного поля Обязательное поле (Required) запрещает ввод пустых (Null) значений. Введите в поле непустое значение.


<Текст условия на значение уровня таблицы>. (Ошибка 3316)

Нарушается условие на значение на значение на уровне таблицы.


Одно или несколько из введенных значений нарушают условие на значение <правило>, заданное для <имя>. Введите допустимое значение. (Ошибка 3317)

Одно или несколько из введенных значений нарушают условие на значение <правило>, заданное для <имя>. Введите значение, допускаемое выражением для данного поля. (Ошибка 3317)

Свойство Условие на значение (ValidationRule) содержит выражение, ограничивающее допустимые значения данного поля. Требуется значение, удовлетворяющее указанному выражению.


Нарушение условий на значение на уровне таблицы. (Ошибка 3716)

Эта запись содержит значение, не отвечающее ограничениям на значения на уровне таблицы. Либо обновите значение поля, нарушающее условие на значение, а затем снова отправьте запись, либо удалите конфликтующую запись.


Слишком много пользователей. (Ошибка 3239)

В многопользовательской среде ядро базы данных Microsoft Jet поддерживает до 255 одновременно работающих пользователей. Подождите, пока один или несколько пользователей прекратят работу, и повторите операцию.


Невозможна инициализация синхронизатора, поскольку запущено слишком много приложений. (Ошибка 3538)

Имеющихся системных ресурсов недостаточно для выполнения всех открытых приложений и запуска синхронизатора. Завершите работу с одним или несколькими приложениями и еще раз выполните эту операцию.


Определено слишком много полей. (Ошибка 3190)

Попытка выполнить операцию, которая включает более 255 полей. Уменьшите число полей и повторите операцию.


Вызвано слишком много сеансов FastFind. (Ошибка 3408)

Метол FIND объектов доступа к данным (DAO) может выполняться только над таблицей или набором записей.


Не удается создать индекс; уже определено слишком много индексов. (Ошибка 3039)

Невозможно создание другого индекса для этой таблицы. Попробуйте удалить существующий индекс, чтобы освободить место для нового индекса. Таблица не может иметь больше 32 индексов.


Ошибка при выполнении операции. В таблице <имя> слишком много индексов. Удалите несколько индексов из указанной таблицы и повторите попытку. (Ошибка 3626)

Таблица в базе данных Microsoft Jet не может иметь больше 32 индексов. Не следует создавать избыточные индексы в таблицах. Более того, не следует сжимать базу данных, если в ней содержатся таблицы с таким количеством индексов, поскольку при сжатии базы данных создаются новые индексы.

Удалите один или несколько индексов из указанной таблицы и повторите попытку.


Индекс не может содержать более десяти полей. (Ошибка 3277)

Определен индекс, содержащий более десяти полей. Необходимо уменьшить количество полей в индексе.


Слишком много полей Memo или объектов OLE. (Ошибка 3054)

Слишком много полей Memo, объектов OLE или гиперссылок. (Ошибка 3054)

Попытка выполнить операцию Btrieve, которая включает слишком много полей Memo или объектов OLE. Сократите число полей Memo или объектов OLE, а затем повторите операцию.


Открытие дополнительных баз данных невозможно. (Ошибка 3048)

Достигнуто максимальное число баз данных, которые могут быть открыты одновременно. Закройте одну или несколько баз данных и повторите операцию.


Открытие дополнительных файлов невозможно. (Ошибка 3025)

Достигнуто предельное число файлов, которые могут быть открыты одновременно. Закройте один или несколько файлов и повторите операцию.


Открытие большего числа таблиц невозможно. (Ошибка 3014)

Достигнуто предельное число таблиц, которые могут быть открыты одновременно. Закройте одну или несколько таблиц и повторите операцию.


Невозможно начать сеанс. Уже запущено слишком много сеансов. (Ошибка 3198)

Попытка выполнить операцию, которая запускает новый сеанс. Однако уже имеется слишком много активных сеансов. Подождите, пока будет завершен один или несколько сеансов, и повторите операцию.


Сбой при загрузке библиотеки. (Ошибка 3462)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Синхронизатор уже запущен. (Ошибка 3544)

Одновременно может использоваться только один экземпляр синхронизатора. Вместо запуска второго синхронизатора используйте уже запущенный экземпляр.


Синхронизатор не может удалить файл. (Ошибка 3568)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Синхронизатору не удается открыть журнал. (Ошибка 3506)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Синхронизатор выполнил поиск, но не нашел ни одного системного события для отчета клиенту. (Ошибка 3534)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Не удается инициализировать синхронизатор. (Ошибка 3532)

Невозможно запустить синхронизатор. Завершите работу и перезагрузите компьютер. Если сбой повторится, измените настройку синхронизатора.

Чтобы настроить синхронизатор

  1. Запустите диспетчер репликации.
  2. Выберите команду Configure Microsoft Replication Manager в меню Сервис диспетчера репликации.
  3. Выполняйте указания мастера.


Синхронизатор не был установлен. (Ошибка 3543)

Синхронизатор не был установлен на данном компьютере.

Чтобы настроить синхронизатор

  1. Запустите диспетчер репликации.
  2. Выберите команду Configure Microsoft Replication Manager в меню Сервис диспетчера репликации.
  3. Выполняйте указания мастера.

Если используется приложение независимого поставщика, получите установочный диск синхронизатора от разработчика, осуществляющего поддержку данного приложения.


Синхронизатор уже обслуживает клиента. (Ошибка 3530)

Была предпринята попытка запустить второго клиента синхронизатора, однако синхронизатор может одновременно обслуживать не более одного клиента. Определите приложение или пользователя, использующего синхронизатор, и закройте это приложение.


Не удается нормально остановить синхронизатор, и он остается в активном состоянии. (Ошибка 3541)

Программе не удалось прекратить работу синхронизатора, и он продолжает работать в фоновом режиме.

Чтобы прервать работу синхронизатора

  1. Нажмите клавиши CTRL+ALT+DELETE. На экране появится диалоговое окно Завершение работы программы.
  2. Выберите Synchronizer.
  3. Нажмите кнопку Снять задачу.


Сбой при отправке сообщения. (Ошибка 3519)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Транзакция не может быть запущена; слишком большое число вложенных транзакций. (Ошибка 3003)

Попытка выполнить транзакцию выше пятого уровня вложенности. Воспользуйтесь методами CommitTrans или Rollback для сохранения или отмены текущей транзакции перед началом следующей.


Несоответствие типа данных в выражении условия отбора. (Ошибка 3464)

В выражении, определяющем условие поиска в методе Find, используется значение с типом, не соответствующим типу данных поля.


Невозможно задать расписание работы синхронизатора. (Ошибка 3497)

Внутренний сбой при задании расписания. Попробуйте выполнить эту операцию еще раз.


Объединение не может содержать несколько таблиц с одинаковым именем <имя>. (Ошибка 3081)

Попытка создать объединение нескольких таблиц с одинаковым именем. Выберите другие таблицы, переименуйте одну из таблиц или воспользуйтесь псевдонимом, а затем повторите операцию. Если предпринимается попытка объединения таблицы с этой же таблицей, воспользуйтесь псевдонимом для изменения второй ссылки на таблицу.


Непредвиденная ошибка драйвера внешней базы данных <номер ошибки>. (Ошибка 3275)

Драйвер внешней (указанной) базы данных возвращает ошибку. Такие ошибки являются результатом попытки выполнения операции, не поддерживаемой базами данных этого типа.


Нарушение уникальности ключа. (Ошибка 3715)

Значение ключа данной записи совпадает со значением ключа в другой записи; допускаются только уникальные значения. Либо измените значение ключа в конфликтной записи или в отобранной записи, а затем повторите отправку записи, либо удалите конфликтующую запись.


Неизвестное имя. (Ошибка 2424)

Введенное выражение содержит имя поля или свойства, которое не удается определить. Убедитесь, что объект существует, а выражение задано без ошибок.


Выражение фильтра частичной реплики содержит неизвестную функцию. (Ошибка 3589)

Проверьте, правильно ли указано имя функции. Необходимо также помнить, что в выражениях фильтра разрешается использовать не все функции.


Недопустимое выражение для свойства ReplicaFilter. (Ошибка 3587)

Строка значения свойства ReplicaFilter содержит недопустимое слово. Проверьте правильность всех компонентов данного выражения.


Неизвестное имя функции. (Ошибка 2425)

Введенное выражение содержит имя функции, которое не удается определить. Убедитесь, что такая функция существует, а выражение задано без ошибок.


Ошибка синтаксиса. (Ошибка 2433)

В команде используется неверная формулировка или пунктуация. Отсутствует оператор, или указан не существующий оператор.


Невозможно выделить имена полей из первой строки импортируемой таблицы. (Ошибка 3245)

Первая строка данных содержит недопустимые имена полей, например сочетание строковых значений в кавычках и без кавычек в одном имени. В следующем примере не будет обработано третье и четвертое имя поля:

"Имя", Дата, "Код " Номер, Телефон" Номер"

Первое и второе имя являются правильными, третье и четвертое имя содержат вне кавычек знаки, не являющиеся пробелами.

Исправьте расстановку кавычек в таблице-источнике и повторите попытку импорта.


Конфликт одновременного обновления. (Ошибка 3713)

Конфликт одновременного обновления. Данная запись также обновлена в другой реплике. Данная запись отвергнута в конфликте. Либо снова отправьте обновление, либо удалите конфликтующую запись. (Ошибка 3713)

Эта запись содержит значение пол, которое было отвергнуто при устранении конфликта с другой репликой. Либо снова отправьте запись, либо удалите конфликтующую запись.


Конфликт обновления/удаления - эта обновленная запись была удалена в другой реплике. (Ошибка 3736)

Конфликт обновления/удаления. Эта обновленная запись была удалена в другой реплике. Либо снова вставьте эту конфликтующую запись, либо удалите ее. (Ошибка 3736)

Когда запись удаляется в одной реплике, но при этом обновляется в другой, то удаленная запись всегда оказывается победителем в конфликте при синхронизации двух реплик. Обновленная запись помещается в таблицу конфликтов. Чтобы отказаться от первоначального способа разрешения конфликта, снова вставьте конфликтующую запись. Чтобы подтвердить первоначальный способ разрешения конфликта, удалите конфликтующую запись.


Обновление данных в присоединенной (или связанной) таблице не поддерживается данным драйвером ISAM. (Ошибка 3616)

Используемый устанавливаемый драйвер ISAM не поддерживает обновление записей во внешних таблицах. Однако разрешается добавление записей.


Конфликт обновления и нарушения условий целостности данных. (Ошибка 3718)

Запись с первичным ключом была обновлена в другой реплике, поэтому ссылающаяся на нее запись была отвергнута. Либо создайте запись с новым первичным ключом, удовлетворяющим условиям целостности данных, а затем повторите отправку обновленной записи, измените значение внешнего ключа в конфликтующей записи соответственно действительному значению первичного ключа, а затем повторите отправку обновленной записи, либо удалите конфликтующую запись.


Возможно представление только в формате версии 1.0. (Ошибка 3334)

Попытка использования характеристики, более не поддерживаемой в текущей версии приложения.


В таблице <имя> ядром базы данных Microsoft Jet не найдены записи с совпадающим ключевым полем <имя>. (Ошибка 3101)

Для отношения «один-ко-многим» введены данные со стороны «многие», для которых отсутствует соответствующая запись со стороны «один». Например, данная ошибка возникает при объединении таблицы «Клиенты» с таблицей «Заказы» на основе поля «КодКлиента», а затем с помощью поля «КодКлиента» добавляется заказ, который не существует в таблице «Клиенты».


VIEW не может содержать параметр. (Ошибка 3730)

Такая ошибка возникает при попытке создать представление с помощью SQL DDL. Такая ошибка возвращается, если часть SELECT инструкции CREATE VIEW содержит любые параметры. Во избежание подобных затруднений пользуйтесь инструкцией CREATE PROCEDURE.


Попытка задать столбец частичной реплики нарушила правило, поддерживающее частичные реплики. (Ошибка 3571)

Первичный ключ таблицы в частичной реплике разрешается изменять только в том случае, если на него нет прямых ссылок.


Нарушение правил для частичных реплик. (Ошибка 3590)

Невозможно обновить столбец таблицы в частичной реплике, когда на этот столбец имеется ссылка из другой таблицы. Наиболее вероятно, это связано с учетом целостности данных при обновлении, когда информация о связанной таблице отсутствует в частичной реплике. При определении фильтров частичных реплик следует учитывать все связи.


Невозможно удаление встроенного свойства. (Ошибка 3384)

Попытка удалить объект Property, определяемый ядром базы данных Microsoft Jet.

Удалить можно только определяемое пользователем свойство (в том числе, свойство, определяемое в приложении), для которого у пользователя имеется разрешение на изменение макета, или свойство, не требующее разрешения на изменение макета.


Добавление невозможно. Поле является частью семейства Fields. (Ошибка 3266).

В аргументе метода Append указан объект Field, уже являющийся компонентом существующего семейства Fields. С помощью инструкции Dim и метода CreateField опишите новый объект Field и укажите его значения, после чего повторите операцию добавления в семейство для нового объекта Field.


Недопустимое значение свойства. (Ошибка 3271)

Возможные причины:

  • Слишком длинное или неверное значение свойства Value объекта Parameter.
  • В имени объекта Index задана пустая строка (" "). При добавлении объекта Index в семейство Indexes необходимо указать имя.
  • В имени объекта Workspace задана пустая строка. При добавлении объекта Workspace в семейство Workspaces необходимо указать имя.


Добавление невозможно. Индекс является частью семейства Indexes. (Ошибка 3269)

В аргументе операции Append указан объект Index, уже являющийся компонентом существующего семейства Indexes. С помощью инструкции Dim и метода CreateIndex опишите новый объект Index и укажите его значения, после чего повторите операцию добавления в семейство для нового объекта Index.


Невозможно установить значение данного свойства для внешних объектов. (Ошибка 3365)

Данное свойство является неприменимым для объектов, связанных с базами данных ODBC.


Перед использованием данного метода необходимо задать значение свойства <имя>. (Ошибка 3386)

Попытка добавить в семейство новый объект Property, для которого не заданы значения всех свойств: Value, Type и Name.


Поля не определены - невозможно добавление объектов Tabledef или Index. (Ошибка 3264)

Не допускается добавление объекта TableDef в семейство без определения в нем по крайней мере одного поля. Создайте поля с помощью метода CreateField, добавьте поля в семейство Fields объекта TableDef, а затем добавьте объект TableDef в семейство TableDefs.


Невозможно добавить связь, не определив поля. (Ошибка 3366)

Попытка добавления в семейство Relations объекта Relation, не содержащего ни одного поля.

Чтобы добавить объект Relation

  1. С помощью метода CreateRelation создайте объект Relation.

    Задайте значения свойств Table, ForeignTable и Attributes объекта Relation, если значения этих свойств не указаны как аргументы метода CreateRelation.

    С помощью метода CreateField создайте новый объект Field для каждого поля ключа и внешнего ключа связи.

  2. Задайте для свойств Name (если значение этого свойства не указано как аргумент метода CreateField) и ForeignName объекта или объектов Field значения свойства Name соответствующих объектов Field, представляющих ключевое поле и поле внешнего ключа в каждой связи.
  3. С помощью метода Append сохраните объект или объекты Field в семействе Fields объекта Relation.
  4. С помощью метода Append сохраните объект Relation в семействе Relations базы данных.


Невозможно задание данного свойства, если объект является частью семейства. (Ошибка 3268)

Попытка изменить значение свойства объекта (TableDef, Field и т.д.), который уже добавлен в семейство.


Метод неприменим к данному объекту. (Ошибка 3273)

Попытка вызвать метод для объекта, не поддерживающего данный метод. Список методов, поддерживаемых объектом, см. в разделе справки «Общие сведения» для данного объекта.


Свойство может быть определено, только если это поле является частью семейства Fields объекта Recordset. (Ошибка 3267)

Данное свойство применимо только к объектам Field, входящим в семейство Fields объекта Recordset. Перечень свойств, применимых к различным семействам Fields, см. в разделе справки Объект Field, семейство Fields - Общие сведения.


Объект не является семейством. (Ошибка 3272)

Ссылка на объект как на семейство. Например, к такой ошибке приведет инструкция qrySales.Refresh или qrySales(2).


Добавление объекта невозможно. Он уже входит в семейство. (Ошибка 3367)

Попытка добавить объект в семейство, уже содержащее объект с тем же именем. Вызовите метод Refresh и проверьте, существует ли в семействе объект с этим именем, или измените значение свойства Name объекта.


Свойство не найдено. (Ошибка 3270)

Не удается найти указанное свойство.

Возможные причины:

  • Свойство не существует. Проверьте правильность имени свойства в вашей программе.
  • Если свойство определяется пользователем, возможно, оно удалено из семейства.


Свойства, определяемые пользователем, не допускают задание пустых значений (Null). (Ошибка 3385)

Определяемые пользователем объекты Property не допускают задание пустых (Null) значений. Вызовите метод Delete для удаления этого свойства из семейства.


Ошибка преобразования типа данных. (Ошибка 3421)

Данные не могут быть преобразованы ядром базы данных Microsoft Jet к типу, требуемому методом или свойством. Такая ошибка обычно возникает, если указан аргумент одного типа, а для метода или свойства требуется другой тип.


Отсутствует файл Jet VBA (VBAJET.dll для 16-разрядных версий или VBAJET32.dll для 32-разрядных версий). Переустановите приложение, возвратившее ошибку. (Ошибка 3446)

Не найден файл Microsoft® Jet VBA (VBAJET.dll для 16-разрядных версий или VBAJET32.dll для 32-разрядных версий). Переустановите приложение, возвратившее ошибку.


Неверный или не заданный объект. (Ошибка 3420)

Попытка ссылки на объект, который более не является определенным или не имеет заданного значения.

Возможные причины:

  • Объект был закрыт.
  • Был закрыт или удален родительский объект, с которым был связан данный объект.
  • Объект вышел из области определения.
  • Библиотека объектов не зарегистрирована в реестре Microsoft® Windows®.
  • Сделана попытка ссылки на метод или свойство семейства без его предварительного присвоения переменной. Например, для ссылки на свойство Name необходимо использовать следующую конструкцию:

    Dim dbsPublish As Database

    Set dbsPublish = OpenDatabase("BIBLIO.mdb")

    dbname = dbsPublish.Name


Неудачный вызов системной функции OLE. Переустановите приложение, возвратившее ошибку. (Ошибка 3448)

Неудачный вызов функция программирования OLE. Переустановите приложение, возвратившее ошибку.


Ошибка инициализации при вызове файла Jet VBA (VBAJET.dll для 16-разрядных версий или VBAJET32.dll для 32-разрядных версий). (Ошибка 3447)

Ошибка инициализации при вызове файла Jet VBA (VBAJET.dll для 16-разрядных версий или VBAJET32.dll для 32-разрядных версий). Переустановите приложение, возвратившее ошибку. (Ошибка 3447)

Не удается инициализировать вызываемый файл Microsoft® Jet VBA (VBAJET.dll для 16-разрядных версий или VBAJET32.dll для 32-разрядных версий). Переустановите приложение, возвратившее ошибку.


Обнаружена ошибочная версия файла библиотеки <имя>. (Ошибка 3445)

Для баз данных Microsoft Jet установленная библиотека Microsoft® Jet (msajt200.dll для 16-разрядных версий или msjt2032 для 32-разрядных версий) должна принадлежать версии 2.5 или более поздней.

Для база данных ODBCDirect должна быть установлена библиотека удаленных объектов данных (RDO) msrdo32.dll версии 1.0 или более поздней.

Переустановите приложение, возвратившее ошибку.


В спецификации <имя> текстового файла с фиксированной длиной записей для столбца <имя столбца> не задана ширина. (Ошибка 3444)

Параметр, задающий ширину полей, указанный в спецификации текстового файла для текстового драйвера ISAM, не задает ширину столбца. Спецификация может быть задана следующим образом:

  • В Microsoft® Access эти значения задаются с помощью мастера по присоединению таблиц (для вызова которого следует выбрать в меню Файл команду Внешние данные и подкоманду Связь с таблицами).
  • Для других приложений, использующих ядро Microsoft Jet, эти значения запоминаются в файле Schema.ini.


Обновление невозможно; блокировка установлена пользователем <имя> на машине <имя>. (Ошибка 3260)

Попытка обновления данных, находящихся на заблокированной странице.

Возможные причины:

  • Сделана попытка сохранить запрос, с которым работает другой пользователь. Для того чтобы сохранить запрос, подождите, пока другой пользователь закончит работу, или укажите другое имя запроса и повторите операцию.
  • Сделана попытка вызвать метод Edit для страницы данных, содержащей открытую или заблокированную запись.


Клиент синхронизатора отсутствует и не может получить уведомление. (Ошибка 3537)

Непредвиденная ошибка. При получении этого сообщения обращайтесь в службу поддержки продуктов корпорации Майкрософт.


Неверное число аргументов функции. (Ошибка 2439)

Введенное выражение содержит функцию с неправильным числом аргументов. Выясните число аргументов функции или убедитесь, что выражение задано без ошибок.


Ошибочная таблица сортировки. (Ошибка 3220)

Попытка присоединить (связать) таблицу Paradox, созданную с использованием порядка сортировки, отличающегося от используемого вами.


Формат файла Memo не соответствует указанному формату внешней базы данных. (Ошибка 3286)

Ваше приложение не может прочитать файл Memo, принадлежащий базе данных, с которой выполняется операция импорта или присоединения (связывания). В результате становится невозможным импорт или присоединение файла. Вероятно, неверно указан формат файла Memo; например, указан тип источника данных dBASE IV, а файл Memo записан в формате Microsoft® FoxPro®.


Недопустимое использование скобок. (Ошибка 2442)

Введенное выражение содержит недопустимые скобки. Например, предпринимается попытка использовать скобки с идентификатором в запросе. В запросах возможно применение только обычного синтаксиса идентификаторов.